
 

 

 
 
 
 
 
 
 
 
Wireless Telecom Group  
25 EASTMANS ROAD, PARSIPPANY, NJ 07054 

Telephone: 973-386-9696 
Fax: 973-386-9191 
Email: boonton@boonton.com 
Web: www.wtcom.com 
 
 

 

 

 

 

 

 

 
 

 

INSTRUCTION MANUAL 
 
 

MODEL 4500B 
 

RF PEAK POWER ANALYZER 
 
 

 

 

 

 

 
This manual covers instrument     REV DATE 7/13/2011 
serial #s: 2001 and higher      MANUAL P/N 98405200A 
        CD P/N  98405299A 

 

http://www.wtcom.com/


Boonton 4500B RF Peak Power Analyzer 

Contents ii 

 
 
 
 
 
 
 
 
 
 
 
 

 
 

 
 
 
INSTRUCTION MANUAL, MODEL 4500B RF PEAK POWER ANALYZER 
 

Revision date 7/13/2011 
 
© Copyright in 2005-2011, by BOONTON Electronics, a subsidiary of the Wireless Telecom 
Group, Inc. 
 
Parsippany, NJ, USA.  All rights reserved.   
 
P/N 98405200A 
 

This manual covers instrument serial numbers: 2001 and higher. 
 
Windows® and Windows XP® are trademarks of Microsoft Corporation. 
 
The Windows XP™ Operating System used in this product is licensed by Microsoft® Corporation. 
The 4500B Application software used in this product is licensed by Boonton Electronics, a 
subsidiary of the Wireless Telecom Group, Inc.  
 
K-Connector® is a registered trademark of Anritsu Corporation. 

 



Boonton 4500B RF Peak Power Analyzer 

Contents iii 

SAFETY SUMMARY 
  

The following general safety precautions must be observed during all phases of operation and maintenance 

of this instrument. Failure to comply with these precautions or with specific warnings elsewhere in this 

manual violates safety standards of design, manufacture, and intended use of the instrument. Boonton 

Electronics assumes no liability for the customer‘s failure to comply with these requirements. 

 

 

THE INSTRUMENT MUST BE GROUNDED 
 

To minimize shock hazard the instrument chassis and cabinet must be connected to an electrical ground. 

The instrument is equipped with a NEMA three conductor, three prong power cable. The power cable must 

either be plugged into an approved three-contact electrical outlet or used with a three-contact to a two-

contact adapter with the (green) grounding wire firmly connected to an electrical ground in the power 

outlet. 

 

 

DO NOT OPERATE THE INSTRUMENT IN AN EXPLOSIVE ATMOSPHERE 
 

Do not operate the instrument in the presence of flammable gases or fumes. 

 

 
KEEP AWAY FROM LIVE CIRCUITS 
 
Operating personnel must not remove instrument covers. Component replacement and internal adjustments 

must be made by qualified maintenance personnel. Do not replace components with the power cable 

connected. Under certain conditions dangerous voltages may exist even though the power cable was 

removed, therefore; always disconnect power and discharge circuits before touching them. 

 

 
DO NOT SERVICE OR ADJUST ALONE 
 

Do not attempt internal service or adjustment unless another person, capable or rendering first aid and 

resuscitation, is present. 

 

 
DO NOT SUBSTITUTE PARTS OR MODIFY INSTRUMENT 
 
Do not install substitute parts or perform any unauthorized modifications or the instrument. Return the 

instrument to Boonton Electronics for repair to ensure that the safety features are maintained. 

 

 

LITHIUM BATTERIES 
 
This product contains Lithium batteries that must be disposed of in strict compliance with environmental 

regulations in your jurisdiction.    
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SAFETY SYMBOLS 
 

This safety requirement symbol (located on the rear panel) has been adopted by the 

International Electro-technical Commission, Document 66 (Central Office) 3, Paragraph 

5.3, which directs that an instrument be so labeled if, for the correct use of the instrument, 

it is necessary to refer to the instruction manual. In this case it is recommended that 

reference be made to the instruction manual when connecting the instrument to the proper 

power source. Verify that the correct fuse is installed for the power available. 

 

  

 

 

The CAUTION symbol denotes a hazard. It calls attention to an operational procedure, 

practice or instruction that, if not followed, could result in damage to or destruction of 

part or all of the instrument and accessories. Do not proceed beyond a CAUTION symbol 

until its conditions are fully understood and met. 

 

 

 

 

 

The NOTE symbol is used to mark information which should be read. This information 

can be very useful to the operating in dealing with the subject covered in this section. 

 

 

 

 

 

The HINT symbol is used to identify additional comments which are outside of the 

normal format of the manual, however can give the user additional information about the 

subject. 
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1. General Information 
 
This instruction manual provides you with the information you need to install, operate and maintain the 

Boonton MODEL 4500B RF Peak Power Analyzer. Section 1 is an introduction to the manual and the 

instrument. 

 

 

1.1 Organization 
 

 

The manual is organized into seven sections and three Appendices, as follows: 

 

Section 1 - General Information presents summary descriptions of the instrument and its principal 

features, accessories and options. Also included are specifications for the instrument. 

 

Section 2 - Installation provides instructions for unpacking the instrument, setting it up for operation, 

connecting power and signal cables, and initial power-up. 

 

Section 3 - Getting Started describes the controls and indicators and the initialization of operating 

parameters. Several practice exercises are provided to familiarize you with essential setup and control 

procedures. 

 

Section 4 - Operation describes the display menus and procedures for operating the instrument locally 

from the front panel. 

 

Section 5 - Remote Operation explains the command set and procedures for operating the instrument 

remotely over GPIB bus. 

 

Section 6 - Application Notes describes automatic measurement procedures and presents an analysis of 

measurement accuracy. Definitions are provided for key terms used in this manual and on the screen 

displays. 

 

Section 7 - Maintenance includes procedures for installing software and verifying fault-free operation. 

 

Appendix A - Error Messages defines the messages that are displayed when errors occur. 

 

Appendix B - Warranty and Repair Policy states the policies governing the return and replacement of 

modules and instruments during and after the warranty period. 

 

Appendix C - End User License Agreements 
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1.2 Description 
 
The Model 4500B RF Peak Power Analyzer is the latest generation of BOONTON RF Peak Power Meters 

and Analyzers, including Models 4400, 4500, 4400A, 4500A and 4530. The Model 4500B, when 

operated with 56000, 57000 and 58000 series power sensors, provides the most versatile power measuring 

system available, with capability to make over 25 different power related measurements on captured 

signals. The 4500B is available with a single or dual measurement channels.  

 

All Model 4500B instruments provide two basic measurement modes - pulse power and modulated power 

with an optional third mode - statistical power. Each mode is targeted towards a specific type of 

measurement. 

 

In the pulse power mode the instrument functions as an enhanced peak power analyzer. It can be 

configured as a single or dual channel instrument. This mode provides the functionality of a random 

repetitive sampling oscilloscope for viewing the RF envelope of signal frequencies up to 40 GHz. The RF 

frequency range and detection bandwidth are sensor model dependent. Accuracy approaches that of 

average power meters, but with the ability to capture power versus time data. With the requirement of an 

internal or external trigger event it can automatically measure up to 15 characteristics of the RF envelope. 

These are peak power, pulse power, average power, pulse width, risetime, falltime, overshoot, pulse period, 

pulse repetition rate, duty cycle, top amplitude, bottom amplitude, offtime, edge delay and the delay 

between two RF pulses or an RF pulse with an external trigger signal. In addition to the automatic 

measurements, the instrument offers a powerful set of marker measurements which includes the ability to 

make marker measurements at full accuracy, independent of vertical scale or offset. This is possible 

because of the use of logarithmic amplifiers, and 14-bit analog to digital converters that provide 

rangeless operation. In addition, the markers can be used to define regions of the waveform for analysis. 

This analysis includes average power of a portion of the waveform, minimum power, and maximum power.  

 

The modulated mode is designed for continuous true average power measurements of complex modulated 

signals.   

 

The optional statistical mode of the Model 4500B offers significant new features. This mode does not 

require a trigger event to make measurements and is useful for signals that are noise-like or contain a burst 

of noise-like modulation. In the continuous mode the RF signal is sampled 25 million times per second, 

without discarding or losing any data. In the new gated mode, the samples are taken only within a time 

window related to a trigger. All of this data is processed statistically to determine peak power, average 

power, minimum power, peak to average power ratio, and dynamic range, while reporting the sampling 

time and total samples captured. 

 

The sampled data can be displayed as a CCDF, CDF or PDF statistical function. Power values can be 

expressed in units of power, log power (dBm) or equivalent voltage across 50 ohms. Probability can be 

expressed in percent or in log percent.  
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1.3 Features 

. 

 Software. A control computer running WINDOWS XP™ provides display, I/O and system 

memory functions for the instrument. Each channel contains a dedicated floating-point DSP, 

FPGA and memory to perform the measurement functions. Software updates are easily made 

using a USB memory drive.    

 

 

 Auto-Setup.  The instrument will automatically select a vertical scale, vertical offset, timebase, 

holdoff and trigger level to display at least one pulse period at full amplitude of the full waveform.  

  

 Menu-Driven Operation.  Setup and control of the instrument is menu-driven to simplify 

operation. User-selected parameters appear in a menu to the right of the waveform, together with 

applicable variables. Selections are arranged opposite adjacent ―soft keys‖ that select parameters 

and activate data entry controls. Required numerical values are entered through the keypad, arrow 

keys or spin knob. 

 

 Help Displays.  Context-sensitive HELP screens are accessible at the touch of a key for all menus. 

The HELP information guides the user step-by-step to assure accurate instrument setup. 

 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 1-1. Model 4500B RF Peak Power Analyzer 
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 Color Display Waveforms, control menus, measurement values and related text are displayed on 

an 8.4-inch diagonal, 640 x 480 pixel, VGA color LCD. Display element colors are user-selectable 

to maximize clarity. 

 

 Dual Independent Channels.  When equipped with the optional second measurement channel, the 

instrument can display two pulsed signals and two external trigger signals simultaneously. Each 

channel is calibrated and all channel parameters are channel-independent. 

 

 Balanced Diode Sensors.  The balanced diode sensor configuration provides high sensitivity and 

even-order harmonic suppression. Low VSWR minimizes mismatch errors. Frequency Calibration 

factors traceable to NIST standards are stored in each power sensor‘s EEPROM and downloaded 

to the instrument. A thermal sensor in each power sensor tracks temperature variations. 

 

 Waveform Envelope and Persistence.  The waveform envelope can be displayed and the infinite 

persistence display mode can be used with any waveform. 

 

 Built-In Precision Calibrator. A 1 GHz step calibrator, traceable to NIST, enhances measurement 

accuracy and reliability. The user-selectable automatic calibration routine calibrates the sensor and 

instrument in steps over the full dynamic range. The calibrator also provides a versatile 1 GHz 

pulse modulated test signal. 

 

 Adjustable Averaging.  Random repetitive sampling and averaging with an exponential filter 

(performed on each point of the waveform) reduces noise contribution and provides accurate, 

stable measurements. The number of repetitions to be averaged can be adjusted to the smallest 

value that achieves the desired noise suppression, thereby avoiding excessive averaging delays. 

 

 Automatic Waveform Analysis.   The instrument can measure fifteen pulse parameters related to 

power, time and/or frequency. All programmed measurements are made automatically and 

displayed in text mode. Measurement information is available directly, eliminating the need for 

interpretation by the user. 

 

 Single-Shot Measurements.  The 50 MHz sampling rate yields a 5 MHz single-shot bandwidth (10 

samples per pulse) for capturing and analyzing infrequent events in the time domain. 

 

 USB Ports. A  USB port connector is supplied on the front and rear panels. The port can be used 

with any USB compatible memory device to store data. The instrument can store its setup 

configuration, reference waveforms, trace data or screen images in the USB memory. Stored 

waveforms can be recalled into a reference channel and used for channel math or marker 

measurements. The image and data files can be read and displayed by a PC or output to a 

peripheral device. A USB mouse can be used to navigate the Windows desktop. 

 

 Self-Test and Diagnostics. An automatic self-diagnostic routine can be initiated at any time to 

isolate and identify a faulty module. Error reports direct the user to the relevant instrument module 

or sensor.  

 

 GPIB Bus Control.  All instrument functions except power on/off can be controlled remotely via 

the parallel GPIB bus interface. Setup of interface parameters is menu driven; front panel 

indicators keep the user informed of bus activity. Both SCPI and 4500A emulation languages are 

provided. 

 

 Stored Configurations. For applications in which the same instrument configurations are used 

repeatedly complete setups can be stored and recalled by user defined filename. 
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1.4 Accessories 
 

Optional 4500B accessories that can be ordered from Boonton Electronics. 

 

 

Table 1-1 Accessories for the Model 4500B 
 
Selection           Part Number     Description 

 
Standard 

568106000  Line Cord (US) 

95600401A  Keyboard/Mouse Y-Cable, PS-2 type 

96411301A  Fuse Kit 

53305300A 128M USB Flash Memory Drive 

98601300F  Manual CD-ROM, Boonton Instruments 

 

 

Optional 
54554900A  Fuse, USA (1.6A, Type T, 250V) 

  95005591B  Rack Mounting Kit (Brackets only) 

95005592B  Rack Mounting Kit (Brackets with handles) 

  95105501A  Type N to K Adaptor (for sensors with K-Connector®) 

95600005A  Sensor Cable - 5 ft. (1.52 m) 

95600010A  Sensor Cable - 10 ft. (3.05 m) 

95600020A  Sensor Cable - 20 ft. (6.09 m) 

95600025A  Sensor Cable - 25 ft. (7.62 m) 

95600050A  Sensor Cable - 50 ft. (15.24 m) 

 

 

 

Sensors 
For sensor selection refer to the BOONTON Sensor Manual. 
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1.5 Optional Configurations 

 

Basic.  One measurement channel; the channel and trigger connectors are located on the front panel. 

 

Opt 01. Two measurement channels; the channel and trigger connectors are located on the front panel. 

 

Opt 02. One measurement channel; the channel and trigger connectors are located on the rear panel. 

 

Opt 03. Two measurement channels; the channel and trigger connectors are located on the rear panel. 

 

 

1.5.1 Other Options 
 

Opt 06.  Adds trigger output connector(s) to the rear panel only. 

 

Opt 07.  Move Calibrator Output to rear panel.  

 

Opt 10.  Adds the Statistical function package.  

 

Opt 11.  Adds LAN Remote programmable.  

 

Opt 15.  Security option, customer removable hard drive.   

 

Opt 30.  Extend Warranty to 3 years. 

 

Specials.  Custom configurations have –S/n appended to the model number, where n is a unique number. 

 

 

1.6 Specifications 
 
Performance specifications for the Model 4500B are listed in Table 1-2. 

 

Performance specifications for all power sensors are found in the BOONTON Sensor Manual. 
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Table 1-2 Model 4500B Performance Specifications  
  (Specifications are subject to change without notice) 

 
SENSOR INPUTS               
(performance specifications are sensor model dependent) 

 
RF Frequency Range:  1 MHz to 40 GHz 

Pulse Measurement Range: -40 to +20 dBm 

Modulated Measurement Range: -50 to +20 dBm 

Relative Offset Range:  ±99.99 dB 

 

Vertical Scale: Logarithmic 0.1 to 50 dBm/div in 1-2-5 sequence 

0.1 to 50 dBV/div in 1-2-5 sequence 

0.1 to 50 dBmV/div in 1-2-5 sequence 

    0.1 to 50 dBuV/div in 1-2-5 sequence    

  Linear  1 nW/div to 50 MW/div in 1-2-5 sequence 

1 nV/div to 50 MV/div in 1-2-5 sequence 

 

Rise time:   <3 nsec 

Single-Shot Bandwidth:  5 MHz  (based on 10 samples per pulse) 

Pulse Repetition Rate:  50 MHz max 

Minimum Pulse Width:  6 nsec 

 

 

TIME BASE 
 
Time Base Range:  5 nsec/div to 1 hr/div  

Time Base Accuracy:  0.01% 

Time Base Resolution:  100 psec 

Time Base Display:  Sweeping or Roll Mode 

 

 

X-AXIS (Statistical)  
 
Scale:     Linear or Logarithmic, 1 to 7 cycles   

Linear Ranges:   0.1%/div to 10%/div 

Linear Offset:       0 to 99.9%, 0.1% resolution 

Log Range:   1e-9% to 100%  

 

 

TRIGGER 
 
Trigger Source:   Channel 1 (internal) 

    Channel 2 (internal, with optional channel 2) 

    External Trigger 1 

    External Trigger 2  (with optional channel 2) 

 

Trigger Slope:   + or – 

 

Trigger Delay Range:  Time Base Setting Delay Range; pre trig (-), post trig (+) 

    5 nsec to 500 nsec -4 msec to +100 msec 

    1 usec to 10 msec  4000 divisions 

    20 msec to 3600 sec -40 to +100 sec  
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Table 1-2 Model 4500B Performance Specifications (continued) 
  (Specifications are subject to change without notice) 
 

Trigger Delay Resolution:  0.02 divisions 

 

Trigger Hold-off Range:  0.0 – 1.0 sec 

 

Trigger Hold-off Resolution: 10 nsec 

 

Trigger Mode:   Normal, Auto, Auto pk-to-pk, Free Run 

 

B Trigger Mode:   A only, B Delay-by-time, B Delay-by-events 

 

B Trigger Source:  Chan 1, Chan 2, Ext Trig 1, Ext Trig 2 

 

B Trigger Slope:   + or – 

 

B Trigger Events Counter Range: 1 to 999,999 events 

 

B Trigger Time Delay Range: 0.0 – 1.0 sec in 10 nsec increments 

 

B Trigger Time Delay Resolution: 10 nsec 

 

Internal Trigger Level Range: -39.9 to +20 dBm (sensor dependent) 

 

External Trigger Level Range: ±5 volts, ±50 volts 

 

External Trigger Input:  1 Megohm in parallel with 70 pF, or 50 ohm, DC Coupled 

 

Trigger Output (option 06): One TTL output per channel via rear-panel BNC connector(s).  Output 

indicates state of channel‘s trigger system.  Latency <30ns, minimum 

pulse width 20ns, max pulse frequency 20MHz (trigger source limited). 

 

 

CALIBRATION SOURCE 
 
Operating Modes:  CW, Internal Pulse or External Pulse 

Frequency:   1.024 GHz ± 0.01% 

Level Range:   -50 to +20 dBm  

Resolution:   0.1 dB 

Output VSWR:   1.20 maximum 

CW Absolute Accuracy:  ±0.065 dB (±1.5%) at 0 dBm 

CW Accuracy vs level:  add ±0.03 dB per 5 dB increment from 0 dBm 

 

Preset Internal Pulse Period: 100 usec, 1 msec or 10 msec 

Preset Internal Pulse Duty Cycle: 10% to 90% in 10% increments 

 

Variable Pulse On Time:    7 usec to 65.535 msec in 1 usec steps 

Variable Pulse Period:    28 usec to 131.072 msec in 2 usec steps 

    Off-time limits - within 7 usec to 65.535 msec  

 

Pulse Polarity;   + or – 

RF Connector:   Precision Type N 

External Pulse Input:  Rear panel BNC, TTL level compatible 

Auto-calibration: The Calibrator is used to automatically generate linearity calibration 

data for peak power sensors. It is also provides test signals. 
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Table 1-2 Model 4500B Performance Specifications (continued) 
  (Specifications are subject to change without notice) 
 
 

MEASUREMENT SYSTEM 
 
Sensor inputs:   One or two sensor measurement channels. 

Measurement Technique: Random repetitive sampling system that provides pre and post-trigger 

data as well as statistical histogram accumulation. 

Maximum Sampling Rate: 50 Mega-samples/second on four channels simultaneously. (Equivalent 

effective sampling rate of 10 Giga-samples/second) 

Memory depth: 1 million samples at max sampling rate 

Vertical Resolution: 0.008%, 14-bit A/D Converter 

Waveform Averaging: 1 to 16,384 samples per data point (time domain measurement) 

Number of Histogram Bins: 16,384 

Size of Sample Bins: 32-bits 

Bin Power Resolution: <0.02 dB 

 

 

 

STATISTICAL ACQUISITION 
 
Modes: Continuous and gated by pulse mode time markers 

Sampling rate: 25 Mega-samples/second on 2 channels simultaneously. 

Limit count:   Adjustable, 2 – 4096 Mega-samples 

Terminal action: Stop, flush and or decimate 

 

 

 

SYSTEM DISPLAYS 
 
Power versus time (PULSE MODE) 

Power versus time (MODULATED MODE) 

Cumulative Distribution Function (CDF) 

Complementary Cumulative Distribution Function (CCDF) 

Split screen, Gated CCDF and Power versus time  

Distribution Function (Histogram) 

External Trigger versus time (PULSE MODE) 

External Trigger statistical (STATISTICAL MODE) 

Auto-measure Text (PULSE MODE) 

Auto-measure Text (Statistical Mode) 

Help Text (All Modes) 

Reports (Sensors, Configuration, Calibrator, Files, Stored Waveforms, GPIB Commands, GPIB Buffers) 

 

 

  
PULSE AND MODULATED MODE MARKER MEASUREMENTS 
 
Markers (vertical cursors) are settable in time relative to the trigger position: 

 

For each marker independently: Power at specified time 
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Table 1-2 Model 4500B Performance Specifications (continued) 
  (Specifications are subject to change without notice) 
 

 

For a pair of markers: Power at two specified times and the ratio or average power between 

them 

The minimum and maximum power between the markers and the ratio 

or average power between them 

    The average power, peak power (hold) and peak-to-average power ratio 

    between the markers 

    Statistical analysis between markers (using triggered statistical mode) 

  

Reference lines (horizontal cursors) are settable in power and may be automatically set to track the 

intersection of either marker and the waveform or either marker and pulse distal, mesial or proximal levels. 

 
 

 

STATISTICAL MODE MARKER MEASUREMENTS 
 
Markers (vertical cursors) are settable in percent (distribution functions): 

 

For each marker independently: Power at specified percent   

For a pair of markers:  Power ratio at two specified percents. 

 

 

Reference lines (horizontal cursors) are settable in power and may be automatically set to track the 

intersection of either marker and the distribution function. Ref lines also can measure the percent at a set 

power level. 

 
  

PULSE MODE AUTOMATIC MEASUREMENTS 
 
The following automatic measurements are selectable in the power versus time (Pulse) mode: 

 

    Pulse width 

 Pulse rise-time 

 Pulse fall-time 

 Pulse period 

 Pulse repetition frequency 

 Pulse duty cycle 

 Pulse off-time 

 Peak power 

 Pulse power 

 Percent overshoot 

 Average power 

 IEEE Top level power 

 IEEE Bottom level power 

 Skew 

 Edge delay 
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Table 1-2 Model 4500B Performance Specifications (continued) 
  (Specifications are subject to change without notice) 
 
 
MODULATED MODE AUTOMATIC MEASUREMENTS 
 
The following automatic measurements are continuously updated during signal acquisition in the  

modulated mode: 

 
Average power 

Peak power 

Minimum power 

Peak to Average ratio 

Dynamic range 
 
 
 
STATISTICAL MODE AUTOMATIC MEASUREMENTS 
 
The following automatic measurements are continuously updated during signal acquisition in the statistical   

Mode (with Option 10 only): 

 

 Peak power 

 Average power 

     Minimum power 

 Peak to Average ratio 

 Dynamic range 

 Power at Markers 

 Percent at Reference Lines 

 Total time (indicated) 

 Total number of samples (indicated) 

 

 

 

WAVEFORM STORAGE 
 
Waveforms and Distribution Functions can be saved to and recalled from internal storage locations and 

removable file-based memory devices.  

 

 
EXTERNAL INTERFACES 

 
GPIB:   Programmable interface; complies with SCPI ver.  

 

RS-232C:    Serial Printer/Plotter interface 

 

USB:   General purpose I/O interface 

 

LPT1:   Parallel Printer/Plotter (Centronics type) 

 

LAN:   Ethernet port 
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Table 1-2 Model 4500B Performance Specifications (continued) 
  (Specifications are subject to change without notice) 
 

OTHER CHARACTERISTICS 
 
Display:   8.4‖ Diagonal TFT color LCD, 640 x 480 pixels, with CCFL Backlight. 

 

Main Computer:  Pentium based single board computer 

 

Hard Disk:  Internal EIDE 40 Gbytes 

 

DSP:    32-bit Floating Point DSP in each installed channel  

 

CE Mark:   Compliance for use in the European Union 

   Safety: EN61010-1 

EMC: EN 61326, EN 61000-4-2, EN 61000-4-3, 

EN 61000-4-4, EN 61000-4-5, EN 61000-4-6, 

EN 61000-4-8, EN 61000-4-11, EN 55022 

 

Operating Temperature: 0 to 50 degrees C 

 

Storage Temperature: -20 to +70 degrees C 

 

Humidity:  0 to 95% (non-condensing) 

 

Power Requirements: 90 to 260 VAC, 47 to 63 Hz, 120W 

 

Dimensions:  19‖ rack-mountable; 7‖ x 17.5‖ x 19.5‖ HWD 

 

Weight:   25 lbs (approx) 

 

Construction:  Manufactured to the intent of MIL-PRF-28800F, Class 4 
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2. Installation 
 

This section contains unpacking and repacking instructions, power requirements, connection descriptions and 

preliminary checkout procedures. 

 

 

2.1 Unpacking & Repacking 
 
The Model 4500B is shipped complete and is ready to use upon receipt. Figure 2-1 shows you the various 

pieces included in the packaging and the order in which they are loaded into the container. Actual details may 

vary from the illustration. 

 
 

Note  Save the packing material and container to ship the instrument, if necessary. If the original 

materials (or suitable substitute) are not available, contact Boonton Electronics to purchase 

replacements. Store materials in a dry environment. Refer to the Physical and 

Environmental Specifications in Table 1-2. for further information. 

 
 

 
Figure 2-1. Packaging Diagram 
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Table 2-1 Model 4500B Packing List 
 
INSTRUMENT (See also Table 1-1) 
 

Model 4500B RF Peak Power Analyzer    

Line Cord 

Y-Cable (PS-2)       

Fuse Kit 

USB Flash ROM Drive (Contains a copy of the application software) 

Instruction Manual, Boonton Instruments (CDROM) 

 

SENSOR(S) (packaged separately) 
Sensor(s) 

Sensor Cable(s) 

Type N to SMA Adapter (if required) 

 

 

For bench-top use, choose a clear, uncluttered area. Ensure that there is at least 6" of clearance at the air 

intake and exhaust vents on the rear of the case. Pull-down feet are located on the bottom of the instrument. 

Rack mounting instructions are provided with the (optional) rack mount kit. 

 

 

2.2 Power Requirements 
 

The Model 4500B is equipped with a switching power supply that provides automatic operation from a 90 to 

260 volt, 47 to 63 Hz, single-phase, AC power source. Power consumption is 125VA maximum. For metric 

fuse sizes, use the metric fuse kit supplied. Connect the power cord supplied with the instrument to the power 

receptacle on the rear panel. See Figure 3-2.  

 

 

Caution  Before connecting the instrument to the power source, make certain that a 1.6 ampere time 

delay fuse is installed in the fuse holder on the rear panel.  

 

Before removing the instrument cover or any of the circuit boards, position the input 

module power switch to off (0 = OFF; 1 = ON) and disconnect the power cord. 

 

 

 

 

2.3 Connections 
 

Sensor(s) Connect the sensor that covers the frequency range of the measurement to the  

CHANNEL 1 sensor connector on the front (Standard) or rear (Optional) panel, 

as follows. Connect the sensor to the sensor cable by aligning the red mark on 

each part and pressing the connectors together firmly. Connect the sensor cable 

to the CHANNEL 1 Input, holding the red mark on the cable connector up. For 

two-channel measurements, use the same procedures to connect the second 

sensor to the CHANNEL 2 Input. 
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Note  If the sensor connector is not a type N, install the appropriate adapter (from the  

  accessories kit) on the calibrator output connector. 

 

 

 

 
 

 

Trigger  For measurements requiring external triggering, connect the external trigger  

signal to TRIGGER Input 1. For two-channel measurements requiring two  

external triggers, connect the Channel 2 trigger signal to TRIGGER Input 2. 

 

 

Printer / Plotter If a printer or plotter is to be used to record measurement data, connect the 

   device to the RS-232 connector or LPT1 port on the rear panel, or USB port on  

   the front or rear panel, with an appropriate cable. 

 

 

GPIB   If the instrument is to be operated remotely, using the GPIB (IEEE-488) bus, 

connect the instrument to the bus using the rear panel GPIB connector and  

appropriate cable. 

 

 

 

2.4 Preliminary Check 
 

The following preliminary check verifies that the instrument is operational and has the correct software 

installed. It should be performed before the instrument is placed into service. To perform the preliminary 

check, proceed as follows: 

 

 

1. Press the lower half (marked "0") of the power switch in the center of the power module on the rear 

panel.  

 

2. Connect the AC (mains) power cord to a suitable AC power source; 90 to 260 volts AC, 47 to 63 Hz, 

with a capacity in excess of 125 W. The power supply will automatically adjust to voltages within this 

range.  

 

3. Press the upper half (marked "1") of the power switch in the center of the power module on the rear 

panel. The yellow ―STBY‖ LED on the front panel should be lit. 

 

4. Press the PWR key to turn the instrument on. The green ―ON‖ LED on the front panel should be lit. 

 

5. After a self-check, the instrument will execute the application program. A blue and white initialization 

screen should briefly appear that shows the instrument name, model number, and software version. After 

several moments a screen similar to Figure 2-2 should be displayed. 

 

6. On the front panel, press the UTIL function key followed by the Util > Inst Status > REPORT menu 

key. A display similar to Figure 2-3 should appear. 
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7. Verify that the message ―Channel 1 is installed (Rev _._)‖ appears. If a sensor is plugged into channel 1, 

the phrase ―with Sensor Connected" will also appear. A phrase indicating the sensor cable length 

expected may also be appended. 

 

8. If the optional second channel is installed and a sensor is connected to it, a similar message should 

appear for Channel 2. 

 

 

 

Note  If the display does not appear or differs significantly from the illustrated display, try 

reinstalling the instrument software as described in Section 7.5 "Software Upgrade". If this 

does not correct the problem, contact Boonton Electronics for technical support. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2-2. Power-On Display 
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9. Verify that the Instrument Serial Number matches the number on the label at the top center of the rear 

panel. See Figure 3-2. If an improper serial number appears on the screen, contact Boonton Electronics 

for technical support. 

 

10. Follow steps in Sections 3.4 and 3.5 to initialize and calibrate the instrument. 

 

 

 

Note  You will not be able to perform measurements with the Model 4500B until an AutoCal 

procedure (see Section 3.5) has been performed on the measurement channel. However, 

AutoCal data is saved when power is removed, so AutoCal need not be repeated with each 

power-on. 

 
 
. 
 

 

 

  
 

 
 
 
 
 
 

 

 

 

 

 

 

 
. 

 

 

 

 

 

 

 

 

 
Figure 2-3. Util > Inst Status Display 
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3. Getting Started 
 
This chapter will introduce the user to the Model 4500B. The chapter will identify objects on the front and rear panels, 

identify display organization, list the initial configuration of the instrument after reset, demonstrate how to calibrate the 

sensors, and provide practice exercises for front panel operation. For additional information you should see Chapter 4 

"Operation." 

 

3.1 Organization 
 

Subsection 3.2 Operating Controls, Indicators and Connections identifies the control features and connections on the front 

and rear panels. 

 

Subsection 3.3 Monitor Display describes the data fields in the standard (graphic mode) display. 

 

Subsection 3.4 Initialization explains how to turn the instrument on for the first time, connect a sensor, set the instrument up 

for operation, and initialize it to a known state. See Table 3-3. for initialized parameters and their values. 

 

Subsection 3.5 Calibration is critical to the proper operation of an instrument. The Model 4500B comes with a 1 GHz level 

programmable calibrator. Before making any measurement the sensor(s) must be calibrated. 

 

Subsection 3.6 Practice Exercises for power measurements, in pulse mode. Pulse mode operation requires an internal or 

external trigger event. 

 

Subsection 3.7 Practice Exercises for statistical power measurement. 

 

 

 

3.2 Operating Controls, Indicators and Connections 

 

 

 Figures 3-1 and 3-2 illustrate the controls, indicators and connectors on the front and rear panels, respectively, of the 

standard instrument. Refer to Table 3-1 for a description of each of the illustrated items. Connectors indicated by an asterisk 

(*) may be front or rear-mounted, depending on the option selected. The function and operation of all controls, indicators and 

connectors are the same on the standard and optional models. 
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Figure 3-1. Standard Model 4500B RF Peak Power Analyzer - Front Panel 
 
 
 
 
 
 

 

Table 3-1 Operating Controls, Indicators and Connections 
 

Ref. No. 
Front  Rear  Nomenclature   Function 
 

1  Display screen     VGA LCD color display for the measurement and trigger channels, screen  

    menus, status messages, text reports and help screens. 

 
2  Menu keys   Six keys which enable the user to make an entry, a selection  

choose a submenu.  (PC kbd equivalent: F1 – F6) 

 
    3    PREV key   Returns control to the next higher menu in the hierarchy or to 

the previous menu displayed, depending on whether the current and previous 

menu are from the same or different branches of the menu tree. 

(PC kbd equivalent: Shift-TAB) 
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Figure 3-1a. Model 4500B - Front Panel – System and Function keys 
 
 
 

Table 3-1 Operating Controls, Indicators and Connections (continued) 

 
Ref. No. 
Front  Rear  Nomenclature   Function 
 
  4   System keys  ESC key. In Local mode, this key returns control to the Top Level Menu, exits  

      operations in process, and clears reports.  (PC kbd equivalent: ESC) 

 
TEXT/(GRAPH) key. Selects either a text report of automatic waveform 

measurement results or the standard (graphics) display of waveforms, menus 

and messages.  (PC kbd equivalent: Cntl-T) 

 

HELP key. Presents a Help screen containing brief operating instructions for 

each displayed menu function. When a red error message is displayed, pressing 

HELP will provide more detailed information about the error.  (PC kbd 

equivalent: Cntl-H) 

 

PRINT key. Creates a .bmp or .pcx file of the image on the display screen when 

the key is pressed.  (PC kbd equivalent: Cntl-P) 

 

INIT key. Initializes the measurement/display selections and parameters to a set 

of default values.  (PC kbd equivalent: Cntl-I) 

 

LOCAL key. When the instrument is remote-enabled, pressing this key returns 

it to the Local mode unless the local lockout mode is set by the controller. 
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Table 3-1 Operating Controls, Indicators and Connections (continued) 

 
Ref. No. 
Front  Rear  Nomenclature   Function 
 
5 Function keys   CHAN/(NEXT) key. Selects the next channel in sequence and enables the   

display and adjustment of on/off, vertical scale, vertical center and calibration 

for each channel; by extension enables unit selection, offset corrections and 

mode dependent parameters.  (PC kbd equivalent: Alt-C) 

 

     TIME/(STAT) key. Selects timebase and horizontal position of displayed 

waveforms. In optional statistical mode selects the horizontal probability scale,  

the horizontal position of distribution functions and other parameters.  (PC kbd 

equivalent: Alt-T)  
 

TRIG key. Specifies trigger mode, source, level, polarity and holdoff and 

selects B trigger menu. In optional statistical mode controls gating.  (PC kbd 

equivalent: Alt-G) 

 

MARK key. Positions the selected marker on the horizontal axis. By extension 

controls marker channel assignment and marker math.  (PC kbd equivalent: Alt-

M) 

 

REF key. Positions the selected reference lines on the vertical axis and by 

extension controls channel assignment and tracking.  (PC kbd equivalent: Alt-R) 

 

     SHIFT key. Future expansion and message directed use.  

 

MEAS key. Entry of measurement frequency and controls channel tracking of 

frequency. By extension sets up auto measure parameter display.  (PC kbd 

equivalent: Alt-E) 

 

UTIL key. Selects  instrument status report, GPIB remote configuration, disk 

file management, printing and clock functions.  (PC kbd equivalent: Alt-U) 

 

CAL key. Controls internal I GHz Calibrator.  (PC kbd equivalent: Alt-L) 

    

PRGM key. Stores and recalls instrument setup data, reference waveforms, and 

trace data to internal and external memory.  (PC kbd equivalent: Alt-P) 

 

DISP key. Controls the appearance of the displays, including back-lighting , 

color, trace style, grid type, color and persistence.  (PC kbd equivalent: Alt-D) 

 

SPCL key. Reports sensor parameters and provides servicing information and 

functions.  (PC kbd equivalent: Alt-S) 
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Figure 3-1b. Model 4500B - Front Panel – System and Function keys 
 

 

Table 3-1 Operating Controls, Indicators and Connections (continued) 

 
Ref. No. 
Front  Rear  Nomenclature   Function 
 
7 Inputs parameters and selections to the instrument; duplicates the spin knob and 

data entry keypad; increments/decrements in single steps or repeats if held 

down.  (PC kbd equivalents: +, -, <, >) 

 

8 USB (1) port for loading the operating program and storing/recalling data. 

 

9 * Calibrator output Type-N for the 1 GHz calibrator signal.  
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Table 3-1 Operating Controls, Indicators and Connections (continued) 

 
Ref. No. 
Front  Rear  Nomenclature   Function 
 
10 Spin knob Inputs control parameters and selections to the instrument. Input   

values are automatically limited to their allowable minimums and maximums. 

Duplicates the and data entry keypad. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-1c. Model 4500B - Front Panel – Connectors and PWR key 
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Table 3-1 Operating Controls, Indicators and Connections (continued) 

 
Ref. No. 
Front  Rear  Nomenclature   Function 

 
11  * Trigger input BNC connector for Channel 1 and (optional) Channel 2 trigger 

signals.  

 

12 Data entry keypad for parameter input and selections to the instrument. Includes 

keys to specify units and to clear display errors.  (PC kbd equivalents: <ENT>,  

0 – 9, ‗.‘ , ‗-', m, u, n, G, M, K) 

 

13 * Measurement channel multipin sensor connector for Channel 1 and (optional) 

Channel 2. For connecting BOONTON peak power sensors ONLY!  

 

14  ON-STBY switch. In STBY (Standby) mode, amber LED is on and internal 1 

GHz calibrator remains powered (not operable) to enhance accuracy and 

stability; other modules are off. In ON mode, green LED is on and all modules 

are powered and operable. From ON mode, press once to go to Standby. To 

force the Standby condition, hold down for at least 3 seconds. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-2. Model 4500B - Rear Panel 
(Shown without optional rear panel connectors) 
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Figure 3-2a. Model 4500B - Rear Panel I/O connectors 
 
 
 
 
 
 

Table 3-1 Operating Controls, Indicators and Connections (continued) 

 
Ref. No. 
Front  Rear  Nomenclature   Function 

 
15 COM1 RS-232C Connector 

 

16 LPT1 Parallel Printer Connector (Centronics) 

 

17 Fuse holder (See Table 1-1). 

 

18 Intake cooling fan and filter 

 

19 Exhaust cooling fan 

 

20 NEMA power cord connector. Supplies AC power to the instrument (see 

Subsection 2.2). 

 

21 Power switch. Connects or disconnects all power to the instrument; overrides 

PWR switch. 
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Table 3-1 Operating Controls, Indicators and Connections (continued) 

 
Ref. No. 
Front  Rear  Nomenclature   Function 
 

22 External pulse. Input for external pulse generator to calibrator. TTL compatible.  

  

23 GPIB connector. Connects instrument to a GPIB bus controller.  

 

24 USB (2) port for loading the operating program and storing/recalling data. 

 

25 COM2 RS-232C Connector 

 

26 LAN Connector 

 

27 SVGA Video Connector for CRT or LCD monitor 

 

28 System Keyboard Connector. With Y-Adapter dual mode, Keyboard and Mouse. 

 

* May be front or rear-mounted, depending on the option selected. 

 

 

 

 

3.3 LCD Monitor Display 
 

This subsection includes a picture (Figure 3-3) and a table (Table 3-2) of descriptions of the display layout of the Model 

4500B. Figure 3-3a shows the graphics (trace) display mode of the instrument. Figure 3-3b shows the text (automeasure) 

display mode of the instrument. In addition there are text formats for reports, files and help. See Section 4.5 for more 

information on the display format. 

 

 

Table 3-2 LCD Monitor Display Fields 
Ref. No.  Field Name    Description 
 
     1   Header     Can be set to display the Boonton logo and mode, 

date/time, sensor temperature or blank. 

 
     2  Path name    Lists the all of the menus in the path of the current 

menu. 

 

     3   Menu     The current menu. 

 

     4   Error field    Identifies errors as they occur. 
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Figure 3-3a. LCD Monitor Graphic Display 
 
 
 

Table 3-2 LCD Monitor Display Fields   (continued) 

 
Ref. No.  Field Name    Description 
 

     5   Timebase    Indicates the timebase per division selected for the  

waveform display. 

 

     6   Message line    Describes ongoing operations. 

 

     7   Priority message    Displays status on a priority basis. Messages include ―Measuring  

Stopped‖, ―No Sensor‖, ―Needs AutoCal‖, ―AutoTriggering‖, ―Waiting 

for Trigger‖ and ―Capturing New Data‖. When multiple messages are 

active, the message having the highest priority is displayed. For 

example, if no sensor is connected, only the ―No Sensor‖ message is 

displayed; the lower priority  ―Sensor Needs AutoCal‖ message is 

suppressed. 
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Table 3-2 LCD Monitor Display Fields   (continued) 

 
Ref. No.  Field Name    Description 
 

    8   Marker measurements   The two outside fields display the instantaneous average power  or 

      maximum (or minimum) power at Time Markers 1 and 2. (Marker 1 is 

      on the left; Marker 2 is on the right.) The field above the centerline may  

      display either the ratio of the two power levels, the difference of the 

      two power levels or the average power in the waveform segment 

      located between the Time Markers. It can also show the peak-to- 

average ratio between the markers. See Section 4.12 for a complete 

description of marker functions. 

 

     9   Vertical Markers    There are two vertical markers that allow level measurements at  

      specific times relative to the trigger event. . See Section 4.12  for a  

complete description of marker functions 

 

10   Parameters    Displays a table of measurement status parameters for the currently   

selected channel or any selected  automatic measurement. 

 

   11  Active Marker Indicator   This indicator shows the marker that is active in the marker menu and  

is the measurement at the marker with the triangle located on the 

vertical markers in the waveform display. 

 

12   Time Base Limits   These fields show the timebase limits. In the pulse mode the time is  

relative to the trigger event. 

 

 

13   GPIB Status   The small field at the bottom of the menu column is 

       the GPIB status indicator.  

 

      Blank  - GPIB is not active and in Local state. 

 

REM.  Indicates the 4500B is in the Remote state. 

 

      LSN. Indicates the 4500B is addressed to Listen. 

. 

      TLK. Indicates the 4500B is addressed to Talk. 

 

      SRQ. Indicates the 4500B is requesting service from 

 the bus controller. 
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Figure 3-3b. LCD Monitor Text Display 
 

 

 

 

 

 

3.4 Initialize 

 

The procedures presented in this section will initialize the Model 4500B and prepare it for operation. Steps 1 through 3 

should be performed every time you turn on the instrument. Step 4 only needs to be performed when you wish to return the 

instrument operation to a known state. This usually occurs after turning the instrument on or at the beginning of a new test. If 

you have completed Subsection 2.4 Preliminary Check, you may skip this section and continue to Subsection 3.6 Practice 

Exercises. 

 

STEP    PROCEDURE 
 

1. If the main power is off, press the power switch located on the rear panel. See Figure 3-2. If the 

STBY indicator LED on the front panel is on, press the PWR key. See Figure 3-1. After a self-check, the instrument 

will execute the application program. A brief initialization screen will appear, which shows the instrument name, 

model number, and software version. After several moments the main measurement screen will appear. If it is 

necessary to change the sensor installed on the instrument, perform Steps 2, 3 and 4. 
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Caution 
 

When selecting a sensor for an exercise or a measurement, be sure you know the power range of the sensor. 

Extended operation beyond the sensor‘s specified upper power limit may result in permanent change of 

characteristics or burnout. 

 

 

 

2. Connect the sensor to the sensor cable by aligning the red mark on each part and pressing the connectors together 

firmly.  

 

3.    Connect the sensor cable to the Channel 1 input (holding the red mark UP). 

 

When the sensor is connected, the instrument will download the factory installed calibration data from the sensor 

memory. While the download is in process, the message ―CH 1 Sensor Data Loading‖ will appear on the display. If 

the sensor is disconnected during the download, either the ―Sensor Data Error‖ or ―I2C Error‖ message will appear. 

When this occurs, (press CLR) to clear the error; reconnect the sensor. 

 

In general, when any sensor error message occurs, disconnect and reconnect the sensor and press CLR. If the 

message persists, refer the problem to Boonton Electronics for technical support. 

 

 

Note  The INIT key does not affect parameters selected for the GPIB Bus, RS-232, display colors, or the printer 

configurations. It does not affect stored waveforms, setups or calibrations. 

 

 

 

 

 

4 .  Press the INIT function key to initialize the operating parameters listed in Table 3-3. This table represents all the 

parameters that are affected by initialization. This table lists the value or the option to which the function will be 

assigned after initialization. 
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Table 3-3. Initialized Parameters 

 
Parameter     Applies to:     Default 
 

Graph/Text/Help Mode Select       Graph 

 

Top Level Menu 
Measurement        Run 

Measurement Mode       Pulse                                                       

 

Parameters Related to the Chan # > Menu   

Select          CH 1 

Channel      CH1    On 

CH2, CH Math   Off 

TRIG1, TRIG2                    Off 

MEM1, MEM2   Off 

Vertical Scale (active marker) 

Log Power   All Channels   20 dB/Div 

Linear Power   All Channels   20 mW/Div 

Log Volts    All Channels   10 dBV/Div 

Linear Volts   All Channels   200mV/Div 

 Trig display      TRIG1, TRIG2   0.5 V/Div 

Vertical Center 

Log     All Channels   0.00 dB 

Linear     All Channels   0.00 dBm  

Trig display   TRIG1, TRIG2   0 Volts 

Extensions (Menu) 

 Units    CH1, CH2, CH Math  dBm 

     MEM1, MEM2   dBm 

     TRIG1, TRIG2   Volts 

      dB Offset   CH1, CH2   0.00 dB 

Freq CF    CH1, CH2         (if no sensor, 0.00 dB)   

  Peak Hold (Pulse, Modulated)    All Channels   Off  

 

Define Pulse    

 Distal   All Except CH Math  90% 

 Mesial   All Except CH Math  50% 

 Proximal  All Except CH Math  10% 

 Pulse Units  All Except CH Math  Volts 

Video Bandwidth /Bandwidth CH1, CH2/TRIG1, TRIG2  High 

Averaging    CH1, CH2, TRIG1, TRIG2 8 

Filter     CH1, CH2, TRIG1, TRIG2 Auto 

Range    TRIG1, TRIG2   +/-50V 

Impedance   TRIG1, TRIG2   1M Ohms 
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Table 3-3. Initialized Parameters  (continued) 

 
Parameter     Applies to:     Default 
 

 

 Expression      

Argument A    CH Math   CH1 

Operator    CH Math   - 

Argument B    CH Math   CH 2 

  Result Units   CH Math   mW 

Display Units   CH Math   dBm 

 

 

 

Parameters Related to the Disp > Menu   

Persistence         Off 

 Envelope        Off 

 Beep        (not changed by init) 

 Brightness       (not changed by init)  

 Screen Saver (Menu)         

  Brightness      (not changed by init)  

  Delay Time      (not changed by init)  

 Format (Menu) 

Grid Type       (not changed by init)  

  Trace Type    All Channels   (not changed by init)  

Disp Header       (not changed by init)  

Set Colors   (not changed by init) 

 

 

Parameters Related to the Mark > Menu 

Marker 1 (active marker)    Pulse Mode    5 us 

 Marker 2    Pulse Mode    -10 us 

 Marker 1 (active marker)    Statistical Mode    0.00 % 

Marker 2     Statistical Mode   50.00 % 

 Extensions (menu) 

  MK Group        Both 

Marker Chan       Active 

Delta Marker    Pulse Mode   Ratio 

      Stat Mode   Ratio 

  Mk Math    Pulse Mode    MK2-MK1 

      Stat Mode    MK1-MK2 
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Table 3-3. Initialized Parameters  (continued) 

 
Parameter     Applies to:     Default 
 

Parameters Related to the Ref > Menu 

 REF Line 1        0.00 dBm 

 REF Line 2         0.00 dBm 

 Extensions (Menu) 

  REF CH Sel        Off   

  REF Tracking    Pulse Mode   Off 

 

 

Parameters Related to the Trig > Menu  

Trig Mode    Pulse Mode    Auto Pk/Pk 

         Stat Mode   Free Run 

Trig Source         CH 1  

Trig Level         Auto  

Trig Slope         + 

HoldOff          0 us 

 B Trigger (menu) 

  B Mode        Off 

 

 

Parameters Related to the Time > Menu  

Timebase     Pulse Mode    50 us/Div 

Position      Pulse Mode   M 

Trig Delay    Pulse Mode          0 us 

Fast Trigger    Pulse Mode   Off 

Presentation    Statistical Mode   Lin 

Horiz Scale    Statistical Mode   10%/Div 

Horiz Offset    Statistical Mode   0.0% 

Statistical Mode        CCDF 

PDF Bars    Statistical Mode   35/Div 

Term Settings (menu) 

Term Time    Statistical Mode   Off 

Term Count    Statistical Mode   100.0 M 

Term Action    Statistical Mode   Decimate 

 

 

Parameters Related to the Meas > Menu  

 Freq Track        Off 

 Freq CH1        1.00 GHz 

 Freq CH2        1.00 GHz 

 Sys Tracking        Off 

 Normalize Pwr    Statistical Mode   Off 

 Param Meas (menu)   Pulse Mode-Status 

  Selection       CH1 

  Param Mode       Status 

 Param Meas (Menu)    Pulse Mode-Meas 

Selection        CH 1 

Param Mode       Meas 

Param Column        L 
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Table 3-3. Initialized Parameters  (continued) 

 
Parameter     Applies to:     Default 
 

Param Top (active menu)       Pulse Width 

Param Middle        Risetime 

Param Bottom        Falltime 

 

 

Parameters Related to the CAL > Menu 

 Cal Output        Off 

Set Level (active menu)       0.0 dBm 

Max Power         20.0 dBm 

Cal Mode         Pulse 

Pulse (Menu)    Preset 

  Source         Int 

Polarity         + 

Duty Cycle        10% 

Pulse Period        100 us 

Pulse Control       Preset 

   

Pulse (Menu)    Var 

  Source         Int 

 Pulse Width       0.007 us 

Pulse Period        0.028 us 

Pulse Control       Var 

  Extensions (Menu)  

  Level Step (active menu)       0.1 dBm 

 

 

Parameters Related to the SPCL > Menu 

 Servicing (Menu) 

  Svc Cal Mode       Off 
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3.5 Calibration 
 

Before any measurements can be acquired with the Model 4500B, a sensor must be connected from the instrument to the 

built-in calibrator, and calibrated. The following steps will guide the operator through the calibration process. This 

explanation covers a single channel configuration. If a second channel and sensor is available, repeat the steps for channel 2. 

 

 

 

 

Note   If the sensor was just connected to the instrument or the instrument was just turned  

on, please wait at least 15 minutes for the instrument to warm up before autocalibration. 

 

Also, if the sensor has been previously calibrated on this instrument and channel, the 4500B will remember 

the calibration and apply the result. If  this is the case, the ―Sensor_ Needs AutoCal‖ message will not 

appear. Instead, normal operation will begin. You may want to continue with the steps following to learn 

the calibration procedure. 

    

 

  STEP      PROCEDURE 
 

1. Connect a Boonton Peak Power sensor to the instrument‘s CHANNEL_ input using the supplied cable. The cable 

will have a silver multipin connector on each end. To connect the cable, align the red dots between the connector 

and sensor and insert. Once the connector clicks into place, the cable will not pull out without sliding the barrel of 

the connector away from the connection point. The other end of the cable connects to the measurement channel (1) 

input connector as identified in Figure 3-1 item 13. 

 

2. Connect the sensor to the "N" connector for the internal calibrator as identified by Figure 3-1 item 9. If the sensor 

has a "K" style connector, use the "K" to "N" adapter (95105501A) provided. 26.5 GHz and 40 GHz sensors will 

need this adapter. 

 

3. Press INIT key. This configures the instrument to pulse mode. However, a pulse waveform will not appear unless 

the calibrator is turned on. 

 

4. Press MEAS key. 

 

5. Select Meas > Freq CH1> by pressing the menu key associated with it. The box around the menu will be 

highlighted. This indicates that the frequency function is selected for number entry. Frequency is given in hertz. To 

select a frequency value of 1 GHz, press the "1" key followed by the "G" (for giga) key. This causes the frequency 

cal factor (correction factor) for the sensor to be read from the sensor‘s internal memory and automatically be 

applied to the measurement. The actual value of the cal factor can be displayed at Chan 1 > Exten > Corrections > 

Freq CF. Although in this case the value should have already been set to 1 GHz by the INIT key, it is good practice 

for learning the operation of the instrument. 

 

6. Press the CHAN function key. 

 

7. Press the Chan 1 > Calibration menu key. 
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STEP      PROCEDURE 

 

8. Press the Chan 1 > Calibration > AutoCal menu key to initiate the automatic zeroing and sensor calibration routine. 

The AutoCal routine will calibrate the entire dynamic range of the sensor in approximately 1.5 minutes while 

reporting status via screen messages. AutoCal will not start if there are any pending errors. Press CLR to clear errors 

before initiating AutoCal. A listing of error messages appears in Appendix A Error Messages. 

 

9. If an error message appears after you have initiated AutoCal, verify the following: 

a. Is the sensor that is connected to the calibrator also connected to the channel indicated in the Chan 1 > 

Select menu? 

b. Are the sensor cable connections secure at both the sensor and instrument input channels? 

c. Were any errors pending before you initiated AutoCal? 

d. Does the instrument pass its self-test (no errors reported when you pressed PWR)? 

To repeat the self-test, press Spcl > Servicing > Self Test. 

e. Has an improper value been entered into the CF in dB window? (Refer to the discussion of the Chan 1 > 

Extensions menu later in this section.) 

f. Are any attenuators or other devices that are connected between the sensor and the calibrator not 

accounted for in the CF in dB value? (Refer to the discussion of the Chan 1 > Extensions menu later in this 

section.)  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 

Figure 3-4. Menus for Sensor Calibration Procedure 
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This completes the Calibration exercise. When you have accomplished these steps, the instrument‘s zero level will 

be properly adjusted, the sensor will be calibrated, the calibrator must be manually turned on and a pulsed waveform 

display will appear. The instrument will be ready for the practice exercises presented in the next subsection. 

 
 
3.6 Practice Exercise for Pulse Power Measurements 
 
 

In the following exercises you will practice adjusting the display settings and pulse train parameters to become 

familiar with the Model 4500B controls. Complete instructions for each control function are presented in Section 4 

OPERATION. 

 

It is suggested that you review the front panel control conventions presented in Subsection 4.3 Menu Conventions 

before proceeding. 

 

Before beginning the exercise connect a sensor to the calibrator from channel 1. In the CALIBRATOR > menu set 

the level to +5 dBm, set Cal Mode to ―Pulse‖, and turn the calibrator output "On". 

 

 

MENU ITEM   EXERCISE 
 
CHAN Press the CHAN function key and perform the following exercises to become familiar with the 

items in the Chan 1 > menu. Continue to press the CHAN function key and the channels will be 

sequentially selected, CH 2, Ext Trig 1, Ext Trig 2, CH Math, Mem 1, Mem 2 and back to CH1. 

 

Chan 1 > Select  Press the Chan 1 > Selection key to open the Chan 1 > Chan Select  > 1 of  2 channel selection 

menu. The first page lists channels CH 1, CH2, Ext Trig 1, Ext Trig 2, CH Math and < -more->. If 

the channel you seek is not listed, press the  

Chan 1 > Chan Select  > 1 of  2 <-more-> key. Chan 1 > Chan Select  > 2 of  2 lists Mem 1, 

Mem 2 and <-more->.  

 

 

Note  There are 2 ways to locate a channel menu. The first is stepping through the list by repeatedly 

pressing the CHAN function key. The second is by pressing  the current Chan_ > Selection key to 

obtain a menu of channels. 

 

 

 

When CH Math is current in the Chan > Select window, those instruments equipped with the 

optional Channel 2 will display the difference between the signals applied to Channels 1 and 2. 

Use the Chan (CH Math) > Expression window to set the operation of the (CH Math) display. 

 

Use the CHAN function key or the Chan_ > Selection menu key to re-select  

CH 1 before proceeding. 

 

 

Chan 1 > Channel Press the Chan > Channel menu key to toggle the CH 1 display ―Off ―and ―On‖. The waveform 

should disappear and reappear. (Leave it ―On‖.) 
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MENU ITEM   EXERCISE 
 

CHAN  (continued) 
 

Chan 1 > Vert Scale If the Chan 1 > Vert Scale selection is not active, press the Chan1 > Vert Scale menu key. Use the 

spin knob or to step the vertical sensitivity of the display through the range from 0.1 dB/Div to 20 

dB/Div. Observe the resulting changes in the pulse height, and note that the VertScale parameter 

changes at each step to match the selected sensitivity. Note also that the display is rescaled without 

recapture of data, and that the markers continue to make full-resolution  measurements on 

waveforms that are off the screen. 

 

 

Chan 1 > Vert Center Press the Chan 1 > Vert Center menu key. Use any of the data entry controls to shift the vertical 

center of the display to correspond to power levels of -10, 0 and +10 dBm. Observe the position of 

the display at each setting and note that the VertCenter parameter changes to match the selected 

level. Note also that the power readings do not change and the display is moved  without recapture 

of data. 

 

 

Chan 1 > Calibration Used at the start of this procedure to calibrate the sensor. 

  

 

Chan 1 > Exten >  Press the Chan 1 > Exten menu key to access the Extensions submenu (Figure 3-6). 

 

 

 

Chan 1 > Exten Press the Chan 1 > Exten >Units menu key to see the Units selection menu. The  

> Units top menu box displays the current units of the channel. To change the units to Watts, Volts, dBV, 

dBmV or dBuV, press the corresponding menu key. The selected unit will appear in the top menu 

box location. Return the units to dBm before proceeding to the next step. 

 

 

Chan 1 > Exten Press the Chan 1 > Exten  > Corrections menu key to see the Corrections sub 

> Corrections menu 

 

 

Chan 1 > Exten Press the Chan 1 > Exten  > Corrections > dB Offset menu key to display or  

>Corrections enter the dB Offset vertically on the display (Positive offsets move the waveform 

> dB Offset  up; negative offsets move it down).  Unlike Chan 1 > Vert Center above, dB offset does affect the 

power readings.  

 

  

 

Note In practice, dB Offset is used to compensate for attenuators or amplifiers inserted between the sensor and 

the device under test. Freq CF is used to compensate for losses in cables, adapters, switches and other line 

equipment inserted between the sensor and the calibrator output, or between the sensor and the device 

under test, but not both. 
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MENU ITEM   EXERCISE 
 

CHAN  (continued) 
 

Chan 1 > Exten  Press the Chan 1 > Exten >Corrections > FreqCF menu key to display or enter a frequency 

>Corrections  cal-factor. If a value is entered it will temporarily override the > FreqCF interpolated value and  

  change Meas > Freq CH1 to ―—― (undefined). If a frequency value is entered into Meas  

   > Freq CH1 or if the 4500B is powered to Standby or OFF, the interpolated value will be restored. 

 

 

Chan 1 > Exten   Not used in this exercise. Leave ―Off‖. 

> Peak Hold   

 

Chan 1 > Exten  Not used in this exercise.  

> Define Pulse 

 

 

 

 

 

 

 

 
 
 
 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-5. Channel Extensions Menu 
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MENU ITEM   EXERCISE 
 

CHAN  (continued) 
 

Chan 1 > Exten  Press the Chan 1 > Extensions > Averaging menu key. Use any of the data entry 

> Averaging controls to select the number of samples to be averaged at each point of the waveform to produce 

the waveform display. Restore the normal setting of  8 before continuing to the next step. 

 
 
TIME   Press the TIME function key and  

perform the following exercises to 

become familiar with the items in the  

Time > menu (Figure 3-7): 

 

 

Time > Timebase This selection will be highlighted. Use  

the spin knob to step the timebase  

through the range from 5 ns/Div to  

1 s/Div. Observe the changes in the 

display and note that for each selection,  

the Time > Tr Dly reading remains 

consistent with the limits set by the  

resolution of the display and pre-trigger  

memory. 

 

For 10 s/Div to 60 min/Div, limits on  

pre-trigger storage size may require  

minimum trigger delay greater than zero  

for the Middle and Right trigger positions. 

 Select the Left edge trigger position to  

avoid this. See below. 

 

 

Time > Position  Press the Time > Position menu key to  

shift the start of the waveform to the left 

(L) edge, middle (M) or right (R) edge of  

the display area. 

 

 

 

             Fig 3-7. Time > Menu 
 

 

 

Note   In practice, this feature is used to observe a specific segment of the waveform. Select ―L‖  

to observe the waveform immediately after the trigger occurs; ―R‖ to observe the waveform immediately 

before; and ―M‖ to observe segments of the waveform just before and after the trigger. 
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Figure 3-8. Trig > Menu 
 
 
MENU ITEM   EXERCISE 
 
 
TRIG Press the TRIG function key and perform the following exercises to become  

familiar with the items in the Trig > menu  (Figure 3-8): 

 
 

Time > Trig Delay  Press the Time > Trig Delay menu key. Use any of the data entry controls to adjust the time delay 

between the trigger and the start of the data capture display. The instrument adjusts the limits of 

the Trig Delay parameter based on the timebase selection to reflect an appropriate resolution for 

that timebase. 

 

 
Time > Fast  Trigger Press the Time > Fast  Trigger menu key to turn the Fast Trigger function on or off. The Fast 

Trigger operates only for mid-timebases (500 us/Div to 2 us/Div) and  minimizes trigger arming 

delay. Used to speed the formation of persistence type displays, e.g. eye diagrams. Normally off. 
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MENU ITEM   EXERCISE 
 

 

TRIG (continued) 
 

Trig > Trig Mode  Press the Trig > Trig Mode menu key to switch between Auto Pk/Pk, Auto, Normal and Free Run.  

 

In Auto mode, if no  trigger signal is present that traverses the  trigger level plus trigger hysteresis, 

the timebase is triggered automatically after a prespecified timeout period.  

 

The Auto Pk/Pk mode continually adjusts the trigger level based on the signal characteristics to 

achieve synchronization. If this is not possible, it triggers the time base automatically after a 

prespecified timeout period. 

 

In the Normal mode, the timebase is triggered only when the trigger signal traverses the trigger 

level plus trigger hysteresis. 

 

The Free Run mode triggers the timebase continually without regard to the trigger signal. This 

mode is used briefly to locate the baseline and signal at the fastest sweep speeds.  

 

Note  The convenient Auto Pk/Pk mode can be used for almost all signals.  

 

 

 

 
 
 
 

Trig > Trig Source Press the Trig > Trig Source menu key to toggle between CH 1, CH2, Ext Trig 1 and Ext TRIG 2. 

The CH 2 and Ext Trig 2 selections will be activated only if the optional Channel 2 is installed. 

The Ext Trig sources require an external signal connected to the corresponding input. 

 

 

Trig > Trig Level  In the Auto Pk/Pk mode, the trigger level is set automatically. In the Auto mode and Normal mode 

use any of the data entry controls to adjust the trigger level. 

 In the Free Run mode trigger level is not used. For CH 1 and CH2 (if installed) the trigger level is 

expressed in the same units as the channel and is allowed to range over the specified trigger level 

range of the sensor in use. For Ext Trig 1 and Ext Trig 2 (if installed) the trigger level range is  

40 volts. 

 

For this exercise, the calibrator pulse test signal is set to +5 dBm. Therefore, the trace will 

disappear or become un-synchronized if the trigger level is set higher than +5 dBm in the Auto or 

Normal modes.  

 

 

Trig > Trig Slope Press the Trig > Trig Slope menu key to toggle between rising edge triggering and falling edge 

triggering. Note that in the Status parameter field at the top of the graph mode display the trigger 

slope is indicated by the sign preceding the name of the trigger channel. 
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MENU ITEM   EXERCISE 
 
TRIG (continued) 
 

 

Trig > HoldOff This effect of this control cannot be easily observed when the calibrator signal is used as the test 

signal. Consequently, it is not used for these exercises. See Table 4-9 for a discussion of the 

HoldOff parameter. 

 

Trig > B Trigger         Not used in this exercise. 

 

 

 

MARK   Press the MARK function key and perform the following exercises to become 

familiar with the items in the Mark > menu (Figure 3-9): 

 

 

Mark > Marker 1 If Marker 1 is inactive, press the Mark >  Marker 1 menu key to activate it. Observe that the 

active marker is designated by triangles at top and bottom. 

Use the spin knob or to move Marker 1 to the leading edge of any pulse in the display. Move the 

marker across the pulse and observe the power reading labeled MK1 (in dBm) located above the 

left-hand side of the waveform display grid box. This reading is the average power level at Marker 

1 and will be displayed in the same color as the measured waveform. Also observe that the Marker 

1 display box shows the time delay of the marker position relative to the trigger event. Use this 

feature to determine the relative time of any point on the measured waveform. 

 

 

Mark > Delta Time Move either marker and observe that the Mark > Delta Time box displays the difference in time 

between the two markers. 

 

 

Mark > Marker 2  If  Marker 2 is inactive, press the Mark > Marker 2 menu key to activate it. Use the spin knob to 

move Marker 2 a few divisions away from Marker 1. Observe that the active marker is designated 

by triangles at top and bottom. Note that the power reading above the right-hand side of the 

waveform grid box labeled MK2 

corresponds to Marker 2. Note also that the ratio of the waveform power levels at Marker 1 and 

Marker 2 (which is equivalent to the difference of the two levels 

expressed in ―dBm‖) is displayed above the centerline of the waveform. 

 

 

Mark > Set Vrt Cntr  Press the Mark > Set Vrt Cntr menu key to move the display window so that the  signal level at 

the active marker crossing will be displayed at the center of the screen. 

 

For example, pressing the Set Vrt Cntr menu key when the active marker is on a pulse measuring 

+10 dBm will shift the display up or down, so that the center of the vertical scale corresponds to 

+10 dBm. If you move the active marker off the pulse so that its power reading is -15 dBm, for 

example, pressing the Set Vrt Cntr key will shift the display so the vertical center corresponds to -

15 dBm When you press the Mark > Set Vrt Cntr menu key, the Vertical Center parameter is 

automatically adjusted in the applicable Chan # > menu. 
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Figure 3-9. Mark > Exten Menu 
 
 
MENU ITEM   EXERCISE 
 
MEAS   Press the MEAS function key, and perform the following exercises to become  

familiar with frequency entry. 

 

 

The instrument will automatically read the frequency correction data from the sensor and apply 

the correction to the measurement. 

 

Because the sensor is connected to the calibrator output for these exercises, the 

measurement frequency must be set to 1.0 GHz (the frequency of the calibrator signal) to obtain a 

valid reading. 

 
 
Meas > Freq Track            This selection turns frequency tracking On and Off. Frequency tracking ―On‖ 

links both channels together with the same frequency. The ―Off‖ setting allows the channels to be 

set to different frequencies. 
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MENU ITEM   EXERCISE 
 
MEAS (continued) 
 
 
Meas > Freq CH1 Use any of the data entry controls to select the measurement frequency for  

CH 1. This frequency selection is used to calculate the required correction factor. 

 

The data can be entered in Hz, kHz, MHz or GHz, however, the frequency must lie within the 

range of the CH 1 sensor in use. If a value outside this range is entered, the nearest limit frequency 

will actually be entered and displayed, and no error will result. The frequency limits may be 

different for the sensor‘s high and low bandwidth ranges. You can find the frequency range limits 

for the sensor in use by pressing the Spcl > Sensor Data > CH 1 Sensor>  Report menu key. If a 

frequency becomes illegal because of a bandwidth change, it will be forced to the nearest limit 

frequency.  The frequency resolution is 0.01 GHz (10 MHz).   

 

 

Meas > Freq CH2 Frequency entry for Channel 2 (if installed) operation. The procedure is the same as for Channel 1 

discussed above. 

 

 

Meas > Sys Tracking When  System Tracking is ―On‖, the following channel parameters are linked together such that 

changing the value in any channel changes the parameter value in all of the linked channels. An 

asterisk  ―*‖ appears in the menu title of linked parameters. The parameters are: Units, Peak Hold, 

Video BW, Averaging, Distal, Mesial, Proximal, Pulse Units Start Gate, End Gate. 

 

 

 

Note The Model 4500B readings are always full scale, so data is not lost when vertical settings are changed. 

Thus, there is no danger of losing data related to events that occur during adjustment of Vertical Scale, 

Vertical Center, dB Offset, Freq CF  or Frequency. 

 

 

 

 

 

 

This concludes the Practice Pulse Power Exercises. Press the INIT function key to clear the practice parameter 

settings and the instrument will be ready to use. 

 

 

Hint  For best results, read the rest of this Instruction Manual through Section 6, APPLICATION NOTES,  

  Before using the Model 4500B to make operational measurements. 
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3.7 Practice Exercise for Statistical Power Measurements (4500B Opt 10 only) 
 

In the following exercises you will practice adjusting settings for the Model 4500B Opt 10 RF Peak Power Analyzer 

in the statistical power mode. In statistical power measurements, the instrument does not require a trigger event from 

the signal to make power measurements. The signal is continuously sampled at 25 million samples per second.  

 

Before beginning the exercise, turn the instrument power on and connect a sensor to channel 1. Press the INIT key 

to initialize the instrument to a known state. Then connect the sensor to the built-in calibrator. If the sensor requires 

calibration see Section 3.5 for instructions. 

 

In the Calibrator > Set Level menu set the calibrator level to +5 dBm, cal mode to pulse and turn the output power 

level on. 

 

  For more information on the statistical power measure mode definitions, see Chapter 6 – Applications. 

 

 

MENU ITEM   EXERCISE 
 
Top Level 
 

> Measure Mode Press > Measure Mode to cycle through the available measurement modes. On the Model 4500B 

Opt 10 these are: Pulse, Modulated and Statistical. Statistical mode sets the 4500B Opt 10 for 

continuous data acquisition with statistical display formats. 

 

 Select the Statistical measurement mode. 

 

 

> Measurement   Toggle > Measurement from RUN to STOP. This will stop the instrument from    

   measuring. 

 

 

>Display   Press > Display: CLEAR to clear all data and display. All readings will go to dashes (invalid).  

Use this function any time old data needs to be cleared and new data captured. Now toggle the  

Measure menu to RUN to start acquiring data. 

 

As the instrument captures data a CCDF (complementary cumulative distribution function) plot 

will appear on the display (Figure 3-14). This plot represents all data points captured by the 

instrument. The plot shows the percentage of points that have been accumulated that are greater 

than a selected power level. By definition of the CCDF, no points greater then the highest or peak 

power have been accumulated, so the peak power value lies at the 0% index.  
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Figure 3-14. CCDF > Statistics Menu 
 
 
 
MENU ITEM   EXERCISE 
 
Top Level (continued) 
 

   Parameter and Marker fields 

    

   There are 9 parameter fields above the statistical display in the graph mode.    

   These are: 

 

  Average Power - The calculated average power based on all samples 

   Total Time - This is the total time over which readings are captured 

Total Points - This is the actual number of samples captured with 0.1 mega sample resolution 

  

   Vertical Scale – current setting 

 

Peak Power - The maximum power level sampled 

   Peak to Average Ratio - Peak power minus the average power in dB 

   Vertical Center – current setting  
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MENU ITEM   EXERCISE 
 
Top Level (continued) 
        

Ref 1, R Delta and Ref 2 - These are the values returned as readings from the  

 horizontal reference lines. The reference lines are set in power and return a value in percent. 

 

   Press the TEXT button and the screen changes to the text mode to show markers, reference lines,  

   and all the automatic measurements on one screen. Press the TEXT button again to change the  

   screen back to the graph display. 

 

 

 
CHAN Press the CHAN function key and perform the following exercises to become familiar with the 

items in the Chan 1 > menu. Continue to press the CHAN function key and the channels will be 

sequentially selected, CH 2, Ext Trig 1, Ext Trig 2, CH Math, Mem 1, Mem 2 and back to CH1. 

 

Chan 1 > Select  Press the Chan 1 > Selection key to open the Chan 1 > Chan Select  > 1 of  2 channel selection 

menu. The first page lists channels CH 1, CH2, Ext Trig 1, Ext Trig 2, CH Math and < -more->. If 

the channel you seek is not listed, press the Chan 1 > Chan Select  > 1 of  2 <-more-> key. Chan 

1 > Chan Select  > 2 of  2 lists Mem 1, Mem 2 and <-more->.  

 

 

Note  There are 2 ways to locate a channel menu. The first is stepping through the list by repeatedly 

pressing the CHAN function key. The second is by pressing  the current Chan_ > Selection key to 

obtain a menu of channels. 

 

 

 

When CH Math is current in the Chan > Select window, those instruments equipped with the 

optional Channel 2 will display the difference between the signals applied to Channels 1 and 2. 

Use the Chan (CH Math) > Expression window to set the operation of the (CH Math) display. 

 

Use the CHAN function key or the Chan_ > Selection menu key to re-select  

CH 1 before proceeding. 

 

 

Chan 1 > Channel Press the Chan > Channel menu key to toggle the CH 1 display ―Off ―and ―On‖. The waveform 

should disappear and reappear. (Leave it ―On‖.) 

 

 

Chan 1 > Vert Scale If the Chan 1 > Vert Scale selection is not active, press the Chan1 > Vert Scale menu key. Use the 

spin knob or to step the vertical sensitivity of the display through the range from 0.1 dB/Div to 20 

dB/Div. Observe the resulting changes in the pulse height, and note that the VertScale parameter 

changes at each step to match the selected sensitivity. Note also that the display is rescaled without 

recapture of data, and that the markers continue to make full-resolution  measurements on 

waveforms that are off the screen. 
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MENU ITEM   EXERCISE 
 

CHAN  (continued) 
 
 

Chan 1 > Vert Center Press the Chan 1 > Vert Center menu key. Use any of the data entry controls to shift the vertical 

center of the display to correspond to power levels of -10, 0 and +10 dBm. Observe the position of 

the display at each setting and note that the VertCenter parameter changes to match the selected 

level. Note also that the power readings do not change and the display is moved  without recapture 

of data. 

 

 

Chan 1 > Calibration Used at the start of this procedure to calibrate the sensor. 

 

 

Chan 1 > Exten >  Press the Chan 1 > Exten menu key to access the Extensions submenu (Figure 3-6). 

 

 

 

Chan 1 > Exten Press the Chan 1 > Exten >Units menu key to see the Units selection menu. The top menu box 

> Units displays the current units of the channel. To change the units to Watts, Volts, dBV, dBmV or 

dBuV, press the corresponding menu key. The selected unit will appear in the top menu box 

location. Return the units to dBm before proceeding to the next step. 

 

 

Chan 1 > Exten Press the Chan 1 > Exten  > Corrections menu key to see the Corrections sub-menu. 

> Corrections  

 

 

Chan 1 > Exten Press the Chan 1 > Exten  > Corrections > dB Offset menu key to display or enter the dB Offset 

>Corrections vertically on the display (Positive offsets move the CCDF up; negative offsets move it down).   

> dB Offset  Unlike Chan 1 > Vert Center above, dB offset does affect the power readings.  

 

  

 
Note In practice, dB Offset is used to compensate for attenuators or amplifiers inserted between the sensor and 

the device under test. Freq CF is used to compensate for losses in cables, adapters, switches and other line 

equipment inserted between the sensor and the calibrator output, or between the sensor and the device 

under test, but not both. 

 

 

 

 

Chan 1 > Exten  Press the Chan 1 > Exten >Corrections > FreqCF menu key to display or enter  a frequency 

>Corrections  cal-factor. If a value is entered it will temporarily override the interpolated value and change 

> FreqCF Meas > Freq CH1 to ―—― (undefined). If a frequency value is entered into Meas > Freq CH1 or if 

the 4500B is powered to Standby or OFF, the interpolated value will be restored. 
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CHAN  (continued) 
 
 

Chan 1 > Exten  Press the Chan 1 > Extensions > Video BW menu key to toggle between the  ―Low‖ (narrowband) 

> Video BW  and ―High‖ (wideband) sensor bandwidths. The bandwidths and risetimes corresponding to the 

―Low‖ and ―High‖ sensor selections are presented in the specifications section of the Boonton 

Sensor Manual. In general the ―Low‖ position reduces the RF noise level, but has a slower 

risetime and falltime. The ―High‖ position is used for most applications, especially when the 

fastest risetime and falltime is needed. Some sensor models may have only a single bandwidth 

available. In this case the menu setting will have no effect. 

 

 

TIME Press the TIME function key to obtain the Statistics controls and perform the following exercises 

to become familiar with the items in the Time > menu (Figure 3-7): 

 

 

Time (Statistics) Press the Time (Statistics) > Presentation menu key to alternately select a linear > Presentation or 

logarithmic probability scale. Both scales have range and offset controls. 

    

 

Time (Statistics)  Press the Time (Statistics) > Horz Scale menu key to adjust the probability scale. 

> Horz Scale  

Linear Scale: Use any of the data entry controls to step the horizontal scale through the sensitivity 

settings, 10 %/Div, 5%/Div, 2%/Div, 1%/Div, 0.5%/Div, 0.2%/Div and  0.1%/Div. 

 

Log Scale: Use any of the data entry controls to step the horizontal scale through the choices of 

number of displayed decades: 1 to 7 decades. 

 

 

Time (Statistics-LIN) For linear scales press the Time (Statistics) > Horz Offset menu key to adjust the probability scale 

> Horiz Offset  linear offset. Use any of the data entry controls to enter the percentage offset required. The 

allowable range is 0% to 100% 10*Horiz Scale setting.  (e.g. for 0.5%/Div, the max offset is 

95%) 

 

 

Time (Statistics-LOG) For logarithmic scales press the Time (Statistics) > Full Scale menu key to >Full Scale adjust the 

full scale decade value. This is the value of the right hand edge of the display. Use any of the data 

entry controls to enter the decade full scale value required.  The allowable range is 0.01% to 

100%. By shifting in this way a total of 11 decades of probability can be displayed. 
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TIME (continued) 
 
 

Time (Statistics)  Press the Time (Statistics) > Stat Mode menu key to determine how the captured > Stat Mode 

   data is plotted. The 3 choices are complementary cumulative distribution function (CCDF) the 

    default mode, cumulative distribution function (CDF, and probability distribution function (PDF).  

 

The CCDF (also known as 1-CDF) plot presents the data as the percent of total  samples above a 

selected  level. 

 

The CDF plot presents the data in a running total by level which can be read by markers or 

reference lines as the percent of total samples at or below a selected level. 

 

The PDF plot presents the percentage of samples that lie within equal sized bins. The number of 

bins per division can be specified. The PDF display is for interpretation and is not usually used to 

make measurements.  

 

 

Time (Statistics)  Press the Time (Statistics) > PDF Bars to select the number of bars that make 

> PDF Bars  up the PDF display. The bars correspond to sample data bins. Use any of the 

data entry controls to enter  1 to 35 bars/Div.  

 

 

Time (Statistics)  Press the Time (Statistics) > Term Settings menu key to display the termination > Term Settings 

   settings menu.  

 

 

Time (Statistics)  Press the Time (Statistics) > Term Settings > Term Action to control the  

> Term Settings   measurement process when a terminal condition is met. Statistical measurements 

> Term Action are often thought of as a single Start-Stop sequence. With the histogram cleared to zero, samples 

are accumulated for a fixed sample total count or until available memory is full, when the 

measurement automatically stops.  

 

 Term Action ―Stop‖ automatically stops the measurement when a terminal condition is met. . 

  

 Term Action ―Flush‖ automatically starts a new measurement when a terminal 

 condition is met. 

 

 Terminal Action ―Decimate‖ on detecting a terminal condition, automatically divides the 

histogram and count by 2, and continues the measurement. This allows the measurement to run 

indefinitely without overflow, but limits the lowest event probability that can be detected.  

 

 

Time (Statistics) Press the Time (Statistics) > Term Settings > Term Action > Term Time to set  

> Term Settings   a terminal condition in running time. Set ―Off‖ to disable running time as a  

> Term Time  terminal  condition. Use any of the data entry controls to enter a time in seconds. Limits are 1 to 

3600 seconds. 
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TIME (continued) 
 

 

Time (Statistics)  Press the Time (Statistics) > Term Settings > Term Action > Term Count to set > Term Settings 

> Term Count  a terminal sample count. Use any of the data entry controls to enter a terminal count in 

   Megasamples. Limits 2.0 M to 4096.0 M Megasamples. 

 

 

 

Note If both  total sample count and running time terminal conditions are set, the first terminal condition met will 

control the process. 

 

 

 

 

 

 

. 

MENU ITEM   EXERCISE 
 
MEAS   Press the MEAS function key, and perform the following exercises to become  

familiar with frequency entry. 

 

 

The instrument will automatically read the frequency correction data from the sensor and apply 

the correction to the measurement. 

 

Because the sensor is connected to the calibrator output for these exercises, the 

measurement frequency must be set to 1.0 GHz (the frequency of the calibrator signal) to obtain a 

valid reading. 

 
 
Meas > Freq Track            This selection turns frequency tracking On and Off. Frequency tracking ―On‖ 

links both channels together with the same frequency. The ―Off‖ setting allows the channels to be 

set to different frequencies. 

 
 
Meas > Freq CH1 Use any of the data entry controls to select the measurement frequency for  

CH 1. This frequency selection is used to calculate the required correction factor. 

 

The data can be entered in Hz, kHz, MHz or GHz, however, the frequency must lie within the 

range of the CH 1 sensor in use. If a value outside this range is entered, the nearest limit frequency 

will actually be entered and displayed, and no error will result. The frequency limits may be 

different for the sensor‘s high and low bandwidth ranges. You can find the frequency range limits 

for the sensor in use by pressing the Spcl > Sensor Data > CH 1 Sensor>  Report menu key. If a 

frequency becomes illegal because of a bandwidth change, it will be forced to the nearest limit 

frequency.  The frequency resolution is 0.01 GHz (10 MHz).   
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MEAS (continued)  
 

 

Meas > Freq CH2 Frequency entry for Channel 2 (if installed) operation. The procedure is the same as for Channel 1 

discussed above. 

 

 

Meas > Sys Tracking When  System Tracking is ―On‖, the following channel parameters are linked together such that 

changing the value in any channel changes the parameter value in all of the linked channels. An 

asterisk  ―*‖ appears in the menu title of linked parameters. The parameters are: Units, Peak Hold, 

Video BW, Averaging, Distal, Mesial, Proximal, Pulse Units Start Gate, End Gate. 

 

 

 

TRIG   Press the TRIG function key and perform the following exercises to become  

familiar with setting the trigger conditions for a gated statistical measurement. 

 
 
Trig (Statistical)  Press the Trig > Gating menu key to select  the controls for gated statistical 

> Gating mode. If ―Free Run‖ is selected, the statistical measurement operates as described in the preceding 

section. If ―Pulse Gated‖ is selected, additional menu selections are enabled that allow the 

statistical mode to accumulate samples only between two gate cursors, Gate 1 and Gate 2. This 

mode is used to gather the statistics within a burst that can be synchronized with the trigger 

system. 

 

 Select ―Pulse Gated‖ to enable the full menu and continue with this exercise. 

 

 

Trig (Statistical) Press the Trig > Pulse Preview menu key to alternately select the full window 

>Pulse Preview statistical display or a split window pulse and statistical display. Use the split window to obtain 

synchronization of the pulse or burst waveform and adjust Gate 1 and Gate 2 to enclose the region 

to be analyzed. 

 

 

Trig (Statistical) Press the Trig > Trig Setup  menu key. This menu is identical to the pulse mode 

> Trig Setup   trigger menu.       
 
 
Trig (Statistical)  Press the Trig > Time Setup menu key. This menu is identical to the pulse mode > Time Setup 

   time menu. 
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TRIG (continued) 
 

 

Trig (Statistical)  Press the Trig > Gate 1 menu key to make it active. Use any of the data entry 

> Gate 1  controls to enter a gate position that defines the start of  the waveform segment to be analyzed. 
 
 
Trig (Statistical)  Press the Trig > Gate 2 menu key to make it active. Use any of the data entry 

> Gate 2  controls to enter a gate position that defines the end of  the waveform segment to be analyzed. 
 
 
 
 
REF Press the REF function key and perform the following exercises to become familiar with the items 

in the Ref > menu. 

 
 

Ref > Ref Line 1  If Ref Line 1 is inactive, press the Ref > Ref Line 1 menu key to activate it. Use the spin knob or to 

move Ref Line 1 to the power level where the desired measurement is to be made. Move the Ref 

Line around the waveform and observe the percentage of occurrence shown above the left-hand 

side of the waveform display in the parameter field. In CCDF this reading refers to the percentage 

of the total readings that are above the power level for the reference line and are displayed in the 

same color as the measured waveform. 

 

 

Ref > Ref Line 2  Ref Line 2 is inactive, press the Ref > Ref Line 2 menu key to activate it. Use the spin knob to 

move Ref Line 2 a few divisions away from Ref Line 1. Observe that the active reference line is 

designated by triangles at left and right. Note that the reading above the right-hand side of the 

waveform display window corresponds to Ref Line 2. Note also that the absolute delta of the 

percent of Ref Line 1 and Ref Line 2 is displayed above the centerline of the waveform. 

 

 

The first step in using the reference lines is to enable them and assign them to a channel. 

 

 

Ref > Extensions > With Ref Line 1 active (white border), press the Ref > Extensions menu key to 

see the current channel  assignment for Ref Line 1. To change the assignment, press the Ref > 

Extensions > Ref CH Sel menu key to display the list of assignments. Press the menu key  next to 

your choice. They are: -more-, Off (none selected), Active (the current active measurement 

channel), CH1 and CH2. Press the -more- menu key to see the remaining choices, -more- (returns 

to the previous list) , Trig 1, Trig 2, CH Math,  Mem1 and Mem 2.  

 

 With Ref Line 2 active (white border), press the Ref > Extensions menu key to 

see the current channel  assignment for Ref Line 2. To change the assignment, press the Ref > 

Extensions > Ref CH Sel menu key to display the list of assignments. Press the menu key  next to 

your choice. They are: -more-, Off (none selected), Active (the current active measurement 

channel), CH1 and CH2. Press the -more- menu key to see the remaining choices, -more- (returns 

to the previous list) , Trig 1, Trig 2, CH Math,  Mem1 and Mem 2.  
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4. Operation 

 

 

This section presents the control menus and procedures for operating the Model 4500B in the manual mode. All the display 

menus that control the instrument are illustrated and accompanied by instructions for using each menu item. 

 

The operation section of the manual begins with instructions on how to calibrate the sensors that will be used with the 

instrument. This calibration is required to begin taking measures using the Peak  Power Analyzer. 

 

 

4.1 Calibration 
 

The Model 4500B features a built-in automatic calibration (AutoCal) process that calibrates the peak power sensors for all 

measurement modes. An internal programmable calibrator outputs discrete incremental power levels covering the dynamic 

range of the sensor. Zeroing is adjusted for the High and Low video bandwidths where applicable. 

 

 
Note   You must calibrate the channel 1 sensor using the AutoCal routine whenever the Priority Message field 

reads ―CH 1 Needs AutoCal‖; and, similarly, the channel 2 sensor when the  message ―CH 2 Needs 

AutoCal‖ appears. If a sensor is to be used in both channels, a calibration is required for each. During the 

power-on initialization, the instrument checks its calibration files and restores channel and sensor 

calibration data previously stored. Measurements using a particular channel and sensor cannot be 

performed unless a valid set of calibration data is present. 

 

 
Before beginning calibration a warm-up period may be required. If the instrument is not connected to main power or the rear 

panel power switch is off, a 30 minute warm-up period will be required before the sensors can be calibrated to full accuracy. 

The front panel power switch is an On/Standby switch, and the calibrator is always powered. If the sensors have not been 

connected and the standby power mode has been active, the sensors should be allowed a 15 minute warm up. 

 

 

Before initiating AutoCal, clear any pending errors by pressing CLR. To initiate AutoCal, press the CHAN function key, 

followed by the Chan 1 > Calibration > AutoCal or Chan 2 > Calibration > AutoCal menu keys. See Figure 4-1b. During 

AutoCal, progress is reported on the display status line. If necessary, you can abort AutoCal by pressing the ESC key. This 

will restore the calibration status that existed before the AutoCal was started. 

 

Calibration accuracy varies with signal power, as described in Subsection 1.6 Specifications. An analysis of calibration 

accuracy is presented in Section 6.0 Application Notes. 
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4.2 Manual Operation 
 
In the manual mode, the instrument is controlled from the front panel by selecting items from a system of screen menus. The 

menu structure is illustrated in Figure 4-2. To properly input commands and data using these menus, you must be familiar 

with the menu conventions described in the next subsection. Subsequent subsections provide detailed instructions for the 

control keys and menus: 

 

4.6   Top Level Menu 

4.7  System Keys 

4.8 - 4.19 Function Keys and Associated Menus 

4.19  Automatic Operation 

4.21  4500B Menu Map 

 

 

 

4.3 Menu Conventions 

 

This section of the manual describes the menu conventions used throughout Chapter 4 "Operation" and the rest of the 

manual. The control menu conventions are summarized as follows: 

 

1. Path description is a notation to indicate the entry location in the menu structure. The greater than ">" symbol is 

used to indicate each indented level of the menu. The first name should be one of the function keys. If the ">" 

symbol is the first character then the top level menu is being referenced. The top level can be accessed by pressing         

the "ESC" key. If a colon ":" symbol is part of the description, the value that follows the colon ":" is the choice of 

value in that menu. In the top level menu of the Model 4500B, > Measure Mode offers Pulse, Modulated and 

Statistical (Option 10 only). Without Option 10, only Pulse and Modulated measurement modes are available. 

The following sections of this manual will use the label Pulse, Mod & Stat to indicate that a menu selection is  

applicable for all three measurement modes; the same words are use singly or in pairs to indicate applicability to one 

or two modes. The label may be omitted entirely if the menu selection is unrelated to measurement mode. 

 

2. Entries in the menu selection boxes (see Figure 4-1 Inset) can be any of the following types: Multiple Choices, 

Actions, Toggles, Menus, Reports or Numerical Values 

 

3. A single word or abbreviation in a selection box written in upper and lower case letters indicates a Multiple Choice. 

Press the menu box key to see a repeating list of choices. As each choice appears, it is automatically selected.   

 

4. A single word in the selection box written in all upper case indicates an Action or a submenu of actions. An 

Action submenu box may contain  ―- more- ―. Pressing the ―- more- ― menu key will present additional choices of 

Action. Action submenus are self-closing when a selection is made, returning to the calling menu. Examples are 

presented in Figures 4-1. 

 

The  top level (press Esc) Display window in Figure 4-1b is an example of an Action. To initiate the indicated 

action, CLEAR, simply press the associated menu key. 

 

5. Two words (one of which is highlighted) appearing side-by-side within a menu indicate a Toggle. See, for example, 

the Chan 1 > Channel selection box in Figure 4-1a. Press the associated menu key to toggle the selection between 

Off and On. 
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6. A Numerical Value in a menu entry box represents the current value of that parameter. See the Chan 1 > Vert Center 

menu entry box in Figure 4-1a. If the frame of the menu entry box containing the parameter you wish to change is 

not highlighted, press the associated menu key to highlight it.  Highlighting is indicated by a color change of the 

frame of the selection box (white is default).  Some menu selection boxes are automatically highlighted when the 

menu is first selected. 

 

7. When an entry box is highlighted, you may use any of the data entry controls (spin knob, arrow direction buttons, or 

keypad) to adjust the parameter value. Pressing the menu key of a highlighted item deactivates the item and disables 

data entry. 

 

8. Numerical Values can either be continuously variable throughout a range, or restricted to a predefined set of discrete 

values. For discrete sets, the spin knob and arrow keys are programmed to select only valid values in the set. For 

discrete ranges, if you key in an incorrect value, the instrument will automatically select the nearest correct value. If 

you input a value outside the range of the parameter, the instrument may respond with the error message ―Number 

Entry Over (Under) Limit‖, ignore the entry without error or force the upper or lower limit value without comment.  

 

9. The word MENU appearing in a menu selection box indicates that there is a submenu of additional selections at the 

next lower menu level. In the menu shown in Figure 4-3a, for example, when you press the Disp > Format menu 

key, you will call up the Disp > Format  submenu illustrated in Figure 4-3b. This menu contains two submenus, 

Trace Type and Set Color. Press the associated menu to key call up either of these submenus. You can back out of 

the menu tree at any time by pressing the PREV function key which will remove one sub-level each time it is 

pressed until the top level menu is reached.  

 

10. The word REPORT in a menu selection box indicates that a text display of data related to the associated item is 

available. In the example of Figure 4-4a, pressing the Spcl > Sensor Data > CH 1 Sensor menu key will display a 

text report similar to the one illustrated in Figure 4-4b. 

 

11. Pressing the CLR data entry key (see Figure 3-1) clears errors, text reports and any entry in progress. 

 

12. Pressing a menu key associated with the Action CENTER, causes the instrument to center the waveform at the 

active Time Mark . See the Mark > Set Vert Cntr menu box in Figure 4-5. 

 

 

These twelve rules apply generally to all the Model 4500B control menus. By becoming familiar with them, you will 

expedite instrument operations and avoid errors. 

 
 

Note Help screens for each menu describe the menu items. See Subsection 4-7 System Keys. Press the HELP 

key to access the help screen for the current menu. Press ESC or press the HELP key again to return to the 

previous display mode. 

 

 

 

 

 

In following subsections you will be introduced to the Top Level Menu and operating procedures for the three primary key 

groups: System, Function, and Data Entry. 
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4.4 Data Entry Controls 
 
The numeric keypad illustrated in Figure 4-6 is one of the three data entry controls that enable you to enter parameters for the 

various control functions. The keypad is subdivided into three areas: numerals, units of measure and controls. The ten 

numerals, the minus sign and the decimal point are used to enter numerical data. Six ―units of measure‖ keys are provided for 

you to use to complete numerical entries. When entering time intervals, press the ―m‖ after entering the numbers to indicate 

milliseconds or milliseconds/division; press ―u‖ to indicate microseconds or microseconds/division; and press ―n‖ to indicate 

nanoseconds or nanoseconds/division. Press ENT to indicate seconds or seconds/division. Pressing any one of these ―units‖ 

keys enters the numerical data. 

 

When entering numbers that are not time intervals (dBm for example), press the ENT key after keying the number. Pressing 

one of the units keys after entering a non-time-related number has the same effect as pressing ENT. 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 4-6. Data Entry 
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The units keys labeled G, M, and k are used to enter frequencies in Gigahertz, Megahertz, and kilohertz, respectively. They 

operate in a manner similar to the time-related units keys. 

 

You may cancel a value before it is entered by pressing the CLR key. The CLR key is also used to clear status and error 

messages from the display. 

 

Two alternative controls are provided for entering selections and numeric data. These are the spin knob and the 

right/left/up/down arrow keys. To control the position of traces and lines on the display, rotate the spin knob clockwise to 

move up or to the right; counter-clockwise to move down or to the left. To control the size or rate of display elements, rotate 

the spin knob clockwise to increase size or rate; counter-clockwise to decrease size or rate. To control the size of non-

graphical parameters, rotate the spin knob clockwise to increase or counter-clockwise to decrease the parameter. Generally, 

the right and up arrow keys correspond to clockwise rotation of the knob; the left and down arrow keys to counter-clockwise 

rotation Holding down an arrow key causes it to repeat. 

 

 

 

4.5 Display Data 
 
The 4500B has four display modes. These are the Graph mode, Text mode, Report mode, and Help mode. Whichever mode 

the display is in, the menu portion of the display is always present and active.  

 

The HELP mode is activated by pressing the HELP key. The instrument will display up to three lines of information related 

to the active menu. The menus remain active in the help mode. This allows the operator to move to any menu level and make 

multiple instrument configuration changes without leaving the help mode. To leave the help mode press the HELP key again 

or the ESC key. When a red error message is displayed, pressing HELP will provide more detailed information about the 

error. 

 

The REPORT mode is active when a report is requested by a menu selection or a GPIB command. Each report is contains 

information on one or more related subjects. The report mode is exited by pressing the ESC key or selecting another display 

mode. 

 

The TEXT mode presents a tabular display of measurement values for channels 1 and 2 (if installed). In Pulse measurement 

mode, this table consists of all 15 automatic pulse measurements. In all Statistical measurement modes (Model 4500B Opt 10 

only), level statistics, marker and reference line values and global measurement status parameters are shown in the units of 

the channel. In the Modulated measurement mode a summary of level readings are shown in the units of the channel. 

 

The GRAPH mode is the primary display mode for the instrument. After initialization with the INIT function key, the 

display is in the graph mode. The graph mode includes a 501 by 281 pixel waveform display area, header field, menu path 

field, priority message field, error message field and general message field. The header field is in the top left corner. Its 

display preferences are model number, time and date, sensor temperature and blank. The menu path is located in the upper 

right of the display. It shows the current menu location in the menu structure. See Figure 4-2 for menu information. The error 

message is below the waveform display on the right. The default color is red. Errors are cleared by pressing the ESC or CLR 

key. The general message field is at the bottom of the display. It shows temporary information about the status of the 

instrument. 

 

The Priority Message field located below the waveform display in the graph mode. This field displays a series of messages 

based on a pre-assigned priority. If multiple conditions exist only the highest priority message is displayed. These messages 

describe the current status of the measurement system. Corrective action is needed only if the indicated condition does not 

match the users intentions. 
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The message priority from highest to lowest is: 

 

Highest   

 

Measuring Stopped!!  No measurements are being made. 

CH 1 & 2 No Sensor The instrument cannot detect a sensor connected on the specified channel. 

CH 1 No Sensor   

CH 2 No Sensor 

 

CH 1 & 2 Need Autocal A new calibration must be performed before measurements can be made. This 

CH 1 Needs Autocal occurs when no record of a  previous calibration for the sensor and channel 

CH 2 Needs Autocal  combination  can be found. 

 

CH 1 & 2 Temp Drift The "Temperature Drift" message occurs only for sensors that do not contain 

CH 1 Temp Drift  temperature compensation data. It indicates that the sensor has drifted more 

CH 2 Temp Drift  than ± °C from the original auto calibration temperature. For maximum accuracy a new autocal 

should be performed on the channel. If not, a small additional error can be introduced into the 

measurements. 

 

Auto Triggering Indicates that a valid, signal related trigger event is not occurring at regular intervals and the 

instrument is supplying a trigger event to maintain a visible trace. The Auto and Auto Pk/Pk 

modes create a visible trace even if the input signal does not meet the selected trigger conditions. 

Under some conditions, the auto-trigger may interfere with the signal trigger. If this occurs, switch 

the instrument to the Normal trigger mode in the Trig > Trig Mode menu. 

 

Waiting for Trigger In the Normal trigger mode the instrument is waiting for a valid trigger event. When a valid 

trigger event occurs, the message is cleared. On slow time bases the message may appear for each 

sweep.  

 

Acquiring New Data Indicates that the instrument is triggering and accumulating new measurements, but there is not 

yet enough data for the instrument to complete the assigned averaging. If two channels are active 

the channel with the largest averaging value is used to determine when the message is cleared. 

 

Acquiring Pre-trigger Data  Indicates that the instrument is triggering and accumulating new measurements 

in anticipation of a trigger event. When a trigger event occurs, the most recent measurement data 

will be resolved in time and placed ahead of the trigger position on the trace. At this point the 

message will be changed to Acquiring New Data. This activity can only be observed on the slower 

time bases. 

 

Triggered Indicates that the instrument is triggering normally. If the Auto or Auto Pk/Pk mode is selected, it 

indicates that the signal trigger is occurring often enough to avoid the need for instrument supplied 

auto-triggers.  

 

Free Run  Indicates that traces are generated repetitively without regard to triggers. Helpful for locating 

traces on the faster time bases when triggering is lost or erratic. No synchronization will occur. 

After locating the trace and adjusting trigger conditions, select a Normal or Auto trigger mode for 

synchronization.  

 

Lowest  (Blank Field) 
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4.6 Top Level Menu 
 
The commands in the Top Level Menu (Figure 4-7) enable you to control the measurement modes. These functions are 

detailed in Table 4-1. All commands affect both measurement Channels 1 and 2. 

 

 

 

Table 4-1. Top Level Menu 
 

Menu Item        Function   
 (Type)   Selections     (SCPI cmd) 

 
 

Measurement  Pulse, Mod & Stat Controls the capture of new data.    

(Toggle)   Run, Stop 

Press the >Measurement menu key to 

stop the capture of data by the 

measurement channel(s). Press it again 

to restart the data capture. Marker and 

Ref Line measurements continue  

to be made when data capture is  

stopped. 

 
      INITiate:CONTinuous {ON, OFF} 
 
 
Single Sweep  Pulse, Mod & Stat  Initiate a single measurement 

 (Action)  START  

 

Pulse   Acquires data for one trigger event 

 

When data capture has been stopped  

(see previous discussion of the 

Measurement menu key), you can press 

the >Single Sweep menu key to capture  

the data gathered from one trigger  

event. Pressing the key repeatedly adds 

new data for each capture.  

 

Mod & Stat  Forces stopped measurement to Run.  

 

   INITiate[:IMMediate[:ALL]] 
 

 

Display   Pulse, Mod & Stat Clears the waveform display and the 

(Action)   CLEAR   internal data buffers   

     

Press the  >Display> CLEAR  menu key 

to clear the waveform display and any  

data in the measurement data buffers.  

If the instrument is in the Run mode,   Figure 4-7. 
capture of new data begins immediately            Top Level Menu 

 

 



Boonton 4500B RF Peak Power Analyzer 

Operation 4-8 

Table 4-1. Top Level Menu (continued) 
 

Menu Item         Function   
 (Type)   Selections      (SCPI cmd) 

 
 

If the instrument is in the Stop mode, the measurement data buffers are  

cleared and the waveform display is blanked. Data capture will resume 

when >Measurement> Run is initiated. 

 

When in the Modulated mode or the Pulse mode,  use the >Display > 

menu key to clear the averaging filters. This removes the effect of old 

data on the trace, allowing newly acquired data to dominate. 

 

When in the Stat mode,  use the >Display> CLEAR key to discard the 

histogram data and begin a new histogram. The total time and the total 

points counters are also cleared. 

 

A short cut to using the Esc key to return to the top level menu to get to 

the  >Display> CLEAR the Shift key followed by the Clr key clears the 

display from any menu level. 

 

*CLS               
 

 

Measure   Pulse, Mod & Stat Selects the measurement mode for the entire instrument 

(Mult. Choice)       Pulse, Modulated, Statistical   

Pressing the measurement mode menu key, >Measure Mode>, switches 

the instrument between the Pulse mode, the Modulated mode and the 

Statistical modes. This change affects the entire instrument. The 

measurement capture, processing , channel selection, data displays and 

menu structure all change. 

 

In the Pulse mode the instrument operates as a peak power 

meter. This mode requires a valid trigger event. Instantaneous 

power measurements are taken at random intervals and are 

resolved in time relative to the trigger event. The instrument 

reconstructs the waveform from points that fall within the 

display‘s time window. This window is defined by the 

timebase and trigger delay. Markers return measurements of 

power at specific time offsets from the trigger point. All 

automatic measurements are limited to the instrument‘s time 

window. 
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Table 4-1. Top Level Menu (continued) 
 

Menu Item         Function    
 (Type)   Selections      {SCPI cmd)

  
In the Modulated mode the instrument operates in a 

continuous mode that does not require a trigger. It 

continuously measures the true average power, peak power, 

minimum power and peak to average ratio of the input signal. 

The trace is displayed with a wide range of time bases and 

provides a roll mode for slow timebases. The continuous 

averaging process results in somewhat lower noise than the 

Pulse mode, increasing the dynamic range. 

 

In the Statistical mode the instrument continuously samples 

the input signal and  processes all of the samples to build 

power histograms. There is no need for a trigger signal. The 

histograms are processed and displayed as cumulative 

distribution functions or as a discrete density function. See 

Chapter 6, Applications for more information on statistical 

power measurements. 

 

       CALCulate:MODE {PULSE, MODULATED,   
       STATISTICAL} 

 

 

Auto-Setup  Pulse     Initiates the auto-setup process. 

(Action)   START 

       Auto-setup will adjust the vertical scale, vertical offset, trigger 

level, timebase and trigger holdoff for channel 1 and 2. The 

instrument uses the currently selected trigger source to search 

for the trigger event. The setup will display the full amplitude 

of the pulse with at least one full cycle. 

 

SYSTem:AUTOSET                          
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Figure 4-8. System Keys 
 

4.7 System Keys 
 

The system keys are located at the top of the front panel control area. See Figure 4-8. 

They control functions related to the operating mode, display mode, hard copy output 

and configuration. 

 

 

 

Prev  Pressing Prev returns control to the next higher menu in the menu structure (Figure 4-2), unless 

the last menu displayed was from a different branch. In that case, pressing Prev returns to the last 

menu displayed.  

 

 

Esc   Pressing Esc halts a process, clears reports and displays the Top Level Menu. 

 
 
Text  Pressing Text (Graph) toggles the display between the graphic mode and a text screen summarizing results  

(Graph)  of automatic signal measurements. The text display is shown in Figure 4-9. 

 

 
Help Pressing the Help key enables the Help mode and displays the Help screen associated with the current 

menu. See Figure 4-10. In the Help mode the instrument continues to operate and all controls remain 

active. The Help key operates as a toggle; press it to deactivate the Help mode and return to the graphic 

display. You may also press the Esc key to deactivate the Help mode. When a red error message is 

displayed, pressing HELP will provide more detailed information about the error. 
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Print  Pressing the Print key will cause the screen image to be captured to memory and the Print > menu to 

appear.  Press the Print > To Next File START menu key to save the captured screen image to the next 

sequential *.bmp file. To save the image as a *.pcx file, a non-sequential filename or a user selected 

filename, press the Print > Select  File  MENU key.  

  

  Use the Print > Select File  menu to create new folder names and filenames.  

 

 

Init  Press Init to initialize the parameters in Table 3-3 to their default values. Use Init to cancel an undesired set 

of configuration parameters, or whenever you are uncertain of the instrument configuration. 

 

 

Local The Local key is enabled only when the 4500B is in the GPIB remote state and the Local Lockout state is 

inactive. Pressing the enabled Local key returns the instrument to the GPIB Local mode. In Remote mode, 

all  front panel controls except the Local and  PWR keys are disabled. When the Local Lockout state is 

active, the Local key is also disabled. 

 

 

 

 

4.8 Function Keys 

 

The twelve function keys illustrated in Figure 4-8 access the principal control menus of the Model 4500B. Together with 

associated submenus, they enable you to establish the measurement display modes and analyzer configurations; query the 

processor database; perform and record measurements; perform internal diagnostics; and communicate with other devices 

over the GPIB bus and serial communication ports. 

 

Sections 4.9 through 4.19 discuss the twelve function keys and describe the selections in their associated menus and 

submenus. 
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4.9 CHAN Key and Chan # > Menu 
 
The CHAN key activates the Chan # > menu and associated submenus, which enable you to calibrate the sensor, specify 

units, define pulse parameters, set measurement correction factors, and select sensor bandwidth. See Figure 4-12. 

 

 

Menu Configuration The configuration of the Chan # > menu depends on the item selected  

 in the Chan # > Selection window. Figure 4-12 presents the Chan # >  

 menu, which is displayed when the instrument is initialized. (Chan 1  

  is the default menu.) The Chan # > menu items enable you to control  

 the display of the measurement channel. Instructions for using the  

 Chan # > menu are presented in Table 4-2.  

 

The default Chan # > menu contains two submenus of additional  

functions: 

 

Figure 4-13 illustrates the Chan # > Calibration > submenu,  

which is used to initiate the calibration and zeroing functions.  

Instructions for using the Chan # > Calibration > submenu  

are presented in Table 4-3. 

 

Figure 4-14 illustrates the Chan # > Extensions > submenu,  

which provides access to a number of additional setup functions. 

Instructions for using the Chan # > Extensions > submenu are  

presented in Table 4-4. 

 

Figure 4-16 illustrates a second version of the Chan > menu that appears 

when ―CH Math‖ has been selected. A submenu of the Chan Math > 

menu enables you to control the display of the calculated sum or  

difference of the detected Channel 1 and/or Channel 2 signals.  

Instructions for the Chan Math > menu are presented in Tables 4-5  

and 4-6.                   
 

Figure 4-18 shows the Chan > Mem 1 menu, which appears when 

―Mem 1‖ has been selected. The Mem # waveform is a ―snapshot‖  

of either the Channel 1 or Channel 2 waveforms, which is created  

and stored for later reference. The menu items that enable you to  

control the display of stored waveforms are explained in Table 4-7.        

            Figure 4-12.  

                   Chan # > Menu 
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Figures and Tables    The figures and tables which describe the Chan # > family of menus are summarized as 

follows. 

 

Menu or   

Submenu   Figure    Table 

 
(Default) Chan # >  4-12    4-2 

Chan > Calibration >  4-13    4-3 

Chan > Extensions >  4-14,15, 16  4-4, 4-4A, 4-4B 

Chan Math >   4-17a, 17b, 17c, 18 4-5, 4-6 

Chan > Mem # >   4-19, 20   4-7, 4-7A 

Ext Trig # >    4-21, 22, 23  4-7B, 4-7C, 4-7D 

 

 

 

 

Table 4-2. Chan # > Menu 
 

Menu Item         Function    
 (Type)   Selections      (SCPI cmd) 

 
 

Selection Pulse, Mod & Stat Selects the channel that will be affected by the rest of the menu  

(Mult. Choice) CH1, CH2   

Ext Trig 1, Ext Trig 2 To select a channel press the Chan # > key to view the list; 

CH Math  CH1, Ext Trig 1, CH Math, Mem1and Mem2 (single channel);  

Mem1, Mem2 CH 1, CH 2, Ext Trig 1,Ext Trig 2, CH Math, Mem1, and Mem2 (dual 

channel). 

 

Press the menu key next to the desired channel. The menu will return to 

the Chan # > menu with the selected channel displayed. 

       

Any display parameters set while  ―CH 1‖ is current will apply to the 

signal connected to the Channel 1 input. Similarly, any changes to the 

display parameters while ―CH 2‖, ―Ext Trig 1‖, ―Ext Trig 2‖, ―Mem 1‖, 

―Mem 2‖ or ―CH Math‖ are current will affect the display of that signal 

or function. 

 

 

Channel   Pulse, Mod & Stat Turns the measurement channel off or on 

(Toggle)   Off, On 

Disable the measurement by pressing the Chan > Channel menu key. 

Press it again to restore the display. 

 

Disabling the measurement channel inhibits all priority messages 

related to sensor disconnection, AutoCal required and sensor 

downloading status. Disabling the channel will turn off the display of 

the power and trigger waveforms, but will not affect the internal or 

external triggering of the channel. 

 

CALCulate[1|2|3|4|5|6|7]:STATe {ON, OFF} 
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Table 4-2. Chan # > Menu (continued) 
 

Menu Item         Function    
 (Type)   Selections      (SCPI cmd) 

 
 

Vert Scale Log  Pulse, Mod & Stat Sets the vertical sensitivity of the display in log units  

(Numeric)  Discrete Range: 

0.1 to 20 dB/Div Use this control to size the vertical amplitude of the waveform display 

to fit the display area, or to magnify a waveform segment of particular 

interest. 

. 

 

Press the Chan # > Vert Scale menu key to activate this window. Then 

use any number entry to step the vertical sensitivity of the display to 

any 1-2-5 sequence value in the specified range. Larger sensitivity 

values reduce the height of the display; smaller values increase it. 

 

DISPlay:TRACe[1|2|3|4|5|6|7]:VSCALe <arg> (log units) 
 

 

Vert Scale Linear   Pulse, Mod & Stat Sets the vertical sensitivity of the display in linear units 

(Numeric)  Discrete Range:   

   1 nW to 50 MW/Div Press the Chan # > Vert Scale menu key to activate this window. 

1mV to 50 kV/Div  Then use any number entry to step the vertical sensitivity of the 

display to any 1-2-5 sequence value in the specified range. Larger 

sensitivity values reduce the height of the display; smaller values 

increase it. 

 

Linear values are always positive. The bottom of the screen is zero 

power or the offset level. 

 

DISPlay:TRACe[1|2|3|4|5|6|7]:VSCALe <arg> (linear units) 
 

     

Vert. Center Log  Pulse, Mod & Stat Sets the power level at the vertical center of the display 

(Numeric)  Continuous Range: 

   -99.99 to +99.99 dB Use this control to shift the waveform display vertically to the 

desired position in the window. Press the Chan 1 > Vert Center 

menu key to activate this window. Then use the keypad to shift the 

vertical center of the display to the desired power level. Increasing 

the power level moves the waveform down; decreasing the power 

level moves it up. 

 

DISPlay:TRACe[1|2|3|4|5|6|7]:VCENTer <arg> (log units) 
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Table 4-2. Chan # > Menu (continued) 
 

Menu Item         Function    
 (Type)   Selections      (SCPI cmd) 

 
 

Vert. Center Linear Pulse, Mod & Stat Sets the power level at the vertical center of the display 

(Numeric)  Continuous Range: 

      Use this control to shift the waveform display vertically to the 

  desired position in the window. Press the Chan 1 > Vert Center 

menu key to activate this window. Then use the keypad to shift the 

vertical center of the display to the desired power level. Increasing 

the power level moves the waveform down; decreasing the power 

level moves it up. 

 

DISPlay:TRACe[1|2|3|4|5|6|7]:VCENTer <arg> (linear units) 
 

 

Calibration  Pulse, Mod & Stat Accesses the Chan 1 > Calibration > submenu. See Table 4-3. 

(Submenu)  MENU 

 

 

Extensions  Pulse, Mod &Stat  Accesses the Chan 1 > Extensions > submenu. See Table 4-4, 

(Submenu)  MENU   4-4A and 4-4B. 
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Calibration    A discussion of the internal calibration capability is presented in Subsection 4.1 

Calibration. Figure 4-15 illustrates the Chan{1|2] > Calibration > submenu and Table 

4-3 provides instructions for its use. 

 

 
Table 4-3. Chan # > Calibration > Submenu 

 
Menu Item    
 (Type)   Selections     Function

 
    

AutoCal   Pulse, Mod & Stat Initiates the automatic calibration routine for channel 1 or 2.   

(Action)   START 

      Do the AutoCal procedure for any of the following: 

 

a. When the ―CH # needs Autocal‖ message 

appears in the Priority Message area of 

 the display. This will always occur when 

 a ―new‖ sensor that has not been  

previously calibrated on this instrument  

and channel is plugged-in. It will also  

occur if the auto-cal file for this sensor  

has been deleted.  

 

b. When a temperature drift warning appears 

 in the Priority Message area. The Model  

4500B records the ambient sensor  

temperature when AutoCal is run. If the  

ambient sensor temperature changes 

significantly, a temperature drift warning 

is displayed. For sensors that have  

temperature compensation tables, a much  

larger ambient change is acceptable.  The  

warning message will clear automatically  

when the temperature returns to the  

normal range. 

 

c. When the operating environment has  

changed significantly since the previous  

calibration.  

 

Allow 15 minutes for the sensor temperature  

to stabilize before initiating AutoCal. Connect  

the sensor to the Calibrator type-N  connector  

on the front (or rear) panel, and press the  

START key. The AutoCal routine takes up to  

1-1/2 minutes to zero and calibrate both the  

High and Low video bandwidths. While these  Figure 4-13 

activities are in progress, the display reports          Chan[1|2] > Calib 

the AutoCal status on the Message Line.  

When the process is finished,  

―Autocal Complete‖ is displayed. 
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Table 4-3. Chan # > Calibration > Submenu (continued) 
 

Menu Item         Function    
 (Type)   Selections      (SCPI cmd) 

 
 

The AutoCal procedure can be aborted by pressing the ESC system 

key. The previous calibration file (if any) will be restored.  

 

      See SPCL > Sensor Data > Ch # Sensor for more information. 

 

      CALibration[1|2]:AUTO   
  
   

Note  

 

The Chan # > Calibration > Start selection will only be highlighted when an AutoCal procedure is allowed. 

AutoCal is not available if the channel is Off or no sensor is connected. 

 

 

 

 

Fixed Cal  Pulse, Mod & Stat Sets the sensor 0 dBm point precisely using an external standard. 

(Action)   START    

Allows the operator to perform a 0 dBm fixed calibration using a 

customer-provided source. The Chan # > Calibration > Fixed Cal 

Start selection will be highlighted only when Fixed Cal is valid. To 

activate Fixed Cal the channel must be turned On with a sensor 

connected that has a valid AutoCal file. 

 

Allow 15 minutes for the sensor temperature to stabilize before 

initiating  Fixed Cal. Connect the sensor to the Calibrator type-N  

connector on the front (or rear) panel, and press the START key. 

 

The resulting cal-factor will overwrite the current cal-factor. It will 

persist until the Frequency is changed.   

 

The maximum correction range of the sensor 0 dBm point by the Fixed 

Cal procedure is limited to  1 dB. 

 

CALibration[1|2]:USER:FREQcal 
 

 

Zeroing    Pulse, Mod & Stat  Initiates the automatic internal zero adjustment 

 (Action)   START    

The instrument will automatically adjust its indication of the zero input 

power level. Disable any signal source connected to the sensor before 

initiating the Zeroing procedure. If the sensor is connected to the 

internal calibrator, the calibrator output signal will be turned off 

automatically when Zeroing is initiated and will resume when zeroing 

is complete. 
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Table 4-3. Chan # > Calibration > Submenu (continued) 
 

Menu Item         Function    
 (Type)   Selections      (SCPI cmd) 

 
 

Initiate Zeroing by pressing the Chan # > Calibration > Zeroing menu 

key. During the Zeroing process, the message line will read ―Zeroing 

Channel #.‖ When complete, the message line reads ―Zeroing  

Completed Successfully.‖ 

  

Reactivate any external signal applied to the sensor. 

 

CALibration[1|2]:ZERO                               
 

 
Note   

 
If the SRQ indicator appears at the end of the AutoCal, Fixed Cal or Zeroing procedures, refer to  

Subsection 5.4 SRQ Operation. If an error message appears on the display during the Autocal, Fixed Cal 

or Zeroing  procedures, refer to Appendix A Error Messages. 
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Table 4-4. Chan # > Extensions > Submenu 
 

Menu Item        Function    
 (Type)   Selections     (SCPI cmd)

 
 

Units    Pulse, Mod & Stat Selects measurement units for this channel 

(Selection)     (MENU) 

      The menu window displays the current units  

selected for this channel. 

  

Press the Chan # > Extensions > Units key  

to view the list of available units; dBm,  

Watts, Volts, dBV, dBmV and dBuV. 

 

Press the menu key next to the unit selected. 

The displayed menu will return to  

Chan # > Extensions with the selected units  

indicated. 

 

CALCulate[1|2|3|4|5|6|7]:UNIT {dBm, W,  
V, dBV, dBmV, dBuV} 

 

 

Note   
  Channels 1 and 2 are power meter channels and make power measurements  

directly.  Power is expressed in logarithmic units as decibel milliwatts or dBm.  

Power is also expressed in linear units as nanowatts,  microwatts, milliwatts,  

watts, kilowatts and Megawatts as appropriate. Voltage units are derived from  

power values as the equivalent voltage across a 50 ohm load. Derived voltage  

is expressed in logarithmic units as decibel microvolts, decibel millivolts and  

decibel volts. Derived voltage is also expressed in linear units, including  

microvolts, millivolts, volts and kilovolts. 

 

 

 

Corrections   Pulse, Mod & Stat Selects measurement corrections and offsets  

(Submenu)   MENU 

           Figure 4-14. 
                         Chan # > Extensions 

Peak Hold   Pulse & Mod  Turns Peak Hold function on and off  

(Toggle)   Off, On  

The Peak Hold function is used to hold peak   

measurement values until reset. When Peak   

Hold is Off, the measured peak values decay  

at a rate set by the Averaging function. 

 

CALCulate[1|2|3|4]:PKHLD {OFF, ON} 
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Table 4-4. Chan # > Extensions > Submenu (continued) 
 

Menu Item       Function    
 (Type)   Selections     (SCPI cmd)

 
 

Define Pulse  Pulse   Selects pulse level criteria for pulse time measurements 

(Submenu)  MENU 

 

 

Filter   Mod   Selects filter time in seconds in Modulated mode only 

(Numeric)  Auto, Off, 

2 ms to 16,000 sec Set the filter time constant for Modulated mode measurements. The  

(in 2 ms steps) filter may be set to Off for minimum filtering, Auto for a calculated 

optimum filter based on the time base setting or the time constant in 

seconds can be entered using any of the numeric entry methods. For 

other modes, see Averaging, below. 

 

SENSe[1|2]:FILTer:STATe {OFF, AUTO, ON} 
SENSe[1|2]:FILTer:TIMe <0.002 to 15.00>  (sec) 
 

 

Video BW   Pulse, Mod & Stat Selects either the narrowband or wideband detector response  

(Toggle)   Low, High     

Press Chan # > Extensions > Video BW > Low to select a narrowband 

sensor detector response that is useful for displaying noisy, low 

frequency signals or to reduce carrier feed through. Not all sensor 

models have this feature. 

 

Press Chan # > Extensions > Video BW > High to select a wideband 

response that is useful for measuring short pulses. The actual detector 

bandwidths vary with the sensor model selected.  

 

SENSe[1|2|3|4]:BANDwidth {LOW, HIGH} 
 

 

Averaging   Pulse   Selects the number of samples that are averaged at each point 

(Numeric)  1 to 16,384 

Press Chan # > Extensions > Averaging to activate this function. Use 

any of the data entry controls to select the number of samples to be 

averaged at each point of the waveform to produce the waveform 

display. Default = 8. 

 

SENSe[1|2|3|4]:AVERage <1 to 16384> 
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Table 4-4A. Chan # > Extensions > Corrections > Submenu 
 

Menu Item        Function    
 (Type)   Selections     (SCPI cmd)

 
dB Offset   Pulse, Mod & Stat Set the value of the input  attenuator for channel 1 or 2 

(Numeric)   Continuous Range: 

-99.99 to +99.99 dB  This function is used to account for  

attenuator(s) or amplifier(s) inserted at the  

instrument‘s input to adjust high or low signal  

levels to the input range of the instrument. 

 

The value for offset correction factor is  

always entered in dB but is  correctly applied  

to the signal level for all measurement units. 

 

The offset entered in this function will also  

correct the internal trigger level value. 

 

   To display the un-attenuated signal power,  

press the ―dB Offset‖ menu key and use any  

of the data entry controls to input the known  

value of the offset attenuator. 

       

If the exact value of the attenuator is  

unknown, determine the value by connecting  

the sensor with the attenuator to the calibrator  

output and following these steps: 

 

1. Use Cal  > Cal Mode to select ―CW.‖  

See  Section 4-16. 

2. Set the calibrator output to +20 dBm  

using the Calibrator > Set Level menu  

key and the keypad. 

3. On the top level menu set Measure Mode  

4. to Modulated. 

5. Set Chan # > Extensions >Units to dBm. 

6. Select Chan # > Extensions >  

Corrections > dB Offset and use the spin  

knob to adjust the dB Offset parameter   Figure 4-15 

until the Avg Pwr  reads 20.00 dBm. The      Chan # > Corrections 

exact value of the attenuator is indicated  

by the dB Offset parameter. 

 

 

SENSe[1|2]:CORRection:OFFSet  < -99.99 to 99.99>  (dB) 
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Table 4-4A. Chan # > Extensions > Corrections > Submenu (continued) 
 

Menu Item         Function    
 (Type)   Selections      (SCPI cmd)

 
 

Freq CF   Pulse, Mod & Stat Display(or enter) the Frequency cal-factor 

(Numeric)  Continuous range: 

 3 dB  This menu box displays the value of the current Frequency cal-factor. 

This cal-factor is calculated by interpolation, if necessary, from a table 

stored in the sensor‘s EEPROM for the Frequency entered in the Meas 

> Freq CH #  menu box. This value can be overwritten using any of the 

numeric entry methods. The ―new‖ value will not be used for 

measurements until the Frequency is changed or the instrument is  

initialized or re-started. At that time the interpolated value will be 

restored.  

 

SENSe[1|2]:CORRection:CALFactor < -3.00 to 3.00> 
 

 

Temp Comp  Pulse, Mod & Stat For temperature compensated sensors only, turns Temperature 

  Compensation On or Off 

(Toggle)   On, Off 

This function defaults to On for sensors that have a valid temperature 

compensation table. It may be turned Off for unusual testing situations. 

For uncompensated sensors, this menu box does not appear and the 

function is forced to Off.  

 

SENSe[1/2]:CORRection:TEMPcomp {ON, OFF} 
 

 
 

 

 

 

Table 4-4B. Chan # > Extensions > Define Pulse > Submenu 
 

Menu Item         Function   
 (Type)   Selections      (SCPI cmd)

 
 

Distal    Pulse   Sets the percentage of pulse amplitude defining the distal. 

(Numeric)  Continuous Range 

The distal is normally defined as 90% of the pulse top level amplitude. 

The range is from the 20% to 99.00%. 

 

SENSe[1|2]:PULSe:DISTal <20.00 to 99.00> (percent) 
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Table 4-4B. Chan # > Extensions > Define Pulse > Submenu (continued) 
 

Menu Item         Function   
 (Type)   Selections      (SCPI cmd)

 
 

Mesial    Pulse    Sets the percentage of pulse amplitude  

(Numeric)   Continuous Range  defining the mesial. 

   

The mesial is normally defined as 50 % of the  

pulse top level amplitude. The range is from  

10% to 90%. 

 

SENSe[1|2|3|4|6|7]:PULSe:MESIal  
<10.00 to 90.00> (percent) 
 

 

Proximal   Pulse   Sets  the percentage of pulse amplitude 

(Numeric)   Continuous Range  defining the proximal. 

 

The proximal is normally defined as 10% of  

the pulse top level amplitude. The range is  

from 0.10% to 30%. 

 

SENSe[1|2|3|4|6|7]:PULSe:PROXimal  
<0.10 to 30.00> (percent) 
 
 

Pulse Units  Pulse   Selects voltage or power amplitude 

(Toggle)   Volts, Watts   interpretation of the Distal, Mesial 

and Proximal levels for automatic 

 measurements 

 

SENSe[1|2|3|4|6|7]:PULSe:UNIT  
{WATTS, VOLTS} 

 
         Figure 4-16.  Chan # > 

                    Exten > Def 

 

 

Note  The distal, mesial and proximal levels are set in percentage of the waveform amplitude. If  Distal = 90%  

  Mesial = 50% Proximal = 10% and the power waveform is converted to voltage (Volts), the risetime 

  measured will correspond to the risetime measured by a conventional oscilloscope. Thus, it bears the  

  familiar relationship between risetime and bandwidth for simple systems. Without the conversion, (Watts)  

  the equivalent levels are Distal = 81%, Mesial = 25% and Proximal = 1%.  These values derive from the 

proportionality between power and voltage squared. With Pulse Units set to Volts, the automeasure system 

will assume the level percentages relate to a voltage waveform; and conversely, a power waveform when 

set to Watts. This is without regard to the units of the waveform actually displayed. For the automatic 

measurements to function properly, the distal must be greater than the proximal. 
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Table 4-4B. Chan #  > Extensions > Define Pulse > Submenu (continued) 
 

Menu Item         Function    
(Type)   Selections      (SCPI cmd)

 
HINT  If you want to use 10% and 90% reference levels in measuring risetime, and you want to use the rule of 

thumb  relationship between risetime and bandwidth, always set Pulse Units to Volts. If you also want to 

view a waveform that most closely resembles an oscilloscope display of the same signal, set the display 

units to Volts. The display units setting is optional and will not affect the automeasure result.  

            

     

                                                                                                                                

    

Start Gate   Pulse   Sets the beginning  of the pulse measurement region as a percentage of 

(Numeric)  Continuous range: pulse width  

0.00 % to 40.00 %  

      SENSe[1|2|3|4|6|7]:PULSe:STARTGT <0.00 to 40.00> (percent) 
  

. 

End Gate   Pulse    Sets the end  of the pulse measurement region as a percentage of pulse 

(Numeric)  Continuous range:  width  

   60.00 % to 100.00 % 

SENSe[1|2|3|4|6|7]:PULSe:ENDGT  <60.00 to 100.00> (percent) 
 

 
 
 
 
 
 
 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
    Fig. 4-17b. Markers Indicate Channel 1 power.         Fig. 4-17c. Markers Indicate Channel 2 power. 
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       Figure 4-17a. Sum of Channel 1 and Channel 2 power. Markers indicate Math Channel (Ch1 + Ch2) power. 
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Channel Math  The Channel Math function calculates and displays the sum, difference, ratio or product of two 

waveforms. See Figure 4-17a,b,c. Comparing waveforms using the ratio or difference functions is 

useful for observing the change in a signal as it passes through a circuit element, such as an 

amplifier or filter. For two-channel instruments, connect the Channel 1 sensor at the 

input to the device (through a coupler, for example) and connect the Channel 2 sensor at the 

output. The sum function is used to measure total power and the product function is used with 

voltage waveforms to see the related power waveform.  

 

 

 

Table 4-5. Chan Math > Menu 
 

Menu Item    
 (Type)   Selections     Function

 
Selection   Pulse, Mod & Stat   Identical to Chan # > menu. See Table 4-2. 

See Table 4-2 

 

Channel   Pulse, Mod & Stat Identical to Chan # > menu. See Table 4-2 

See Table 4-2 

 

Vert Scale  Pulse, Mod & Stat Identical to Chan # > menu. See Table 4-2 

See Table 4-2 

 

Vert Center   Pulse, Mod & Stat Identical to Chan # > menu. See Table 4-2 

See Table 4-2 

 

Expression  Pulse, Mod & Stat Accesses the Chan Math > Expression > 

submenu. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
               Figure 4-18a.  
               Chan Math >    
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Table 4-6. Chan Math > Expression > Submenu 
 

Menu Item        Function    
 (Type)   Selections     (SCPI cmd)

 
 

Argument A  Pulse, Mod & Stat Selects the first item in the Channel Math  

(Mult. Choice) CH1, CH2  expression 

   Ext Trig 1, Ext Trig 2  

Mem1, Mem2  Press the Chan Math > Expression >  

Argument A menu key to select either  

―CH 1‖, ―CH 2‖, ―Trig 1‖, ―Trig 2‖, 

―Mem 1‖ or ―Mem 2‖. Select an operator  

 (―+‖,  ―-‖, ―*‖, or ―/‖) and a second argument 

 (see below) to complete the mathematical  

expression that represents the calculated  

waveform you wish to display. Any  

combination of  waveforms of the same type  

can be selected as the arguments of the  

expression. Statistical data can only be  

compared with statistical data, and likewise  

time based data can only be compared with  

time based data. Cross comparisons result  

in an error condition.  

     

CALCulate:MATH:ARGA {CH1, CH2,  
TRIG1, TRIG2, MEM1, MEM2} 

 

 

Operator   Pulse, Mod & Stat Selects the operator for the mathematical 

(Mult. Choice)  +, -, *, /   expression 

 

      Press the Chan Math > Expressions >  

Operator menu key to select either the plus  

or minus sign to indicate whether the  

designated waveforms are to be added,  

subtracted, multiplied or divided point by  

point. Not all operations are valid. See     Figure 4-18b. 
Result Units below.      Chan Math > Expression   

 

CALCulate:MATH:OPERator {CH_PROD, CH_SUM, CH_DIF, 
CH_RAT} 

       

       

Result Units   Pulse, Mod & Stat A  read only indicator window that describes the validity and form 

(Indicator)     of  the requested operation. 

       
 mW – the result is the point-by-point sum or difference of the  

waveforms. 

 

%Pwr – the result is the point-by-point ratio of the waveforms. 
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Table 4-6. Chan Math > Expression > Submenu (continued) 
 

Menu Item        Function    
 (Type)   Selections     (SCPI cmd)

 
 

V^2  - the result is the point-by-point product of the waveforms. 

Restricted to Ext Trigger voltage waveforms. 

 

Invalid – the combination of arguments and operator is invalid.  

 

 

 

 

Some of the many valid combinations of arguments and operators provided by this function may 

not be meaningful in any practical sense, or may require further interpretation to be meaningful. 

The most useful are simple ratios, differences and sums. The combination of  Channel Math with 

Marker Math yields ratios of ratios, which are very difficult to interpret.   

 

 
Display Units  Pulse, Mod & Stat Selects the units of the Channel Math display. 

(Mult. Choice)   

The menu window displays the current units. Press the Chan Math > 

Expressions >  Display Units key to view the list of available units; 

dBm, Watts, Volts, dBV, dBmV and dBuV. 

 

Press the menu key next to the unit selected. The displayed menu will 

return to Chan Math > Expressions with the selected units indicated. 

 

CALCulate[5]:UNIT {dBm, W, V, dBV, dBmV, dBuV} 
 

 

Argument B  Pulse, Mod & Stat Selects the second item in the Channel Math expression 

(Mult. Choice) CH1, CH2   

   Ext Trig 1, Ext Trig 2 Press the Chan Math > Expression > Argument B menu key to select 

Mem1, Mem2 either ―CH 1‖, ―CH 2‖, ―Trig 1‖, ―Trig 2‖, ―Mem 1‖ or ―Mem 2‖.  

     

 

CALCulate:MATH:ARGA {CH1, CH2,TRIG1, TRIG2, MEM1, 
MEM2} 
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Stored Traces  Select Chan Mem # > Selection > Mem 1 or  Chan Mem # > Selection > Mem 2 to display a 

signal trace that has been previously stored in RAM or in a file. This feature is useful for 

comparing signals at the input and output of an RF device, such as an amplifier, filter, or 

equalizer.  

  

 Time based waveforms, statistical distributions and Channel Math results can be stored in either 

Mem 1 or Mem2, but the instrument‘s measurement mode must be compatible with that of the 

stored waveform in order to view it. If nothing has been stored or there is a mode incompatibility, 

an error message will be displayed.   

 

 See Section 4-17 and Tables 4-40 thru 4-42  for more information on storing traces. 

 See the Prgm > Mem Save, Prgm > WFM Store and Prgm > Wfm > Recall menus for more 

information. 

 

The Mem 1 and Mem2 channel displays enable you to view the channel and stored traces 

simultaneously or superimposed for comparison. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 4-19. Ch Mem 1 > Waveform Report. 
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Table 4-7. Chan Mem #  > Menu 
 

Menu Item        Function   
 (Type)   Selections     (SCPI cmd)

 
 

Selection   Pulse, Mod & Stat   Identical to Chan # > menu. See Table 4-2. 

See Table 4-2   

Select either ―Mem 1‖ or ―Mem 2.‖ 

 

 

Channel   Pulse, Mod & Stat   Turns the display of the current stored 

(Toggle)   Off, On    waveform off or on.  

 

Remove the stored waveform from the  

waveform display window by pressing the  

Chan Mem # >  Channel menu key. Press  

it again to restore the display. 

 

CALCulate[6|7]:STATe {ON, OFF} 
 
 

Vert Scale  Pulse, Mod & Stat   Initially identical to the Vertical Scale of 

(Numeric)      the waveform when saved. 

 

      The stored waveform is saved in full vertical  

resolution in a floating point array. This  

allows the vertical scale of the memory  

channel waveform to be changed any time  

after being recalled from memory or from  

a file. The memory channel Units can also be  

changed at any time using the Chan Mem # 

 > Exten > Units menu. Changes are  

persistent, but do not modify the original file. 

 

DISPlay:TRACe[6|7]:VSCALe <arg>  
(current units) 
 

 

Vert Center  Pulse, Mod & Stat   Initially identical to the Vertical Center  

(Numeric)                                                                      of the waveform when saved. 

 

                                                                                      The stored waveform is saved in full vertical         Figure 4-20. 
resolution in a floating point array. This            Chan Mem # > 

allows the vertical center or offset of memory  

channel waveforms to be changed any time  

after being saved to memory or recalled from 

a file. Changes are persistent, but do not  

modify the original file. 

   

DISPlay:TRACe[6|7]:VCENTer <arg> (current units) 
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Table 4-7. Chan Mem #  > Menu (continued) 
 

Menu Item        Function   
(Type)   Selections    (SCPI cmd) 

 
             

Waveform   Pulse, Mod & Stat   Displays a report that describes the instrument setup for the 

(Action)    REPORT   waveform stored in Mem #. 

 

This text report typically includes the waveform source and type, the 

instrument serial number, the sensor model number and serial number, 

channel, dB Offset, Frequency, Frequency CF, video bandwidth, 

averaging, timebase, position, trigger delay, trigger mode, trigger 

source, trigger level, trigger holdoff, and trigger slope. For statistical 

distributions trigger information is replaced by running time  

. and number of samples. Format details vary with mode. See Fig 4-19. 

 
 
Extensions  Pulse, Mod & Stat  Accesses the Chan Mem # > Extensions > submenu. See Table 4-7A. 

(Submenu)  

 

 
 

 

 

 

Table 4-7A. Chan Mem #  > Extensions > Submenu 
 

Menu Item    
 (Type)   Selections     Function

 
 

Units   Pulse, Mod & Stat Identical to Chan # > Exten  > Units menu. See Table 4-4. 

 

The stored waveform may be displayed in any of the units allowed for 

the original waveform.  

 

 

Define Pulse  Pulse & Mod  Identical to Chan # > Exten  > Define Pulse menu. See Table 4-4. 
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External Trigger Channels The external trigger channels, one for each installed measurement channel, 
permit external logic signals and analog baseband signals to supply the trigger 
signal for the power measurement system. Unlike the main measurement 
channels, external trigger channels measure and display voltage, with a direct 
input impedance of 1 Megohm or 50 Ohms. External trigger signals can be 
displayed and measured using most of the same functions that apply to the 
power measurement channels. For this reason they are useful independently to 
measure control and modulation signals in addition to supplying a trigger. Use 
the Chan key to select an Ext Trigger channel.  

 

  

 

Table 4-7B. Ext Trig # > Menu 
 

Menu Item        Function    
 (Type)   Selections     (SCPI cmd)

 
 

Selection   Pulse, Mod & Stat   Identical to Chan # > menu. See Table 4-2. 

See Table 4-2 

   Select either ―Ext Trig 1‖ or ―Ext Trig 2.‖ 

 

 

Channel   Pulse, Mod & Stat  Turns the external trigger channel off or on 

 (Toggle)   Off, On     

Disable the trigger channel measurement by  

pressing the Ext Trig # >Channel menu key. 

Press it again to restore the display. 

 

Disabling the measurement channel inhibits  

all priority messages related to sensor  

disconnection, AutoCal required and sensor  

downloading status. Disabling the channel 

 will turn off the display of the power and  

trigger waveforms, but will not affect the  

internal or external triggering of the channel. 

 

CALCulate[3|4]:STATe {ON, OFF} 
 

 

Vert Scale   Pulse, Mod & Stat Sets the vertical sensitivity of the display in 

(Numeric)  Discrete Range:  linear units    

1 mV to 50 kV/Div   

      Press the Ext Trig # > Vert Scale menu key 

to activate this window. Then use any number 

entry to step the vertical sensitivity of the 

display to any 1-2-5 sequence value in the  

specified range. Larger sensitivity values   

reduce the height of the display; smaller  

values increase it. 

                    Figure 4-21 
DISPlay:TRACe[3|4]:VSCALe <arg>     Ext Trig# > 

(volts) 
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Table 4-7B. Ext Trig # > Menu (continued) 
 

Menu Item        Function    
 (Type)   Selections     (SCPI cmd)

 
     

Vert. Center  Pulse, Mod & Stat Sets the voltage level at the vertical center of the display 

(Numeric)  Continuous Range:     

±1 kV Use this control to shift the waveform display vertically to the desired 

position in the window. Press the Ext Trig # > Vert Center menu key 
to activate this window. Then use the keypad to shift the vertical center of the display to the 

desired level. Increasing the level moves the waveform down; decreasing the level moves it up. 

     

DISPlay:TRACe[3|4]:VCENTer <arg> (volts/Div) 
 

 

Calibration  Pulse, Mod & Stat Accesses the Ext Trig # > Calib > submenu. See Table 4-7C. 

(Submenu)  MENU 

 

 

Extensions  Pulse, Mod & Sta t Accesses the Ext Trig > Exten > submenu. See Table 4-7D. 

(Submenu)  MENU    

 

 
 

 

 

 



Boonton 4500B RF Peak Power Analyzer 

Operation 4-34 

Table 4-7C. Ext Trig # > Calibration > Submenu 
 

Menu Item       Function   
 (Type)   Selections    (SCPI cmd)  

 
 

AutoCal   Pulse, Mod & Stat Initiates the automatic trigger channel 

(Action)   START   calibration routine 

 

Disconnect all signal sources from the  

External Trigger input to be calibrated. Press  

the Autocal START menu key to initiate a  

zero and amplitude calibration.  

 

Trigger channel zero and calibration  

information is saved in a system file and  

restored during initialization.  

 
CALibration[3|4]:AUTO   

 
 
Zeroing    Pulse, Mod & Stat  Initiates the automatic trigger channel 

 (Action)  START   zero adjustment    

 

Disconnect all signal sources from the  

External Trigger input to be zeroed. Press  

the Zeroing START menu key to initiate  

a zero.  

 
CALibration[1|2]:ZERO               

 
 
 
 
 
 
 
 
                   Figure 4-22 
               Ext Trig # > Calib 
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Table 4-7D. Ext Trig # > Extensions > Submenu 
 

Menu Item        Function    
 (Type)   Selections     (SCPI cmd)

 
 
Range     Pulse, Mod & Stat Selects the low or high sensitivity range  

(Toggle)    5 V,  50 V          

The 5 V range is for input signals that do  

not exceed 5 volts peak-to-peak amplitude.  

Overrange signals will be clamped. This  

range is used for most logic signals. 

 

The 50 V range is for input signals that do  

not exceed 50 volts peak-to-peak amplitude.  

Overrange signals will be clamped. This  

range is used for general voltage 

measurements including power supplies.  

 

SENSe[3/4]:RANGe {5, 50} (volts/Div)   
 

 

Impedance  Pulse, Mod & Stat Select external trigger channel input 

(Toggle)   1 Megohm, 50 Ohms terminating resistance 

 

The 1 Megohm input impedance is for use 

with an oscilloscope 10:1 divider probe and 

for general use.  

 

The 50 Ohm input impedance is used when 

maximum trigger bandwidth is needed or  

when cable reflections are a problem. It  

should not be used if  voltages in excess  

of  7 volts r.m.s. are likely to occur. 

 

SENSe[3/4]:IMPedance {1, 50}  
(1Mohm or 50 Ohm) 
 

 

Peak Hold   Pulse & Mod  Turns Peak Hold function on and off            Figure 4-23. 

(Toggle)   Off, On           Ext Trig # > Extensions 

The Peak Hold function is used to hold  

peak measurement values until reset. When 

Peak Hold is Off, the measured peak values decay at a rate set by the 

Averaging function.  

 

CALCulate[3|4]:PKHLD {OFF, ON} 
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Table 4-7D. Ext Trig # > Extensions > Submenu (continued) 
 

Menu Item         Function   
 (Type)   Selections      (SCPI cmd)

 
 
Define Pulse  Pulse & Mod  Selects pulse level criteria for pulse time measurements 

(Submenu)  MENU    

Identical to Chan # > Exten  > Define Pulse menu. See Table 4-4. 

 

 
Video BW   Pulse, Mod & Stat Selects either the narrowband or wideband external trigger response,  

(Toggle)   Low, High     

Press Ext Trig # > Extensions > Video BW > Low to select a low 

bandwidth trigger response that is useful for triggering on or displaying 

noisy, low frequency signals.. 

 

Press Ext Trig # > Extensions > Video BW > High to select a wideband 

response that is useful for triggering on or displaying high frequency 

signals, clean signals of any bandwidth or short pulses.  

 

SENSe[3|4]:BANDwidth {LOW, HIGH} 
 

 

Averaging   Pulse   Selects the number of samples that are averaged at each point 

(Numeric)  1 to 16,384 

Press Ext Trig # > Extensions > Averaging to activate this function. 

Use any of the data entry controls to select the number of samples to be 

averaged at each point of the waveform to produce the waveform 

display. Default = 8. 

 

SENSe[3|4]:AVERage <1 to 16384> 
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4.10 TIME (STAT) Key and Time > Menu 
 
In the Pulse & Mod modes the TIME key activates the Time > menu (Figure 4-24). It controls the timebase and horizontal 

position of the waveform display. In Statistical mode the TIME (STATISTICS) key activates the Statistics > menu  

(Figure 4-25a and 4-25b). It controls the x-axis linear and logarithmic scales in percent and percent offset. Table 4-8A 

describes the functions that appear in the Time > menu for pulse and modulated modes, and Table 4-8B describes the 

functions that appear in the Statistics > menu for the statistical mode (Option 10). 

 

 

Table 4-8A. Time > Menu 
 

Menu Item        Function    
 (Type)   Selections     (SCPI cmd)

 
 
Timebase   Pulse & Mod   Sets the horizontal sweep speed, time/Div 

(Numeric)   Discrete Range: 

   5 ns/Div to  Press the Time > Timebase menu key if it is  

   60 min/Div  not already activated. Adjust the timebase  

      using any of the data entry controls. When 

      selecting the timebase locally, using the 

      keypad, or remotely, over the GPIB, any  

      entry between valid timebase values will be 

      rounded up to the next valid timebase. 

  

      The horizontal (time) axis is subdivided into  

      ten major divisions of fifty data points (pixels)  

each, plus one additional point on the right 

border for a total of 501.  

 

      The timebase you select determines the time 

      resolution of all time measurements, including 

      the time markers (See Section 4-12) and the  

trigger delay function (see below). The signal 

sampling rate is 50 Msamples/sec. In the  

timebase range from 5 ns/Div to 1us/Div,  

(Fast Trigger ―off‖) or  5ns/Div to 500 us/Div 

(Fast Trigger ―on‖) each pixel is a single  

sample. For slower timebases, multiple  

samples are averaged together to form each  

pixel. The system automatically selects the  

minimum number of samples to form each  

pixel based on sweep speed and trigger delay.   

 

The maximum and minimum values, before 

averaging, and the average for each pixel are         

saved for use in measurements and displays.      Figure 4-24 

      See Display > Envelope.       Time > Menu (Pulse)    

 

      DISPlay:PULSe:TIMEBASE <5e-9 to 3600> (sec/Div) 
      DISPlay:MODUlated:TIMEBASE   <5e-9 to 3600> (sec/Div) 
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Table 4-8A. Time > Menu (continued) 
 

Menu Item         Function    
 (Type)   Selections      (SCPI cmd)

 
 

Position    Pulse    Positions the trigger within the waveform display window. 

(Multiple Choice)  L, M, R    

      Press the Time > Position menu key to shift the start of the waveform 

display to the left edge (―L‖), middle (―M‖) or right edge (―R‖) of the 

      display area. Use this function to view a specific segment of the  

      waveform. Select ―L‖ to observe the waveform immediately after the  

      trigger occurs; ―R‖ to observe the waveform immediately before;  

      and ―M‖ to observe segments of the waveform just before and after 

the trigger. 

 

      TRIGger:POSition {LEFT, MIDDLE, RIGHT} 
 

 

Trig Delay   Pulse   Sets the amount of delay between the trigger and 

(Numeric)   Continuous Range:  the start of sweep. 

   (See discussion) 

      The trigger delay is a time offset from the trigger event to the point at 

      which the waveform data is captured. Adjust the trigger delay using  

      any of the data entry controls. 

 

      The Model 4500B automatically adjusts the limits of the Time >Trig  

      Delay parameter range not to exceed the limits established by the  

      Time > Timebase selection. Trigger Delay Limits are listed in the 

instrument‘s specifications, Table 1-2. 

 

TRIGger:DELay <arg>. See Table 1-2 for argument range. 
 
 

Fast Trigger Pulse    Press the Time > Fast  Trigger menu key to turn the Fast Trigger  

(Toggle)   Off, On   function on or off. The Fast Trigger operates only for mid-timebases  

      (500 us/Div to 2 us/Div) and minimizes trigger arming delay. Used to  

      speed the formation of persistence type displays, e.g. eye diagrams.  

      Normally off. 

 
      TRIGger:FASTtrig <ON, OFF> 
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Table 4-8B. Statistics > Menu 
 

Menu Item       Function 
 (Type)   Selections     (SCPI cmd)

 
 

Presentation  Stat   Linear or logarithmic x-axis probability display 

(Toggle)   Lin, Log       

      Select Lin to display percent probability on a linear scale. Select Log to 

      display percent probability on a logarithmic scale.   

 

      DISPlay:STATistical:PRESentation {LIN, LOG} 
      

 

Horiz Scale  Stat   Select horizontal scale  

(Numeric)  Lin: Discrete range 

   0.1% / Div to 10% / Div Use any of the data entry controls to select a horizontal range. The  

      10% / Div range displays the total scope of probability values from  

      0% to 100%. For the more sensitive ranges, also use the % Offset  

      function (see, below) to position the expanded scale so that the point  

      of interest is on-screen.  

       

      An invalid combination of Horiz Scale and Horiz Offset is not allowed.  

      The Offset will be forced to a valid value.  

 

      DISPlay:PCTSCALE <10, 5, 2, 1, 0.5, 0.2, 0.1> (%) 
 

   Log: Discrete range Use any of the data entry controls to select the number of  decades of  

   1 to 7 decades  probability displayed on the horizontal axis. 

       

      DISPlay:DECAdes <1 to 7> (decades) 
 

 

Full Scale  Stat   Select the right edge Horiz Scale (Log) value 

(Numeric)  Discrete decade ranges: 

Log: 0.01 % to 100 % For the logarithmic scale only, use any of the data entry controls to 

select the percent value of the right hand edge of the display. Allows 

the display to be shifted to the right by 4 additional decades to display 

probability down to 1E-9 %. See Figure 4-25b.   

 

      DISPlay:FULLscale <.01 to 100> (%) 
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Table 4-8B. Statistics > Menu (continued) 
 

Menu Item        Function  
 (Type)   Selections     (SCPI cmd)

 
 

 

 

Horiz Offset  Stat   Offsets the left edge of the Horiz Scale (Lin) waveform  

(Numeric)  Continuous Range:   

   Lin: 0.0 % to 99.0 % For the linear scale only, use any of the data entry controls to set the  

      offset of the left edge of the display. The upper limit of this function  

      depends on the Horiz Scale setting. The % Offset can not create an  

      invalid display. An invalid display is one for which the right edge of  

      the display exceeds 100% or the left edge is less than 0%. For example, 

      when the X-axis is at 10% per division, the percent offset can only be  

      zero. See Figure 4-25a. 

 

      DISPlay:PCTOFST <0.0 to 99.0> (%) 
 

 

Stat Mode  Stat   Select distribution displayed 

(Mult. Choice)  CCDF, CDF, PDF  

The distribution functions are derived from a histogram of all of the 

power samples taken during the measurement time. None are discarded 

unless decimation is selected as the termination method.  

 

The complementary cumulative distribution function , CCDF (also 

known as 1-CDF), plot presents the data as the percent of total  samples 

above a selected  level. No samples (0.0 %) can be above the peak 

power; therefore, the power at zero probability is the peak power by 

definition.  

 

The cumulative distribution function, CDF, plot presents the data as the   

percent of total samples at or below a selected level. All of the samples 

must be at or above the peak power; therefore, the power at 100% 

probability is the peak power by definition.   

 

The probability distribution function, PDF, plot presents the percentage 

of samples that lie within equal sized bins. The number of bins per 

division can be specified. The PDF display is used mainly for data 

interpretation.  

 

      DISPlay:STATistical:MODE {CCDF, CDF, PDF} 

 

 

PDF Bars  Stat (PDF)  Select the number of bars in the PDF display.    

(Numeric)  1 to 35/ Div 

Use any of the data entry controls to select the number of bars (bins) 

per horizontal division in the PDF display. 

 

      DISPlay:TRACe:PDFBars {1, 2, 5, 10, 20, 35}    
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Table 4-8B. Statistics > Menu (continued) 
 

Menu Item        Function  
 (Type)   Selections     (SCPI cmd)

 
 

Term Settings  Stat   Select termination conditions 

(Submenu)  MENU 

 

 
 

 

       

    

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 4-25a.  Statistics > menu  (Lin)     Figure 4-25b.  Statistics > menu  (Log) 
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Table 4-8C. Statistics > Term Settings > Submenu 
 

Menu Item    
 (Type)   Selections     Function

             

Term Time  Stat   Set terminal run time 

(Numeric)  Discrete ranges: 

    Off, 1, 2, 5, 10, 30, 60,  Use any of the data entry controls to set a 

120, 300, 600, 1800,   running time for statistical data collection. 

   3600 seconds  When the time expires, the measurement will 

execute the Terminal Action. Select Off to  

ignore running time.   

 

      TRIGger:CDF:TIMe {0 to 3600} 
       

        

Term Count  Stat   Set terminal sample count 

(Numeric)  Continuous range: 

   2.0 to 4,096.0   Use any of the data entry controls to set a 

   Megasamples  terminal sample count. When the count is  

reached,  execute the Terminal Action.   

     

      TRIGger:CDF:COUNt <2 to 4096> (M) 
 

   

Term Action  Stat   Select the terminal action to execute 

(Mult. Choice)  Stop, Flush, Decimate 

      Stop – when the terminal time or count is  

reached, stop the measurement.  

 

Flush – when the terminal time or count is  

reached, clear the histograms and buffers  

and continue with a new measurement. 

 

Decimate -  when the terminal time or count  

is reached, divide each histogram bin count 

and the total sample count by 2 and continue. 

      This will provide a continuously updating               Fig. 4-26. 

distribution function.       Statistics > Term Count 

        menu. 

      TRIGger:CDF:DECImate {ON, OFF} 
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4.11 TRIG Key and Trig > Menu 
 
The TRIG key activates the Trig > menu (Figure 4-27), which enables you to specify the trigger  

parameters. Table 4-9 describes the functions that appear in the Trig > menu.  

 

When in the Pulse measurement mode, a trigger signal is required to produce a sweep. The source  

of this trigger can be any of the measurement channels or an external logic or analog baseband  

signal. To assist the user in setting up the trigger, the Auto Trigger modes will create a pseudo  

trigger if the selected source and trigger conditions do not result in an actual trigger. The  

Auto Peak-to-Peak trigger mode will automatically adjust trigger level while attempting to obtain  

a useable trigger. As a result, for many signals, it functions as a fully automatic trigger system.  

The Auto trigger mode does not adjust trigger level, but otherwise operates as described above.  

Both Auto trigger modes will try not to interfere with trigger conditions selected by the user if a  

trigger is generated by those settings. Unfortunately, this is not possible for all signal conditions.  

The Normal trigger mode will not interfere with user settings even if no trigger is generated.  

The Free Run mode causes horizontal sweeps to be generated asynchronously, without regard to  

trigger conditions.  

 

A trigger is not needed for the free running Modulated mode. It runs continuously. A trigger can  

be used to synchronously start a stopped Modulated mode measurement. After starting, it runs  

until stopped.  

 

A trigger is not needed for non-gated Statistical mode. It is started by command and terminates  

according to the conditions set. The gated Statistical mode uses the trigger system described  

above to select the parts of the signal to analyze. In this instance the Trig > Menu becomes a  

submenu of  Trig > Trig Setup (Trig A). 

 

 

Note 
 Stat*  in Table 4-9 & 4-9A applies only to the Trigger Setup submenu of the Pulse Gated  

 Statistical submode. 

 

  

              

              Fig 4-27a. Trig > menu  

             Pulse mode; Auto trigger 

 

 

Table 4-9. Trig > Menu 
 

Menu Item    
 (Type)   Selections     Function

 
 

Trig Mode  Pulse, Mod & Stat* Select the trigger system mode of operation  

(Mult. Choice)  Auto Pk/Pk, Auto, 

Normal, Free Run  Press the Trig > Trig Mode menu key to select the desired mode of 

trigger system operation. 

 

                                           Auto creates horizontal sweep in the absence of a trigger signal. For 

trigger rates below approximately 10 Hz, the Auto trigger may interfere 

with the desired trigger. Use Normal mode if this occurs.  
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Table 4-9. Trig > Menu (continued) 

 
Menu Item        Function    
 (Type)   Selections     ((SCPI cmd)

 
 

 Auto Pk-Pk performs the same function as  

Auto and, in addition, automatically sets the  

trigger level based on the peak-to-peak  

amplitude of the signal. For many signals  

this will provide a fully automatic trigger  

system. For slow rate signals and complex  

level patterns, it may not produce the desired  

display. Use Normal mode if this occurs. 

 

 Normal mode uses only the user specified  

trigger conditions. No automatic actions  

are taken.  

 

 Free Run generates horizontal sweep without  

regard to trigger conditions. This mode is  

useful for locating low duty-cycle events  

visually. 

 

      TRIGger:MODE {AUTOPKPK, AUTO,  

      NORMAL, FREERUN} 

 

 

Trig Source  Pulse, Mod & Stat* Selects internal or external triggering  

(Mult. Choice)   CH1, CH2,   

   Ext Trig1, Ext Trig2 Only one main trigger (A trigger) source is  

needed to capture data on a single or  

dual-channel instrument. The trigger source  

can be a measurement channel (internal  

trigger), Channel 1 or Channel 2 (dual  

channel models only), or the external trigger  

channel associated with each measurement  

channel, Trigger 1 or Trigger 2  (dual channel 

models only).  

 

      Specifications for the trigger source are  

provided in Section 1.6, Table1-2. Internal    

triggering occurs when the level of  the   Fig 4-27b. Trig > menu 

measurement channel signal crosses the    Pulse mode; Auto Pk/Pk 

specified trigger level in the direction   

(positive-going or negative-going) indicated by the slope selection. 

 

External triggering occurs when the level of the signal applied at the 

Trigger 1 or Trigger 2 input reaches the trigger level on the selected 

slope of the waveform. The selected triggering source is always active 

and will generate triggers even if the source channel is turned off  
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Table 4-9. Trig > Menu (continued) 
 

Menu Item        Function   
 (Type)   Selections     (SCPI cmd)

 
 

The choice of internal or external triggering will depend on the 

characteristics of the measured signal.  

 

      To select a trigger source press the Trig > Trig Source key to view the  

      list of available sources; CH1 and Ext Trig 1 (single channel); CH 1,  

      CH 2, Ext Trig 1and Ext Trig 2 (dual channel). 

 

      Press the menu key next to the source selected. The menu will return to 

      the Trig > menu with the selected source displayed. 

 

* In the gated Statistical mode the Trig > Menu is a submenu of   

Trig > Trig Setup (Trig A). 

 

      TRIGger:SOURce {CH1, CH2, TRIG1,  
      TRIG2} 
 

 
Trig Level  Pulse, Mod & Stat* Sets the threshold level for the trigger signal. 

(Numeric)   Auto Pk/Pk trig mode: 

   AUTO LEVEL  In the Auto Pk-to-Pk mode the trigger level is  

adjusted automatically. 

 

   Auto and Normal trig 

   modes: Internal source  

Continuous Range: Press Trig > Trig Level to highlight this  

selection and use any of the 

data entry controls to adjust the trigger level  

for the internal trigger source. (Trigger level  

settings are set independently for each trigger  

source.) 

 

The range of the internal trigger level is  

determined by the sensor model in use. For 

all peak sensor models the trigger range  

includes the sensor‘s maximum power and  

extends down to the level at which noise  

begins to interfere with triggering (High  

Bandwidth).  

 

The trigger range is automatically adjusted 

to include the dB Offset parameter selected  

in the Chan # > Exten > Corrections menu.  

For example, if the trigger level = 10 dBm  

and the dB Offset is changed from 0 to 20 dB, 

the trigger level will change to 30 dBm. The     Fig 4-27c. Trig > menu 

 trigger range is shifted upward by 20 dB.         Pulse; Normal trigger 
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Table 4-9. Trig > Menu (continued) 
 

Menu Item        Function   
 (Type)   Selections     (SCPI cmd)

 
 
      TRIGger:LEVel <-39.99 to 20.00> (dBm typ) 

 

Auto and Normal trig Press Trig > Trig Level to highlight this 

   modes: External source selection and use any of the data entry controls to adjust the trigger  

Continuous Range: level for the external trigger source. (Trigger level settings are set  

    independently for each trigger source.) 

       
The range of the external trigger level is  

determined by the setting of the  

Ext Trig # > Exten > Range menu 

 ( 5 V or 50 V). 
 

      TRIGger:LEVel <-5 to +5> (volts typ) 
 

 

Trig Slope  Pulse, Mod & Stat* Causes the trigger to occur on the selected 

(Toggle)   +,     slope of the trigger signal 
    

Press the Trig > Trig Slope menu key to  

select the desired triggering slope. 

 

      TRIGger:SLOPe {POS, NEG} 
 

 

Holdoff   Pulse & Stat*  Prevents false triggering when measuring 

(Numeric)   Continuous Range:   complex digital waveforms 

10 ns to 1 sec  

The Trig > HoldOff function is used to  

stabilize the display of complex signals when  

the triggering signal has multiple pulses  

within a triggering period. Measuring framed  

communication signals is a good example of  

an application of the Trig > HoldOff function.  

These signals are characterized by repetitive  

frames of random data bursts. Each frame is 

marked by a framing pattern of several bits. 

To achieve a stable display with the Model  

4500B, it is necessary to trigger the data  

capture with the framing pattern. However,      Fig 4-27d. Trig > menu 

without an external trigger, the instrument     Ext Trig 1; Auto trigger 

would trigger repeatedly on the data pulses,  

as well as on the framing pattern, resulting  

in an unstable display.           
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Table 4-9. Trig > Menu (continued) 
 

Menu Item        Function   
(Type)   Selections     (SCPI cmd)

 
 

To solve this problem, the Trig > HoldOff  

function specifies a time period during which triggering is inhibited. By 

setting the Trig > HoldOff period to be slightly less than the frame 

interval, the instrument can be made to ―lock on‖ to the framing pattern 

and present a stable display. The minimum HoldOff value is 100 ns, the  

minimum interval after a trigger event before the next trigger can 

occur. Entering ―0‖ as the HoldOff parameter disables HoldOff.  

 

      TRIGger:HOLDoff <0 to 65000e-6> (sec) 
 

 

B trigger   Pulse & Stat*  Displays a menu for the B Trigger 

(Submenu)  MENU 

 

 
 
 

Table 4-9A. Trig > B Trig > Submenu 
 

Menu Item        Function    
 (Type)   Selections     (SCPI cmd)

 
 

B Mode   Pulse & Stat*  Selects the operating mode of the B Trigger 

(Mult. Choice)  Off,  

   B Dly by Time  The B trigger or delayed trigger provides a means to delay the start of  

B Dly by Evnt sweep, after the receipt of the A trigger or delaying trigger, for a 

specified time period or after a specified number of trigger events. The 

A and B triggers may have the same or different signal source, level 

and slope.  

 

B Dly by Time – This mode delays the start of sweep, after the A 

trigger, by the time specified in Trig > B Trig > B Dly Time. 

 

B Dly by Evnt – This mode delays the start of sweep, after the A 

trigger, by the number of B trigger events specified in 

Trig > B Trig > B Dly EvntCnt.  

 

Select Off to disable the B trigger.  

 

      TRIGger:BTRIGger:MODE {OFF, TDLY, EDLY} 
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Table 4-9A. Trig > B Trig > Submenu (continued) 
 

Menu Item        Function    
 (Type)   Selections     (SCPI cmd)

 
 

 

B Source  Pulse & Stat*  Same as Trig > Source for the A Trigger, Table 4-9.  

 
      TRIGger:BTRIGger:SOURce {CH1, TRIG1, CH2, TRIG2} 
 

 

Trig Level  Pulse & Stat*  Same as Trig > Trig Level for the A Trigger, Table 4-9 . 

 

      TRIGger:BTRIGger:LEVel <-39.99 to 20.00> (dBm typ) 
  

  

B Slope   Pulse & Stat*  Same as Trig > Trig Slope for the A Trigger, Table 4-9. 

 

      TRIGger:BTRIGger:SLOPe {POS, NEG} 
 

 

B Dly Time  Pulse & Stat*  Set delay time for B Dly by Time mode 

(Numeric)  Continuous range: 

10 ns to 1 sec Set the time delay that must occur after the A trigger before the sweep 

starts. If the time delay is set to zero, the sweep will start on the first B 

trigger following the A trigger (minimum delay). If the time delay is set 

to T seconds, the sweep will start on the first B trigger that follows the 

A trigger plus an interval of T seconds. If there is no B trigger, the 

sweep will not start.  

 

      TRIGger:BTRIGger:TDLY <0 to 10000e-3> (sec) 
 

 

B Dly EvntCnt  Pulse & Stat*  Set trigger event count for B Dly by Evnt mode 

(Numeric)  Continuous range: 

0 to 999,999 Set the number of B trigger events that must occur after the A trigger 

before the sweep starts.  When the count is set to zero, the sweep will 

start when the A trigger occurs (no delay). If the count is set to 1, the 

sweep will start on the first B trigger following the A trigger.). If the 

count is set to N, the sweep will start on the Nth B trigger following the 

A trigger.  

 

      TRIGger:BTRIGger:ECOUNT  <0 to 999999> 
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Table 4-9B. Trig > Menu (modulated) 
 

Menu Item    
 (Type)   Selections     Function

 
 

Trig Mode   Mod   Select the trigger system mode of operation  

(Toggle)   Triggered, Free Run 

 Press the Trig > Trig Mode menu key to  

select the desired mode of trigger system  

operation. 

                                                                                                          

      Triggered – A trigger can be used to Start 

      the measurement, equivalent to pressing the 

Run menu key. The measurement will  

Continue until stopped with the menu key 

or a bus command. 
        

      Free Run – Measurements are made  

      continuously  without the need for a 

      Trigger.  

        

      TRIGger:MODE {TRIGGERED, FREERUN} 

  

 

Trig Source  Mod   Same as Trig > Trig Source, Table 4-9 above 

(Mult. Choice)   CH1, CH2,   

   Ext Trig1, Ext Trig2 

 

 

Trig Level  Mod   Same as Trig > Trig Level , Table 4-9 above 

(Numeric)  See Table 4-9 

 

 

Trig Slope  Mod   Same as Trig > Trig Slope, Table 4-9 above 

(Toggle)   +, -  

           

              Fig. 4-27e. Trig > menu 

              Modulated Mode 
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Table 4-9C. Trig > Menu (statistical) 
 

Menu Item    
 (Type)   Selections     Function

 
 

Gating   Stat   Select free running or gated statistical mode 

(Toggle)   Free Run, Pulse Gated  

Free Run – use this mode to build a  

distribution function that contains all of the  

samples collected between the Start and  

Stop measurement commands.  

 

Pulse Gated – use this mode to build a  

distribution function that contains only the 

samples within the time interval defined by  

Gate 1 and Gate 2 that are collected between  

the Start and Stop measurement commands.  

This mode is used to measure the statistics  

of a burst that can be synchronized with the  

trigger and timebase system.  

  

      TRIGger:STATistical:GATIng {ON, OFF} 
      OFF = Free Run; ON = Pulse Gated 

 

 

Trig Setup  Gated Stat  Setup the pulse gate trigger parameters 

(Submenu)  MENU    

This menu is identical to Trig > menu above,  

Table 4-9 and its submenu, Table 4-9A.  

Trig > B Trigger. The paths will appear as  

Trig  > Trig A and Trig > Trig A > B Trig.  

Stat* indicates a parameter that applies to  

this setup. 

 

 

Time Setup  Gated Stat  Setup the pulse gate timebase parameters 

(Submenu)  MENU 

This menu is identical to the Time > menu  

above, Table 4-8A. The path will appear as       Fig. 4-27f. Trig > menu 

the Trig > Time Settings > menu. Stat*       Statistical Mode 

indicates a parameter that applies to this  

setup.          

           

 

Gate 1   Gated Stat  Mark the beginning of the statistical time gate 

(Numeric)  Continuous range: 

With the burst of interest synchronized in the Pulse Preview window 

position the Gate 1 vertical cursor at the start of the region to be 

included in the distribution function.  

 

      TRIGger:STATistical:GATE[1] <arg>  (sec) 
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Table 4-9C. Trig > Menu (statistical) (continued) 
 

Menu Item    
 (Type)   Selections     Function

 
 

Gate 2   Gated Stat  Mark the end of the statistical time gate 

(Numeric)  Continuous range: 

With the burst of interest synchronized in the Pulse Preview window 

position the Gate 2 vertical cursor at the end of the region to be  

      included in the distribution function. 

 

      TRIGger:STATistical:GATE2 <arg>  (sec) 
 

 

Pulse Preview  Gated Stat  Select a split screen view with the amplitude vs time display on top and 

(Toggle)   Off, On   the distribution function of the same signal view on the bottom. 

 

 
 

 

 

4.12 MARK Key and Mark > Menu 
 

In the Pulse and Modulated modes, the MARK function key activates the Mark > menu (Figure 4-28) which enables you to 

position the time marks, and make power (or voltage) and time interval measurements. In the Statistical mode (Option 10) 

you can position the percent probability marks and make power (or voltage) cumulative distribution measurements. The 

markers are disabled in the discrete probability density function (PDF)mode. See Section 4.13 on Reference Lines for PDF 

measurements.  

 

In the Pulse and Modulated modes the signal level at Time Mark 1 or the maximum (or minimum) level between Time Mark 

1 and Time Mark 2 can be selected to appear above the left-hand side of the display window; similarly, the signal level at 

Time Mark 2 or the minimum (or maximum) level between Time Mark 1 and Time Mark 2 can be selected to appear above 

the right-hand side of the display window. 

 

The center position above the display window can indicate either the ratio of the two marker measurements, the average of 

the waveform between the markers or the peak-to-average ratio between the markers. For non-logarithmic units, the 

difference of the values at the markers can also be displayed (see Table 4-12).  

 

In the Statistical mode the markers are positioned in percent and return the signal levels of the cumulative distributions at the 

markers. The center position indicates the ratio of  the two marker values.  

 

Table 4-11 explains the operation of each item in the Mark > menu. Figure 4-28 and Table 4-12 describe the items in the 

Mark > Extensions > submenu. Each marker field is color-coded to match the waveform the marker is assigned to measure. 

When each marker is assigned to a different channel, the power ratio readout is assigned a neutral color and the choice of 

functions for the center is reduced.  

 

One marker is designated the active marker for control purposes, and is recognizable by the small triangles at top and bottom. 

To change the active marker, press the Mark > Marker # menu key corresponding to the marker you wish to activate. The 

markers read the level at the instant specified by their pixel location on the waveform. Readings are not affected by the 

setting of the vertical scale or vertical center offset parameters (see Subsection 4.9), nor must waveform data points be visible 

screen to be measured. When there are no valid data to be measured at a marker, the corresponding display field will show a 

series of dashes ( . ). The symbol (^^^.^^) indicates an overrange condition; the symbol ( . ) indicates an 

underrange condition. 
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Procedure  To make time interval measurements, position Time Marks 1 and 2 at the beginning and end of the interval  

  you wish to measure. The time interval measurement appears in the Mark > Delta Time window. The  

  resolution of time interval measurements depends on the timebase selection (see Subsection 4.10). 

 

 

 

Table 4-11. Mark > Menu 
 

Menu Item       Function    
 (Type)   Selections    (SCPI cmd) 

 
 

Marker #  Pulse & Mod  Controls the position of Marker # in time units. 

(Numeric)  Continuous Range:  

   (Left and Right  Press the Mark > Marker # menu key to  

   boundaries of the                activate this function. 

   display.)    

      Use any of the data entry controls to position  

the time marker anywhere  within the left and  

right boundaries of the waveform display. The  

marker position is expressed as the time offset  

relative to the trigger event. 

 

Stat    Controls the position of  Marker # in percent. 

Continuous Range:  

(Left and Right  Press the Mark > Marker # menu key to  

boundaries of the   activate this function. 

display.)  

  Use any of the data entry controls to position  

the percent marker anywhere within the left  

and right boundaries of the distribution 

display. The marker position is expressed as  

the percent of total occurrence. 

 

      MARKer[1/2]:POSItion:TIMe <arg> (sec) 
 

      MARKer[1/2]:POSItion:PERcent  
      <0 thru 100> (percent) 
 

      MARKer[1/2]:POSItion:PIXel <0 thru 500> 
 

 

Delta Time  Pulse & Mod  Displays the time difference between   

(None)      Marker 1 and Marker 2 

 

      The value that appears in this window is  

      automatically calculated by the instrument.      Fig. 4-28. Mark > menu 

 

Stat    Displays the percent difference between  

Marker 1 and Marker 2 

 

The value that appears in this window is  

automatically calculated by the Model 4500B. 
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Table 4-11. Mark > Menu (continued) 
 

Menu Item       Function  
 (Type)   Selections    (SCPI cmd)   

 
 

 Set Vrt Cntr  Pulse, Mod & Stat Shifts the waveform display vertically to  

(Action)   CENTER   position it according to the location of 

the active time mark. 

   

Press the Mark > Set Vrt Cntr menu key to move the intersection of the 

active marker and the waveform or trace of the active channel to the 

vertical center of the display window. This function allows you to use 

the active marker to designate the point on the active channel waveform 

or trace that appears at the center of the display window. This is useful 

when the vertical size is expanded so that much of the waveform is not 

visible.   

 

      DISPlay:TRACe:MKCENTer 
 

 

Extensions  Pulse, Mod & Stat Selects the Mark > Extensions submenu 

(Submenu)  MENU 
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Table 4-12. Mark > Extensions > Submenu 
 

Menu Item        Function    
 (Type)   Selections     (SCPI cmd)

 
 

MK Group  Pulse, Mod & Stat Selects the marker channel assignment mode. 

(Toggle)   Both, Each   

   When ―Both‖ has been selected, both markers  

are assigned to the same channel. Changing  

either marker channel assignment changes  

both assignments. Also, selecting ―Both‖  

activates two choices in the Mark > Exten  >  

Delta Marker menu, ―Ratio‖ and ―Average.‖ 

 

When ―Each‖ has been selected, the markers  

can be assigned individually; that is, Mark >  

Extensions > Mk 1 CH and Mark >  

Extensions > Mk 2 CH can be assigned to  

different channels. The marker channel  

assignments for the ―Both‖ and ―Each‖  

selections are independent and are saved  

separately. 

 

      MARKer:GROUp {BOTH, EACH }   
 

 

Marker Chan  Pulse, Mod & Stat For MK Group both, assigns Marker 1 and  

Mk 1 CH  Active, CH1, CH2 Marker 2 to the same measurement channel. 

Mk 2 CH  Ext Trig 1, Ext Trig 2 

(Mult. Choice)  CH Math,   For MK Group each, assigns Marker 1 and  

Mem 1, Mem 2,  Marker 2 to measurement channels. 

       

      When Active is selected, the Marker(s) is  

assigned to and tracks the active channel. 

in the Chan > Selection window. 

 

      The Time Mark # assignment for each of the  

   two group assignments (―Both‖ and ―Each‖) 

   are independent of each other. When      Fig. 4-29a.   

   Mark > Exten > Mk Group Both has been      Mark > Exten menu 

   selected, both Marker 1 and Marker 2 are      Both-Active 

   assigned to the same channel. Changing  

   either entry changes both.          

 

When Mark > Mk Group Each has been selected, the marker 

assignments are recalled from the last selections made in the Mark > 

Mk Group Each mode. Each of the markers can be assigned to separate 

 measurement channels.       
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Table 4-12. Mark > Extensions > Submenu (continued) 
 

Menu Item         Function    
 (Type)   Selections      (SCPI cmd)

 
 

Each marker can be assigned to the memory channels also. All marker 

functions will function on the memory channels including minimum 

and maximum power measurements between markers and average 

power between markers. 

 

      MARKer[1/2]:ASSIgn  {ACTIVE, CH1, CH2, TRIG1, TRIG2,  
      CHM, MEM1, MEM2} 

 

 

Delta Marker  Pulse & Mod   Selects the function of the center marker  

(Mult. Choice)  Ratio, Avg,  window above the graphical display 

   Delta 

      Use Mark > Marker # menu function to place  

      the time markers in the active window at  

      the points of interest on the waveform. Press  

      the Mark  > Delta Marker menu key to select 

either ―Ratio‖, ―Avg.‖ , or "Delta". (―Delta‖  

is available for non-logarithmic units only.)  

 

Select ―Ratio‖ to display the power (or  

voltage) ratio of Marker 1 and Marker 2 in 

the center window. If Marker 1 and Marker 2  

are expressed in logarithmic units, ratio will  

be in dB. If  Marker 1 and Marker 2 are  

expressed in linear (non-logarithmic) units,  

the ratio will be in percent.  

 

Select ―Avg‖ to display the average power  

(or voltage) in the waveform interval between  

the two markers. The average power (or  

voltage) will be expressed in the same units  

as the Markers 1 and 2. 

 

The ―Avg‖ selection is available only when  

Mark > Extensions > Mk Group Both is  

selected. When Mark > Extensions >  

Mk Group Each is selected, the Delta Marker 

selection is automatically switched to 

―Ratio.‖ When Mark > Extensions > Mk  

Group Both is reselected, the Delta Marker  

selection returns to ―Avg.‖ 

         Fig. 29b  

 The "Delta" selection is available only for      Mark > Exten menu 

 linear (non-logarithmic) units (e.g. watts,      Each – CH1,Ch2 

 volts). The delta function displays the  

      power (or voltage) difference between 
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Table 4-12. Mark > Extensions > Submenu (continued) 
 

Menu Item    
 (Type)   Selections     Function

 
 

the two markers. If Mark > Extensions > Delta Marker is set to ―Delta‖ 

and the units are changed to logarithmic, the selection is automatically 

switched to the previous selection of Ratio or Avg. If the units are 

changed back to linear units, the ―Delta‖ function will be re-selected.  

 

The MK1-MK2 and MK2-MK1 selections for marker math are valid 

for the above functions. The  MIN-MAX, MAX-MIN and Pk/Avg 

marker math functions are available only when Mark > Extensions > 

Mk Group is set to Both. In addition, Pk/Avg requires that Mark > 

Extensions > Delta Marker is set to ―Ratio‖. 

 

  Stat   In the Statistical mode (Option 10) , only ―Ratio‖ is available for all 

Ratio units. Only the MK1-MK2 selection for marker math is valid for this 

function. 

 

     See Marker Math SCPI commands. 

 

 

Marker Math  Pulse & Mod  Selects the type and order of measurement markers 

(Mult. Choice) 

   Marker 1 and Marker 2 measure the signal level at the set point on the  

   waveform. 

   MK2 - MK1  Ratio = MK2/MK1, Delta = MK2 MK1 

MK1 - MK2 Ratio = MK1/MK2, Delta = MK1 MK2  

   

 MIN and MAX measure the minimum and maximum instantaneous 

signal level between the markers. 

   MAX – MIN  Ratio = MAX/MIN, Delta = MAX MIN 

   MIN – MAX  Ratio = MIN/MAX, Delta = MIN MAX 

 

 MINF and MAXF measure the minimum and maximum filtered signal 

level between the markers. 

   MAXF – MINF  Ratio = MAXF/MINF, Delta = MAXF MINF 

   MIN F– MAXF  Ratio = MINF/MAXF, Delta = MINF MAXF 

 

   Pk/Avg   Ratio = Pk/Avg  

      LAvg measures the long term signal average between the markers. 

      PkHld measures and holds the peak signal value. See the 

      Chan # > Exten > Peak Hold function for more information. 

    

 
   Stat   Selects the type and order of statistical measurement markers 

 

   Marker 1 and Marker 2 measure the signal level at the set points on the 

   distribution.    

MK1 - MK2 Ratio = MK1/MK2 (only) 
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Table 4-12. Mark > Extensions > Submenu (continued) 
 

Menu Item        Function 
 (Type)   Selections     (SCPI cmd)

 
 

MARKer:MATH:BOTH  See Chapter 5 for argument description. 
 
      MARKer:MATH:EACH  See Chapter 5 for argument description. 
 
 

 

 

 

 

 

 
 

 

 

Note  The Peak-to-Average Marker Math function allows users without the Statistical option (Option 10) to make 

peak-to-average (also called Crest Factor) measurements in the Pulse mode. Note that the measurement is 

made between the two time markers This is a very important characteristic because the primary use of this 

function is to measure within a GSM pulse burst. Usually, one of three or more bursts in a sequence or 

frame is selected by placing the markers just inside the leading and trailing edges. Typically, 5% to 95% of 

the burst length is actually measured.  

 

If Chan # > Exten > Peak Hold function is Off, the PkHld reading will slowly decay at a rate related to the 

Averaging setting. If Peak Hold is On, the PkHld reading will be held until reset. This is more precise, but 

less convenient, since it requires a STOP, CLEAR, RUN sequence at the beginning of each new 

measurement. 

 

The Statistical option also provides this capability in its gated mode, along with the distribution functions 

and other parameters. It can also measure non-synchronous signals such as CDMA and OFDM. 
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    Fig. 29c. Characteristics of the Peak-to-Average Ratio measurement. 

 

 

Note  In Fig. 29c, the Peak power and top level power of the pulse are similar and the time markers are placed so  

  that the  pulse occupies approximately half of the time interval. Therefore, a peak-to-average ratio of about  

  3 dB is expected.  
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4.13 REF Key and Ref > Menu 
 
The REF function key activates the Ref > menu, which controls the horizontal reference lines.  Figures 4-30 and 4-31, and 

Tables 4-13 and 4-14 describe the Ref > menu and its submenus. 

 

 

 
Table 4-13. Ref > Menu 

 
Menu Item        Function    
 (Type)   Selections     (SCPI cmd) 

 
 

Ref Line 1   Pulse, Mod & Stat Controls position of reference line 1. 

(Numeric)   Continuous Range 

The reference line will indicate the amplitude 

level that corresponds to its display position  

based on the reference channel‘s vertical  

scale, vertical offset and units. 

 

 

Ref Delta   Pulse, Mod & Stat Displays the difference between the amplitude 

(None)    NONE   levels at reference lines 1 & 2. 

 

 

Ref Line 2   Pulse, Mod & Stat  Controls position of reference line 2. 

(Numeric)   Continuous Range 

The reference line will indicate the amplitude  

level that corresponds to its display position  

based on the reference channel‘s vertical  

scale, vertical offset and units. 

 

      REFLine[1|2]:POSItion:LEVel  
      <-99.00 to 99.00>, dBm typical 
 

 

 Note   

  When REF > Ref Tracking is active, Ref Line 1, Ref Line 2 and Ref Line Delta 

                             will be dimmed and not adjustable. The Tracking Mode will automatically set  

their position.  

 

 

 

REF CH Sel   Pulse, Mod & Stat Assign reference lines to a channel 

(Mult. Choice)  Off, Active, CH1, CH2,  

   Ext Trig 1, Ext Trig 2, The reference lines indicate power (or        Fig. 4-30. Ref > Menu 

Mem 1, Mem 2,   voltage) level based on position on the   

CH Math   display grid. The relationship between  

dependent on the vertical the screen position and the level is scale and 

offset of the assigned channel. To make measurements on any specific 

channel, that channel must be selected, or for a pair of  channels, both 

must have the same vertical scale, vertical center and units.  
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Table 4-13. Ref > Menu (continued) 
 

Menu Item        Function   
 (Type)   Selections     (SCPI cmd) 

 
 

To remove Reference lines from the display, select Off. To make the 

Reference line refer to the active channel, select Active. To refer to a 

specific channel, select it from the list.  

 

      REFLine:ASSIgn  {OFF, ACTIVE, CH1,  
      CH2, TRIG1, TRIG2, CHM, MEM1, MEM2} 
 

 

Ref Tracking   Pulse   Control reference line tracking 

(Mult. Choice)  Off, 

Markers,   In reference line tracking mode the instrument sets the level reference 

   Top-Bottom,  markers to the position indicated by the Ref Tracking menu description 

   Distal-Mesial,  on the reference channel selected. 

   Distal-Prox.,    

When tracking is ―Off‖, the reference lines are set to the levels entered 

Mod    in the Ref Line1 and Ref Line  2 menus. The ―Markers‖ tracking  

Off, Markers   selection sets the reference lines to the marker levels. Marker 1 is  

loaded into Ref 1 and Marker 2 is loaded into Ref 2. The ―Top –  

Stat    Bottom‖ selection loads the automatic measurement of the Top line  

Off    amplitude into Ref 1 and the Bottom line amplitude into Ref 2. The  

Distal - Mesial selection loads the automatic measurement of the distal  

level into Ref 1 and the Mesial level into Ref 2. The Distal – Proximal  

selection loads the automatic measurement of the Distal into Ref 1 and  

the Proximal level into Ref 2. 

 

     REFLine:TRACk {OFF, X1X2, TOPBOT, DISTMESIAL,   
      DISTPROX}  
 

 

Ref to Mks  Pulse, Mod & Stat  Sets the levels of both of the Ref lines to the levels displayed by the 

(Action)       Set measurement markers MK1 and MK2 

      .    

      Ref 1 is set to MK1 level, Ref2 is set to  

MK2 level. 

 

REFLine:POSItion:FORCetomk      
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4.14 MEAS Key and Meas > Menu 
 
The MEAS function key activates the Meas > menu (Figure 4-32). This menu contains the frequency assignments for each 

channel,  the system tracking control and the automatic measurement assignments for the parameter fields. In the Meas > 

menu three items are dedicated to the frequency assignment for the channel 1 and channel 2 inputs. Frequency entries can be 

assigned to each channel individually or to both channels at the same time. The entries in the two modes are independent, 

which allows the instrument to hold three different frequency assignments. The selection of the frequency is determined by 

the frequency of the signal being applied to the measurement channel. These entries are used to recall frequency related 

correction data from the sensors connected to that channel. This data is automatically applied to the measurement. The range 

of allowable frequency entries is determined by the sensor connected to channel. The limits can be viewed under the Spcl > 

Sensor Data > CH 1 Sensor > Report. For Pulse and Modulated modes use Table 4-15; for Statistical mode, Table 4-17. 

 

 

Table 4-14. Meas > Menu (pulse and modulated) 
 

Menu Item       Function   
 (Type)   Selections    (SCPI cmd) 

 
 

 

 

Freq Track   Pulse, Mod    Selects the channel frequency entry mode. 

(Toggle)   On, Off 

When frequency tracking is ‖On‖, the same  

frequency is assigned to both channels.  

Changing either CH1 or CH2 frequencies  

changes both of them. Both windows are  

updated. 

 

When frequency tracking is ―Off‖, the  

frequency for each channel can be  

individually assigned. 

 

      SENSe:CORRection:FRQTRK {ON, OFF} 
 

 

Freq CH1   Pulse, Mod    Selects the input signal frequency on CH1 for 

(Numeric)   Continuous Range:  frequency correction. 

   (Sensor Dependent) 

   To set the CH 1measurement frequency, press  

the Meas > menu key and use any of the data  

entry controls to select the measurement  

frequency in GHz. If frequency tracking is  

―On‖, CH 2 will be set to the same frequency. 

 

The frequency response characteristic for  

each power sensor is recorded in an EEPROM 

in the sensor before shipment from the factory. 

The Model 4500B downloads this data and  

creates a look-up table of correction factors  

that are applied to each power measurement.  

If the measurement frequency lies between        Fig. 4-32. Meas > menu 

two values in the table, the correction factor 

is interpolated. 
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Table 4-15. Meas > Menu (pulse and modulated) (continued) 
 

Menu Item         Function    
 (Type)   Selections      (SCPI cmd) 

 
 

 

Freq CH2   Pulse, Mod  Selects the input signal frequency on CH2 for frequency correction. 

(Numeric)   Continuous Range: 

(Sensor Dependent)  Identical to Freq CH1 above, except applied to CH 2.  

 

      SENSe[1/2]:CORRection:FREQuency <0.01e9 to 40.00e9> (Hz) 
      Note: Frequency range is sensor dependent. 

 

 

Sys Tracking  Pulse, Mod  Controls the tracking of channel parameters. 

(Toggle)   Off, On 

When ―On‖, selected parameters track changes made on any channel. 

For example, changing units on Channel 1 will cause the same change 

on Channel 2, Ext Trig 1, Ext Trig 2, Mem 1 and Mem 2. Active 

tracked parameters are indicated by an asterisk (*) in the affected menu 

box titles. 

 

The ―tracking‖ parameters are: 

 

Units, Start Gate, End Gate, Peak Hold, Video BW,  

Averaging, Distal, Mesial, Proximal 

 

Pulse Units (in Ext Trig 1,2, cannot be set to watts) 

 

When ―Off‖, the above parameters are set independently  

on each channel. 

 

      CALCulate:SYSTRK {ON, OFF} 
 

 

Auto Measure  Pulse   Selects menu for pulse parameter automatic measurement  

(Submenu)  MENU   functions 

                 
Param Meas  Pulse   Selects menu to setup upper display fields for pulse automatic 

(Submenu)  MENU    parameter measurements 
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Table 4-15A. Meas > Auto Meas Menu (pulse) (continued) 
 
Menu Item       Function   
 (Type)   Selections    (SCPI cmd) 

 
 

 

AutoMeas Gate  Pulse  Selects the pulse gating mode                            

 (Mult. Choice)            

Choices are: 

All – Auto measurements based on all pulses in the display 

 

First - Auto measurements based on the first pulse in the display 

 

Markers – Automatic pulse  measurements based on the first pulse 

  in the marker interval 

 

Off – No automatic pulse measurements are performed (maximizes  

         acquisition speed) 

 

CALCulate:AMEAsure:MODE { ALL, FRST, MRKRS, OFF } 
 

 

EdgeDly Mode  Pulse  Selects the method of measuring the edge delay 

 from the start of  the trace display. 

                  Fig. 4-32a. Meas > 

Choices are:              Auto Meas 

First Edge  – Edge Delay from the beginning of the trace to the first rising 

or falling edge when AutoMeas Gate set to All or First.  For   

AutoMeas set to Markers, the Edge Delay is from the beginning  

of the trace to the first rising or falling edge within the marker interval. 

 

Last Edge   – Edge Delay from beginning of the trace to the last rising or falling  

edge when AutoMeas Gate set to All or First.  For AutoMeas Gate  

set to Markers, the Edge Delay is from the Beginning of the trace  

to the last rising or falling edge within the marker interval.    

 

Burst          – Edge Delay is the time interval from the first rising or falling edge  

to the last rising or falling edge in the trace display when AutoMeas  

Gate set to All or First.  For AutoMeas set to Markers, the time interval  

is from the first rising or falling edge to the last rising or galling edge  

within the marker interval. 

 
CALCulate:AMEAsure:EDGEdelay  { FRST, LAST, BRST} 

 

 
Bottom Detect  Pulse  Enables or disables signal-based IEEE pulse bottom detection.                           

   On, Off   

When off, IEEE pulse bottom is forced to 0.0 mW or -99.99 dBm. 

On uses automatic bottom detection method described in Section 6.3. 

 
CALCulate:AMEAsure:BOTtom  {OFF, ON} 
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Table 4-15B. Meas > Auto Meas > Skew > Submenu (pulse) 
 

Menu Item         Function    
 (Type)   Selections      (SCPI cmd)

 
 

 

 

CH1 Skew Ref  Pulse   To change the reference channel for  

(Selection Menu)  CH1, CH2  Channel 1 time skew measurements, press  

   Trig1, Trig2  the menu key. When ―Selection‖ appears 

   Mem1, Mem2  in all menu box titles, all reference channel  

      choices will be displayed. 

 
Press the menu key beside the desired 

reference for Channel 1. The display will  

revert to the Skew Ref display with the 

selected reference for Channel 1.  

 

 

CH2 Skew Ref  Pulse   See procedure above. 

(Selection Menu)  CH1, CH2 

   Trig1, Trig2 

   Mem1, Mem2 

 

 

Trg1 Skew Ref  Pulse   See procedure above. 

(Selection Menu)  CH1, CH2 

   Trig1, Trig2 

   Mem1, Mem2 

 

 

Trg2 Skew Ref  Pulse   See procedure above. 

(Selection Menu)  CH1, CH2 

   Trig1, Trig2 

   Mem1, Mem2 

 

           Fig. 4-32a. Meas >Skew 

Mem1 Skew Ref  Pulse   See procedure above.   > men 

(Selection Menu)  CH1, CH2          

   Trig1, Trig2          

   Mem1, Mem2       . 

 

 

 

Mem2 Skew Ref  Pulse   See procedure above. 

(Selection Menu)  CH1, CH2 

   Trig1, Trig2 

   Mem1, Mem2 

 

DISPlay:SKEW[1/2/3/4/6/7]:REFerence {CH1, CH2, TRIG1, 
TRIG2,  MEM1, MEM2} 

  

 
Time skew is the difference between the reference channel‘s edge delay and the measured channel‘s edge delay.  
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Table 4-16. Meas > Param Meas > Submenu (pulse) 
 

Menu Item        Function  
 (Type)   Selections     (SCPI cmd) 

 
 

Selection   Pulse   Select channel for status or parameter display 

(Mult. Choice) 

 

 

Param Mode  Pulse   Select type of display 

(Toggle)   Status, Meas   

      Select Status to display the following nine 

      parameters for the active channel in the field  

above the grid box: 

Freq, VidBW, Avging, TrA, TrB, Tr Dly, 

Vscale, Vcent and Offset. 

 

Select Meas to display nine selected  

parameters in the display field above the 

Grid box. The parameters are selected from  

a list that includes the fifteen auto-measure  

parameters as well as the status parameters. 

The channel selection for each parameter is  

determined by the active channel when the  

selection is made. See Table 4-16A. 

 

      DISPlay:PARAmeter:MODE {MEAS, 
      STAT} 
 

 

 

Param Column  Pulse   Select column in parameter display 

(Mult. Choice)  L, M, R 

 

 

Param Top  Pulse   Select top item in column 

(Mult. Choice)  See Table 4-16A. 

 

 

Param Middle  Pulse   Select middle item in column 

(Mult. Choice)  See Table 4-16A.           Fig. 4-33. 

               Meas > Param  Meas 

    menu 

 

Param bottom  Pulse   Select bottom item in column 

(Mult. Choice)  See Table 4-16A. 
       

      DISPlay:PARAmeter:TOP:LEFT {see Table 5-1} 
      DISPlay:PARAmeter:MIDdle:LEFT  {see Table 5-1} 
      DISPlay:PARAmeter:BOTtom:LEFT {see Table 5-1}          

Middle and Right columns similar to above. See Chapter 5.     
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Table 4-16A. DISPLAY PARAMETER TABLE 
 

      NUMBER  PARAMETER  DESCRIPTION 

 
 

 1 Pulse Width                 Pulse width 

 2 Risetime   Pulse risetime 

 3 Falltime   Pulse falltime 

 4 Period   Pulse Period  

 5 PRFreq   Pulse repetition frequency  

 6 Duty Cycle  Duty cycle  

 7 OffTime   Pulse offtime  

 8 Peak   Peak Power 

 9 Pulse   Pulse Power  

 10 Oversh                           Pulse overshoot 

 11 AvgPower  Average power  

 12 Top Amp Pwr  Pulse top level power 

 13 Bot Amp Pwr  Pulse bottom level power 

 14 Skew   Edge time skew to skew reference channel 

 15 EdgeDelay  Edge delay, time from trigger to first displayed edge transition 

 16 Freq   Measurement frequency setting 

 17 VidBW   Sensor video bandwidth setting 

 18 Avging   Channel averaging value 

 19 TrA   A Trigger slope, source and level    

 20 TrB   B Trigger slope, source and level or off 

 21 Tr Dly   Trigger delay setting 

 22 VScale   Vertical scale setting 

 23 VCent   Vertical center setting 

 24 Offset   Vertical offset setting  

 

Note: For equivalent SCPI command parameters, see Table 5-1. 
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Table 4-17. Meas > Menu (Statistical) 
 

Menu Item       Function   
 (Type)   Selections    (SCPI cmd) 

 
 

Freq Track   Stat    Selects the channel frequency entry mode. 

(Toggle)   On, Off 

When frequency tracking is ‖On‖, the same  

frequency is assigned to both channels.  

Changing either CH1 or CH2 frequencies  

changes both of them. Both windows are  

updated. 

 

When frequency tracking is ―Off‖, the  

frequency for each channel can be  

individually assigned. 

 

      SENSe:CORRection:FRQTRK {ON, OFF} 
 
 

Freq CH1   Stat    Selects the input signal frequency on CH1 

(Numeric)   Continuous Range: for  frequency response  correction.    

(Sensor Dependent)   

See Table 4-15 above. 

 

    

Freq CH2   Stat   Selects the input signal frequency on CH2 

(Numeric)   Continuous Range:  for frequency response correction. 

   (Sensor Dependent) 

See Table 4- 15 above. 

 

 

Sys Tracking  Stat   Controls the tracking of channel parameters. 

(Toggle)   Off, On    

   When ―On‖, Channel 1 and Channel 2 units 

   and video bandwidth track any changes made  

   on either channel.  

Fig. 4-33a. Meas >  
      CALCulate:SYSTRK {ON, OFF}     menu                 
 

Normalize Pwr  Stat   Select display and marker scaling of distributions 

(Toggle)   Off, On    

When ―Off‖, power distributions are displayed as power versus 

probability. When ―On‖, power distributions are displayed as  

normalized power versus probability. Each power point is divided by 

the average power of all the points. Marker measurements also  

change from power (dBm or watts) at a point to normalized power at 

that point (dBr or percent).          

 

      SENSe:NORMalize {ON, OFF }   
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4.15 UTIL Key and Util > Menu 
 
The UTIL key activates the Util > menu (See Table 4-20 and Figure 4-26), which enables you to view the instrument status 

summary, set up the IEEE-488 bus and serial input/output ports, and set the internal real-time clock. 

 

 

Table 4-18. Util > Menu 
 

Menu Item    
 (Type)   Selections     Function 

 
 

Inst Status  REPORT  Displays equipment serial numbers, 

      configuration and revision status.  

 

Press the Util > Inst Status menu key to  

display the serial number, configuration,  

and revision status. See Figure 4-34. If  

Channel 1 or 2 is not responding, a channel  

card is either not functional or not installed.  

If  the Instrument Status Report indicates that  

the sensor is not connected, check the cable  

and sensor connections. The Report will  

also indicate the cable length for the input  

board. The cable length should match the  

configuration for the input board. 

 

 

Remote Conf      MENU   Opens the Util > Remote Conf submenu 

       

   Press the Util > Remote Conf menu key to  

open the remote configuration submenu. 

 

 

Disk    MENU   Opens the Util > Disk submenu 

 

 

Hardcopy  MENU   Opens the Util > Hardcopy submenu 

 

 

Clock   MENU   Opens the Util > Clock submenu 

               Fig.4-32. Util > menu 

 

              Fig. 4-34. Util > menu 

 

 



Boonton 4500B RF Peak Power Analyzer 

Operation 4-69 

Table 4-19. Util > Remote Conf > Submenu 
 

Menu Item    
 (Type)   Selections     Function 

 
 

       

Interface  GPIB, LAN  Select the active remote interface. 

 

 

 

       

GPIB Config  MENU   Configure the GPIB (IEEE-488) interface. 

 

 

 

 

LAN Config  MENU   Configure the LAN (Ethernet) interface. 

 

 

 

 

Session Log  On, Off   If On, creates a session log file of GPIB 

      commands received and sent. 

 

 

 

Emulation  MENU   Opens the Util > Remote Conf > Emulation  

      Submenu 

       

       

 

Mnemonics  MENU   View a list of GPIB mnemonics and the  

(Action)      associated arguments for the current 

      language selection. 

 

 

 

               Fig. 4-35. Util >  

               Remote Conf >  

               submenu 
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Table 4-20. Util > Remote Conf > GPIB > Submenu 
 

Menu Item       Function    
 (Type)   Selections     (SCPI cmd) 

 
       

Bus Setup  MENU   Accesses the Util > Remote Conf  > GPIB >  

(Action)      Bus Setup > submenu. See Figure 4-34 and  

Table 4-21. 

 

 

Set Mask  Continuous Range Enters the SRQ mask as a decimal number 

(Numeric)  0 to 255 

Press the Util > Remote Conf  > GPIB > 

 Set Mask menu key to highlight this function.  

Use any of the data entry controls to enter the  

decimal equivalent of the SRQ mask.  

 

The SRQ mask is a bit-level mask that is  

entered in a decimal number base. For  

example, enter 2 decimal to activate the  

second bit ; enter 16 decimal to activate the  

fourth bit; or enter 128 decimal to activate  

the eighth bit. 

 

Each bit in the mask enables the reporting of  

a service request for an individual function or  

group of functions. The functions assigned to  

each bit are listed in section 5.5.1 IEEE 488.2  

Commands, *STB? 

 

      *SRE <0 to 255> 
 

 

Set SRQ    SRQ    Key request for service to the GPIB bus 

(Action)      controller 

 

      Set the SRQ mask to 32 to enable the Event    

      Status Summary bit in the Service Request       Fig. 4-36. Util > 

      Enable Register and set 64 in the Standard       Remote Conf  > GPIB 

Event Status Enable Register to enable a    submenu. 

User Request for service. Refer to Chapter 5, 

Remote Operation, for a description of the *SRE and *ESE commands 

and queries. 

 

The SRQ signal is true when ―request for service‖ is active and the 

front panel SRQ message will be appear. 

 

The manual SRQ feature is useful in automatic routines that prompt 

users to initiate manual measurements, calibration or other functions. 

 

The user can signal the controller at the appropriate time. 
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Table 4-20. Util > Remote Conf > GPIB > Submenu (continued) 
 

Menu Item    
 (Type)   Selections     Function

 
The number that is displayed in the ―Set SRQ‖ selection window is the 

current SRQ number, which is in effect after the mask is applied. If the 

SRQ message appears on the front panel, the operator can view the 

SRQ value that will be reported to the controller in the next polling 

cycle. 

 

Press the ESC key when in GPIB Local mode to clear any pending 

SRQ conditions. 

 

 

View Buffers  REPORT   Contents of GPIB Listen and Talk buffers 

(Action) 

This function allows the inspection of received bus messages in Listen 

mode, and current outgoing messages in Talk mode. It is provided as a 

tool for troubleshooting bus communication problems. 
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Table 4-21. Util > Remote Conf > GPIB > Setup > Submenu 
 

Menu Item        Function    
 (Type)   Selections     (SCPI cmd) 

 
 

 

Address   Continuous Range: Sets the GPIB address for the Model 4500B 

(Numeric)  1 to 30 

      The instrument address can be set to any value  

in the range from 1 to 30. Each instrument on  

the bus is assigned a unique address.  

 

 

Listen Term  EOI only,  Selects the terminating character for the  

(Mult. Choice)  LF, CR    Listen mode. 

 

Each command string sent to the 4500B  

requires a terminating signal or character. The  

preferred practice is to use the EOI (End or  

Identify) signal from the controller. The bus  

controller sends the EOI signal with the last  

character of  each string. The 4500B will  

always respond to the EOI signal, either alone  

   or in combination with a special character.  

 

Some legacy controllers and equipment  

cannot generate or respond to the EOI signal.  

In this case, a special character, usually the  

ASCII line feed (LF) or carriage return (CR) 

is used. The EOI signal may also be used in  

combination with special characters. 

 

Select ―EOI only‖ whenever possible. If  

necessary for compatibility with older  

equipment, use ‖LF‖ or ―CR‖ as required.   

 

SYSTem:COMMunicate:GPIB:LISTen   Fig. 4-37. Util > 

      {EOIONLY, CR, LF}    Remote Conf > GPIB > 

        submenu 

   

Talk Term  EOI only,  Selects the terminating character(s) for the Talk mode 

(Mult. Choice)  CRLF, 

LF, CR Each data string returned by the 4500B requires a terminating signal or 

character. The preferred practice is to send the EOI (End or Identify) 

signal with the last character of each string.  

 

Some legacy controllers and equipment cannot generate or respond to 

the EOI signal. In this case, a special character, usually the ASCII line 

feed (LF), carriage return (CR) or (CRLF or NL) is used. If necessary, 

the user can suppress the EOI signal when a special character(s) is 

used. See ―EOI on Talk‖ below. If  used, the EOI signal is true with the 

last character returned.  
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Table 4-21. Util > Remote Conf > GPIB > Setup > Submenu (continued) 
 

Menu Item         Function    
 (Type)   Selections      (SCPI CMD) 

 
 

Select ―EOI only‖ whenever possible. If necessary for compatibility 

with older equipment, use ‖LF‖, ―CR‖ or ―CRLF‖ as required.   

 

      SYSTem:COMMunicate:GPIB:TALK {EOIONLY, CRLF, CR, LF} 
 

 

EOI on Talk  On, Off   Select ―Off‖ only when a special terminating character(s) without EOI 

(Toggle)      is required. Used only for compatibility with legacy and mixed vintage  

GPIB equipment.  
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Table 4-21A. Util > Remote > LAN Config > Submenu (Opt 11 only) 
 

Menu Item         
(Type)   Selections      Function 

 
 

 
IP Address  None, info only  Displays the current LAN IP address.  This 

is configured by Windows network settings. 

          

      A display of  0.0.0.0 usually means that 

either Util > Remote > Interface is set to 

GPIB, or else it is set to LAN and the 4500B 

is expecting an automatically assigned IP 

address, but has not  received one from a 

DHCP server. 

 

 
Network Conn       EXECUTE  Pressing this menu key will exit the 4500B 

(Action)      application, and bring up the Windows™ 

―Network settings‖ dialog.  Consult 

Microsoft® documentation for details on 

configuring network settings. 

 

Navigating the dialog may be easier with 

a keyboard and mouse connected, although 

the 4500B‘s keyboard provides enough 

functionality to perform certain configuration 

tasks.  

 

Once configuration is complete, close the 

dialog and press the Init key to restart the 

4500B application.  If a new IP address has 

been set or assigned, it should now be shown 

in the IP Address menu box. 
 

        Fig. 4-37A. Util > 

                       Remote Conf > LAN 

               Config > submenu 
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Table 4-22. Util > Remote Conf > Emulation > Submenu 
 

Menu Item        Function 
(Type)   Selections      (SCPI CMD) 

 
 

 

Boot Language  SCPI, 4500A  Boot Language selects the default language  

(Toggle)      at instrument power-up. It does not change 

      the Current Language. 

 

 

Curr Language  SCPI, 4500A  Current Language permits viewing and  

(Toggle)      changing the language at any time without a 

      remote command.  At power-up, the Current 

      Language is set to the Boot Language.   

 

      SYSTem:LANGuage EMUL4500A 
 

 

*IDN Response  4400, 4400A  Selects model number the instrument returns  

 (Mult. Choice)  4500, 4500A  in Emulation mode to *IDN? query. 

   4500B 

 

 

Option Select  None,  -S/1,   Selects the option identifier appended to   

(Mult. Choice)  -04, -05, 06  the Emulation mode *IDN? query. 

 

 

Ignore Unsupp  On, Off   In 4400/4500/4400A/4500AEmulation mode  

(Toggle)      only, if ―On‖, ignores GPIB bus when an  

unsupported command is received. 

If  ―Off‖, returns error message. 

 

       

 

 

 

 

         Fig. 4-38. Util > 

                       Remote Conf >  

                Emulation > submenu 

 
 

Note  For compatibility purposes, the 4500B remote interface can be set to emulate the BOONTON 4400, 4500, 4400A  

 (including 4400A-L) and 4500A (including 4500A-L) series of instruments. For additional discussion of this 

 subject,  see Section 5.2. To use the 4500B SCPI interface, set the Util > Remote Conf  > Emulation >  Curr 

 Language menu selection to SCPI. To emulate the 4400/4500 legacy interface, set the Util > Remote Conf  > 

 Emulation > Curr Language menu selection to the desired model. To control the language in use at instrument 

 power-up, select your choice in the in the Util > Remote Conf  > Emulation > Boot Language menu box.   
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Table 4-23. Util > Disk (1 of 2) > Submenu 
 

Menu Item    
 (Type)   Selections     Function 

 
 

Folder   UP   Select next higher level folder 

(Action) 

 

 

Folder   OPEN   Open the selected folder 

(Action) 

 

 

Extension     Select file extension for listing 

(Mult. Choice)  See list 

.AC* - Sensor Calibration data. .AC1 for  

 Channel 1 and .AC2 for Channel 2 

      .INS – Saved instrument setup file. 

      .MMP –  Waveform memory file - Pulse mode 

      .MMM-  Waveform memory file – Modulated  

mode 

      .MMS – Trace memory file – Statistical mode 

      .DAT – Data file. 

      .TXT – Text file (ASCII). 

      .TRC – Trigger Calibration file. 

      .BMP – Display image file. 

      .PCX – Display image file. 

     .* - Wildcard, matches all files. 

 

 

Rename   MENU   Open menu for renaming file 

(Submenu) 

 

 

Copy   MENU   Open menu for copying a file 

(Submenu) 

 

               Fig. 4-39. Util > Disk  

1 of 2   - more -   Opens the 2 of 2 section       (1 of 2) > submenu 

 (Action) 
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Table 4-24. Util > Disk (1 of 2) > Rename > Submenu 
 

Menu Item    
 (Type)   Selections     Function 

 
 

Cursor   <-Position 

(Action) 

 

Cursor   Position-> 

(Action) 

 

 

(none)   Clear Name 

(Action) 

 

                  

         

(none)   Backspace 

(Action) 

 

 

(none)   SELECT CHAR 

(Action) 

 

 

(none)   RENAME 

(Action)       Fig. 4-40. Util > Disk (1 of 2) > Rename 

 

 
 

 

 

 

Table 4-25. Util > Disk (1 of 2) > Copy > Submenu 
 

Menu Item    
 (Type)   Selections     Function 

 
 

Folder   UP   Same as Util > Disk > menu Table 4-22. 

(Action) 

 

 

Folder   OPEN   Same as Util > Disk > menu Table 4-22. 

(Action) 

 

 

(none)   PASTE 

(Action) 
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Table 4-26. Util > Disk (2 of 2) > Submenu 
 

Menu Item    
 (Type)   Selections     Function 

 
 

Folder   UP   Select next higher level folder 

(Action) 

 

 

Folder   OPEN   Open the selected folder 

(Action) 

 

 

(none)   DELETE  Delete the selected folder 

(Submenu) 

      This command deletes the selected folder and  

all of its contents! Press the Util > Disk  

      (2 of 2) menu key to delete the folder. 

      The ―Are You Sure? Press DELETE to 

Remove, CLR to cancel.‖ message will 

appear at the bottom of the display. 

Press the Util >Disk (2 of 2) menu key a 

second time to delete the folder. Otherwise 

press the CLR key to cancel the delete. 

    

 

Folder   MENU   Opens the Folder submenu 

(Submenu) 

 

 

2 of 2   - more -   Opens the 1of 2 section 

 (Action) 

 

 

 

 

               Fig. 4-41. Util > Disk 

                (2 of 2) > submenu 
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Table 4-27. Util > Disk (2 of 2) > Folder > Submenu 
 

Menu Item    
 (Type)   Selections     Function 

 
 

Create Folder  MENU   Opens menu to create a new folder 

(Submenu) 

 

 

Use Folder  Active, Last 

(Toggle) 

           r 

 

 

Select   Active Folder 

(Action) 

 

 

2 of 2   - more - 

 (Action) 

 

 

 

 

 

 

 

 

 

 

      Fig. 4-42. Util > Disk > (2 of 2) > Folder 
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Table 4-28. Util > Disk (2 of 2) > Folder > Create  > Submenu 
 

Menu Item    
 (Type)   Selections     Function 

 
 

Cursor   <-Position 

(Action) 

 

Cursor   Position-> 

(Action) 

 

 

(none)   Clear Name 

(Action) 

 

                  

(none)   Backspace 

(Action) 

 

 

(none)   SELECT CHAR 

(Action) 

 

 

(none)   CREATE 

(Action) 

 

 

 

 

 

 

 

 

 

 

               Fig. 4-42a. Util > Disk 

               (2 of 2) > Folder Create 
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Table 4-29. Util > Hardcopy > Submenu 
 

Menu Item        Function    
 (Type)   Selections     (SCPI cmd) 

 
 

Plot Labels     Show optional Plot Labels on the display  

(Toggle)   On, Off   and the hardcopy 

 

DISPlay:PLABel:MODE {ON, OFF} 
 

 

 

Plot BackGrnd     Select the background color for hardcopy 

(Mult. Choice)  Black, White, Gray 

      For printing and plotting, the black display 

      background may be undesirable. Use this 

      menu to select a black, gray or white back- 

ground for the hardcopy.  

       

HCOPy:BACKground:COLor  
{BLACK, WHITE, GRAY}     

  
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Fig. 4-43. Util > 

Hardcopy Submenu 

 

 

Related commands to enter up to 4 custom labels: 

 

DISPlay:PLABel:TEXTA  ―string of up to 19 characters‖ 

DISPlay:PLABel:TEXTB  ―string of up to 19 characters‖ 

DISPlay:PLABel:TEXTC  ―string of up to 19 characters‖ 

DISPlay:PLABel:TEXTD  ―string of up to 19 characters‖ 
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Table 4-30. Util > Clock > Menu 
 

Menu Item        Function    
 (Type)   Selections     (SCPI cmd) 

 
   

Year     Present to 2037  Sets the system clock year 

(Numeric)         

      SYSTem:DATE:YEAR <2003 to 2037>       
 

   

 Month    1 to 12   January = 1; December = 12. 

(Numeric)     

      SYSTem:DATE:MONTH <1 to 12> 
   

   

Day of the Month   1 to 31   Calendar 

(Numeric)   

      SYSTem:DATE:DAY <1 to 31>             
 

   

Hour   0 to 23   24 hour local time 

(Numeric)    

      SYSTem:TIMe:HOUR  <0 to 23>     
  

  

Minute   1 to 59   Clock 

(Numeric)    

      SYSTem:TIMe:MINUTE <0 to 60>          
 

 

 

Day of the Week   None   Automatically calculated by the system clock 

(Read only) 

  

 

CAUTION 
 

The 4500B Clock function sets the internal computer‘s system clock. The system    Fig 4-44. Util > Clock 

clock is used to operate various features of the 4500B. Therefore, care should be     submenu 

taken to set the clock accurately to local time. In some situations features may 

fail to operate if the system clock is set back or set ahead by a significant amount.  
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4.16 CAL Key and Calibrator > Menu 
 

With the Calibrator > menu (Figure 4-45), you can turn on the calibrator output and adjust the calibrator signal parameters. 

The items in the Calibrator> menu and its two submenus are presented in the following figures and tables: 

 

Menu or Submenu    Figure   Table 

 

Calibrator >   4-45   4-31 

Calibrator > Pulse (Preset) 4-46   4-32 

Calibrator > Pulse (Variable) 4-47  4-33 

Calibrator > Extensions  4-48   4-34 

 

 

 

Table 4-31. Calibrator > Menu 
 

Menu Item        Function   
 (Type)   Selections     (SCPI cmd) 

 
 

 

Cal Output   Off, On    Controls the calibrator RF output. 

(Toggle) 

      Press the Calibrator > Cal Output menu key  

to alternately the turn the calibrator‘s RF 

output signal ―On‖ and ―Off‖. 

 

      OUTPut:SIGnal {ON, OFF}   
 

 

Set Level  Continuous Range:  Sets the calibrator output level. 

(Numeric)   -50.0 to +20.0 dBm 

Press the Calibrator > Set Level menu key  

to activate this function. Use the data entry  

controls to adjust the calibrator output 

power to the desired level. 

 

      OUTPut:LEVel <-50.0 to 20.0> 
                          

 

Max Power   Continuous Range:  Establishes the upper limit for the calibrator 

(Numeric)   -50.0 to +20.0 dBm output power. 

 

Press the Calibrator > Max Power menu key  

to activate this function. Use the data entry  

controls to adjust the upper limit of calibrator  

output power. 

 

An error message will be generated if you  

attempt to set the Calibrator > Max Power 

      value lower than Set Level, or if you attempt      Fig. 4-45. Calibrator > 

               menu. 
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Table 4-31. Calibrator > Menu (continued) 
 

Menu Item       Function 
 (Type)   Selections     (SCPI cmd) 

 
 

to set the Set Level value greater than the 

Calibrator > Max Power value. 

 

      OUTPut:LEVel:LIMit <-50.0 to 20.0> 
 

 

Cal Mode   CW, Pulse   Selects the calibrator output signal format. 

(Toggle) 

Press the Calibrator > Cal Mode menu key to alternately select a CW 

or a Pulse modulated RF output signal.  

 

      OUTPut:MODUlation {CW, PULSE} 
 

 

Pulse   MENU   Opens the Calibrator > Pulse submenu 

(Submenu) 

 

 

Extensions   MENU    Opens the Calibrator > Extensions submenu 

(Submenu) 

 

 
 

 

 

Table 4-32. Calibrator > Pulse (Preset) > Submenu 
 

Menu Item         Function 
 (Type)   Selections      (SCPI cmd) 

 
 

Source    Int, Ext    Selects the source for the calibrator output pulse modulation 

(Toggle) 

Press the Calibrator > Pulse > menu key to specify whether the 

calibrator output pulse is to be internally or externally generated. 

 

      OUTPut:PULSe:SOURce {INT, EXT}  
 
 

Polarity    +,     Selects the polarity for calibrator’s preset internal pulse modulation 

(Toggle) 

Press the Calibrator > Pulse > Polarity menu key to select positive-

going or negative-going calibrator output pulses when Preset internal 

pulse modulation is used. This control has no effect on External or 

Internal Variable pulse modulation.  

 

      OUTPut:POLArity {POS, NEG} 
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Table 4-32. Calibrator > Pulse (Preset) > Submenu (continued) 
 

Menu Item        Function 
 (Type)   Selections      (SCPI cmd) 

 
 

Duty Cycle   Discrete Range:   Selects the duty cycle for calibrator’s preset internal pulse modulation  

(Numeric)   + Polarity: 

10, 20, 30, 40, 50 % Press the Calibrator > Pulse > Duty Cycle menu key to step through  

Polarity: the range of available duty cycles. This control has no effect on 

90, 80, 70, 10, 50 % External or Internal Variable pulse modulation.  

 

      OUTPut:PULSe:DCYCle {10, 20, 30, 40, 50} 
 

 

Pulse Period   Discrete Range   Selects the period of the calibrator’s preset pulse modulation 

(Numeric)   100 us, 1 ms, 10 ms 

Press the Calibrator > Pulse > Pulse Period 

menu key to step through the range of  

available pulse periods.  

 

      OUTPut:PULSe:PERiod {0.1, 1, 10} 
 

 

Pulse Control  Preset, Var  Selects the Preset or Variable internal Pulse 

(Toggle)      modulator 

 

Press the Calibrator > Pulse > Pulse Control 

menu key to select the Variable method of 

internal pulse modulation control.  

See Table 4-32. 

 

      OUTPut:PULSe:CTRL {PRESET, VAR} 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

                   Fig. 4-46. Calibrator > 

         Pulse > (Preset) 
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Table 4-33. Calibrator > Pulse (Variable) > Submenu 
 
Menu Item         Function 
 (Type)   Selections      (SCPI cmd) 

 
 

Source    Int, Ext   Selects the source for the calibrator output pulse modulation 

(Toggle) 

Press the Calibrator > Pulse > menu key to  

specify whether the calibrator output pulse is 

to be internally or externally generated. 

 

      OUTPut:PULSe:SOURce {INT, EXT} 

 

 

Pulse Width  Continuous Range: Set variable mode pulse width 

(Numeric)  7 us to 65.535 ms, for 

   period  65.542 ms, and Use any of the data entry controls to enter  

   width + 7us   period; the pulse width.  

   Min width increases 

   with increasing period   

   above period = 65.544  

ms.  

        

      See below: OUTPut:PULSe:PERWID 

 

 

Pulse Period  Continuous Range: Set variable mode pulse period 

(Numeric)  28 us to 131.077 ms; 

   Pulse width must be Use any of the data entry controls to enter the 

   compatible.  the pulse period. 

 

      OUTPut:PULSe:PERWID <period> <width> 
               <period> = 28e-6 to 131.07e-3  
      <width> = 7e-6 to 65.535e-3 
 
 

Pulse Control  Preset, Var  Selects the Preset or Variable internal Pulse 

(Toggle)      modulator 

 

      Press the Calibrator > Pulse > Pulse Control      Fig. 4-47. Calibrator  

menu key to select the Preset method of         > Pulse > (Variable 

internal pulse modulation control.  

See Table 4-31. 

 

      OUTPut:PULSe:CTRL {PRESET, VAR}    

 
NOTE   

Calibrator pulse modulation can also be supplied by an external pulse generator via the rear-mounted BNC 

connector labeled ―EXT PULSE‖. Select ―Ext‖  in the Calibrator > Pulse > Source menu window. TTL-

level signals connected at this input port will gate the 1 GHz calibration signal on and off. A low level 

signal turns the RF output off.  
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Figure 4-48. 
 

 

Table 4-34. Calibrator > Extensions > Submenu 
 

Menu Item       Function  
(Type)   Selections     (SCPI Cmd) 

 
 

Level Step   0.1 to 60 dB   Selects the step level for the calibrator. 

(Numeric) 

The step level value is incremented or decremented from the current 

calibrator when the knob or arrow keys are activated. 

 

      OUTPut:LEVel:STEP  <0.1 to 60.0> 
 
 

Calibrator   REPORT   Includes information about the installed calibrator. 

 

Press the Calibrator > Extensions > Calibrator menu key to list 

calibrator information. The report includes: Status, Serial Number,   

Software Version, Calibration Date and Internal Temperature.  

A non-zero status reading indicates that an error condition exits. 
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4.17 PRGM Key and Prgm > Menu 
 
The PRGM key activates the Prgm > menu (Figure 4-49), which enables you to store one or more instrument configurations 

and waveforms for later recall and reuse. 

 

The Model 4500B is equipped with a file system for saving complete instrument setups. This is useful for saving 

configurations you develop for specific measurements. To make similar measurements later, you can save time by recalling 

the appropriate configuration from memory, rather than accessing several control menus to reestablish the desired conditions. 

You can specify the name of configuration files and their storage locations on the instrument‘s hard drive. The number of 

configuration files is limited only by the size of the storage media.   

 

The items contained in each saved configuration file are listed in Table 3-3. Items not included in the store and recall 

operations include parameters related to the GPIB bus, Serial Ports 1 and 2, plotter, clock and display colors. 

 

 

 

 

Menu or Submenu    Figure   Table 

Prgm menu   4-49  4-35 

Prgm > Inst Store menu  4-50  4-36 

Prgm > Inst Store > Basename 4-51  4-37 

Prgm > Inst Store > Filename 4-52  4-38 

Prgm > Instr Recall menu  4-53  4-39 

Prgm > Instr Recall display 4-54  4-39 

Prgm > Mem Save menu  4-55  4-40 

Prgm > WFM Store menu  4-56  4-41 

Prgm > WFM Recall Report 4-57  4-42 

Prgm > WFM Recall menu 4-58  4-42 

Prgm > Trace Data menu  4-59  4-43 
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Table 4-35. Prgm > Menu 
 
Menu Item       Function 
 (Type)   Selections     (SCPI Cmd) 

 
 

Inst Store  MENU   Opens the instrument Store to file submenu 

(Submenu) 

 

 

Instr Recall  MENU   Opens the instrument Recall from file 

(Submenu)      submenu 

 

 

Mem Save  MENU   Opens the waveform save to Memory channel 

(Submenu)      submenu 

 

 

WFM Store  MENU   Opens the waveform store to file submenu 

(Submenu) 

 

 

WFM Recall  MENU   Opens the waveform recall from file submenu 

(Submenu) 

 

 

Trace Data  MENU   Opens the waveform save data to file submenu  

(Submenu) 

 

 

 

 

 

 

 

 

 

              Fig. 4-49. Prgm > 

              menu. 

 

 
 

To save the current configuration, press the Prgm > Instr Store menu key (Table 4-36). A file system directory display will 

appear. Use the data entry controls to select an existing filename or create a new filename following the instructions on the 

display. Press the Prgm > Instr Store > Store menu key to create the configuration file and write it to disk memory. If you 

have not entered a new filename, you will be asked to confirm the over-write of an existing file or cancel the operation.  
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Table 4-36. Prgm > Inst Store > Menu 
 
Menu Item        
 (Type)   Selections     Function 

 
 

Folder   UP   Select next higher level folder 

(Action) 

 

 

Folder   OPEN   Open the selected folder 

(Action) 

Use any of the data entry controls to move the  

selection cursor up and down the list of files,  

and select a particular file. 

 

 

Basename  UsrImg   Opens the filename basename submenu 

(Submenu) 

Press the Prgm > Inst Store > Basename  

menu key to open a menu that allows you to  

change the basename of instrument  

configuration storage files. The default  

basename is UsrImg. This can be followed  

by a number that indicates the stored  

sequence, e.g. UsrImg001.dat, 

UsrImg002.dat, UsrImg003.dat, etc. The 

instrument will then index the file sequence  

number automatically. A user  defined   

basename may be used instead 

 

(None)  DELETE  Deletes the selected file.  

(Action)      

     User confirmation is requested before a file is  

     deleted. 

 

              Fig. 4-50. Prgm > Inst  

Store  MENU   Opens the filename submenu      Store menu. 

(Submenu) 

Press the Prgm > Inst Store menu key to open a menu that allows you 

to change the filename of an instrument configuration storage file. The 

default filename is made up of the basename entered above plus the 

next sequential number. You can use the default filename or change 

part or all of it. 

 

 

NOTE 
  A filename extension that identifies the type of waveform saved is supplied by the system. This extension  

  should not be changed by the user. An error will occur on recall if the extension is not correct.  
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Table 4-37. Prgm > Inst Store > Basename > Menu 
 

Menu Type 
 (Type)   Selections     Function 

 
 

Cursor   <-Position 

(Action) 

 

Cursor   Position-> 

(Action) 

 

(none)   Clear Name 

(Action) 

                  

(none)   Backspace 

(Action) 

 

(none)   SELECT CHAR 

(Action) 

 

Basename  DONE 

(Action) 

 

      Figure 4-51.  Prgm > Inst Store > Basename display. 

 
 

 

Table 4-38. Prgm > Inst Store > Filename > Menu 
 
Menu Item 
 (Type)   Selections     Function 

 
 

Cursor   <-Position 

(Action) 

 

Cursor   Position-> 

(Action) 

 

(none)   Clear Name 

(Action) 

                  

(none)   Backspace 

(Action) 

 

(none)   SELECT CHAR 

(Action) 

 

Filename  STORE 

(Action) 

 

      Figure 4-52.  Prgm > Inst Store > Filename display. 
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To recall a previously stored configuration, press the Prgm > Instr Recall menu key. A file system directory display will 

appear. Use the data entry controls to select the name of the configuration file you need. Press the Prgm > Instr Recall  > 

Instrument menu key to restore the recorded setup. 

 

Table 4-39. Prgm > Inst Recall > Menu 
 

Menu Item 
 (Type)   Selections     Function 

 
 

Folder   UP   Select next higher level folder 

(Action) 

 

Folder   OPEN   Open the selected folder 

(Action) 

Use any of the data entry controls to move  

the selection cursor up and down the list of  

files, and select a particular file. 

 

 

Instrument  RECALL  Recalls the instrument setup  

(Action) 

Press the Prgm > Instr Recall > Instrument  

menu key to RECALL the stored instrument  

configuration file selected above. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

              Fig. 4-53. Instr > Recall  

              menu.  

 

 

 

 

 

 

 

 

Fig. 4-54. Instr > Recall display. 
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Table 4-40. Prgm > Mem Save > Menu 
 

Menu Item         Function   
 (Type)   Selections      (SCPI cmd)    

 
 

Source  CH1, CH2  Select a channel waveform to be saved to a memory channel 

(Mult. Choice)  Ext Trig 1, Ext Trig 2 

To select a source channel to save, press the  

Prog > Mem > Save menu key to view the  

list of available sources; CH 1 and Ext Trig 1  

(single channel); CH 1, CH 2, Ext Trig 1and  

Ext Trig 2 (dual channel). 

 

Press the menu key next to the source  

selected. The menu will return to the  

Prog > Mem > Save menu with the  

selected source displayed. 

 

 

Destination  Mem1, Mem2  Select the memory channel  

(Toggle) 

     Press the Prog > Mem >Destination menu  

     key to alternately select the Mem 1 or Mem 2  

     memory channel as the destination for the  

     channel selected above. 

 

 

Waveform  STORE   Store the source channel waveform to the  

(Action)     selected destination  

 

 

     See MMEMory:COPY in Chapter 5. 
 

 

 

 

 

 

              Fig. 4-55. Prgm > Mem 

              > Save menu. 
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Table 4-41. Prgm > WFM Store > Menu 
 
Menu Item 
 (Type)   Selections     Function 

 
 

Folder   UP   Select next higher level folder 

(Action) 

 

Folder   OPEN   Open the selected folder 

(Action) 

Use any of the data entry controls to move the  

selection cursor up and down the list of files,  

and select a particular file. 

 

 

Source  CH1, CH2  Select a channel waveform to be saved to file 

(Mult. Choice)  Ext Trig 1, Ext Trig 2 

  Mem1, Mem2  To select a channel waveform to save to a  

     file, press the Prog > WFM Store >Source  

     menu  key to view the list of available  

     sources:  

     CH 1, Ext Trig 1, Mem 1 and Mem 2  

     (single channel);  

     CH 1, CH 2, Ext Trig 1, Ext Trig 2, Mem 1  

     and Mem 2 (dual channel). 

 

Press the menu key next to the source  

selected. The menu will return to the   

Prog > WFM Store menu with the selected  

source displayed. 

 

 

Basename  Wfm   Opens the filename basename submenu 

(Submenu) 

Press the Prgm > WFM Store > Basename  

menu key to open a menu that allows you to 

change the basename of waveform storage  

files. The default basename is Wfm. This     Fig. 4-56. Prgm > WFM 

can be followed by a number that indicates    > Store menu.     

the stored sequence, e.g. Wfm001.mmp,  

Wfm002.mmp, Wfm003.mmp, etc. The 

instrument will then index the file sequence  

number automatically. A user defined  

basename may be used instead.  

 

 

(None)  DELETE  Deletes the selected file.  

(Action)      

     User confirmation is requested before a file is deleted. 



Boonton 4500B RF Peak Power Analyzer 

Operation 4-95 

Table 4-41. Prgm > WFM Store > Menu (continued) 
 
Menu Item        Function 
 (Type)   Selections      (SCPI cmd) 

 
 

Store  MENU   Opens the filename submenu 

(Submenu) 

Press the Prgm > WFM Store > Store menu key to open a menu that 

allows you to change the filename of a waveform storage file. The 

default filename is made up of the basename entered above plus a 

sequential number. You can use the default filename or change part or 

all of it.  

 

See MMEMory:STORe in Chapter 5. 
 

NOTE 
  A filename extension that identifies the type of waveform saved is supplied by the system. This extension  

  should not be changed by the user. An error will occur on recall if the extension is not correct. 

  

    

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Figure 4-57. Prgm > WFM > Recall REPORT.  
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Table 4-42. Prgm > WFM Recall > Menu 
 
Menu Item       Function 
 (Type)   Selections     (SCPI cmd) 

 
 

Folder   UP   Select next higher level folder 

(Action) 

 

 

Folder   OPEN   Open the selected folder 

(Action) 

Use any of the data entry controls to move the  

selection cursor up and down the list of files,  

and select a particular file. 

 

 

Destination  Mem1, Mem2  Select a memory channel to display a saved  

(Toggle)     waveform  

   

 To select a memory channel to display a  

 waveform saved to a file, press the  

 Prog > WFM Recall > Destination menu  

 key to alternately select Mem 1 and Mem2.  

      

 

WFM Report  REPORT  Reports the contents of a saved waveform file 

 

Press the Prog > WFM Recall > WFM Report  

menu key to see detailed  information about a  

saved waveform file.  

 

Press the Prog > WFM Recall > WFM Report  

menu key again to close the report display. 

 

 

Waveform  RECALL  Recall a stored waveform file 

(Action)              Fig. 4-58. Prgm > WFM 

Press the Prog > WFM Recall >Waveform     > Recall menu. 

menu key to recall the stored waveform file  

to the specified memory channel. 

 

      See MMEMory:LOAD in Chapter 5. 
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Table 4-43. Prgm > Trace Data > Menu 
 

Menu Item        Function 
 (Type)   Selections      (SCPI cmd) 

 
 

Source  See Chart  Select a source for trace data 

(Mult. Choice)   

     To select a source for trace data to save to a file, press the Prog > 

     TraceData > Source menu key to view the available sources:   

   

     Single Chan  Dual Chan   

     CH1   CH1, CH2   

     Ext Trig 1  Ext Trig 1, Ext Trig 2 

     Mem1, Mem2  Mem1, Mem2 

     CH Math  CH Math 

                                                             

     + Opt 10   + Opt 10 

     Cal Tbl 1  Cal Tbl 1, Cal Tbl 2 

     Histogram 1  Histogram 1, Histogram 2 

 

      TRACe:SOURce {CH1, CH2, TRIG1, TRIG2, CHM, MEM1,  
      MEM2, CAL1,CAL2, HIST1,HIST2} 

 

 
Delimiter  Comma, LF,   Select an item delimiter character  

(Mult. Choice)  CR, Space 

Press the Prog > Trace Data >Delimiter  

menu key to select a character delimiter for  

the trace file. The intended use of the data file  

will determine your choice. The CR delimiter  

is useful for the direct entry of the file into an  

Excel™ spreadsheet column.  

 

      TRACe:DELImiter {COMMA, CR, LF, SPACE} 
  
  

Basename  Trace   Opens the filename basename submenu 

(Submenu) 

Press the Prgm > Trace Data > Basename  

menu key to open a menu that allows you to  

change the basename of trace files. The  

default basename is Trace. This can be  

followed by a number that indicates the  

stored sequence, e.g. Trace001.mmp,  

Trace002.mmp, Trace003.mmp, etc.  

An arbitrary basename may be used instead.  

 

  

(None)  DELETE  Deletes the selected file.  

(Action)      

     User confirmation is requested before a file is deleted. 
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Table 4-43. Prgm > Trace Data > Menu (continued) 
 
Menu Item       Function 
 (Type)   Selections     (SCPI cmd) 

 
 

 

Filename  MENU   Opens the filename submenu 

(Submenu)              

Press the Prgm > Trace Data > Filename    

menu key to open a menu that allows you  

to change the filename of a trace file.  

 

The default basename is Trace. This can be  

followed by a number that indicates the  

stored sequence, e.g. Trace001.txt,  

Trace002.txt, Trace003.txt, etc. The  

instrument will then index the file sequence  

number automatically. A user defined  

basename may be used instead. 

 

The file format is ASCII text with the  

delimiter chosen above as the item delimiter.   

 

      See TRACe:SEND in Chapter 5. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

              Fig. 4-59. Trace > Data 

               menu. 
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4.18 DISP Key and Disp > Menu 
 
The Display menu  controls the way traces are drawn and how they appear. Use the Display > Format  submenu to draw 

traces as individual points, ―Points‖, or as points connected by lines, ―Lines‖. A trace can also be removed from the display 

altogether by setting it to ―Off‖. The grid layout and header of the display can be selected. 

 

The Persistence and Envelope modes provide additional help in displaying signal excursions. When the persistence and 

envelope display modes are both ―Off‖, the trace is drawn as a narrow line, which shows the averaged or filtered power 

reading.  A single vertical pixel, representing the filtered or average power reading will be illuminated for each horizontal 

trace pixel. 

 

In Pulse mode, each pixel will be the average of one or more samples and/or sweeps, depending on timebase and 

Averaging settings. 

 

In Modulated mode, each pixel is the filtered average power, as determined by the Filter settings. 

 

In Statistical mode, the trace is a narrow line representing the CDF, CCDF.  The PDF is always drawn as a filled 

distribution. 

 

 

PERSISTENCE 
 

When persistence is ―On‖ (infinite), the trace will automatically be drawn with single points (pixels) that remain visible on 

the screen until cleared by pressing Display CLEAR key on the top level menu. The data points are not connected by lines 

when persistence is enabled and changing any measurement or display parameters that could affect the waveform will cause 

the accumulated points to be erased. This prevents invalid data from being drawn or remaining visible on the screen. Note 

that the persistence mode has no effect on memory channels and only operates when the instrument is in the pulse 

measurement mode. 

 

 

ENVELOPE 
 

In Pulse and Modulated modes, the Envelope display is used to highlight the range of signal excursions. When envelope 

display mode is ―On‖, the trace is drawn as a wide line, which is filled in between the minimum and maximum power 

readings.  A series of vertical pixels, representing the range of signal excursions or "envelope" of the signal will be 

illuminated for each horizontal trace pixel. 

 

Note that for power channels, the term "envelope" refers to the range of fluctuations of the demodulated signal, NOT the "RF 

Envelope".  A CW signal will appear as a narrow line, since its demodulated amplitude is stable, NOT as a wide bar. 

 

In Pulse mode, the min and max are the highest and lowest instantaneous power samples acquired during a horizontal pixel 

interval.  The min or max are updated on each sweep only if the acquired min or max exceed the trace's currently displayed 

min or max.  Before each sweep is acquired, the min and max values of the sweep are decayed towards the average reading 

with a time constant proportional to the Averaging setting.  This results in a "peak hold" characteristic where the min and 

max peaks may be held long enough for visual identification, but are not held indefinitely.  To hold the peaks longer, increase 

the Chan # > Exten > Averaging setting.  To maintain the min and max peaks, turn Chan # > Exten > Peak Hold ―On‖ for 

the selected channel.  

 

In Modulated mode, the min and max are the highest and lowest instantaneous power samples acquired during an acquisition 

interval (typically 2ms).  The min and max are decayed towards the average reading with a time constant proportional to the  
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Filter setting.  This results in a "peak hold" characteristic where the min and max peaks increase immediately on the trace 

when acquired and then, decay slowly.  To hold the peaks longer, increase the Chan # > Exten > Filter setting.  To maintain 

the min and max peaks, turn Chan # > Exten > Peak Hold ―On‖ for the selected channel. 

 

In Statistical mode (Option 10 only), the CDF and CCDF are drawn filled in below the trace line when enveloping is on.  The 

PDF is always drawn as a filled distribution. 

 

Note that the envelope setting does not affect any readings returned by markers, automeasure system, or remote commands.  

Only the display presentation is affected. 

 

 

 

Table 4-44. Display > Menu 
 
Menu Item       Function 
 (Type)   Selections     (SCPI cmd) 

 
 

Persistence   Pulse   Enables or disables trace persistence. 

(Toggle)   Off, On    See discussion above, Sect. 4-18. 

 

      DISPlay:PERSistence {ON, OFF} 
 

 

Envelope  Pulse, Mod & Stat Enables or disables trace envelope mode. 

(Toggle)   Off, On    See discussion above, Sect 4-18. 

 

      DISPlay:ENVElope {ON, OFF} 
 

 

Beep   Off, On   Controls the processor audible beeper 

(Toggle)      If ―On‖, an audible beep occurs when a key 

is pressed. 

 

      SYSTem:BEEP {ON, OFF} 
 

 

Brightness  10% to 100%  Controls the display backlight 

(Numeric) 

Use any of the data entry keys to vary the  

intensity of the LCD backlight. The default  

setting is 90%. 

 

      DISPlay:BACKlight:BRIGhtness   

      <0 to 100> 
 

 

Screen Saver  MENU   Opens the screen saver submenu 

(Submenu) 

                  Fig 4-60. Display > 

               Menu 
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Table 4-44. Display > Menu continued) 
 
Menu Item       Function 
(Type)   Selections     (SCPI cmd) 

 
 

Format    MENU    Allows operator to reconfigure the screen  

(Submenu)     grid, trace type and assignment, the header 

and the display colors. 
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Table 4-45. Display > Screen Saver > Submenu 
 
Menu Item       Function 
 (Type)   Selections     (SCPI command) 

 
 
 
Brightness  10% to 50%, Off  Controls the display backlight intensity when dimmed 

(Numeric)      

Use any of the data entry keys to set the intensity of the LCD backlight 

when the screensaver‘s delay time has elapsed. The default setting is 

20%. 

 

      DISPlay:SCREensaver:BRIGhtness  <10 to 50> 
 

 

Delay Time  1 to 240 min,  Sets the inactivity time before dimming the  

(Numeric)  Infinite   backlight 

   

   The screen saver is used to increase the life  

   of the display backlight by lowering its 

   intensity during times of no activity. Activity  

   is determined by detecting any keypad  

   activity, including the knob and arrow keys.  

   The timer is reset when any activity occurs. 

   If the Display > Screen Saver > Delay Time  

   expires with no activity detected, the display  

   backlight is dimmed to the Display > Screen  

   Saver > Brightness value.  

 

   Use any of the data entry keys to set the  

   desired delay time. Set the time to Infinite  

   to disable the screensaver. 

 

      Any activity detected restores the Display > 

 Brightness value. 

 

      DISPlay:SCREensaver:TIMe <1 to 240 
 

 

 

 

 

 

 

 

               Fig. 4-61. Display > 

               Screen Saver menu. 
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Table 4-46. Display > Format > Submenu 
 
Menu Item       Function 
 (Type)   Selections     (SCPI cmd) 

 
 
Grid Type  Box, Crosshair,  Selects the background markings of the 

(Mult. Choice)  Hash Marks,  window display. 

Grid, Grid Xhair  

The reference grid in the display area makes  

it easier to make precise measurements. The  

grid type should be chosen to be compatible  

with the trace characteristics and units of 

measure. In selecting the grid type, consider  

any requirements that apply to printouts. To  

select the grid, press the Display > Format > 

GridType menu key until the desired  

background markings appear. 

 

      DISPlay:GRID {GRID, XHAIR, BOX,  

      XHAIRGRID, HASH} 

 

 

Trace Type   MENU    Opens the Disp > Format > Trace Type  

(Submenu)     submenu 

 

 

Disp Header   Logo, Time/Date,  Selects which item will appear in the header 

(Mult. Choice)  Sens Temp,    field of the display. 

Blank (space)   

You can display any one of the items in the  

header field: ―Boonton Model 4500B (mode)‖, 

the date and time, or the sensor temperature 

(Celsius scale). You may also choose to leave  

the space blank. 

 

Press the Disp > Format > Disp Header 

menu key until the desired  function appears     Fig. 4-62. Display > 

on the header line.        Format menu 

           .  

      DISPlay:HEADer {BLANK, DATE, LOGO, TEMP} 
 

 

Set Color  MENU   Opens the display color control submenu 

(Submenu) 
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Table 4-47. Display > Format > Trace Type (1 of 2 ) > Submenu 
 

Menu Item 
(Type)   Selections     Function 

 
 
 
1 of 2   - more -   Opens 2 of 2 menu section 

(Action) 

 

 

CH 1   Lines, Points, Off  Sets channel trace drawing method  

(Mult. Choice)     See discussion above, Sect 4-18. 

 

 

CH 2   Lines, Points, Off  Sets channel trace drawing method  

(Mult. Choice)     See discussion above, Sect 4-18. 

 

 

Ext Trig 1  Lines, Points, Off  Sets channel trace drawing method  

(Mult. Choice)     See discussion above, Sect 4-18. 

 

 

Ext Trig 2  Lines, Points, Off  Sets channel trace drawing method  

(Mult. Choice)     See discussion above, Sect 4-18. 

 

 

CH Math  Lines, Points, Off  Sets channel trace drawing method  

(Mult. Choice)     See discussion above, Sect 4-18. 

 

 

 

 

 

 

 

              Fig. 4-63. Display > 

              Trace Type > (1 of 2) 
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Table 4-48. Display > Format > Trace Type (2 of 2 ) > Submenu 
 

Menu Item        Function    
 (Type)   Selections     (SCPI cmd)

 
 
2 of 2   - more -   Opens 1 of 2 menu section 

(Action) 

 

Mem 1   Lines, Points, Off  Sets channel trace drawing method  

(Mult. Choice)     See discussion above, Sect 4-18. 

 

Mem 2   Lines, Points, Off  Sets channel trace drawing method  

(Mult. Choice)     See discussion above, Sect 4-18. 

 

      DISPlay:TRACe[1/2/3/4/5/6/7]:TYPE {POINTS, LINES, OFF} 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Set Colors  You may color the various elements of the display for photographic purposes, or for any other reason. 

Color choices can be solid Red, Green, Blue, or mixtures of these. Set the color for a display element by 

selecting it in the Disp > Format > Set Color > Item Color window and adjust the mix of Red, Green and 

Blue. See Table 4-48. The intersection of traces will be appear in the color of the active intersecting 

channel, followed by the most recently active intersecting channel, etc.  

 

Color selections are stored in non-volatile memory and are retained when the instrument is turned off. They 

are not reset by operation of the INIT function key and are not included in the Prgm > Instrument > 

―Store‖ and ―Recall‖ parameters. (See Subsection 4-17.) Reloading the Model 4500B control software or 

selecting Disp > Format > Set Color > Init Colors will reinitialize the color selections to the factory 

default settings. 



Boonton 4500B RF Peak Power Analyzer 

Operation 4-106 

Table 4-49. Display > Format > Set Color > Submenu 
  
Menu Item        Function   
 (Type)   Selections     (SCPI cmd)

 
 

Item Color  23 Items   Selects the graphic elements of the window display 

(Mult. Choice)   (See discussion) 

To select or adjust the color of any of the 23  

items on the screen, press the Disp >  

Format > Set Color > Item Color menu  

key to activate this window. Use any of the  

data entry controls to select the item to be  

color-adjusted. The factory defaults are: 

 

Name   R G B   

   Background*    0    0   0   

   Grid   64  80 64   

   Time Markers    0 255   0    

   CH1  255 255   0   

   CH2     0 255 255   

   Trig 1  255     0 255   

   Trig 2      0 255     0   

   CH Math 255     0     0   

   Mem 1  128 128 128   

   Mem 2      0     0 255   

   Ref Lines 128 128 128   

   Status Msg 255 255     0 

Error Msg 255     0     0 

   Path Msg 255 255     0 

   Priority Msg 255 255 255   

   Box Low     0 128     0 

   Box High 255 255 255 

   Label Back   64   64 128 

   Menu Label 255 255     0 

   Data Back     0     0     0 

   Menu Data 255 255     0 

   Data Low 128 128   64 

   Text    64 255   64 

              Fig. 4-64. Display > 

   * Background color is restricted to 0 0 0.       Format  > Set Color 

  

      DISPlay:BRIGhtness:COLor  {Item Color}    (Example: GRID) 
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Table 4-49. Display > Format > Set Color > Submenu (continued) 
 
Menu Item       Function 
 (Type)   Selections     (SCPI cmd) 

 
 

Red, Green, Blue   0 to 252    Selects the mixture of primary colors in each display element. 

(Numeric) 

      To indicate the color or mix of colors for the selected display element, 

press one of the color keys and use the data entry controls to set its 

intensity value (from 0 to 255). Repeat this process for the other two 

colors. To indicate a solid (unmixed) color, assign an intensity of 255 

to it and assign ―0‖ to the other two colors.  

 

      DISPlay:BRIGhtness:RED  <0 to 255> 
DISPlay:BRIGhtness:GREEn <0 to 255> 
DISPlay:BRIGhtness:BLUE <0 to 255>              
 

 

Init Colors   INIT    Resets all colors to factory default settings 

(Action) 

      Press the Disp > Format > Set Color > INIT Colors menu key to reset 

the colors for all display items to their original factory settings.  

 

      DISPlay:BRIGhtness:INIT                  
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4.19. SPCL Key and Spcl > Menu 
 

The SPCL key activates the Spcl > menu (Figure 4-65), which enables you to initiate the internal self-test and diagnostic 

routines, adjust the calibrator output and view sensor specifications, and control special instrument functions. 

 

 

Table 4-50. Spcl > Menu 
 
Menu Item 
 (Type)   Selections     Function 

 
 

 

 

 

 

 

Servicing   MENU   Accesses the SPCL > Servicing submenu  

(Submenu) 

 

 

Sensor Data  MENU  Accesses the data stored within each sensor 

(Submenu) 

 

Trigger Out  MENU  Accesses the channel 1 and channel 2  

(Submenu)    rear panel trigger output modes 

 

 

 

 

 

Exit   MENU  Open menu to exit the application 

(Submenu) 

 

 

Debug   MENU  Self test functions. 

(Submenu) 

 

 

 
 
 
 
 
 
                 Fig. 4-65. Spcl menu 
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Table 4-51. Spcl >Trigger Out>Menu 
 
Menu Item 
 (Type)   Selections     Function 

 
 

 

 

 

 

 

Trig1 Source   CH1, Trig1 Select the channel 1 rear panel BNC trigger out mode  

(Mult. Choice)  Sweep, 10 MHz 

   Clock 

      

Trig1 Slope  +, -  Select rising or falling edge for Trig1 BNC out 

(Toggle) 

 

 

 

 

Trig2 Source  CH2, Trig2 Select the channel 2 rear panel BNC trigger out mode   

(Mult. Choice)  Sweep, 10 MHz   

   Clock 

 

Trig2 Slope  +, -  Select rising or falling edge for Trig2 BNC out 

(Toggle) 

 

 

   

     OUTPut:TRIGout[1/2]:SOURce 
     {CH1. TRIG1, SWP, CLK for chan 1 
      CH2, TRIG2, SWP, CLK for chan 2} 
 

 
     OUTPut:TRIGout[1/2]:POLArity { POS, NEG} 
 

   Fig. 4-65.S pcl>Trig   

  Out menu 
       

When TrigX Source is set to CH1 or CH2, that channel‘s trigger output is TTL signal which indicates the current state of that 

its trigger comparator in real time.  Any Low-to-High transition of this signal is a potentially triggerable edge, but does not 

indicate that a sweep has actually been triggered. 

 

When TrigX Source is set to Sweep, that channel‘s trigger output is a TTL signal which indicates the current state of the 

sweep trigger.  The signal will be low when the trigger is armed and waiting for a triggerable signal edge, and high from the 

time the sweep is triggered until it has been acquired, processed, and the trigger re-arm criteria met for the next sweep, 

including trigger holdoff and pre-trigger acquisition. 

 

When TrigX Source is set to 10MHz, that channel‘s trigger output is a 10MHz squarewave derived from the 4500B‘s internal 

timebase reference.  This is useful for verifying the instrument‘s timebase accuracy. 
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Table 4-52. Spcl > Servicing > Submenu 
 

Menu Item 
 (Type)   Selections     Function 

 
     

Update Version  EXECUTE  Software update  

 (Action) 

Press the Spcl > Servicing > Update Ver 

EXECUTE menu key to search the USB  

D: drive for *.btn software update files and 

update or re-install the most recent version  

found. Does nothing if no files are found. 

 

 

NOTE   
 

  This update is similar to the boot-time update procedure except, it will re-install 

  a software version that is already in place while the boot-time procedure will not. 

 

 

  

  

Configuration  REPORT  Reports instrument configuration, options  

(Action)      and status 

 

      Press the Spcl > Servicing > Configuration  

REPORT menu key to display a report of the 

current hardware configuration and status.  

This information is a useful troubleshooting  

aid when reporting operational difficulties to  

Boonton Electronics Technical Support. 

 

 

Hardware Info  REPORT  Reports internal voltages and temperatures 

(Action) 

Press the Spcl > Servicing > Hardware Info  

REPORT menu key to display a report of   

channel board voltages and temperatures.  

This information is a useful troubleshooting    

aid when reporting operational difficulties         Fig. 4-66. Spcl >     

to Boonton Electronics Technical Support.        Servicing menu. 

 

Time Skew  MENU   Opens time skew adjustment submenu 

(Submenu) 
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Table 4-52. Spcl > Servicing > Submenu (continued) 
 
Menu Item 
 (Type)   Selections     Function 

 
 

 

 Svc Cal Mode  Off, On   Enables the service calibration mode 

 (Toggle)      

Press the Svc Cal Mode menu key to turn the Service Cal Mode ―On‖.   

This provides additional functionality under the Calibrator > Extension 

submenu.  The procedures for using these functions is described in  

Section 7 Maintenance. 

 

In the Calibrator > Extension submenu, the Cal Adj and Restore FCal 

menu boxes will appear. Press the Calibrator > Extension > Cal Adjust 

menu key to enable you to adjust the absolute 0 dBm output level of  

the internal calibrator using keyboard and knob numeric input controls. 

The adjusted value of the Calibrator‘s global cal factor will appear in 

the Cal Adjust window. There is a 1 second update delay after each 

change. The factory global cal factor appears in the Restore FCal 

window. It cannot be changed. 

 

Procedures for making this adjustment are provided in Section 7 

Maintenance. 

 

Press the Calibrator > Extension > Restore Fcal menu key to restore 

the factory calibration setting. 

 

 

Warning 
 

Setting the calibrator‘s global cal factor to a value that differs from the factory global cal factor , invalidates 

the factory calibration and certifications.  See Section 7 Maintenance. 

 

 

 

 

 

Caution  Be sure to disable Spcl > Servicing > Cal Mode after you have completed the calibrator adjustment 

procedure. The Spcl > Servicing > Cal Mode is volatile. It will not be restored after power off. 
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Table 4-53. Spcl > Servicing > Time Skew Adj > Submenu 
 
Menu Item        Function    
 (Type)   Selections     (SCPI cmd)

 
 

CH1 Skew Adj  0.0 to ± 99.9 nsec  Adjust the time skew of channel 1 

(Numeric) 

Press the Spcl > Servicing > Time Skew > CH1 Skew Adj menu key to 

display a menu to adjust the timing skew between channel 1 and the 

trigger system time reference. 

 

 

CH2 Skew Adj  0.0 to ± 99.9 nsec  Adjust the time skew of channel 1 

(Numeric)      

Press the Spcl > Servicing > Time Skew > CH2 Skew Adj menu key to 

display a menu to adjust the timing skew between channel 2 and the 

trigger system time reference. 
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Table 4-54. Spcl > Sensor Data > Submenu 
 
Menu Item 
 (Type)   Selections    Function 

 
 
 
CH 1, 2 Sensor  REPORT  Reports a summary of the Channel 1,2 sensor’s stored data 

(Action) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

      Figure 4-66. Spcl > Sensor Data > CH 1 REPORT 

 

CH 1, 2Details  MENU   Opens a menu to display detailed data from the Channel 1, 2 sensor 

(Submenu) 
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Table 4-55. Spcl > Sensor Data > CH 1,(2) Detail > Submenu 
 
Menu Type 
 (Type)   Selections     Function 

 
 
 
(none)   Page UP   Press to see next higher page of sensor data 

(Action) 

 

 

(none)   Page Down  Press to see next lower page of sensor data 

(Action) 

 

 

 
 
 
 

Table 4-56. Spcl > Exit > Submenu 
 

Menu Item 
(Type)   Selections    Function 

 
 
 
Sys Shutdown Power Off  Shut down power to Standby mode. Same as pressing the ON/STBY 

(Action)       key. 

 

  

Exit   To Windows™  Exit the 4500B application to the Windows™ Desktop.            

(Action) 
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4.20 Automatic Operation 
 

The Model 4500B can make up to 15 automatic measurements. The available measurements depend upon the operating mode 

and the characteristics of the displayed waveform. Pressing the Text system key will display all of the available automatic 

measurements in the current mode. When the readings are invalid the numeric display will be filled with dashes ―--.-‖. Over 

range will be indicated by up arrows " " and under range by down arrows "v ". 

 

A single channel instrument can make the following list of measurements on Channel 1, External Trigger 1, Memory channel 

1 and Mem channel 2. For a dual channel instrument add Channel 2 and External Trigger 2. Memory channel measurements 

correspond with the type of waveform stored.  

 

AUTOMATIC MEASUREMENTS – PULSE MODE 
 
The information displayed in the Pulse mode text report is based on the data captured. Parameters such as pulse width, 

period, and repetition frequency, can only be displayed if there are a sufficient number of pulse transitions on the display. For 

pulse width, there must be at least two pulse transitions; for pulse period, duty cycle and repetition frequency there must be 

three. If the number of transitions is insufficient to determine one of these parameters, the display will show ―--.-‖ instead of 

a numeric value. Rise and fall times are most accurately measured when the instrument‘s timebase is set so that each 

transition takes at least one full display division. 

 

 
Table 4-57. Pulse Mode – Automatic Measurements I 

 
   CH1&2     CH 1&2 
Name   (Power Units)    (Voltage Units) 

 
Width   Pulse width     Pulse width 

Rise  Pulse risetime    Pulse risetime 

Fall  Pulse falltime    Pulse falltime 

Period  Pulse Period     Pulse Period 

PRFreq  Pulse repetition frequency   Pulse repetition frequency  

Duty C  Pulse duty cycle     Pulse duty cycle  

OffTime  Pulse offtime    Pulse offtime  

Peak  Peak power    Peak voltage  

Pulse  Pulse (on) average power   Pulse (on) average voltage (converted) 

Oversh  Pulse overshoot  (power ratio)  Pulse overshoot (voltage ratio) 

Avg  Average power of pulse period   Average voltage (converted) of pulse period 

Top  Pulse top level power   Pulse top level voltage 

Bot  Pulse bottom level power    Pulse bottom level voltage 

Skew  Pulse time skew, Ch 1 to Ch 2  Pulse time skew, Ch 1 to Ch 2 

EdgeDly   Edge delay - time from left edge of   Edge delay - time from left edge of 

display to first mesial edge of either  display to first mesial edge of either 

slope on the displayed waveform  slope on the displayed waveform   
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NOTE The Channel 1 and Channel 2 voltage readings are derived by converting power to equivalent voltage. 

Since power is non-polar, the derived voltage will always have positive polarity.  Also, the average power 

of a signal converted to voltage is not identical to the average voltage of that signal.  

 

The External Trigger 1 and External Trigger 2 signals are always voltages and may be positive and 

negative (bipolar). This must be taken into account when interpreting the ―Avg‖ parameter. For example, a 

rectangular 50% duty cycle bipolar trigger signal will have an ―Avg‖ value near zero volts, but a 

rectangular 50% duty cycle power waveform converted to volts will have and ―Avg‖ value near 70.7% of 

the Pulse average voltage.  
 

 

 

Table 4-58. Pulse Mode – Automatic Measurements II 
 

   EXT TRIG 1&2 
Name   (Voltage Units) 

 
 

Width   Pulse width      

Rise  Pulse risetime     

Fall  Pulse falltime     

Period  Pulse Period      

PRFreq  Pulse repetition frequency     

Duty C  Pulse duty cycle       

OffTime  Pulse offtime      

Peak  Peak positive voltage  

Pulse  Pulse average voltage 

Oversh  Pulse overshoot (voltage ratio) 

Avg  Average voltage of pulse period 

Top  Pulse top level voltage 

Bot  Pulse bottom level voltage 

Skew  ---- 

EdgeDly  Edge delay - time from left edge of 

display to first mesial edge of either  

slope on the displayed waveform 
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AUTOMATIC MEASUREMENTS – MODULATED MODE 
 
The Modulated mode is most often used to measure the true average power of a signal on a continuous basis. The average 

readings reflect the filtered average value. The peak readings are affected by the Chan # > Exten > Peak Hold setting. If peak 

hold is ―On‖, the highest peak value is held until reset by pressing the Top Level  > Display > CLEAR menu key. If peak 

hold is ―Off‖, the peak value decays at a rate determined by the Chan # > Exten > Filter setting. For memory channels, the 

peak value displayed is the peak value at the time the waveform was stored.  

 

The peak-to-average reading is always in dB units and is not measured on External Trigger channels. 

 

 

 

Table 4-59. Modulated Mode – Automatic Measurements I 
 

   CH1&2     CH 1&2 
Name   (Power Units)    (Voltage Units) 

 
    

 Avg     Average power    Average voltage (converted) 

  

 Peak   Peak power    Peak voltage 

  

 Min   Minimum power    Minimum voltage 

  

 Pk/Avg   Peak to Average Ratio (dB)   Peak to Average Ratio (dB) 

 

 Dyn Rng  Dynamic range (dB)    Dynamic range (dB) 

  

 
  

  

  

  

Table 4-60. Modulated Mode – Automatic Measurements II 
 

   EXT TRIG 1&2 
Name   (Voltage Units) 

 
    

 Avg     Average voltage 

  

 Peak   Peak positive voltage 

  

 Min   Minimum voltage 

  

 Pk/Avg   ----    

 

 Dyn Rng  Peak-to-peak voltage    
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AUTOMATIC MEASUREMENTS – STATISTICAL MODE (Opt 10 only) 
 
In the Statistical mode automatic measurements are made only in the ―Run‖ mode. When the Top Level  > Measurement  > 

Stop selection is made, the latest value is displayed. Press the Top Level  > Display > CLEAR menu key to clear previous 

results. Press the Top Level  > Measurement  > Stop menu key to select ―Run‖. The measurement will begin and continue 

until a terminate condition is met. The automatic measurements will continuously update with the results of the accumulating 

data. The peak-to-average reading is not measured on External Trigger channels. The peak-to-average and dynamic range 

results are always displayed in dB units. The average, peak and minimum results will have the same units as the associated 

channel.    

 
 

Table 4-61. Statistical Mode – Automatic Measurements I 
 

   CH1&2     CH 1&2 
Name   (Power Units)    (Voltage Units) 

 
 

Avg   Average power    Average voltage (converted) 

 

Peak   Peak power    Peak voltage 

 

Min   Minimum power    Minimum voltage 

 

Pk/Avg   Peak-to-average ratio (dB)   Peak-to-average ratio (dB) 

 

Dyn Rng  Dynamic range (dB)   Dynamic range (dB) 

 

  

 
 

 

 

Table 4-62. Statistical Mode – Automatic Measurements II 
 

   EXT TRIG 1&2 
Name   (Voltage Units) 

 
 

Avg   Average voltage 

 

Peak   Peak voltage 

 

Min   Minimum voltage 

 

Pk/Avg   ---- 

 

Dyn Rng  Peak-to-peak voltage    
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4.21 Model 4500B MENU MAP 

 
 

Table 4-63. Control Menu Structure 

 
 

 

 

 

 

 

 

 

 

 

  
  
    
   
   
 
 
 
 
 
 
 
    
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Top Level Menu 
 
Measurement 
 SingleSweep 
 Display 
 Measure Mode 
 Auto-Setup  

  

Print 
- 
To Next File 
- 
- 
- 
Select File 
 Folder 
 Folder 
 Extension 
 Basename 
  Cursor 
  Cursor 

 [Clear Name] 
 [Backspace] 
 [Select Char] 

  Basename 
 [Delete]  
 Filename 
  Cursor 
  Cursor 
  [Clear Name] 
  [Backspace] 
  [Select Char] 
  Filename 

   

Init 
 

Defaults 
- 
- 
- 
- 
4500A Default 
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 Table 4-63. Control 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Chan 1/Chan 2 (pulse) 
Mem 1/Mem 2 (pulse) 

 
Selection 
Channel 
Vert Scale 
Vert Center 
*Calibration 
 *AutoCal 
 *FixedCal 
 *Zeroing 
 - 
 - 
 - 
Extensions 
 Units 
 *Corrections 
  *dB Offset 
  *Freq CF 
  - 
  - 
  - 
  - 
 *Peak Hold 
 Define Pulse 
  Distal 
  Mesial 
  Proximal 
  Start Gate 
  End Gate 
  Pulse Units 
 *Video BW 
 *Averaging 
 
* Chan1/Chan2 only 

Chan 1/Chan 2 (mod) 
Mem 1/Mem 2 (mod) 

 
Selection 
Channel 
Vert Scale 
Vert Center 
*Calibration 
 *AutoCal 
 *FixedCal 
 *Zeroing 
 - 
 - 
 - 
Extensions 
 Units 
 *Corrections 
  *dB Offset 
  *Freq CF 
  - 
  - 
  - 
  - 
 *Peak Hold 
 *Filter 
 *Video BW 
 - 
 
* Chan1/Chan2 only 
 

Chan 1/Chan 2 (stat) 
Mem 1/Mem 2 (stat) 

 
Selection 
Channel 
Vert Scale 
Vert Center 
*Calibration 
 *AutoCal 
 *FixedCal 
 *Zeroing 
 - 
 - 
 - 
Extensions 
 Units 
 *Corrections 
  *dB Offset 
  *Freq CF 
  - 
  - 
  - 
  - 
 *Video BW 
 - 
 
 
* Chan1/Chan2 only 
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Menu Structure (continued) 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Ext Trig1/Ext Trig 2 (pulse) 
Mem 1/Mem 2 (pulse) 

 
Selection 
Channel 
Vert Scale 
Vert Center 
*Calibration 
 *AutoCal 
 - 
 *Zeroing 
 - 
 - 
 - 
Extensions 
 *Range 
 *Impedance 
 *Peak Hold 
 Define Pulse 
  Distal 
  Mesial 
  Proximal 
  Start Gate 
  End Gate 
  Pulse Units 
 *Bandwidth 
 *Averaging 
 
 
* Ext Trig1/ Ext Trig2 only 

Ch Math 
 
Selection 
Channel 
Vert Scale 
Vert Center 
Expression 
 Argument A 
 Operator 
 Argument B 
 Result Units 
 Display Units 
 - 
 - 
 

Ext Trig1/Ext Trig 2 (mod) 
Mem 1/Mem 2 (mod) 

 
Selection 
Channel 
Vert Scale 
Vert Center 
*Calibration 
 *AutoCal 
 - 
 *Zeroing 
 - 
 - 
 - 
*Extensions 
 *Range 
 *Impedance 
 *Peak Hold 
 *Filter 
 *Bandwidth 
 
   
* Ext Trig1/ Ext Trig2 only 

Ext Trig1/Ext Trig 2 (stat) 
Mem 1/Mem 2 (stat) 

 
Selection 
Channel 
Vert Scale 
Vert Center 
*Calibration 
 *AutoCal 
 - 
 *Zeroing 
 - 
 - 
 - 
*Extensions 
 *Range 
 *Impedance 
 - 
 - 
 *Bandwidth 
 
   
* Ext Trig1/ Ext Trig2 only 
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Table 4-63. Control Menu Structure (continued) 

 
 

 

 

                                                                      
 
 
    
   
    
   
    
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Time (pulse) 
 
Timebase 
Position 
Trig Delay 
Fast Trigger 
- 
- 
 

Time (mod) 
 
Timebase 
- 
- 
- 
- 
- 
 
 
 

Statistics (stat - lin) 
 
Presentation 
Horz Scale 
Horz Offset 
Stat Mode 
PDF Bars 
Term Settings 
 Term Time 
 Term Count 
 Term Action 
 - 
 - 
 - 

 

Statistics (stat - log) 
 

Presentation 
Horz Scale 
Full Scale 
Stat Mode 
PDF Bars 
Term Settings 
 Term Time 
 Term Count 
 Term Action 
 - 
 - 
 - 

Trig (mod) 
 

Trig Mode 
Trig Source 
Trig Level 
Trig Slope 
- 
- 
 
 

Trig (stat) 
 
Gating 
Trig Setup 
 Trig Mode 
 Trig Source 
 Trig Level 
 Trig Slope 
 Holdoff 
 B Trigger 
  B Mode 
  B Source 
  Trig Level 
  B Slope 
  B Dly Time 
  B Dly EvntCnt 
Time Setup 
 Timebase 
 Position 
 Trig Delay 
 Fast Trigger 
 - 
 - 
Gate 1 
Gate 2 
Pulse Preview 
 

Trig (pulse) 
 

Trig Mode 
Trig Source 
Trig Level 
Trig Slope 
Holdoff 
B Trigger 
 B Mode 
 B Source 
 Trig Level 
 B Slope 
 B Dly Time 
 B DlyEvnt Cnt 
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Table 4-63. Control Menu Structure (continued) 

 
 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Mark (pulse) 
 
Marker 1 
Delta Time 
Marker 2 
Set Vrt Cntr 
- 
Extensions 
 MK Group 
 Marker Chan 
 - 
 Delta Marker 
 Marker Math 
 - 
 

Ref (pulse and mod) 
 
REF Line 1 
REF Delta 
REF Line 2 
Ref CH Sel 
Ref Tracking 
Refs to Mks 
 
 

Reference (stat) 
 
REF Line 1 
REF Delta 
REF Line 2 
Ref CH Sel 
- 
- 
  
 

Meas (pulse) 
 
Freq Track 
Freq CH1 
Freq CH2 
Sys Tracking 
Skew Meas 
 CH1 Skew Ref 
 CH2 Skew Ref 
 Trg1 Skew Ref 
 Trg2 Skew Ref 
 Mem1 Skew Ref 
 Mem2 Skew Ref 
Param Meas 
 Selection 
 Param Mode 
 Param Column 
 Param Top 
 Param Middle 
 Param Bottom 
 
 

Meas (mod) 
 
Freq Track 
Freq CH1 
Freq CH2 
Sys Tracking 
- 
- 
 
 

Meas (stat) 
 

Freq Track 
Freq CH1 
Freq CH2 
Sys Tracking 
Normalize Pwr 
- 
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Table 4-63. Control Menu Structure (continued) 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

 
 

Util: Remote Conf 
 

GPIB 
 Bus Setup 
  Address 
  Listen Term 
  Talk Term 
  EOI on Talk 
  - 
  - 
 Set Mask 
 Set SRQ 
 View Buffers 
  GPIB Listen Buffer 
  GPIB Talk Buffer 
 -    
 - 
- 
Session Log 
Emulation 
 Boot Language 
 Curr Language 
 *IDN Response 
 Option Select 
 Ignore Unsupp 
 - 
 Mnemonics 
- 

Util:Disk (1 of 2) 
 
Folder 
Folder 
Extension 
Rename 
 Cursor 
 Cursor 
 [Clear Name] 
 [Backspace] 
 [Select Char] 
 [Rename]
  
Copy 
 Folder 
 Folder 
 - 
 - 
 [Paste] 
1 of 2 

Util:Disk (2 of 2) 
 
Folder 
Folder 
[Delete] 
Folder 
 (Folder) 
 (Folder) 
 Create Folder 

Cursor 
  Cursor 
  [Clear Name] 
  [Backspace] 
  [Select Char] 
  [Create] 
 Use Folder 
 Select 
 - 
- 
2 of 2 

Util: Hardcopy 
 
Plot Labels 
Plot BackGrnd 
 - 
 - 
 - 
 - 
 

Util: Clock 
 
Year 
Month 
Day of Month 
Hour 
Minute 
Day of Week 
 

 

Util 
 
Inst Status 
Remote Conf 
- 
Disk (2) 
Hardcopy 
Clock 
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Table 4-63. Control Menu Structure (continued) 

 
 
 
 
  
   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Calibrator (preset pulse) 
 
Cal Output 
Set Level 
Max Power 
Cal Mode 
Pulse 
 Source 
 Polarity 
 Duty Cycle 
 Pulse Period 
 - 
 Pulse Control 
Extensions 
 - 
 Level Step 
 - 
 - 
 - 
 Calibrator 
 

Calibrator (variable pulse) 
 
Cal Output 
Set Level 
Max Power 
Cal Mode 
Pulse 
 Source 
 Pulse Width 
 Pulse Period 
 - 

- 
 Pulse Control 
Extensions 
 - 
 Level Step 
 - 
 - 
 - 
 Calibrator 
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Table 4-63. Control Menu Structure (continued) 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Prgm 
 
Inst Store 
Instr Recall 
Mem Save 
WFM Store 
WFM Recall 
Trace Data 

Prgm: Inst Store 
 

Folder 
Folder 
- 
Basename 
 Cursor 
 Cursor 
[Delete]  
Store 
 Cursor 
 Cursor 
 [Clear Name] 
 [Backspace] 
 [Select Char] 
 Instrument 

Prgm: Instr Recall 
 

Folder 
Folder 
- 
- 
- 
Instrument 
 

Prgm: Mem Save 
 
- 
Source 
Destination 
- 
- 
Waveform 

Prgm: WFM Store 
 

Folder 
Folder 
Source 
Basename 
 Cursor 
 Cursor 
[Delete]  
Store 
 Cursor 
 Cursor 
 [Clear Name] 
 [Backspace] 
 [Select Char] 
 Waveform
   

Prgm: WFM Recall 
 

Folder 
Folder 
Destination 
WFM Report 
 - 
 - 
 - 
 WFM File 
 - 
 - 
- 
Waveform 
 

Prgm: Trace Data 
 

Folder 
Folder 
Source 
Options 

Delimiter 
Basename 

Cursor 
  Cursor 
[Delete] 
Filename 
 Cursor 
 Cursor 
 [Clear Name] 
 [Backspace] 
 [Select Char] 
 Save Data 
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Table 4-63. Control Menu Structure (continued) 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Disp 
 
Persistence 
Envelope 
Beep 
Brightness 
Screen Saver 
 Brightness 
 Delay Time 
 - 
 - 
 - 
 - 
Format 
 Grid Type 
 Trace Type (1) 
  1 of 2 
  CH 1 
  CH 2 
  Ext Trig 1 
  Ext Trig 2 
  CH Math 

Trace Type (2) 
  2 of 2 
  Mem1 
  Mem2 
  - 
  - 
  - 
 - 
 Disp Header 
 Set Color 
  Item Color 
  - 
  Red 
  Green 
  Blue 
  Init Colors 
 - 
 

Spcl 
 
Servicing 
 Update Ver 
 Configuration 
 - 
 Hardware Info 
 Time Skew 
  CH1 Skew Adj 
  CH2 Skew Adj 
  - 
  - 
  - 
  - 
 Svc Cal Mode 
Sensor Data 
 CH 1 Sensor 
 CH 1 Details 
 CH 2 Sensor 
 CH 2 Details 
 - 
 - 
- 
- 
Exit 
 Sys Shutdown 
 - 
 - 
 - 
 - 
 Exit 
Debug 
 Dump Cmds 
 - 
 - 
 - 
 - 
 - 
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5. Remote Operation 

 

5.1  GPIB CONFIGURATION 
 

The 4500B GPIB interface is configured using the Util > Remote > GPIB > Bus Setup menu. The primary listen/talk address 

(MLTA) under menu item Util > Remote > GPIB > Bus Setup > Address can be set to any value from 1 to 30 inclusive. The 

value assigned must be unique to each GPIB device.  Secondary address is not implemented. 

The Listen string terminator character (EOS) can be set under menu item Util  > Remote > GPIB > Bus Setup > Listen Term 

to ASCII character LF ( decimal 10), CR (decimal 13) or EOI Only. ―EOI only‖ is the default. The 4500B always responds to 

the GPIB ―end‖ signal (EOI), which may be sent by the controller with the last character of the command string or with the 

EOS character.  If the controller does not, or cannot send the EOI signal, a mutually agreed upon EOS character must be 

used.  

The Talk string terminator character (EOS) can be set under menu item Util > Remote > GPIB > Bus Setup > Talk Term to 

ASCII character LF ( decimal 10), CR (decimal 13), the two character sequence CRLF or EOI only.  ―EOI only‖ is the 

default.  The 4500B always sends the GPIB ―end‖ signal (EOI) with the last character of every string.  If a one or two 

character EOS is selected, the EOI signal will be sent with the last EOS character.  If ―EOI only‖ is selected, the EOI signal 

will be sent with the last character of the string.   

In a new setup try the 4500B default settings ―EOI only‖ for both Listen and Talk. If this does not work, the controller‘s 

requirements will have to be satisfied for communications to take place.     

At menu item Util > Remote > GPIB > Set Mask, the bus service request enable byte mask value can be set.  If the value is 

zero, SRQ is disabled. 

The menu report item Util > Remote > GPIB > View Buffers alternately displays the current contents of the Listen and Talk 

internal buffers. Press the > View Buffers menu key to switch between Listen and Talk buffers. This feature is very useful for 

analyzing bus communication problems. The buffers show what has been received from the controller and what has been sent 

to the controller.  

 

5.2   4500A EMULATION MODE 
 

The 4500B provides a 4500A Emulation Mode for compatibility with programs written for models 4400, 4500, 4400A, 

4500A, 4400A-L and 4500A-L. The emulation mode does not provide access to new features of the 4500B that were not 

available in the 4500A. To take full advantage of the 4500B‘s capabilities, the SCPI Language must be used. It is strongly 

recommended that you use SCPI for all new programs. To select the 4500A Emulation mode, set  the Util > Remote > GPIB 

> Emulate 4500A menu selection to ―On‖. The emulation mode selection is non-volatile so that the 4500B will power up in 

the emulation mode. The menu item Util > Remote > GPIB > Mnemonics will display a multi-page list of all valid emulation 

GPIB command  mnemonics in an outline format. Use the  and  arrow keys, the knob and the menu keys to highlight an 

item. The highlighted command is described and arguments (if any) are listed at the bottom of the report window.  
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5.3  SCPI LANGUAGE 
 

All of the features of the Model 4500B are accessible with the SCPI command language. All new programming should use 

SCPI. To select the SCPI language make sure the Util > Remote > GPIB > Emulate 4500A menu selection is set to ―Off‖. 

This is an important step since the two 4500B languages are incompatible.  

The SCPI Model of the 4500B provides a single or dual SENSe sub-system to handle sensor input and a matching single or 

dual CALCulate sub-system to process the data obtained from the sensors into useful results.  A TRIGger sub-system 

provides for measurement and signal synchronization.  The CALibration sub-system is used to calibrate Peak Power sensors.  

Channel dependent commands end with a number to indicate the desired channel as follows: 

 

  Channel     Number  Symbol 

Measurement  Channel 1       1  CH1 

Measurement  Channel 2       2       CH2      (optional, Model 4500B Opt 01 only) 

Ext Trigger Channel 1     3  TRIG1 

Ext Trigger Channel 2           4  TRIG2  (optional, Model 4500B Opt 01 only) 

Channel Math      5  CHM 

Memory Channel 1     6  MEM1 

Memory Channel 2     7  MEM2 

If the channel number is omitted, channel 1 is selected by default. 

                

Commands may be transmitted together if separated by a semicolon ―;‖ character. Any query command must be the last 

command in a line. The 4500B‘s listen buffer can accept 65,535 characters, so buffer overflow should not be a problem.  It is 

a good idea, however, to limit strings of commands to a manageable size for ease in troubleshooting communication 

difficulties.  Also, programmers should be aware that sending long strings of commands reduces the ―sequential‖ nature of 

the command execution, and can cause some of the more complex commands (such as mode changes), which take longer to 

complete, to ―overlap‖ the short commands. Most commands have an optional short form that reduces the number of 

characters necessary over the bus.  When commands are printed in this document, the short form letters will be capitalized, 

with the remaining characters in lower case.  If a channel number designation and/or query ? symbol is needed, it is appended 

to either the long or short form of the command.  Commands which take numerical or literal arguments require an ASCII 

space between the command and the argument. 

Examples: 

CALCulate:STATe ON   Turn on measurement channel 1 (default channel number) 

 CALCulate1:STATe ON   Turn on measurement channel 1 (specified channel number) 

CALC:STAT ON    Turn on measurement channel 1 (short form, default channel number) 

 CALC1:STAT ON   Turn on measurement channel 1 (short form, specified channel number) 

 

CALCulate:STATe?   Query the state of measurement channel 1 (default channel number) 

 CALC:STAT?    Query the state of channel 1 (short form, default channel number) 

CALCulate1:STATe?   Query the state of measurement channel 1 (specified channel number) 

 CALC1:STAT?    Query the state of channel 1 (short form, specified channel number) 
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 SENSe3:RANGe?   Query the range of external trigger channel TRIG1 

 SENS3:RANG? Query the range of external trigger channel TRIG1 (short form) 

 

 DISPlay:PULSe:TIMEBASE 0.0001 Set timebase range to 100 usec/Div  (time in seconds) 

 DISP:PULS:TIMEBASE 100 us Set timebase range to 100 usec/Div (short form with time units) 

 

 SENSe:CORRection:OFFSet 0.42 Set channel 1 offset correction to 0.42 dB (chan units dBm) 

 TRIGger:LEVel –3.12 Set trigger level to –3.12 dBm (trig units dBm) 

 SENS:CORR:OFF 0.42; TRIG:LEV –3.12 Concatenated using semi-colon (short form) 

 

In the discussion and tables below, the following notation will be used: 

 

 Command name long and short form: SYSTem 

 Optional command name in brackets: SYSTem:ERRor[:NEXT]? 

 Command with channel dependence: CALCulate[1|2|3|4|5|6|7]:STATe OFF 

 Default channel 1: CALibration:AUTO 

 Explicit channel 1: CALibration1:AUTO 

 Select channel 2: CALibration2:AUTO 

 Short Form: CAL2:AUTO 

 Command which takes numeric argument: SENSe1:AVERage <n>  

 Same command; query: SENSe1:AVERage? 

 Command with literal text argument: TRIGger:SOURce <asc> 

 Command with no query form: *CLS 

 Command with query form only: SYSTem:DATE:WEEKday? 

 

 

 

NOTES 

Square brackets [ ] are used to enclose the list of valid channels for a command, or a list of command 

options separated by the vertical separator bar | character. This character is for syntax only, and is not to 

be entered as part of the command. By default, if no channel number is specified, Channel 1 is selected.  

A literal argument denoted by <asc> indicates a text string, which must exactly match one of the choices for the 

command, while an argument denoted by <n> is a string which can be converted to a number which is within the 

range of valid arguments.  Numerical values can generally be in any common form including decimal and scientific 

notation. 

Curly braces { } are used to enclose two or more possible choices for a mandatory entry, separated by the 

comma character.  One of the enclosed options MUST be inserted into the command, and the braces are 

not to be entered as part of the command. 
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5.4  BASIC MEASUREMENT OPERATION.  
 

The easiest way to obtain a reading is by use of the MEASure command.  This command initiates one complete measurement 

sequence which includes a default configuration.  Examples are: 

 

 MEAS1:POWER? To return the average power of channel 1, or 

 MEAS1:VOLTAGE? To return the average voltage of channel 1. 

 

For finer control over the measurement, individual configuration and function commands should be used.  Readings are 

obtained using the FETCh[ ]? command for current data or the READ[ ]? command for fresh data.  These commands may 

return multiple results if an array is read. 

Readings are in fundamental units as set by the CALCulate[1|2|5|6|7]:UNIT command.  Each reading is preceded by a 

condition code, which has the following meaning: 

 -1 Measurement is STOPPED.  Value returned is not updated. 

  0 Error return.  Measurement is not valid. 

  1 Normal return.  No error. 

2 An Under-range condition exists. 

3 An Over-range condition exists. 

 

With the INITiate:CONTinuous OFF condition, a single measurement cycle is started by use of the 

INITiate[:IMMEDIATE] command, where bracketed commands are optional.  Multiple triggered measurement cycles are 

enabled by INITiate:CONTinuous ON and a TRIGger source selection.  If TRIGger:SOURce IMMediate is selected, a 

free running measurement process is started.  Otherwise, a measurement cycle begins with each valid trigger condition. 

 

5.4.1  Service Request 

 

Service requests provide a means to signal the GPIB Controller that a particular event or group of events have occurred in the 

instrument. Service requests are controlled by the Status Byte Register and the Service Request Enable Register. The Service 

Request Enable Register is a bit mask that determines which summary bits of the Status Byte Register can cause a request for 

service to be sent to the Controller. The summary bits of the Status Byte are the MAV, or Message Available bit, and three 

bits from event driven registers. The first of these is the Standard Event Status Register. The bits of this register are set and 

latched by specific events within the instrument and cleared when the register is read. The remaining two registers are the 

Operation Status Register and the Questionable Status Register. These two registers are similar to the Standard Event Status 

Register but have the additional capability to detect changes in the individual bits of the associated register‘s condition 

register. The bits are not only selected by a mask register, but a change in a selected bit, either a high to low, low to high or 

either transition, can be specified by transition mask registers.  

The Status Byte is read by the *STB? command. The bit enable mask is set by the *SRE command and read by the *SRE? 

query. The Standard Event Status Register is read by the *ESR? Command and the bit enable mask is set by the *ESE 

command or read by the *ESE? Command. 
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The Operation Status Register is read by the STATus:OPERation:CONDition? command. The transition masks are set by the 

STATus:OPERation:NTransition and  STATus:OPERation:PTransition commands. The bit enable mask is set by the 

STATus:OPERation:ENABle command and read by the STATus:OPERation:ENABle? query. The Operation Event Register 

is read by the STATus:OPERation:EVENt? query. 

The Questionable Event Status Register has the same structure as the Operation Status Register. Refer to the command 

descriptions that follow for detailed information. 

 

 

5.5  SCPI COMMAND REFERENCE. 
 

This section contains a list of all SCPI remote commands accepted by the 4500B.  The list is grouped by SCPI or IEEE488.2 

function, and includes a detailed description of each command. 

  

 Command Group Section 

 

 IEEE-488.2 Commands 5.5.1 

 CALCulate Subsystem 5.5.2 

 CALibration Subsystem 5.5.3 

 DISPlay Subsystem 5.5.4 

 FETCh Queries 5.5.5 

 HCOPy Commands 5.5.6 

 INITiate and ABORt Commands 5.5.7 

 MARKer Subsystem 5.5.8 

 MEASure Queries 5.5.9 

 MEMory Subsystem 5.5.10 

 OUTPut Subsystem  5.5.11 

 READ Queries 5.5.12 

 REFline Subsystem 5.5.13 

 SENSe Subsystem 5.5.14 

 STATus Subsystem 5.5.15 

 SYSTem Subsystem 5.5.16 

 TRACe Data Array Commands 5.5.17 

 TRIGger Subsystem 5.5.18 
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5.5.1  IEEE 488.2 Commands 

The purpose of IEEE488.2 commands is to provide management and data communication instructions for the system by 

defining a set of  ―*‖ commands (an asterisk followed by a three character code).  These commands allow device control and 

status monitoring, and are the basis for some of the commands of the SCPI STATus subsystem (see Section 5.5.17). 

 

 

*CLS 
 Description: Clear Status command.  This command resets the SCPI status registers (Questionable Status and 

Operation Status), the error queue, the IEEE488.2 Status Byte (STB) and Standard Event Status 

(ESR) registers, and the measurement. 

 Syntax: *CLS 

 Argument: None 

 Valid Modes: Any 

 

 

*ESE 
 Description: Set or return the Standard Event Status Enable Register. The mask value in this register is used to 

enable bits of the Standard Event Status Register that are or‘ed together to form the ESB summary 

bit in the instrument Status Byte.  When a mask bit is set, and the corresponding ESR bit goes 

true, an SRQ will be generated, provided the Event Status Summary bit (ESB, bit 5) is enabled in 

the SRE register.  No SRQ can be generated for that condition if the mask bit is cleared. To clear 

the entire Standard Event Status Enable Register, send *ESE = 0. See the *ESR command for bit 

assignments. This register is not cleared by *CLS, *RST or DCLR.  

 Syntax: *ESE <n> 

 Argument: <n> = 0 to 127 

 Valid Modes: Any 
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*ESR? 
 

 Description: Return the current value of the Standard Event Status Register, then clear the register. This register 

has bits assigned to a number of possible events or conditions of the instrument. When the event 

occurs, the corresponding bit is latched. The register value is read using this command. Individual 

bits may be enabled or disabled for SRQ generation using the ESE mask (see *ESE command).  

The following table shows the bit assignments in the Standard Event Status Register: 

 

 Bit Value Definition 

 0 1 Operation Complete flag 1 = all current operations have completed execution. 

 1 2 Not used always returns 0 

 2 4 Not used always returns 0 

 3 8 Device Dependent Error 1 = the instrument encountered a device dependent error. 

 4 16 Not used always returns 0 

 5 32 Command Error 1 = a remote interface command error exists. 

 6 64 User Request 1 = user pressed Util > Remote > GPIB > Set SRQ menu button 

 7 128 Not used always returns 0 

 
 Syntax: *ESR? 

 Returns: Current Value of Event Status Register (0 to 255) 

 Valid Modes: Any 

 

 

*IDN? 
 

 Description: Return the instrument identification string.  This string contains the manufacturer, model number, 

serial number and firmware version number. 

 Syntax: *IDN? 

 Returns: < Mfgr, Model#, Serial#, Version# > 

 Valid Modes: Any 
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*OPC 
 

 Description: Clears the OPC (Operation Complete) status flag. This command is issued before the command to 

be checked for completion. After this, the flag may be queried by *OPC? until a value of one is 

returned, indicating the command has completed.  Note that the query is not a true query - a value 

of zero will never be returned.   

 Syntax: *OPC  

 Argument: None 

 Valid Modes: Any 

 

 

*OPC? 
  

 Description: This command examines the OPC (Operation Complete) status flag and returns a ―1‖ if all 

pending operations are complete. If pending operations are not  yet complete, it does not return. 

 Syntax: *OPC?  

 Returns: Always returns 1 to indicate operations complete. Otherwise, does not return. 

 Valid Modes: Any 

  

  

*OPT? 
 

 Description: Return the status of  channel 1 and channel 2 followed by a list of installed options. 

 Syntax: *OPT? 

 Returns: f1 – chan 1 installed?, f2 – chan1 sensor  present?, f3 – chan 2 installed?, f4 – chan 2 sensor 

 present?, opt1, opt2, etc. (option list may be empty).  

 Valid modes:  Any 

  

 

*RST 
 

 Description: Set the instrument to a known configuration. The current language selection (SCPI or 4500A 

Emulation) is preserved. For SCPI, set measurements to STOP; for 4500A, set ,measurements to 

RUN. Set the sensor temperature offset flag to FALSE, set the SCPI file over-write permission  to 

FALSE, turn the 1 GHz Calibrator output OFF and clear the error queues. System communication 

parameters are not changed. Instrument measurement functions are set their default values (See 

Table 3-3, Initialized Parameters).    

 Syntax: *RST 

 Argument: None 

 Valid Modes: Any 
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*SRE 
 

 Description: Set or return the mask value in the Service Request Enable Register.  This value is used to enable 

particular bits for generating a service request (SRQ) over the GPIB when certain conditions exist 

in the Status Byte register.  When a mask bit in the SRE Register is set, and the corresponding 

STB register bit goes true, an SRQ will be generated.  No SRQ can be generated for that condition 

if the mask bit is clear.  The bits in the Status Byte register are generally summary bits, which are 

the logical OR of the enabled bits from other registers.  See the *STB command for bit 

assignments. 

 Syntax: *SRE <n> 

 Argument: <n> = 0 to 255 

 Valid Modes: Any 

 

 

*STB? 
 

 Description: Return the current value of the Status Byte register.  This register has bits assigned to a number of 

possible events or conditions of the instrument.  The register value may be read using this 

command, or may be used to generate a service request (SRQ) over the GPIB when certain 

conditions exist.  Individual bits may be enabled or disabled for SRQ generation using the SRE 

mask (see *SRE command).  Note that the bits in the Status Byte register are generally summary 

bits, which are the logical OR of the enabled bits from other registers.  The following table shows 

the bit assignments in the Status Byte register: 

 Bit Value Definition 

 0 1 Not used 

 1 2 Not used 

 2 4 Error/Event queue status 1 = there is at least one message in the queue. 

 3 8 QUEStionable Status Summary 1 = an enabled QUEStionable condition is true. 

 4 16 Message AVailable flag bit 1 = an output message is ready to transmit. 

 5 32 Event Status Summary 1 = an enabled Event Status condition is true. 

 6 64 MSS Summary Status 1 = at least one other Status Byte bit is true. 

 7 128 OPERation Status Summary 1 = an enabled OPERation condition is true. 

 

 Syntax: *STB? 

 Returns: Current Value of Status Byte register (0 to 255) 

 Valid Modes: Any 
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*TRG 
 

 Description: Simulate the bus trigger command.. This command has the same effect as GET, Group Execute 

Trigger, except it must be parsed and decoded before the action takes place. There is no query 

form of this command. 

 Syntax: *TRG 

 Argument: None 

 Valid Modes: Any 

 

 

*TST? 
 

 Description: Self-test query.  This command initiates a self-test of the instrument, and returns a result code 

when complete.  The result is zero for no errors, or a signed, 16-bit number if any errors are 

detected. 

 Syntax: *TST 

 Returns: Error Code 

 Valid Modes: Any 

 

 

*WAI 
 

 Description: Wait command.  This command insures sequential, non-overlapped execution. The 4500B always 

operates in non-overlapped, sequential mode. The command is accepted as valid but takes no 

action. 

 Syntax: *WAI 

 Argument: None 

 Valid Modes: Any 
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5.5.2  CALCulate Subsystem 

The CALCulate group of the command subsystem is used to configure post acquisition data processing.  Functions in the 

CALCulate subsystem are used to configure the measurement mode and control which portions of the acquired measurement 

data is used and how it is processed to yield a finished measurement.  In addition to measurement mode, CALCulate is used 

to define mathematical operations, measurement units, and limit monitoring.  The numeric suffix of the CALCulate program 

mnemonic in the CALCulate commands refers to a processing and display ―channel‖, that is CALCulate1 and CALCulate2 

represent the power analyzer‘s Channel 1 and Channel 2 functions.  The CALCulate commands generally DO NOT affect the 

data acquisition portion of the measurement (see the SENSe subsystem, Section 5.5.12 ).  In a signal-flow block diagram, the 

CALCulate block operations will follow those of the SENSe block.  Note that CALCulate2 commands will generate an error 

if used with a single channel Model 4500B. 

 

CALCulate:AMEAsure:BOTtom 
 

 Description: Set or return the state of automatic IEEE pulse bottom detection for all channels. ON (default 

state) enables the signal-based automatic detection of IEEE pulse bottom power as described in 

section 6.3 on Automatic Pulse Measurements.  OFF disables signal-based automatic bottom 

detection, and forces the pulse bottom level to 0.0mW (-99.99dBm).  This may be useful for 

performing measurements in cases where the pulse bottom is noisy or there is RF leakage. 

 Syntax: CALCulate:AMEAsure:BOTtom<asc> 

 Argument: <asc> = {OFF, ON} 

 Valid Modes: Pulse  

 

 
CALCulate:AMEAsure:EDGEdelay 
 

 Description: Set or return the edge delay selection method for all channels. FRST (default state) returns time 

delay from left screen boundary to first edge transition on screen.  LAST returns delay to last edge 

transition on screen  BRST returns the time interval from the first rising or falling edge onscreen 

to the last rising or falling edge onscreen when AutoMeas Gate set to All or First.  When 

AutoMeas set to Markers, the BRST setting will return the time interval from the first rising or 

falling edge to the last rising or galling edge within the marker interval. 

 Syntax: CALCulate:AMEAsure:EDGEdelay<asc> 

 Argument: <asc> = {FRST, LAST, BRST} 

 Valid Modes: Pulse  

 

 
CALCulate:AMEAsure:MODE 
 

 Description: Set or return the automatic pulse measurement mode for all channels. ALL (default state) uses all 

pulses that appear on the display; FRST uses only the first pulse from the left hand side; MRKRS 

uses the trace data within the marker band; and OFF does not compute any auto measurements 

which minimizes the processing time associated with signal acquisition and display.   

 Syntax: CALCulate:AMEAsure:MODE <asc> 

 Argument: <asc> = {ALL, FRST, MRKRS, OFF} 

 Valid Modes: Pulse  
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CALCulate:MATH:ARGA 
 

 Description: Set or return the signal source of the A argument for use in channel math. Channel math operates 

pixel by pixel on two source channels to produce a third channel result 

 Syntax: CALCulate:MATH:ARGA <asc> 

 Argument: <asc> = {CH1 CH2, TRIG1, TRIG2, MEM1, MEM2} 

 Valid Modes: Any  

 

 

CALCulate:MATH:ARGB 
 

 Description: Set or return the signal source of the B argument for use in channel math. Channel math operates 

pixel by pixel on two source channels to produce a third channel result 

 Syntax: CALCulate:MATH:ARGB <asc> 

 Argument: <asc> = {CH1 CH2, TRIG1, TRIG2, MEM1, MEM2} 

 Valid Modes: Any  

 

 

CALCulate:MATH:OPERator  
  

 Description: Set or return the pixel-by-pixel mathematical operation performed between sources A and B to 

create the math channel result. Note that the apparent operation performed is different for 

logarithmic and non-logarithmic units for equivalent results.  

 Syntax: CALCulate:MATH:OPERator <asc> 

 Argument: <asc> = {CH_SUM, CH_DIFF, CH_RAT} 

    Log units  Non-log units 

  CH_SUM ------     add  

                                           CH_DIFF             ------   subtract 

  CH_RAT             subtract   divide  

 Valid Modes: Any  

 

 

CALCulate:MODE 
 

 Description: Set or return the system measurement mode. MODULATED is a continuous measurement mode, 

PULSE is a triggered, oscilloscope-like mode, and STATISTICAL, which includes CDF, CCDF 

and PDF as sub-modes, may be operated in a start-stop continuous mode, a decimated continuous 

mode or a gated (triggered) mode.  

 Syntax: CALCulate:MODE <asc> 

 Argument: <asc> = {MODULATED, PULSE, STATISTICAL}   

  Note: The STATISTICAL sub-mode CDF, CCDF or PDF is restored but not reported.  

 Valid Modes: Any 
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CALCulate:PKHLD 
 

 Description: Set or return the operating mode of the selected channel‘s peak hold function.  OFF: instantaneous 

peaks are only held for a short time, and then decayed towards the average power at a rate 

proportional to the filter time.  This is the best setting for most signals, because the peak will 

always represent the peak power of the current signal, and the resulting peak-to-average ratio will 

be correct shortly after any signal level changes.  INST: instantaneous peaks are held until reset by 

a new INITiate command.  This setting is used to hold the highest peak over a long measurement 

interval.  AVG: The held peaks correspond to the highest and lowest filtered average power, and 

are held until reset.  This is useful for monitoring average power fluctuations over a period of 

time.  In the case of pulse mode, note that all average and peak hold measurements are performed 

on the interval between the markers 

 Syntax: CALCulate[1|2|3|4]:PKHLD <asc>  

 Argument: <asc> = {OFF, ON} 

 Valid Modes: Modulated and Pulse modes 

 
 
CALCulate:STATe 
 

 Description: Set or return the measurement state of the selected channel.  When ON, the channel performs 

measurements; when OFF, the channel is disabled and no measurements are performed. 

 Syntax: CALCulate[1|2|3|4|5|6|7]:STATe <asc> 

 Argument: <asc> = {ON, OFF} 

 Valid Modes: Any 

 

 

CALCulate: SYSTRK 
 

 Description: Set or return the state of the system tracking function. When ON, selected parameters of CH 1 and 

2, Ext Trig 1 and 2 and Mem 1 and 2 are made to track. Changing either will cause the 

corresponding change in all.  

  CH1, CH2  -  Units, Pulse Units (definition), Distal, Mesial, Proximal, Start Gate, End Gate, Peak 

Hold, Video BW 

  Ext Trig 1, Ext Trig 2, Mem 1, Mem2 - Distal, Mesial, Proximal 

 Syntax: CALCulate:SYSTRK 

 Argument: <asc> = {ON, OFF} 

 Valid Modes: Any  
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CALCulate:UNIT 
 

 Description: Set or return units for the selected channel.  For power sensors, voltage is calculated with 

reference to the sensor input impedance.  Note that for ratiometric results, logarithmic units will 

always return dBr (dB relative) and all other units return percent. Units for external trigger inputs 

are always volts. 

 Syntax: CALCulate[1|2|5|6|7]:UNIT <asc> 

 Argument: <asc> = {dBm, W, V, dBV, dBmV, dBuV} 

 Valid Modes: Any 
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5.5.3  CALibration Subsystem 

The CALibration group of commands is used to control automatic zero offset and linearity adjustments to the RF power 

sensor and the channel to which it is connected.  Zero offset adjustment can be performed at any time if no RF signal is 

applied to the sensor.  Linearity calibration requires that the sensor be connected to the built-in 1 GHz calibration signal. 

The CALibration group also makes automatic zero and gain adjustments to the external trigger channels. Trigger channels 

can be calibrated only when there is no external signal connected.   

The numeric suffix of the CALibration commands refers to a measurement channel, that is CALibration1 and CALibration2 

refer to CH1 and CH2 input channels, respectively and CALibration3 and Calibration4 refer to TRIG1 and TRIG2 

respectively. . 

Note that CALibration2 and CALibration4 commands will generate an error if used with a single channel Model 4500B.  

Also note that although CALibration commands do not accept any arguments, all have a query form, which returns an error 

flag upon completion of the zero or calibration process.  This allows the user to determine when the process has completed, 

and whether it was successful. 

 

 

CALibration:AUTO 
 

 Description: Performs a multi-point sensor gain calibration of the selected sensor with the internal 1 GHz 

calibrator. This procedure calibrates the sensor‘s linearity at a number of points across its entire 

dynamic range 

 Syntax: CALibration[1|2]:AUTO[?] 

 Returns: 0 if successful, 1 otherwise (query form only) 

 Valid Modes: Power sensors only. 

 

 

CALibration:AUTO 
 

 Description: Performs an offset and gain calibration of the selected external trigger channel. This procedure 

requires that no external signal be applied during calibration. 

 Syntax: CALibration[3|4]:AUTO[?] 

 Returns: 0 if successful, 1 otherwise (query form only) 

 Valid Modes: External trigger channels only. 
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CALibration:USER:FREQcal 
 

 Description: Performs a single-point sensor gain calibration of the selected sensor using an external (user-

supplied) 0dBm power reference at the current operating frequency.  This method can be 

combined with an AUTOCAL to yield the most accurate power readings at frequencies that are far 

from the calibration frequency.  It temporarily replaces the calfactor computed from the sensor‘s 

factory-stored values with a measured result. If the channel Frequency setting is changed, the 

original cal-factor will be restored. A FREQcal that attempts to set a cal-factor larger than 3 dB 

will be rejected and an error returned. 

 Syntax: CALibration[1|2]:USER:FREQcal ?] 

 Returns: 0 if successful, 1 otherwise (query form only) 

 Valid Modes: Power sensors only.   

 

 

CALibration:ZERO 
 

 Description: For a sensor that has been previously auto calibrated and has valid auto-cal status, performs a zero 

offset null adjustment.  

 Syntax: CALibration[1|2]: ZERO[?] 

 Returns: 0 if successful, 1 otherwise (query form only) 

 Valid Modes: Power sensors only.   

 

 

CALibration:ZERO 
 

 Description: Performs an offset null adjustment for the specified external trigger input. No external signal can 

be applied during calibration.  

 Syntax: CALibration[3|4]: ZERO[?] 

 Returns: 0 if successful, 1 otherwise (query form only) 

 Valid Modes: External trigger inputs only..   



Boonton 4500B RF Peak Power Analyzer 

Remote Operation 5-17 

5.5.4  DISPlay Subsystem 

The DISPlay group of commands is used to control the selection and presentation of textual, graphical and TRACe 

measurements.   

 

DISPlay:ACTive 
 

 Description: Set or return the active channel. The active channel trace is drawn on top of all other traces. The 

active channel‘s menu appears on the right side of the display, and its status display appears above 

the trace area if status display is selected.   

 Syntax: DISPlay:ACTive <asc> 

 Argument: <asc> = {CH1, CH2, TRIG1, TRIG2, CHM, MEM1, MEM2} 

 Valid Modes: All 

 

 

DISPlay:BACKlight:BRIGhtness 
 

 Description: Set or return the backlight brightness for the LCD display in percent. 

 Syntax: DISPlay:BACKlight:BRIGhtness <n>  

 Argument: <n> =  10 to 100  

 Valid Modes: All 

 

 

DISPlay:BRIGhtness:COLor 
 

 Description: Set or return the color item to be set by the RGB commands that follow. 

 Syntax: DISPlay:BRIGhtness COLor <asc>  

 Argument: <asc>  = see Color Item Table below 

  Color Item Table  { 

  BACKGROUND   GRID  TIME_MARKERS 

  CH1   CH2  TRIG1 

  TRIG2   CH_MATH MEM1 

  MEM2   REF_LINES STATUS_MSG 

  ERROR_MSG  PATH_MSG PRIORITY_MSG 

  BOX_LOW  BOX_HIGH LABEL_BACK 

  MENU_LABEL  DATA_BACK MENU_DATA 

  DATA_LOW  TEXT} 

                                          

     Valid Modes: All                              
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DISPlay:BRIGhtness:BLUE 
 

 Description: Set or return the intensity of the blue component of the color item selected by 

DISPlay:BRIGhtness:COLor 

 Syntax: DISPlay:BRIGhtness:BLUE <n>  

 Argument: <n> = 0 to 255 

 Valid Modes: All 

 

   

DISPlay:BRIGhtness:GREEn 

  
 Description: Set or return the intensity of the green component of the color item selected by 

DISPlay:BRIGhtness:COLor 

 Syntax: DISPlay:BRIGhtness:GREEn <n>  

 Argument: <n> = 0 to 255 

 Valid Modes: All 

 

 

DISPlay:BRIGhtness:INIT 
 

 Description: Initialize the display colors to the factory default values. 

 Syntax: DISPlay:BRIGhtness:INIT 

 Argument: None 

 Valid Modes: All 

 

 

DISPlay:BRIGhtness: RED 
 

 Description: Set or return the intensity of the red component of the color item selected by 

DISPlay:BRIGhtness:COLor 

 Syntax: DISPlay:BRIGhtness:RED <n>  

 Argument: <n> = 0 to 255 

 Valid Modes: All 

 

 

DISPlay:CLEar 
 

 Description: Clear display traces and all data buffers for CH1, CH2, TRIG1 and TRIG2 measurement channels. 

Clears averaging filters to empty. Does NOT clear errors. 

 Syntax: DISPlay:CLEar 

 Argument: None 

     Valid Modes: All                                          
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DISPlay:DECAdes 
 

 Description: Set or return the number of decades displayed on a Statistical mode (CDF, CCDF, PDF) 

logarithmic horizontal scale.  

 Syntax: DISPlay:DECAdes <n> 

 Argument: <n> = 1 to 7 

 Valid Modes: Statistical modes only 

 

 

DISPlay:ENVElope 
 

 Description: Set or return the status of the trace envelope display mode. Envelope mode plots the maximum 

and minimum value for each measurement pixel.  

 Syntax: DISPlay:ENVElope <asc> 

 Argument: <asc> = {ON, OFF} 

 Valid Modes: Any 

 

 

DISPlay:FULLscale 
 

 Description: Set or return the fullscale (right edge) value of the Statistical mode (CDF, CCDF, PDF) 

logarithmic horizontal scale in percent.  

 Syntax: DISPlay:FULLscale <n> 

 Argument: <n> = {100, 10, 1, 0.1, 0.01} 

 Valid Modes: Statistical modes only  

 

 

DISPlay:GRID 

  
 Description: Set or return the type of axes and graticule displayed in the traces box.  

 Syntax: DISPlay:GRID <asc> 

 Argument: <asc> = {BOX (box only), XHAIR (box with crosshair), GRID (box with grid), HASH (box with 

hash-marks), XHAIRGRID (box with grid and crosshair)} 

 Valid Modes: All 
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DISPlay:HEADer 
  

 Description: Set or return the type of header shown at the top left of the display. 

 Syntax: DISPlay:HEADer <asc> 

 Argument: <asc> = {BLANK (none), DATE (time and date), LOGO (instrument model), TEMP (sensors‘ 

internal temperature)} 

 Valid Modes: All  

 

 

DISPlay:HELP 
  

 Description: Set the display to the show the Help page instead of Graphics or Text page. Help provides a short 

description of each menu item. Set ON to see the HELP page; set OFF to restore the previous 

GRAPH or TEXT page. 

 Syntax: DISPlay:HELP <asc> 

 Argument: <asc> = {ON, OFF} 

 Valid Modes: All 

 

  

DISPlay:MODE 

  
 Description: Set or return the Text or Graphics page display setting. The Graphics page displays traces and 

Marker measurements. The Text page displays auto-measure values in text form. 

 Syntax: DISPlay:MODE <asc> 

 Argument: <asc> = {GRAPH, TEXT} 

 Valid Modes: All  

 

 

DISPlay:MODUlated:TIMEBASE 
 

 Description: Set or return the modulated mode timebase in seconds/division. The 4500B has fixed timebase 

settings in a 1-2-5 sequence, and if the argument does not match one of these settings, it will be 

forced to the next highest entry.   

 Syntax: DISPlay:MODUlated:TIMEBASE <n> 

 Argument: <n> =  5e-9 to 10 sec/div in a 1-2-5 sequence,  

   30 sec/div, 

   1 to 10 min/div, 

   30 min/div and 60 min/div 

 Valid Modes: Modulated mode 

  Note: There are separate time bases for the Modulated mode and the Pulse/Gated Statistical 

 modes. The arguments selected are saved and restored independently by mode. 
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DISPlay:PARAmeter:MODE 

  
 Description: Set or return the type of content displayed in the parameter area above the trace box. The STAT 

(status) command causes a fixed set of nine status parameters for the active channel to be 

displayed. The MEAS command causes a group of nine user selected auto-measure and fixed 

parameters from any measurement channel to be displayed.  

 Syntax: DISPlay:PARAmeter:MODE <asc> 

 Argument: <asc> = {MEAS, STAT} 

 Valid Modes: Pulse Mode only. Note: Modulated mode does not display Status and Measurement parameters. 

Statistical mode displays a fixed combination of status and auto-measure parameters. 

 

DISPlay:CHANnel:BOTtom:LEFT 

 
 Description: Set or return the channel for the auto-measure or fixed parameter displayed in the Bottom row, 

Left column of the nine element parameter field above the trace box.  

DISPlay:PARAmeter:MODE must be set to MEAS. 

  Syntax: DISPlay:CHANnel:BOTtom:LEFT <asc> 

 Argument: <asc> = {CH1, CH2, TRIG1, TRIG2, CHM, MEM1, MEM2} 

 Valid Modes: Pulse Mode only. Note: Modulated mode does not display Status and Measurement parameters. 

Statistical mode displays a fixed combination of status and auto-measure parameters. 

 

 

DISPlay:CHANnel:BOTtom:MIDdle 

 
 Description: Set or return the channel for the auto-measure or fixed parameter displayed in the Bottom row, 

Middle column of the nine element parameter field above the trace box.  

DISPlay:PARAmeter:MODE must be set to MEAS. 

  Syntax: DISPlay:CHANnel:BOTtom: MIDdle <asc> 

 Argument: <asc> = {CH1, CH2, TRIG1, TRIG2, CHM, MEM1, MEM2} 

 Valid Modes: Pulse Mode only. Note: Modulated mode does not display Status and Measurement parameters. 

Statistical mode displays a fixed combination of status and auto-measure parameters. 

 

 
DISPlay:CHANnel:BOTtom:RIGHt 

 
 Description: Set or return the channel for the auto-measure or fixed parameter displayed in the Bottom row, 

Right column of the nine element parameter field above the trace box.  

DISPlay:PARAmeter:MODE must be set to MEAS. 

  Syntax: DISPlay:CHANnel:BOTtom: RIGHt <asc> 

 Argument: <asc> = {CH1, CH2, TRIG1, TRIG2, CHM, MEM1, MEM2} 

 Valid Modes: Pulse Mode only. Note: Modulated mode does not display Status and Measurement parameters. 

Statistical mode displays a fixed combination of status and auto-measure parameters. 
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DISPlay:CHANnel: MIDdle: LEFT 

 
 Description: Set or return the channel for the auto-measure or fixed parameter displayed in the Middle row, 

Left column of the nine element parameter field above the trace box.  

DISPlay:PARAmeter:MODE must be set to MEAS. 

  Syntax: DISPlay:CHANnel: MIDdle:LEFT <asc> 

 Argument: <asc> = {CH1, CH2, TRIG1, TRIG2, CHM, MEM1, MEM2} 

 Valid Modes: Pulse Mode only. Note: Modulated mode does not display Status and Measurement parameters. 

Statistical mode displays a fixed combination of status and auto-measure parameters. 

 

DISPlay:CHANnel: MIDdle:MIDdle 

 
 Description: Set or return the channel for the auto-measure or fixed parameter displayed in the Middle row, 

Middle column of the nine element parameter field above the trace box.  

DISPlay:PARAmeter:MODE must be set to MEAS. 

  Syntax: DISPlay:CHANnel: MIDdle: MIDdle <asc> 

 Argument: <asc> = {CH1, CH2, TRIG1, TRIG2, CHM, MEM1, MEM2} 

 Valid Modes: Pulse Mode only. Note: Modulated mode does not display Status and Measurement parameters. 

Statistical mode displays a fixed combination of status and auto-measure parameters. 

 
 
DISPlay:CHANnel: MIDdle:RIGHt 

 
 Description: Set or return the channel for the auto-measure or fixed parameter displayed in the Middle row, 

Right column of the nine element parameter field above the trace box.  

DISPlay:PARAmeter:MODE must be set to MEAS. 

  Syntax: DISPlay:CHANnel: MIDdle: RIGHt <asc> 

 Argument: <asc> = {CH1, CH2, TRIG1, TRIG2, CHM, MEM1, MEM2} 

 Valid Modes: Pulse Mode only. Note: Modulated mode does not display Status and Measurement parameters. 

Statistical mode displays a fixed combination of status and auto-measure parameters. 

 
 
DISPlay:CHANnel:TOP:LEFT 

 
 Description: Set or return the channel for the auto-measure or fixed parameter displayed in the Top row, Left 

column of the nine element parameter field above the trace box.  DISPlay:PARAmeter:MODE 

must be set to MEAS. 

  Syntax: DISPlay:CHANnel:TOP:LEFT <asc> 

 Argument: <asc> = {CH1, CH2, TRIG1, TRIG2, CHM, MEM1, MEM2} 

 Valid Modes: Pulse Mode only. Note: Modulated mode does not display Status and Measurement parameters. 

Statistical mode displays a fixed combination of status and auto-measure parameters. 
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DISPlay:CHANnel:TOP: MIDdle 

 
 Description: Set or return the channel for the auto-measure or fixed parameter displayed in the Top row, 

Middle column of the nine element parameter field above the trace box.  

DISPlay:PARAmeter:MODE must be set to MEAS. 

  Syntax: DISPlay:CHANnel:TOP: MIDdle <asc> 

 Argument: <asc> = {CH1, CH2, TRIG1, TRIG2, CHM, MEM1, MEM2} 

 Valid Modes: Pulse Mode only. Note: Modulated mode does not display Status and Measurement parameters. 

Statistical mode displays a fixed combination of status and auto-measure parameters. 

 

 

DISPlay:CHANnel:TOP: RIGHt 

 
 Description: Set or return the channel for the auto-measure or fixed parameter displayed in the Top row, Right 

column of the nine element parameter field above the trace box.  DISPlay:PARAmeter:MODE 

must be set to MEAS. 

  Syntax: DISPlay:CHANnel:TOP: RIGHt <asc> 

 Argument: <asc> = {CH1, CH2, TRIG1, TRIG2, CHM, MEM1, MEM2} 

 Valid Modes: Pulse Mode only. Note: Modulated mode does not display Status and Measurement parameters. 

Statistical mode displays a fixed combination of status and auto-measure parameters. 

 

 

DISPlay:PARAmeter:BOTtom:LEFT 

  
 Description: Set or return the auto-measure or fixed parameter displayed in the Bottom row, Left column of the 

nine element parameter field above the trace box. The selected parameter will be for the currently 

active channel. See DISPlay:ACTive command. DISPlay:PARAmeter:MODE must be set to 

MEAS. 

  Syntax: DISPlay:PARAmeter:BOTtom:LEFT <asc> 

 Argument: See Display Parameter Table below 

 Valid Modes: Pulse Mode only. Note: Modulated mode does not display Status and Measurement parameters. 

Statistical mode displays a fixed combination of status and auto-measure parameters. 

 

 

DISPlay:PARAmeter:BOTtom:MIDdle 
 

 Description: Set or return the auto-measure or fixed parameter displayed in the Bottom row, Middle column of 

the nine element parameter field above the trace box. The selected parameter will be for the 

currently active channel. See DISPlay:ACTive command. DISPlay:PARAmeter:MODE must be 

set to MEAS. 

  Syntax: DISPlay:PARAmeter:BOTtom:MIDdle <asc> 

 Argument: See Display Parameter Table below 

 Valid Modes: Pulse Mode only. Note: Modulated mode does not display Status and Measurement parameters. 

Statistical mode displays a fixed combination of status and auto-measure parameters. 
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DISPlay:PARAmeter:BOTtom:RIGHt 
 

 Description: Set or return the auto-measure or fixed parameter displayed in the Bottom row, Right column of 

the nine element parameter field above the trace box. The selected parameter will be for the 

currently active channel. See DISPlay:ACTive command. DISPlay:PARAmeter:MODE must be 

set to MEAS. 

  Syntax: DISPlay:PARAmeter:BOTtom:RIGHt <asc> 

 Argument: See Display Parameter Table below 

 Valid Modes: Pulse Mode only. Note: Modulated mode does not display Status and Measurement parameters. 

Statistical mode displays a fixed combination of status and auto-measure parameters. 

 

 

DISPlay:PARAmeter:MIDdle:LEFT 

  
 Description: Set or return the auto-measure or fixed parameter displayed in the Middle row, Left column of the 

nine element parameter field above the trace box. The selected parameter will be for the currently 

active channel. See DISPlay:ACTive command. DISPlay:PARAmeter:MODE must be set to 

MEAS. 

  Syntax: DISPlay:PARAmeter:MIDdle:LEFT <asc> 

 Argument: See Display Parameter Table below 

 Valid Modes: Pulse Mode only. Note: Modulated mode does not display Status and Measurement parameters. 

Statistical mode displays a fixed combination of status and auto-measure parameters. 

 

 

DISPlay:PARAmeter:MIDdle:MIDdle 
 

 Description: Set or return the auto-measure or fixed parameter displayed in the Middle row, Middle column of 

the nine element parameter field above the trace box. The selected parameter will be for the 

currently active channel. See DISPlay:ACTive command. DISPlay:PARAmeter:MODE must be 

set to MEAS. 

  Syntax: DISPlay:PARAmeter:MIDdle:MIDdle <asc> 

 Argument: See Display Parameter Table below 

 Valid Modes: Pulse Mode only. Note: Modulated mode does not display Status and Measurement parameters. 

Statistical mode displays a fixed combination of status and auto-measure parameters. 
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DISPlay:PARAmeter:MIDdle:RIGHt 
 

 Description: Set or return the auto-measure or fixed parameter displayed in the Middle row, Right column of 

the nine element parameter field above the trace box. The selected parameter will be for the 

currently active channel. See DISPlay:ACTive command. DISPlay:PARAmeter:MODE must be 

set to MEAS. 

  Syntax: DISPlay:PARAmeter:MIDdle:RIGHt <asc> 

 Argument: See Display Parameter Table below 

 Valid Modes: Pulse Mode only. Note: Modulated mode does not display Status and Measurement parameters. 

Statistical mode displays a fixed combination of status and auto-measure parameters. 

 

 

DISPlay:PARAmeter:TOP:LEFT 

  
 Description: Set or return the auto-measure or fixed parameter displayed in the Top row, Left column of the 

nine element parameter field above the trace box. The selected parameter will be for the currently 

active channel. See DISPlay:ACTive command. DISPlay:PARAmeter:MODE must be set to 

MEAS. 

  Syntax: DISPlay:PARAmeter:TOP:LEFT <asc> 

 Argument: See Display Parameter Table below 

 Valid Modes: Pulse Mode only. Note: Modulated mode does not display Status and Measurement parameters. 

Statistical mode displays a fixed combination of status and auto-measure parameters. 

 

 

DISPlay:PARAmeter:TOP:MIDdle 
 

 Description: Set or return the auto-measure or fixed parameter displayed in the Top row, Middle column of the 

nine element parameter field above the trace box. The selected parameter will be for the currently 

active channel. See DISPlay:ACTive command. DISPlay:PARAmeter:MODE must be set to 

MEAS. 

  Syntax: DISPlay:PARAmeter:TOP:MIDdle <asc> 

 Argument: See Display Parameter Table below 

 Valid Modes: Pulse Mode only. Note: Modulated mode does not display Status and Measurement parameters. 

Statistical mode displays a fixed combination of status and auto-measure parameters. 



Boonton 4500B RF Peak Power Analyzer 

Remote Operation 5-26 

DISPlay:PARAmeter:TOP:RIGHt 
 

 Description: Set or return the auto-measure or fixed parameter displayed in the Top row, Right column of the 

nine element parameter field above the trace box. The selected parameter will be for the currently 

active channel. See DISPlay:ACTive command. DISPlay:PARAmeter:MODE must be set to 

MEAS. 

  Syntax: DISPlay:PARAmeter:TOP:RIGHt <asc> 

 Argument: See Display Parameter Table below 

 Valid Modes: Pulse Mode only. Note: Modulated mode does not display Status and Measurement parameters. 

Statistical mode displays a fixed combination of status and auto-measure parameters. 

 

  DISPLAY PARAMETER TABLE 

    <asc>      function  { 

  PWIDTH  Pulse width 

  RISETIME  Risetime 

  FALLTIME  Falltime 

  PERIOD  Period * 

  PRFREQ  Pulse repetition frequency * 

  DUTY   Duty cycle * 

  OFFTIME  Pulse offtime * 

  PEAK   Peak Power 

  PULSE   Pulse Power * 

  OVRSHT  Pulse overshoot 

  AVGPWR  Average power  

  TOPPWR  Pulse top level power 

  BOTPWR  Pulse bottom level power 

  SKEW   Trigger skew 

  EDGEDLY  Edge delay  

  FREQ   Measurement frequency setting 

  VIDBW   Sensor video bandwidth setting 

  AVG   Channel averaging value 

  TRA   A Trigger slope, source and level 

  TRB   B Trigger slope, source and level or off 

  TRDLY   Trigger delay setting 

  VSCALE  Vertical scale setting 

  CENTER  Vertical center setting 

  OFFSET }  Vertical offset setting  

* at least one complete waveform cycle must be displayed 
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DISPlay:PCTOFST 
 

 Description: Set or return the horizontal trace percent offset of the statistical linear display mode.  

 Syntax: DISPlay:PCTOFST <n> 

 Argument: <n> = 0.0 to 99.0 % with 0.1% resolution  (see restrictions) 

 Valid Modes: Statistical mode only 

 Restrictions: The sum of (PCTSCALE * 10 div) and PCTOFST must not be greater than 100%. 

 

 

DISPlay:PCTSCALE 
 

 Description: Set or return the horizontal trace percent/div scale in the statistical linear display mode.  Range 

settings are fixed in a 1, 2, 5 sequence, and if the argument does not match one of the settings, it 

will be forced to the next highest entry. 

 Syntax: DISPlay:PCTSCALE <n> 

 Argument: <n> = {0.1, 0.2, 0.5, 1, 2, 5, 10} % 

 Valid Modes: Statistical mode only 

 Restrictions: The sum of 10*PCTSCALE and PCTOFST must not be greater than 100%. 

  

 

DISPlay:PERSistence 
 

 Description: Set or return the status of the display persistence function. Affects CH1, CH2, TRIG1, TRIG2 and 

CHM. The ON argument sets the persistence mode and forces the dot trace type. See 

DISPlay:TRACe:TYPE. 

 Syntax: DISPlay:PERSistence  <asc> 

 Argument: <n > = {0, 1} 

 Valid Modes: All 

 

 

DISPlay:PLABel:MODE 
 

 Description: Set or return the status of the plot label display function. The plot label consists of 4 user 

programmable text lines in the trace box.  

 Syntax: DISPlay:PLABel:MODE <asc> 

 Argument: <asc > = {ON, OFF} 

Valid Modes: All 
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DISPlay:PLABel:TEXTA 
 

 Description: Set or return line 1 of the plot label text up to 19 characters in length. Enclose the string argument 

in double quotes (― ―). Strings longer than 19 characters are truncated. 

 Syntax: DISPlay:PLABel:TEXTA <asc> 

 Argument: <asc > = ―Up to 19 text chars‖ 

 Valid Modes: All 

 

 

DISPlay:PLABel:TEXTB 
 

 Description: Set or return line 2 of the plot label text up to 19 characters in length. Enclose the string argument 

in double quotes (― ―). Strings longer than 19 characters are truncated. 

 Syntax: DISPlay:PLABel:TEXTB <asc> 

 Argument: <asc > = ―Up to 19 text chars‖ 

 Valid Modes: All 

 

 

DISPlay:PLABel:TEXTC 
 

 Description: Set or return line 3 of the plot label text up to 19 characters in length. Enclose the string argument 

in double quotes (― ―). Strings longer than 19 characters are truncated. 

 Syntax: DISPlay:PLABel:TEXTC <asc> 

 Argument: <asc > = ―Up to 19 text chars‖ 

 Valid Modes: All 

 

 

DISPlay:PLABel:TEXTD 
 

 Description: Set or return line 4 of the plot label text up to 19 characters in length. Enclose the string argument 

in double quotes (― ―). Strings longer than 19 characters are truncated. 

 Syntax: DISPlay:PLABel:TEXTD <asc> 

 Argument: <asc > = ―Up to 19 text chars‖ 

 Valid Modes: All 
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DISPlay:PULSe:TIMEBASE 
 

 Description: Set or return the pulse mode timebase in seconds/division. The 4500B has fixed timebase settings 

in a 1-2-5 sequence, and if the argument does not match one of these settings, it will be forced to 

the next highest entry.   

 Syntax: DISPlay:PULSe:TIMEBASE <n> 

 Argument: <n> =  5e-9 to 10 sec/div in a 1-2-5 sequence,  

   30 sec/div, 

   1 to 10 min/div, 

   30 min/div and 60 min/div 

 Valid Modes: Pulse mode and Gated Statistical mode 

 Note:   There are separate timebases for the Pulse/Gated Statistical mode and the Modulated mode.  

The arguments selected are saved and restored independently by mode. 
 

 

DISPlay:SCREensaver:BRIGhtness 
 

 Description: Set or return the display backlight brightness in percent when dimmed.. 

 Syntax: DISPlay:SCREensaver:BRIGhtness <n> 

 Argument: <n> =10 to 50 

 Valid Modes: All 

 

 

DISPlay:SCREensaver:STATe 
 

 Description: Set or return the state of the screensaver function. When ON, the screensaver dims the LCD 

backlight to a specified intensity after a specified period of keyboard inactivity. GPIB activity 

does not disturb display backlighting unless DISPlay:SCREensaver commands are sent.  

 Syntax: DISPlay:SCREensaver:STATe <asc> 

 Argument: <asc> =  {ON, OFF} 

 Valid Modes: All 

 

 

DISPlay:SCREensaver:TIME 
 

 Description: Set or return the time in minutes of no activity that dims the display backlight. 

 Syntax: DISPlay:SCREensaver:TIME <n> 

 Argument: <n> = 1 to 240, 999 disables the screensaver 

 Valid Modes: All 
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DISPlay:SKEW:REFerence 
 

 Description:  Set or return the reference channel for time skew measurements between channels. 

 Syntax: DISPlay:SKEW[1|2|3|4|6|7]:REFerence <asc> 

 Argument: <asc> = {CH1 CH2, TRIG1, TRIG2, MEM1, MEM2} 

 Valid Mode: Pulse  

 

 

DISPlay:STATistical:MODE 
 

 Description:  Set or return the statistical sub-mode selection. 

 Syntax: DISPlay:STATistical:MODE <asc> 

 Argument: <asc> = {CCDF, CDF, PDF} 

 Valid Mode: Statistical  

 

 

DISPlay:STATistical:PRESentation 
 

 Description: Set or return the horizontal scale type for statistical modes. 

 Syntax: DISPlay:PRESentation <asc> 

 Argument: <asc> = {LIN, LOG} 

 Valid Modes: Statistical  

 

 

DISPlay:STATistical:PREView 
 

 Description:  Set or return the state of the statistical split-screen preview display. 

 Syntax: DISPlay:STATistical:PREView <asc> 

 Argument: <asc> = {ON, OFF} 

 Valid Mode: Gated Statistical  

 

 

DISPlay:TRACe:MKCENTer 
 

 Description: Changes the vertical center (logarithmic units) or the vertical offset (linear units) to the value at 

which the active marker intersects the trace. The trace does not have to be visible on the display. 

 Syntax: DISPlay:TRACe[1|2]:MKCENTer 

 Argument: none  

 Valid Modes: All except Statistical PDF 
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DISPlay:TRACe:PDFBars 
 

 Description: Set or return the number of  bars in the PDF display. 

 Syntax: DISPlay:TRACe[1|2]:PDFBars <asc> 

 Argument: <asc> =  {1, 2, 5, 10, 20, 35} 

 Valid Modes: Statistical PDF mode only. 

 

 

DISPlay:TRACe:TYPE 
 

 Description: Set or return the trace drawing style, points, lines or off. For Points, display pixels are plotted 

individually. For Lines, display pixels are connected with vertical lines. For Off pixels are not 

plotted on the display, however, measurements continue to be made.  

 Syntax: DISPlay:TRACe[1|2|3|4|5|6|7]:TYPE <asc> 

 Argument: <asc> = {POINTS, LINES, OFF} 

 Valid Modes: All 

 

 

DISPlay:TRACe:VCENTer 
 

 Description: Set or return the power or voltage level of the horizontal centerline of the graph for the specified 

channel in channel units. If a change in the vertical scale causes the center maximum value to be 

exceeded, the center will be forced to the maximum value for the new range.  

 Syntax: DISPlay:TRACe[1|2|3|4|5|6|7]:VCENTer <n> 

 Argument: <n> =   -200.00 to +200.00 dBm for dBm units 

   10,000 times the vertical scale power/div for watts units 

   10,000 times the vertical scale volts/div for volts units 

 Valid Modes: All 

 

 

DISPlay:TRACe:VSCALe 
 

 Description: Set or return the power or voltage vertical sensitivity of the trace display in channel units.  

 Syntax: DISPlay:TRACe[1|2|3|4|5|6|7]:VSCALe <n> 

 Argument: Units = dBm, dBV, dBmV, dBuV , <n> = range in dB/division   

  Units = watts   <n> = range in watts/division 

  Units = volts   <n> = range in volts/division  

 Valid Modes: All 



Boonton 4500B RF Peak Power Analyzer 

Remote Operation 5-32 

DISPlay:TSPAN 
 

 Description: Set or return the horizontal time span of the display.  Time span = 10* Time/Division. 

 Syntax: DISPlay:TSPAN <n> 

 Argument: <n> =  5e-8 to 100 sec in a 1-2-5 sequence,  

   300 sec, 

   10 to 100 min, 

   300 min and 600 min 

 Valid Modes: Modulated and Pulse modes 
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5.5.5  FETCh Queries 

The FETCh? group of queries is used to return specific measurement data from a measurement cycle that has been INITiated 

and is complete or free-running.  FETCh? performs the data output portion of the measurement.  FETCh? does not start a 

new measurement, so a series of FETCh? queries may be used to return more than one set of processed measurements from a 

complete set of acquired data.  FETCh? usually returns the current value of measurements, and should be used anytime free 

running data acquisition is taking place (INITiate:CONTinuous ON).  If FETCh? is used for single measurements 

(INITiate:CONTinuous OFF), no data will be returned until a measurement has been INITiated and is complete. 

 

 

FETCh:ARRay:AMEAsure:POWer? 
 

 Description: Returns an array of the current automatic amplitude measurements performed on a periodic pulse 

waveform.  Measurements performed are: peak amplitude during the pulse, average amplitude 

over a full cycle of the pulse waveform, average amplitude during the pulse, IEEE top amplitude, 

IEEE bottom amplitude, and overshoot. Units are the same as the channel‘s units. Note the pulse 

overshoot is returned in dB for logarithmic channel units, and percent for all other units.  Also, the 

pulse ―ON‖ interval used for peak and average  calculations is defined by the 

SENSe:PULSe:STARTGT and :ENDGT time gating settings.  A full pulse (rise and fall) must 

be visible on the display to make average and peak pulse power measurements, and a full cycle of 

the waveform must be visible to calculate average cycle amplitude. 

 Syntax: FETCh[1|2|3|4|6|7]:ARRay:AMEAsure:POWer? 

 Returns: CC1, PulsePeak, CC2, PulseCycleAvg, CC3, PulseOnAvg, CC4, IEEE Top, CC5, IEEE Bot, CC6,  

Overshoot. 

  Where the CCn‘s are the measurement condition codes for each measurement. 

 Valid Modes: Pulse mode only. 

 Restrictions: Timebase must be set appropriately to allow measurements (see above) 

 

 

FETCh:ARRay:AMEAsure:STATistical? 
 

 Description: Returns an array of the current automatic statistical measurements performed on a sample 

population.  Measurements performed are: long term average, peak and minimum amplitude, 

peak-to-average ratio, amplitude at each marker, statistical percent at each marker, and the sample 

population size in megasamples.   Note the peak-to-average ratio is returned in dB for logarithmic 

channel units, and percent for all other channel units. 

 Syntax:  FETCh[1|2|3|4|6|7]:ARRay:AMEAsure:STATistical? 

 Returns: CC1, Pavg, CC2, Ppeak, CC3, Pmin, CC4, PkToAvgRatio, CC5, Pwr@Mrk1, CC6, Pwr@Mrk2, 

CC7, Pct@Refline1, CC8, Pct@Refline2, CC9, Sample-Count 

  Where the CCn‘s are the measurement condition codes for each measurement. 

 Valid Modes: Statistical mode only 
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FETCh:ARRay:AMEAsure:TIMe? 

 
 Description: Returns an array of the current automatic timing measurements performed on a periodic pulse 

waveform.  Measurements performed are: the frequency, period, width, offtime and duty cycle of 

the pulse waveform, and the risetime and falltime of the edge transitions.  For each of the 

measurements to be performed, the appropriate items to be measured must be visible on the 

display in GRAPH mode.  Pulse frequency, period, offtime and duty cycle measurements require 

that an entire cycle of the pulse waveform (minimum of three edge transitions) be present.  Pulse 

width measurement requires that at least one full pulse is visible, and is most accurate if the pulse 

width is at least 0.4 divisions (20 pixels).  Risetime and falltime measurements require that the 

edge being measured is visible, and will be most accurate if the transition takes at least 0.1 

divisions (5 pixels).  It is always best to have the power analyzer set on the fastest timebase 

possible that meets the edge visibility restrictions.  Set the trace averaging as high as practical to 

reduce fluctuations and noise in the pulse timing measurements.  Note that the timing of the edge 

transitions is defined by the settings of the SENSe:PULSe:DISTal, :MESIal and :PROXimal 
settings; see the descriptions for those commands. Units are the same as the channel‘s units. 

 Syntax:  FETCh[1|2|3|4|6|7]:ARRay:AMEAsure:TIMe? 

 Returns: CC1, PulseFreq, CC2, PulsePeriod, CC3, PulseWidth, CC4, Offtime, CC5, DutyCycle, CC6, 

Risetime, CC7, Falltime, CC8, EdgeDly, CC9, Skew  in Hz, percent or seconds 

  Where the CCn‘s are the measurement condition codes for each measurement. 

 Valid Modes: Pulse mode only 

 Restrictions: Timebase must be set appropriately to allow measurements (see above) 

 

 

FETCh:ARRay:CW:POWer? 
 

 Description:  Returns the current average, maximum, minimum powers or voltages and the peak-to-average 

ratio of the specified channel. Units are the same as the channel‘s units. Note the peak-to-average 

ratio is returned in dB for logarithmic channel units, and percent for all other channel units. 

  Note that the values for maximum and minimum power will depend on the peak hold mode; see 

the description of the CALCulate:PKHLD command for details.   

 Syntax: FETCh[1|2|3|4|6|7]:ARRay:CW:POWer? 

 Returns: CC1, Pavg, CC2, Pmax, CC3, Pmin, CC4, PkToAvgRatio 

  Where the CCn‘s are the measurement condition codes for each measurement. 

 Valid Modes: Modulated and Statistical. 
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FETCh:ARRay:MARKer:POWer? 

 
 Description: Returns an array of the current marker measurements for the specified channel.  The array consists 

of the average, maximum, and minimum power and peak-to-average ratio between the two 

markers, powers at both markers, and the ratio of the two markers.  Note the peak-to-average ratio 

and marker ratio are returned in dB for log units, and percent for linear units. 

 Syntax: FETCh[1|2|3|4|6|7]:ARRay:MARKer:POWer? 

 Returns: CC1, Pavg, CC2, Pmax, CC3, Pmin, CC4, PkToAvgRatio, CC5, Pwr@Marker1, CC6, 

Pwr@Marker2, CC7, Mrk1/Mrk2 ratio  

  Where the CCn‘s are the measurement condition codes for each measurement.. 

 Valid Modes: Pulse and Modulated modes 

 

 

FETCh:ARRay:MARKer:WINDow? 
 

 Description: Return the current marker window display contents, MK1, MK2 and marker math result. The 

channel assignment(s), marker math function and basic units are the same as the display.  

 Syntax: FETCh:ARRay:MARKer:WINDow? 

 Returns: CC, MK1, MK2 and marker math display  

  Where CC is the measurement condition code. 

 Valid Modes: All 

 

 

FETCh:ARRay:TEMPerature:AVERage? 
 

Description: Return the averaged internal temperature of the Channel 1 and Channel 2 peak power sensors. 

Note: If a non-temperature compensated peak sensor is in use, the 4500B displays a warning 

message if the temperature has drifted more than 4C from the autocal temperature.  

 Syntax: FETCh:ARRay:TEMPerature:AVERage? 

 Returns: CC1, Sensor1 Average Temp in degrees C, CC2, Sensor2 Average Temp in degrees C 

  Where CC1 and CC2 are the measurement condition codes. 

 Valid Modes: All 
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FETCh:ARRay:TEMPerature:CALTemp? 
 

 Description: Return the internal temperature of the Channel 1 and Channel 2 peak power sensors at the at the 

time of autocalibration.  Note: If a non-temperature compensated peak sensor is in use, the 4500B 

displays a warning message if the temperature has drifted more than 4C from the autocal 

temperature.  

 Syntax: FETCh:ARRay:TEMPerature:CALTemp? 

 Returns: CC1, Sensor1 AutoCal Temp in degrees C, CC2, Sensor2 AutoCal Temp in degrees C 

  Where CC1 and CC2 are the measurement condition codes. 

 Valid Modes: All 

 

 

FETCh:ARRay:TEMPerature:CURRent? 
 

 Description: Return the current internal temperature of the Channel 1 and Channel 2 peak power sensors. Note: 

If a non-temperature compensated peak sensor is in use, the 4500B displays a warning message if 

the temperature has drifted more than 4C from the autocal temperature.  

 Syntax: FETCh:ARRay:TEMPerature:CURRent? 

 Returns: CC1, Sensor1 Temp in degrees C, CC2, Sensor2 Temp in degrees C 

  Where CCn is the measurement condition code. 

 Valid Modes: All 

 

 

FETCh:CW:POWer? 
 

 Description:  Return current average amplitude reading in channel units.  

 Syntax: FETCh[1|2|3|4|5|6|7]:CW:POWer? 

 Returns: CC, average power (watts, dBm) or average voltage (volts, dBv) 

  Where CC is the measurement condition code. 

 Valid Modes: Modulated and Statistical modes. 

 

 

FETCh:INTERval:AVERage? 
 

 Description: For the specified channel, return the average power or voltage between marker 1 and marker 2.  

The units will be the same as the specified channel.  

 Syntax: FETCh[1|2|3|4|5|6|7]:INTERval:AVERage? 

 Returns: CC, average power or voltage between markers 

  Where CC is the measurement condition code. 

 Valid Modes: Pulse and Modulated 
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FETCh:INTERval:MAXimum? 
 

 Description: For the specified channel, return the maximum instantaneous power or voltage between marker 1 

and marker 2.  The units will be the same as the specified channel.  

 Syntax: FETCh[1|2|3|4|6|7]:INTERval:MAXimum? 

 Returns: CC, maximum instantaneous power or voltage between markers 

  Where CC is the measurement condition code. 

 Valid Modes: Pulse and Modulated 

 

 

FETCh:INTERval:MINimum? 
 

 Description: For the specified channel, return the minimum instantaneous power or voltage between marker 1 

and marker 2.  The units will be the same as the specified channel.  

 Syntax: FETCh[1|2|3|4|6|7]:INTERval:MINimum? 

 Returns: CC, minimum instantaneous power or voltage between markers 

  Where CC is the measurement condition code. 

 Valid Modes: Pulse and Modulated 

 

 

FETCh:INTERval:MAXFilt? 
 

 Description: For the specified channel, return the maximum filtered power or voltage between marker 1 and 

marker 2.  The units will be the same as the specified channel.  

 Syntax: FETCh[1|2|3|4|6|7]:INTERval:MAXFilt? 

 Returns: CC, maximum filtered power or voltage between markers 

  Where CC is the measurement condition code. 

 Valid Modes: Pulse and Modulated 

 

 

FETCh:INTERval:MINFilt? 
 

 Description: For the specified channel, return the minimum filtered power or voltage between marker 1 and 

marker 2.  The units will be the same as the specified channel.  

 Syntax: FETCh[1|2|3|4|6|7]:INTERval:MINFilt? 

 Returns: CC, minimum filtered power or voltage between markers 

  Where CC is the measurement condition code. 

 Valid Modes: Pulse and Modulated 
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FETCh:INTERval:PKAVG? 
 

 Description: For the specified channel, return the peak-to-average ratio of the power or voltage between marker 

1 and marker 2.  The units are dB for logarithmic channel units or percent for linear channel units. 

 Syntax: FETCh[1|2|6|7]:INTERval:PKAVG? 

 Returns: CC, peak-to-average ratio of  power or voltage between markers 

  Where CC is the measurement condition code. 

 Valid Modes: Pulse and Modulated 

 

 

FETCh:KEY? 
 

 Description: Return the key code of the last key depressed; e.g. ESC = 8. 

Syntax: FETCh:KEY 

 Returns: CC, key code 

  Where CC is the measurement condition code. 

 Valid Modes: All 

 

 

 
FETCh:MARKer:AVERage? 
 

 Description: For the specified channel and marker, return the average power or voltage at the marker.  The 

units are the same as the specified channel.  

 Syntax: FETCh[1|2|3|4|5|6|7]:MARKer[1|2]:AVERage? 

 Returns: CC, average power or voltage at marker 

  Where CC is the measurement condition code. 

 Valid Modes: Pulse and Modulated. 

 

 

FETCh:MARKer:DELTa? 
 

 Description: For the specified channel return the difference between MK1 and MK2. The units will be the same 

as marker units.  

 Syntax: FETCh[1|2|3|4|5|6|7]:MARKer:DELTa? 

 Returns: CC, (MK1 – MK2) 

  Where CC is the measurement condition code. 

 Valid Modes: All 
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FETCh:MARKer:MAXimum? 
 

 Description: For the specified channel and marker, return the maximum power or voltage at the marker.  The 

units are the same as the specified channel.  

 Syntax: FETCh[1|2|3|4|6|7]:MARKer[1|2]:MAXimum? 

 Returns: CC,  maximum power or voltage at marker 

  Where CC is the measurement condition code. 

 Valid Modes:  Pulse and Modulated. 

 

 

FETCh:MARKer:MINimum? 
 

 Description: For the specified channel and marker, return the minimum power or voltage at the marker.  The 

units will be the same as the specified channel.  

 Syntax: FETCh[1|2|3|4|6|7]:MARKer[1|2]:MINimum? 

 Returns: CC,  minimum power or voltage at marker 

  Where CC is the measurement condition code. 

 Valid Modes: Pulse and Modulated. 

 

 
 
FETCh:MARKer:RATio? 
 

 Description: For the specified channel return the ratio of MK1 to MK2. The units will be dB for logarithmic 

units or percent for linear units..  

 Syntax: FETCh[1|2|3|4|5|6|7]:Marker:RATio? 

 Returns: CC,  MK1/MK2 

  Where CC is the measurement condition code. 

 Valid Modes: All 

 

 

FETCh:MARKer:RDELTa? 
 

 Description: For the specified channel return the difference between MK2 and MK1. The units will be the same 

as marker units.  

 Syntax: FETCh[1|2|3|4|5|6|7]:MARKer:RDELTa? 

 Returns: CC, (MK2-MK1) 

  Where CC is the measurement condition code. 

 Valid Modes: All 
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FETCh:MARKer:RRATio? 
 

 Description: For the specified channel return the ratio of MK2 to MK1. The units will be dB for logarithmic 

units or percent for linear units..  

 Syntax: FETCh[1|2|3|4|5|6|7]:MARKer:RRATio? 

 Returns: CC,  MK2/MK1 

  Where CC is the measurement condition code. 

 Valid Modes: All 

 

 

FETCh:TEMPerature:AVERage? 
 

 Description: Return the averaged internal temperature of the specified peak power sensor. Note: If a non-

temperature compensated peak sensor is in use, the 4500B displays a warning message if the 

temperature has drifted more than 4C from the autocal temperature.  

 Syntax: FETCh[1|2]:TEMPerature:AVERage? 

 Returns: CC, Sensor[1|2] Average Temp in degrees C 

  Where CC is the measurement condition code. 

 Valid Modes: Peak Sensors only 

 

 
 
FETCh:TEMPerature:CALTemp? 
 

 Description: Return the internal temperature of the specified peak power sensor at the at the time of 

autocalibration.  Note: If a non-temperature compensated peak sensor is in use, the 4500B displays 

a warning message if the temperature has drifted more than 4C from the autocal temperature.  

 Syntax: FETCh[1|2]:TEMPerature:CALTemp? 

 Returns: CC, Sensor[1|2] AutoCal Temp in degrees C 

  Where CC is the measurement condition code. 

 Valid Modes: Peak Sensors only 

 

 

FETCh:TEMPerature:CURRent? 
 

 Description: Return the current internal temperature of the specified peak power sensor. Note: If a non-

temperature compensated peak sensor is in use, the 4500B displays a warning message if the 

temperature has drifted more than 4C from the autocal temperature.  

 Syntax: FETCh[1|2]:TEMPerature:CURRent? 

 Returns: CC, Sensor[1|2] Temp in degrees C 

  Where CCn is the measurement condition code. 

 Valid Modes: Peak Sensors only 
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5.5.6  HCOPy Commands 

The HCOPy commands are used to control the printing of screen images and data. 

 

HCOPy:BACKground:COLor 

 
 Description: Set/return the background color used for printing the screen display. 

 Syntax: HCOPy:BACKground:COLor <asc> 

 Argument: <asc> = { BLACK, WHITE, GRAY } 

 Valid Modes: Any 
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5.5.7  INITiate and ABORt Commands 

The purpose of the INITiate group of commands is to start and control the process of data acquisition once a measurement 

has been configured.  Depending on settings, the 4500B Peak Power Analyzer may be commanded to begin either a single 

measurement (INITiate:CONTinuous OFF) which stops when complete, or enter a ―free-run‖ mode where data acquisition 

occurs continuously (INITiate:CONTinuous ON).  The ABORt command terminates any operation in progress and prepares 

the instrument for an INITiate command.  In some operating modes, the INITiate commands do not actually start 

measurements, but rather arm a hardware trigger, which is then used to gate the actual measurements cycle. 

 

 

ABORt 
 

 Description: Terminates any measurement in progress and resets the state of the trigger system.  Note that 

ABORt will leave the measurement in a stopped condition, and forces INITiate:CONTinuous to 

OFF. 

 Syntax: ABORt 

 Argument: None 

 Valid Modes: Any 

 

 

INITiate:CONTinuous 
 

 Description: Set or return the data acquisition mode for single or free-run measurements.  If 

INITiate:CONTinuous is set to ON, the 4500B immediately begins taking measurements 

(Modulated, CW and Statistical modes), or arms its trigger and takes a measurement each time a 

trigger occurs (Pulse mode).  If set to OFF, the measurement will begin (or be armed) as soon as 

the INITiate command is issued, and will stop once the measurement criteria (averaging, filtering 

or sample count) has been satisfied.  Note that INITiate:IMMediate and READ commands are 

invalid when INITiate:CONTinuous is set to ON; however, by convention this situation does not 

result in a SCPI error.  

 Syntax: INITiate:CONTinuous <asc> 

 Argument: <asc> = {ON, OFF} 

 Valid Modes: Any 
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INITiate[:IMMediate[:ALL]] 
 

 Description: Starts a single measurement cycle when INITiate:CONTinuous is set to OFF.  In Modulated 

mode, the measurement will complete once the power has been integrated for the full FILTer time.  

In Pulse mode, enough trace sweeps must be triggered to satisfy the AVERaging setting.  In 

Statistical mode, acquisition stops once the terminal condition(s) are met.  In each case, no reading 

will be returned until the measurement is complete. This command is not valid when 

INITiate:CONTinuous is ON, however, by convention this situation does not result in a SCPI 

error.  

 Syntax: INITiate[:IMMediate[:ALL]] 

 Argument: None 

 Valid Modes: Any 

 Restrictions: INITiate:CONTinuous must be OFF 
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5.5.8  MARKer Subsystem 

The MARKer group of commands is used to configure and locate measurement markers (cursors) at specific points on the 

processed measurement waveform.  FETCH? or READ? queries may then be used to retrieve measurements at the two 

markers and in the interval between them.  Markers are used in Pulse mode to perform measurements at or between two time 

offsets relative to the trigger, and in Statistical mode to measure the power at a particular statistical percent, or the percent at 

a specified power level.  In Pulse mode, the markers can only be placed on the visible portion of the trace (as defined by the 

timebase and trigger delay settings), while Statistical mode markers may be placed at any power or percent value and will 

still return readings. 

 

MARKer: ASSIgn  
 

Description: Set or return the channel to which the specified marker display window, MK1 or MK2  is 

assigned. The marker math result window will show the result of the specified marker math 

operation on the selected marker sources. Some combinations of markers sources and math 

operations are disallowed. Set ACTIVE to automatically select the displayed channel. 

 Syntax: MARKer[1|2]:ASSIgn <asc> 

 Argument: <asc> =  {ACTIVE, CH1, CH2, CHM, TRIG1, TRIG2, MEM1, MEM2} 

 Valid Modes: All 

 

 

MARKer:GROUp 

  
Description: Set or return the marker grouping rule. If BOTH is set, Marker 1 and Marker 2 will be forced to 

the same channel assignment. If EACH, is set, Marker 1 and Marker 2 will have independent 

channel assignments. If MARKer:GROUp BOTH & MARKer:ASSIgn ACTIVE are set, Marker 1 

and Marker 2 will be assigned to the displayed channel. 

 Syntax: MARKer:GROUp <asc> 

 Argument: <asc> =  {BOTH, EACH} 

 Valid Modes: All 
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MARKer:MATH:BOTH 

  
Description: Set the marker group to BOTH and configure the marker math function. 

 Syntax: MARKer:MATH:BOTH <arg1>, <arg2>, <arg3>  

 Argument: <arg1>  { RATIO, DELTA, AVG } 

                                      Specifies the result displayed in the center marker window:  

   RATIO -the ratio of the left and right marker window readings in dBr or percent. The 

precedence is determined by <arg2>. The ratio of measurements in decibel units is 

expressed in dBr while the ratio of linear units is expressed in percent. See also PKAVG. 

 DELTA -valid only with <arg3> set to W (watts) or V (volts). The difference of the left 

and right marker window readings expressed in channel units 

   AVG -the average power or voltage in the interval between the markers in channel units  

   

<arg2>   For <arg1> = RATIO      { MK1MK2, MK2MK1, MINMAX, MAXMIN, MINFMAXF,   

MAXFMINF, PKAVG } 

               For <arg1> = DELTA    { MK1MK2, MK2MK1, MINMAX, MAXMIN, MINFMAXF,   

MAXFMINF }  

               For <arg1> = AVG        { MINMAX, MAXMIN, MINFMAXF, MAXFMINF } 

  For RATIO (except PKAVG) and DELTA measurements, specifies how the left and right 

marker windows are used to calculate the center marker window.   

    MK1MK2 –ratio is MK1/MK2; difference is MK1-MK2 

       MK2MK1 -ratio is MK2/MK1; difference is MK2-MK1  

    MINMAX –ratio is MIN/MAX; difference is MIN-MAX 

    MAXMIN –ratio is MAX/MIN; difference is MAX-MIN 

    MINFMAXF –ratio is MINF/MAXF; difference is MINF-MAXF 

    MAXFMINF –ratio is MAXF/MINF; difference is MAXF-MINF  

For RATIO only, Peak to Average Ratio measurements, specifies the contents of left, 

right and center marker windows.  

PKAVG -sets the left marker window, LAvg, to the long term average and the 

right marker window, PkHld, to the instantaneous Peak in the interval between 

the markers. The center marker window displays the Peak-to-Average Ratio for 

the interval between the markers in dB or percent.   

For AVG measurements, specifies the contents of the left and right marker windows.  

MINMAX or MAXMIN –the left marker window, MIN, and the right marker 

window, MAX, are the minimum and maximum instantaneous power or voltage 

in the interval between markers  

MINFMAXF or MAXMINF –the left marker window, MINF, and the right 

marker window, MAXF, are the minimum and maximum filtered power or 

voltage in the interval between the markers 

 

  <arg3>  Specifies the channel units. 

   {dBm, W, V, dBV, dBmV, dBuV}  

 Valid Modes: Modulated, Pulse and Statistical (RATIO with MK1MK2 only) modes 
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MARKer:MATH:EACH 
 

Description: Set the marker group to EACH and configure the marker math function. 

 Syntax:  MARKer:MATH:EACH <arg1>, <arg2>, <arg3>  

 Argument: <arg1>  { RATIO, DELTA } 

   Specifies the result displayed in the center marker window  

   RATIO  -the ratio of the left and right marker window readings in dBr or percent.  

 DELTA  -valid only with <arg3> set to W (watts) or V (volts). The difference of the left 

and right marker window readings expressed in channel units  

 

  <arg2> { MK1MK2, MK2MK1} 

Specifies how the left and right marker windows are used to calculate the center marker 

window.  

   MK1MK2 – ratio is MK1/MK2; difference is MK1-MK2 

   MK2MK1 - ratio is MK2/MK1; difference is MK2-MK1  

 

  <arg3>  Specifies the channel units. 

   {dBm, W, V, dBV, dBmV, dBuV}  

 

 Valid Modes: Modulated, Pulse and Statistical (RATIO with MK1MK2 only) modes 

 

 NOTE      There is no query form for  MARKer:MATH:BOTH or  MARKer:MATH;EACH. 

 

 

 

 

 

MARKer:POSItion:PERcent 
 

 Description: Set or return the percent probability (X-axis-position) of the selected vertical marker.  Note that 

the power value returned for each marker will depend on the setting of CALCulate:MODE.  

When set to CDF, the highest power levels are towards the right side of the screen, with maximum 

(highest peak) power occurring at 100%.  When set to CCDF (also called 1-CDF), the highest 

levels are towards the left, with peak power at 0%. 

 Syntax: MARKer[1|2]:POSItion:PERcent <n> 

 Argument: <n> = 0.000 to 100.000 % 

 Valid Modes: Statistical modes only.   
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MARKer:POSItion:PIXel 
 

 Description: Set or return the horizontal pixel position (X-axis-position) of the selected vertical marker. There 

are 501 pixel positions numbered from 0 to 500 inclusive.  

 Syntax: MARKer[1|2]:POSItion:PIXel <n> 

 Argument: <n> = 0 to 500 inclusive 

 Valid Modes: All   

 

 
 
MARKer:POSItion:TIMe 
 

 Description: Set or return the time (X-axis-position) of the selected vertical marker relative to the trigger.  Note 

that time markers must be positioned within the time limits of the trace window in the graph 

display. If a time outside of the display limits is entered, the marker will be placed at the first or 

last time position as appropriate.   

 Syntax: MARKer[1|2]:POSItion:TIMe <n> 

 Argument: <n> =  display-time in seconds (see restrictions) 

 Valid Modes: Pulse and Modulated modes.   

 Restrictions: For zero delay trigger position in the center of the display , the following relationship must be 

satisfied: TrigDly - (5*time/div)  <  MarkerTime  <  TrigDly + (5*time/div) where the timebase 

setting is time/div 
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5.5.9  MEASure Queries 

The MEASure group of commands is used to acquire data using a set of high level instructions.  They are structured to allow 

the user to trade off fine control of the measurement process for easy operability.  MEASure? provides a complete capability 

where the power analyzer is configured, a measurement taken, and results returned in one operation.  The instrument is set to 

a basic, predefined measurement state with little user intervention necessary or possible.  Sometimes, more precise control of 

measurement is required.  In these cases, MEASure? should not be used.  Rather, a sequence of configuration commands, 

generally from the CALCulate and SENSe groups should be used to set up the instrument for the measurement, then READ? 

or FETCH? commands are used to return the desired measurement data in a specific format. 

 

MEASure:POWer? 
 

 Description:  Return average power using a default instrument configuration in Modulated mode and dBm units. 

Instrument remains stopped in modulated mode after a measurement. 

 Syntax:  Measure[1|2]:POWer? 

 Returns: CC, Average power in dBm 

  Where CC is the measurement condition code. 

 Modes: Automatically set to Modulated mode before measurement 

 

 

MEASure:VOLTage? 
 

 Description: Return average voltage using a default instrument configuration in Modulated mode and volts 

units. Instrument remains stopped in modulated mode after a measurement. 

 Syntax: MEASure[1|2|3|4]:VOLTage? 

 Returns: Average voltage in linear volts 

  Where CC is the measurement condition code. 

 Valid Modes: Automatically set to Modulated mode before measurement. 



Boonton 4500B RF Peak Power Analyzer 

Remote Operation 5-49 

5.5.10  MEMory Subsystem 

The MEMory group of commands is used to save and recall instrument operating configurations, and to edit and review user-

supplied frequency dependent offset (FDOF) tables for external devices in the signal path.  Up to four configurations may be 

saved, and two frequency dependent offset tables.  Note, however that assigning a stored FDOF table to a particular 

measurement channel is not a MEMory command; it is handled through the SENSe subsystem. 

 

 

MEMory:DRIVe 
 

Description: Set or return the active drive letter that is the source or destination for saved files.  

 Syntax: MEMory:DRIVe <asc> 

 Argument: <asc> = {A,B,C, … Z} 

 Valid Modes: All. 

 

 

MEMory:FDOFfset:TBLA:DATA 
 

 Description: Set or read back the data array for frequency dependent offset table A.  The array must be in 

comma delimited format, and consists of up to 60 data pairs, each consisting of a frequency, 

followed by the offset for that frequency.  Frequencies are in GHz, and may be any valid number 

within the operating range of the sensor.  Offsets are in dB, and may range from -9.99 to +9.99dB.  

Querying an empty FDOF table will return ―0.00,0.00‖. 

 Syntax: MEMory:FDOFfset:TBLA:DATA <asc> 

 Argument: <asc> = Freq1, Ofset1, Freq2, Ofset2 ... FreqN, OfsetN 

 Valid Modes: All. 

 

 

MEMory:FDOFfset:TBLB:DATA 
 

 Description: Set or read back the data array for frequency dependent offset table B.  The array must be in 

comma delimited format, and consists of up to 60 data pairs, each consisting of a frequency, 

followed by the offset for that frequency.  Frequencies are in GHz, and may be any valid number 

within the operating range of the sensor.  Offsets are in dB, and may range from -9.99 to +9.99dB.  

Querying an empty FDOF table will return ―0.00,0.00‖. 

 Syntax: MEMory:FDOFfset:TBLB:DATA <asc> 

 Argument: <asc> = Freq1, Ofst1, Freq2, Ofst2 ... FreqN, OfstN 

 Valid Modes: All. 
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MEMory:FREE? 
 

 Description: Return the number of free bytes on the active drive. If the active drive specified by the 

MEMory:DRIVe command does not exist, return –1. . 

 Syntax: MEMory:FREE? 

 Argument: None, query only. 

 Returns: <n> = number of  free bytes or –1 if drive letter is invalid 

 Valid Modes: Any 

 

 

MEMory:OVERwrite 
 

 Description: Set or return the state of the memory overwrite flag. If set to ―On‖, an existing file will be 

automatically overwritten. Commands that monitor the state of this flag are: MEM:SYS:STORE, 
MMEM:STORE and MMEMory:SAVE:DISPlay. 

 Syntax: MEMory:OVERwrite <asc> 

 Argument: <asc> = {ON, OFF} 

 Valid Modes: Any 

 

 

MEMory:SNSR:CFFAST? 
 

 Description: Return the sensor high bandwidth (FAST) frequency cal-factor table. 

 Syntax: MEMory:SNSR[1|2]:CFFAST? 

 Argument: None, query only. 

 Valid Modes: Any 

 

  

MEMory:SNSR:CFSLOW? 
 

 Description: Return the sensor low bandwidth (SLOW) frequency cal-factor table. 

 Syntax: MEMory:SNSR[1|2]:CFSLOW? 

 Argument: None, query only. 

 Valid Modes: Any 
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MEMory:SNSR:INFO? 
 

 Description: Return the sensor ID and parameter data.  

 Syntax: MEMory:SNSR[1|2]:INFO? 

 Argument: None 

 Valid Modes: Any 

 

 

MEMory:SNSR:MESSage? 
 

 Description: Return the sensor message data.  

 Syntax: MEMory:SNSR[1|2]:MESSage? 

 Argument: None 

 Valid Modes: Any 

 

 

MEMory:SNSR:TEMPCOMP? 
 

 Description: Return the sensor temperature compensation table. If no table or invalid, return –1 and 0.  

 Syntax: MEMory:SNSR[1|2]:TEMPCOMP? 

 Argument: None 

 Valid Modes: Any 

 

 

MEMory:SYS:LOAD 
 

 Description: Recall and install a stored instrument configuration from the filename specified by the <‖asc‖> 

ASCII string. The string must contain a filename with the entire path, without the extension, 

enclosed in quotes.  

 Syntax: MEMory:SYS:LOAD <‖asc‖> 

 Argument: <‖asc‖> =  ―C:\prog\dat\image4500B‖   (example) 

 Valid Modes: Any 
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MEMory:SYS:STORe 

  
 Description: Store an instrument configuration to the filename specified by the <‖asc‖> ASCII string. The 

string must contain a filename with the entire path, without the extension, enclosed in quotes.  

 Syntax: MEMory:SYS:STORe <‖asc‖> 

 Argument: <‖asc‖> =   ―C:\prog\dat\image4500B‖  (example) 

 Valid Modes: Any 

 

 

MMEMory:COPY 
 

 Description: Copy a waveform from a channel specified by the <asc1> string to a reference channel specified 

by the <asc2> string. A space is required between the two arguments. 

 Syntax: MMEMory:COPY <asc1> sp  <asc2> 

 Argument: <asc1> = {CH1, CH2, TRIG1, TRIG2} 

  <asc2> = {MEM1, MEM2} 

 Valid Modes: Any 

 

 

MMEMory:LOAD 
 

 Description: Recall a stored waveform from the filename specified by the <‖asc1‖> string and load it into 

reference channel MEM1 or MEM2 specified by the <asc2> string. The <‖asc1‖> string must 

contain a filename with the entire path, without the extension, enclosed in quotes, and a reference 

channel destination. A space is required between the two arguments.  

 Syntax: MMEMory:LOAD <‖asc1‖> sp <asc2> 

 Argument: <‖asc1‖> =  ―C:\prog\dat\WFM001‖ (example) 

  <asc2> = {MEM1, MEM2} 

 Valid Modes: Any 



Boonton 4500B RF Peak Power Analyzer 

Remote Operation 5-53 

MMEMory:SAVE:DISPlay 
 

 Description: Make a *.BMP file of the display and write it to a file specified by the <‖asc‖> string.  <"asc"> 

must contain the entire path, a filename without the extension, and be enclosed in quotes.  If the 

file already exists, it can only be overwritten if the command MEMory:OVERwrite ON has been 

issued. 

 Syntax: MMEMory:SAVE:DISPlay <‖asc‖>  

 Argument: <‖asc‖> =  ―C:\prog\dat\Pulse001‖  (example) 

 Valid Modes: All 

 

 

MMEMory:STORe 
 

 Description: Store a waveform from a channel specified by the <asc1> string to a filename specified by the 

<‖asc2‖> string. The <asc1> string is one of  CH1, CH2, TRIG1, TRIG2, MEM1 or MEM2. The 

<‖asc2‖> string must contain a filename with the entire path, without the extension, enclosed in 

quotes. A space is required between the two arguments. 

 Syntax: MMEMory:STORe <asc1> sp  <‖asc2‖> 

 Arguments: <asc1> = {CH1, CH2, TRIG1, TRIG2, MEM1, MEM2} 

  <‖asc2‖>> =  ―C:\prog\dat\WFM001‖   (example) 

  <<asc1> sp  <‖asc2‖>> = CH2 ―C:\prog\dat\WFM001‖   (example) 

 Valid Modes: All 
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5.5.11  OUTPut Subsystem 

The OUTPut group of commands is used to control the internal 1GHz RF calibration source. The internal calibrator can be 

configured as a programmable pulse source, with options for modulation rate and duty cycle. It can also be driven by an 

external pulse modulation source. 

 

 

OUTPut:LEVel:POWer 
 

 Description: Set or return the power level for the 1 GHz calibrator output signal. 

 Syntax: OUTPut:LEVel:POWer <asc>  

 Argument: <asc> = -50.0 to +20.0 dBm (0.1dB resolution) 

 Valid Modes: Any 

 

 

OUTPut:LEVel:LIMit  
 

 Description: Set or return the limit power level in dBm for the 1 GHz calibrator output signal. The calibrator 

output level cannot be set to exceed this limit. 

 Syntax: OUTPut:LEVel:LIMit <n>  

 Argument: <asc> = -40.0 to +20.0  (0.1dB resolution) 

 Valid Modes: Any 

 

 

OUTPut:LEVel:STEP 

  
 Description: Set or return the power step size in dB used by the Knob and Arrow keys on the front panel to 

control the output level of the 1 GHz calibrator.  

 Syntax: OUTPut:LEVel:STEP <n>  

 Argument: <asc> =  0.1 to 60.0  (0.1dB resolution) 

 Valid Modes: Any 
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OUTPut:MODUlation 
 

 Description: Set or return the output modulation state for the 1 GHz calibrator.  If set to CW, a calibrated CW 

signal will be generated.  If set to PULSE, the output will be pulse modulated by the source 

specified in the OUTPut:SOURce <INT, EXT> command. If EXT is selected, an external pulse 

generator with TTL compatible output must be connected to the rear panel EXT PULSE BNC 

connector. If no generator is connected, there will be no calibrator RF output. IF INT is selected, 

the pulse modulation will be controlled by the Preset Group, OUTPut:PULSe:PPERIOD, 

OUTPut:POLARrity and OUTPut:PULSe:PDCYCle or by OUTPut:PULSe:PERWID, depending 

upon the OUTPut:PULse:CTRL <PRESET, VAR> setting.  

 Syntax: OUTPut:MODUlation <asc> 

 Argument: <asc> = {CW, PULSE} 

 Valid Modes: Any 

 

 

OUTPut:POLArity  
 

 Description: Set or return the polarity of the duty cycle in the Preset pulse control mode of the internal 1 GHz 

calibrator. When set to POS, the argument is the percentage of time the pulse is on in each period.  

When set to NEG, the argument is the percentage of time the pulse is off in each period. This 

parameter has no effect in the Variable pulse control mode or the External pulse source mode.  

 Syntax: OUTPut:POLArity <asc> 

 Argument: <asc> = {POS, NEG} 

 Valid Modes: Any  

 

 

OUTPut:PULSe:CTRL 

 
 Description: Set or return the pulse control mode of the internal 1 GHz calibrator‘s pulse modulator.  This 

parameter has no effect in the External source pulse control mode. 

 Syntax: OUTPut:PULSe:CTRL  <asc> 

 Argument: <asc> = {PRESET,  VAR} 

 Valid Modes: Any  

 

 

OUTPut:PULSe:DCYCle  
 

 Description: Set or return the duty cycle in percent in the Preset pulse control mode of the internal 1 GHz 

calibrator. This parameter has no effect in the Variable pulse control mode or the External pulse 

source mode. 

 Syntax: OUTPut:PULSe:DCYCle  <asc> 

 Argument: <asc> =  {10, 20, 30, 40, 50}  

 Valid Modes: Any 
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OUTPut:PULse:PERiod 
 

 Description: Set or return the pulse period in the Preset pulse control mode of the internal 1 GHz calibrator. 

This parameter has no effect in the Variable pulse control mode External pulse source mode. 

 Syntax: OUTPut:PULse:PERiod <arg> 

 Argument: <arg> =  {10e-3, 1e-3, 100e-6} seconds, or  

   {10ms, 1ms, 0.1ms}, or 

   {10000us, 1000us, 100us} 

 Valid Modes: 1 GHz Calibrator Preset Pulse control Mode 

 

 

OUTPut:PULse:PERWID 
 

 Description: Set or return the pulse period <arg1> and pulse width <arg2> in seconds in the Variable pulse 

control mode of the internal 1 GHz calibrator. This parameter has no effect in the Preset pulse 

control mode or the External pulse source mode.  

 Syntax: OUTPut:PULse:PERWID <arg1> sp <arg2> 

 Argument: <arg1> =  28e-6  to 131.07e-3    (Pulse period)   

  <arg2> =    7e-6  to  65.535e-3   (Pulse width)     

 Valid Modes: Any 

 

 

OUTPut:PULse:SOURce 
 

 Description: Set or return the pulse modulation source for the internal 1 GHz calibrator.  If set to INT, the 

internal pulse generator is used. EXT selects the signal from the calibrator‘s rear-panel EXT 

PULSE input.  Note this input requires TTL compatible signal levels. 

 Syntax: OUTPut:PULse:SOURce <asc> 

 Argument: <asc> = {INT, EXT} 

 Valid Modes: Any 

  

 

OUTPut:SIGNal  
 

 Description: Set or return the on/off state of the internal 1 GHz calibrator‘s output signal. 

 Syntax: OUTPut:SIGNal <asc> 

 Argument: <asc> = {OFF, ON} 

 Valid Modes: Any.   
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OUTPut:TRIGout[1/2]:SOURce 
 

 Description: Set or return the signal type for the measurement channel rear panel Trigger Out BNC 

 Syntax: OUTPut:TRIGout[1/2]:SOURce <asc> 

 Argument: <asc> = {CH1, TRIG1, SWP, CLK} for TRIGout1  

  <asc> = {CH2, TRIG2, SWP, CLK} for TRIG2out2 

 Valid Modes: Any.   

 

OUTPut:TRIGout[1/2]:POLArity 
 

 Description: Set or return the slope (rising or falling) for the measurement channel rear panel Trigger Out BNC 

 Syntax: OUTPut:TRIGout[1/2]:POLArity <asc> 

 Argument: <asc> = {POS, NEG} 

 Valid Modes: Any.   
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5.5.12  READ Queries 

The purpose of the READ? group of queries is to initiate a measurement cycle, acquire data, and return specific measurement 

data.  READ? performs the initiation, data acquisition, postprocessing, and data output portions of the measurement.  READ? 

is equivalent to ABORting any operation in progress, INITiating a new measurement, then FETChing the data when it is 

ready.  READ? generally does not return data unless acquisition is complete.  Since READ? INITiates a new measurement 

every time it is issued, READ? queries should not be used for free running data acquisition (INITiate:CONTinuous ON) - in 

this case, use FETCh queries instead.  For CW and Modulated modes, the measurement is generally considered complete 

when the integration filter (see SENSe:FILTer) is filled.  In Pulse mode, the measurement is considered complete when all 

the number of complete traces specified by the SENSe:AVERage command have been acquired and averaged together.  In 

statistical mode, the measurement is considered complete when the number of samples specified by TRIGger:CDF:COUNt 
has been gathered. 

 

READ:ARRay:AMEAsure:POWer? 
 

 Description: Returns an array of the current automatic amplitude measurements performed on a periodic pulse 

waveform.  Measurements performed are: peak amplitude during the pulse, average amplitude 

over a full cycle of the pulse waveform, average amplitude during the pulse, IEEE top amplitude, 

IEEE bottom amplitude, and overshoot. Units are the same as the channel‘s units. Note the pulse 

overshoot is returned in dB for logarithmic channel units, and percent for all other units.  Also, the 

pulse ―ON‖ interval used for peak and average  calculations is defined by the 

SENSe:PULSe:STARTGT and :ENDGT time gating settings.  A full pulse (rise and fall) must 

be visible on the display to make average and peak pulse power measurements, and a full cycle of 

the waveform must be visible to calculate average cycle amplitude. 

 Syntax: READ[1|2|3|4|6|7]:ARRay:AMEAsure:POWer? 

 Returns: CC1, PulsePeak, CC2, PulseCycleAvg, CC3,  PulseOnAvg, CC4, IEEE Top, CC5, IEEE Bot,  

CC6, Overshoot 

  Where the CCn‘s are the measurement condition codes for each measurement. 

 Valid Modes: Pulse mode only 

 Restrictions: Timebase must be set appropriately to allow measurements (see above) 

 

 

 

READ:ARRay:AMEAsure:STATistical? 
 

 Description: Returns an array of the current automatic statistical measurements performed on a sample 

population.  Measurements performed are: long term average, peak and minimum amplitude, 

peak-to-average ratio, amplitude at each marker, statistical percent at each marker, and the sample 

population size in megasamples.   Note the peak-to-average ratio is returned in dB for logarithmic 

channel units, and percent for all other channel units. 

 Syntax:  READ[1|2|3|4|6|7]:ARRay:AMEAsure:STATistical? 

 Returns: CC1, Pavg, CC2, Ppeak, CC3, Pmin, CC4, PkToAvgRatio, CC5, Pwr@Mrk1, CC6, Pwr@Mrk2, 

CC7, Pct@Refline1, CC8, Pct@Refline2, CC9, Sample-Count 

  Where the CCn‘s are the measurement condition codes for each measurement.   

 Valid Modes: Statistical mode only 
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READ:ARRay:AMEAsure:TIMe? 

 
 Description: Returns an array of the current automatic timing measurements performed on a periodic pulse 

waveform.  Measurements performed are: the frequency, period, width, offtime and duty cycle of 

the pulse waveform, and the risetime and falltime of the edge transitions.  For each of the 

measurements to be performed, the appropriate items to be measured must be visible on the 

display in GRAPH mode.  Pulse frequency, period, offtime and duty cycle measurements require 

that an entire cycle of the pulse waveform (minimum of three edge transitions) be present.  Pulse 

width measurement requires that at least one full pulse is visible, and is most accurate if the pulse 

width is at least 0.4 divisions (20 pixels).  Risetime and falltime measurements require that the 

edge being measured is visible, and will be most accurate if the transition takes at least 0.1 

divisions (5 pixels).  It is always best to have the power analyzer set on the fastest timebase 

possible that meets the edge visibility restrictions. Set the trace averaging as high as practical to 

reduce fluctuations and noise in the pulse timing measurements.  Note that the timing of the edge 

transitions is defined by the settings of the SENSe:PULSe:DISTal, :MESIal and :PROXimal 
settings; see the descriptions for those commands. Units are the same as the channel‘s units. 

 Syntax:  READ[1|2|3|4|6|7]:ARRay:AMEAsure:TIMe? 

 Returns: CC1, PulseFreq, CC2, PulsePeriod, CC3, PulseWidth, CC4, Offtime, CC5, DutyCycle, CC6, 

Risetime, CC7, Falltime, CC8, EdgeDly, CC9, Skew  in Hz, percent and seconds 

 ` Where the CCn‘s are the measurement condition codes for each measurement. 

 Valid Modes: Pulse mode only. 

 Restrictions: Timebase must be set appropriately to allow measurements (see above) 

 

 

READ:ARRay:CW:POWer? 
 

 Description:  Returns the current average, maximum, minimum powers or voltages and the peak-to-average 

ratio of the specified channel. Units are the same as the channel‘s units. Note the peak-to-average 

ratio and marker ratio are returned in dB for logarithmic channel units, and percent for all other 

channel units. 

  Note that the values for maximum and minimum power will depend on the peak hold mode; see 

the description of the CALCulate:PKHLD command for details.   

 Syntax: READ[1|2|3|4|6|7]:ARRay:CW:POWer? 

 Returns: CC1, Pavg, CC2, Pmax, CC3, Pmin, CC4, PkToAvgRatio  

  Where the CCn‘s are the measurement condition codes for each measurement. 

 Valid Modes: Modulated and Statistical. 
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READ:ARRay:MARKer:POWer?  

 
 Description: Returns an array of the current marker measurements for the specified channel.  The array consists 

of the average, maximum, and minimum power and peak-to-average ratio between the two 

markers, powers at both markers, and the ratio of the two markers.  Note the peak-to-average ratio 

and marker ratio are returned in dB for log units, and percent for linear units. 

 Syntax: READ[1|2|3|4|6|7]:ARRay:MARKer:POWer? 

 Returns: CC1, Pavg, CC2, Pmax, CC3, Pmin, CC4, PkToAvgRatio, CC5, Pwr@Marker1, CC6, 

Pwr@Marker2, CC7, Mrk1/Mrk2 ratio 

  Where the CCn‘s are the measurement condition codes for each measurement. 

 Valid Modes: Pulse and Modulated 

 

 

READ:ARRay:MARKer:WINDow? 
 

 Description: Return the current marker window display contents, MK1, MK2 and marker math result. The 

channel assignment(s), marker math function and basic units are the same as the display.  

 Syntax: READ:ARRay:MARKer:WINDow? 

 Returns: CC, MK1, MK2 and marker math display  

  Where CC is the measurement condition code. 

 Valid Modes: All 

 

 

READ:CW:POWer? 
 

 Description:  Return current average amplitude reading in channel units.  

 Syntax: READ[1|2|3|4|5|6|7]:CW:POWer? 

 Returns: CC, Average power (watts, dBm) or average voltage (volts, dBv) 

  Where CC is the measurement condition code. 

 Valid Modes: Modulated mode only. 

 

 

READ:INTERval:AVERage? 
 

 Description: For the specified channel, return the average power or voltage between marker 1 and marker 2.  

The units will be the same as the specified channel.  

 Syntax: READ[1|2|3|4|5|6|7]:INTERval:AVERage? 

 Returns: CC, average power or voltage between markers 

  Where CC is the measurement condition code. 

 Valid Modes: Pulse and Modulated 
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READ:INTERval:MAXimum? 
 

 Description: For the specified channel, return the maximum instantaneous power or voltage between marker 1 

and marker 2.  The units will be the same as the specified channel.  

 Syntax: READ[1|2|3|4|6|7]:INTERval:MAXimum? 

 Returns: CC, maximum instantaneous power or voltage between markers 

  Where CC is the measurement condition code. 

 Valid Modes: Pulse and Modulated 

 

 

READ:INTERval:MINimum? 
 

 Description: For the specified channel, return the minimum instantaneous power or voltage between marker 1 

and marker 2.  The units will be the same as the specified channel.  

 Syntax: READ[1|2|3|4|6|7]:INTERval:MINimum? 

 Returns: CC, minimum instantaneous power or voltage between markers 

  Where CC is the measurement condition code. 

 Valid Modes: Pulse and Modulated 

 

 

READ:INTERval:MAXFilt? 
 

 Description: For the specified channel, return the maximum filtered power or voltage between marker 1 and 

marker 2.  The units will be the same as the specified channel.  

 Syntax: READ[1|2|3|4|6|7]:INTERval:MAXFilt? 

 Returns: CC, maximum filtered power or voltage between markers 

  Where CC is the measurement condition code. 

 Valid Modes: Pulse and Modulated 

 

 

READ:INTERval:MINFilt? 
 

 Description: For the specified channel, return the minimum filtered power or voltage between marker 1 and 

marker 2.  The units will be the same as the specified channel.  

 Syntax: READ[1|2|3|4|6|7]:INTERval:MINFilt? 

 Returns: CC, minimum filtered power or voltage between markers 

  Where CC is the measurement condition code. 

 Valid Modes: Pulse and Modulated 
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READ:INTERval:PKAVG? 
 

 Description: For the specified channel, return the peak-to-average ratio of the power or voltage between marker 

1 and marker 2.  The units are dB for logarithmic channel units or percent for linear channel units. 

 Syntax: READ[1|2|6|7]:INTERval:PKAVG? 

 Returns: CC, peak-to-average ratio of  power or voltage between markers 

  Where CC is the measurement condition code. 

 Valid Modes: Pulse and Modulated 

 

 

READ:MARKer:AVERage? 
 

 Description: For the specified channel and marker, return the average power or voltage at the marker.  The 

units are the same as the specified channel.  

 Syntax: READ[1|2|3|4|5|6|7]:MARKer[1|2]:AVERage? 

 Returns: CC, average power or voltage at marker 

  Where CC is the measurement condition code. 

 Valid Modes: Pulse and Modulated. 

 

 

 
READ:MARKer:DELTa? 
 

 Description: For the specified channel return the difference between MK1 and MK2. The units will be the same 

as marker units.  

 Syntax: READ[1|2|3|4|5|6|7]:MARKer:DELTa? 

 Returns: CC, (MK1 – MK2) 

  Where CC is the measurement condition code. 

 Valid Modes: All 

 

 

READ:MARKer:MAXimum? 
 

 Description: For the specified channel and marker, return the maximum power or voltage at the marker.  The 

units are the same as the specified channel.  

Syntax:  READ[1|2|3|4|6|7]:MARKer[1|2]:MAXimum? 

 Returns: CC,  maximum power or voltage at marker 

   Where CC is the measurement condition code. 

 Valid Modes: Pulse and Modulated. 
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READ:MARKer:MINimum? 
 

 Description: For the specified channel and marker, return the minimum power or voltage at the marker.  The 

units will be the same as the specified channel.  

 Syntax: READ[1|2|3|4|6|7]:MARKer[1|2]:MINimum? 

 Returns: CC,  minimum power or voltage at marker 

   Where CC is the measurement condition code. 

 Valid Modes: Pulse and Modulated. 

 

 

READ:MARKer:RATio? 
 

 Description: For the specified channel return the ratio of MK1 to MK2. The units will be dB for logarithmic 

units or percent for linear units..  

 Syntax: READ[1|2|3|4|5|6|7]:Marker:RATio? 

 Returns: CC,  MK1/MK2 

  Where CC is the measurement condition code. 

 Valid Modes: All 

 

 

 

READ:MARKer:RDELTa? 
 

 Description: For the specified channel return the difference between MK2 and MK1. The units will be the same 

as marker units.  

 Syntax: READ[1|2|3|4|5|6|7]:MARKer:RDELTa? 

 Returns: CC, (MK2-MK1) 

  Where CC is the measurement condition code. 

 Valid Modes: All 

 

 

READ:MARKer:RRATio? 
 

 Description: For the specified channel return the ratio of MK2 to MK1. The units will be dB for logarithmic 

units or percent for linear units..  

 Syntax: READ[1|2|3|4|5|6|7]:MARKer:RRATio? 

 Returns: CC,  MK2/MK1 

  Where CC is the measurement condition code. 

 Valid Modes: All 
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5.5.13  REFLine Subsystem 

The REFLine group of commands is used to configure and locate horizontal measurement lines (cursors) at specific levels on 

the display.  Reference lines can also be set to track waveform parameters and marker intersections. 

 

REFLine:ASSIgn 
 

 Description: Set or return the assignment of Reference Line 1 or  Reference Line 2 to a channel. 

 Syntax: REFLine:ASSIgn <asc> 

 Argument: <asc> = {OFF,  ACTIVE, CH1, CH2, TRIG1, TRIG2, MEM1, MEM2} 

 Valid Modes: Any.   

 

 

REFLine:POSItion:LEVel 
 

 Description: Set or return the vertical position (level) of Reference Line 1 or  Reference Line 2 in channel 

units.. 

 Syntax: REFLine[1|2]:POSItion:LEVel <asc> 

 Argument: <asc> = –99.00 to +99.00 dBm (typical for dBm units) 

 Valid Modes: Any.   

 

 

REFLine:POSItion:FORCetomk 
 

 Description: Force the position of Reference Line 1 and Reference Line 2 to the intersections, respectively, of  

Marker 1 and Marker 2 with the assigned channel‘s waveform. If either (or both) of the markers is 

assigned to a different channel or does not intersect the waveform, the corresponding reference 

line(s) will not be moved. If Reference Line Tracking is ―On‖, it will override this command.  

 Syntax: REFLine:POSItion:FORCetomk 

 Argument: None 

 Valid Modes: Any.   
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REFLine:TRACk 
 

 Description: Controls the automatic tracking of waveform parameters using reference lines. The reference lines 

must be assigned to the measurement channel of interest. For CHM, MEM1 and MEM2, only the 

marker tracking function X1X2 is available.    

 Syntax: REFLine:TRACk <asc> 

 Argument <asc> = {OFF, X1X2, TOPBOT, DISTMESIAL, DISTPROX} 

  OFF  No tracking. Reference lines have static positions 

  X1X2 Reference lines track the intersections, respectively, of  Marker 1 and Marker 2 

with the assigned channel‘s waveform. 

  TOPBOT Reference lines track the Top and Bottom level of the assigned channel‘s 

waveform. 

  DISTMESIAL Reference lines track the Distal and Mesial level of the assigned channel‘s 

waveform. 

  DISTPROX Reference lines track the Distal and Proximal level of the assigned channel‘s 

waveform 

  The terms Top Level, Bottom Level, Distal, Proximal and Mesial level are those set in the Pulse 

Definitions menu (or by GPIB command) and refer to the IEEE Definitions of Pulse parameters. 

  

 Valid Modes: Pulse mode.   
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5.5.14  SENSe Subsystem 

The purpose of the SENSe command subsystem is to directly configure device specific settings used to make measurements, 

generally parameters related to the RF power sensor and signal processing.  The SENSe commands are used to configure the 

power analyzer for acquiring data.  SENSe enables you to change measurement parameters such as filtering or averaging, 

sensor bandwidth, operating frequency and calfactors, and measurement gain or offset.  The numeric suffix of the SENSe 

program mnemonic in the SENSe commands refers to a hardware measurement ―channel‖, that is SENSe1 and SENSe2 

represent the instrument‘s SENSOR 1 and SENSOR 2 signal paths, respectively, while SENSe3 and SENSe4 represent the 

TRIGGER 1 and TRIGGER 2 signal paths respectively..  The SENSe commands generally DO NOT affect the data 

processing and display portion of the measurement (see the CALCulate subsystem, below).  Note that SENSe2 and SENSe4 

commands will generate an error if used with a single channel Model 4500B. 

 

SENSe:AVERage 
 

 Description: Set or return the number of traces averaged together to form the measurement result on the 

selected channel.  Can also be used to reduce display noise on both the visible trace, and on 

marker and automatic pulse measurements.  Trace averaging is a continuous process in which the 

measurement points from each sweep are weighted (multiplied) by a appropriate factor, and 

averaged into the existing trace data points.  In this way, the most recent data will always have the 

greatest effect on the trace shape, and older measurements will be decayed at a rate determined by 

the averaging setting and trigger rate. Note that for timebase settings of 500 ns/div and faster, the 

4500B acquires samples using a technique called equivalent time or interleaved sampling.  In this 

mode, not every pixel on the trace gets updated on each sweep, and the total number of sweeps 

needed to satisfy the AVERage setting will be increased by the sample interleave ratio of that 

particular timebase.   

 Syntax: SENSe[1|2|3|4]:AVERage <n> 

 Argument: <n> = Numeric value from 1 to 16,384 (1 = no trace averaging) 

 Valid Modes: Pulse 

 

 

SENSe:BANDwidth 

   
 Description: Set or return the sensor video bandwidth for the selected sensor or the trigger channel bandwidth if 

a trigger channel is selected.  HIGH is the normal setting for most measurements.  The actual 

bandwidth is determined by the peak sensor model used.  Use LOW bandwidth for additional 

noise reduction when measuring CW or signals with very low modulation bandwidth.  If LOW 

bandwidth is used on signals with fast modulation, measurement errors will result because the 

sensor cannot track the fast changing envelope of the signal. 

 Syntax: SENSe[1|2|3|4]:BANDwidth <asc> 

 Argument: <asc> = {LOW, HIGH} 

 Valid Modes: All 
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5.5.14.1  SENSe:CALTAB Data Array Commands 
 

The purpose of the SENS:CALTAB group of commands is to return the power calibration table (or ―caltable‖), which is the 

same size as the histogram (16,384 points), and contains the power level for each corresponding bin in the histogram.  The 

power values are not equally spaced, so it is necessary to know both the histogram and caltable arrays to compute statistical 

information about the input signal. 

 

SENSe:CALTAB:COUNt  
 

 Description: Set or return the number of cal table values to be returned as data by SENSe:CALTAB:DATA?    

 Syntax: SENSe[1|2]:CALTAB:COUNt <n>  

 Argument: <n> =  1 to 16,384 

 Valid Modes: All 

 

 

SENSe:CALTAB:DATA[:NEXT]?  
 

 Description: Return ―count‖ power values from the specified channel‘s cal table (if any) starting at ―index‖. 

Units are milliwatts without regard to the channel‘s units setting.   

 Syntax: SENSe[1|2]:CALTAB:DATA?    

 Argument: None, query only. 

 Valid Modes: All 

 

 

SENSe:CALTAB:INDEX  
 

 Description: Set or return the index of the first cal table value to be returned as data by 

SENSe:CALTAB:DATA?    

 Syntax: SENSe[1|2]:CALTAB:INDEX <n>  

 Argument: <n> =  0 to 16,383 

 Valid Modes: All 

 

 

SENSe:CORRection:CALFactor 
 

 Description: Set or return the frequency calfactor currently in use on the selected channel.  Note setting a 

calfactor with this command will override the ―automatic‖ frequency calfactor that was calculated 

and applied when the operating frequency was set, and setting the operating frequency will 

override this calfactor setting. 

 Syntax: SENSe[1|2]:CORRection:CALFactor <n> 

 Argument: <n> = -3.00 to 3.00 dB 

 Valid Modes: All  
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SENSe:CORRection:FDOFfset 
 

 Description: Set or return the name of the current frequency dependent offset table in use on the selected 

channel.  Two tables (TableA and TableB) are available, and each holds a list of up to 60 

frequencies and corresponding offset values.  See the MEMory:FDOFfset commands for entering 

these tables.  Whenever the operating frequency is changed with one of the tables active, a new 

frequency dependent offset value will be calculated and applied.  Setting the active table to OFF 

cancels any frequency dependent offset.  Frequency dependent offsets are used to compensate for 

external devices such as couplers or attenuators in the RF signal path that have know loss 

characteristics that vary with frequency.  

 Syntax: SENSe[1|2]:CORRection:FDOFfset <asc> 

 Argument: <asc> = {OFF, TBLA, TBLB} 

 Valid Modes: All  

 

 

SENSe:CORRection:FREQuency 
 

 Description: Set or return the RF frequency for the current sensor, and apply the appropriate frequency 

calfactor from the sensor‘s EEPROM table.  Application of this calfactor cancels out the effect of 

variations in the flatness of the sensor‘s frequency response.  If an explicit calfactor has been set, 

either manually or via the SENSe:CORRection:CALFactor command, entering a new frequency 

will override this calfactor and use only the ―automatic‖ frequency calfactor. 

 Syntax: SENSe[1|2]:CORRection:FREQuency <n> 

 Argument: <n> = 1e6 to 40.000e9 (actual sensor may have narrower range) 

 Valid Modes: All  

 

 

SENSe:CORRection:FRQTRK 
 

 Description: Set or return the state of  the frequency tracking function. When frequency tracking is ―On‖, any 

change to the frequency of channel 1 or channel 2 is automatically followed by the other. 

 Syntax: SENSe:CORRection:FRQTRK <asc> 

 Argument: <asc> = {ON, OFF} 

 Valid Modes: All  
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SENSe:CORRection:OFFSet 
 

 Description: Set or return a measurement offset in dB for the selected sensor.  This is used to compensate for 

external couplers, attenuators or amplifiers in the RF signal path ahead of the power sensor.   

 Syntax: SENSe[1|2]:CORRection:OFFSet <n> 

 Argument: <n> = -99.99 to +99.99 dB 

 Valid Modes: Any 

 

 

SENSe:CORRection:TEMPcomp 
 

 Description: Set or return the state of the peak sensor temperature compensation system.  This system 

compensates for drift that might otherwise be caused by changes in the temperature of the peak 

power sensors.  When set to OFF, a warning will be displayed if the sensor temperature drifts 

more than 4 degrees C from the autocal temperature.  When ON, the warning will not appear until 

temperature has drifted by 30C.  

 Syntax: SENSe[1|2]:CORRection:TEMPcomp <asc> 

 Argument: <asc> = {OFF, ON}  (defaults to ON when powered up, or when new sensor inserted) 

 Valid Modes: Peak Sensors Only 

  Note: Some older peak sensors may not have temperature compensation tables. In this case, the 

temperature compensation system is automatically turned off. 

 

 

SENSe:FILTer:STATe 
 

 Description: Set or return the current setting of the integration filter on the selected channel.  OFF provides no 

filtering, and can be used at high signal levels when absolute minimum settling time is required.  

ON allows a user-specified integration time, from 2 milliseconds to 15 seconds (see 

SENSe:FILTer:TIMe command).  Note that setting the filter time will force the state to ON.  

AUTO uses a variable amount of filtering, which is set automatically by the power analyzer based 

on the current signal level to a value that gives a good compromise between measurement noise 

and settling time at most levels. 

 Syntax: SENSe[1|2]:FILTer:STATe <asc> 

 Argument: <asc> = {OFF, ON, AUTO} 

 Valid Modes: Modulated  
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SENSe:FILTer:TIMe 
 

 Description: Set or return the current length of the integration filter on the selected channel.  If the filter state is 

set to AUTO, querying the time will return -0.01, and if set to OFF, a time query will return 0.00.  

Note that setting the filter time will force the state to ON. 

 Syntax: SENSe[1|2]:FILTer:TIMe <n> 

 Argument: <n> = 0.002 to 16.000 seconds in 2 millisecond increments 

 Valid Modes: Modulated  
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5.5.14.2  SENSe:HISTogram Data Array Commands 
 

The purpose of the SENS:HISTogram group of commands is to return a power or voltage distribution histogram array. The 

HISTogram commands return a histogram, which is an array of 16,384 ―bins‖, each one corresponding to a particular power 

level, and containing the number of samples that have occurred at that power level.   

 

SENSe:HISTogram:COUNt  
 

 Description: Set or return the number of  histogram bins to be returned as data by SENSe:HISTogram:DATA?    

 Syntax: SENSe[1|2|3|4|6|7]:HISTogram:COUNt <n>  

 Argument: <n> =  1 to 16,384 

 Valid Modes: All 

 

 

SENSe:HISTogram:DATA[:NEXT]? 

  
 Description: Return ―count‖ bin values from the specified channel‘s histogram starting at ―index‖. Bin values 

are 0 to 4,000,000,000. 

 Syntax: SENSe[1|2|3|4|6|7]:HISTogram:DATA[:NEXT]?    

 Argument: None, query only 

 Valid Modes: All 

 

 

SENSe:HISTogram:INDEX  
 

 Description: Set or return the index of the first histogram bin to be returned as data by SENSe:HIST:DATA?    

 Syntax: SENSe[1|2|3|4|6|7]:HISTogram:INDEX <n>  

 Argument: <n> =  0 to 16,383  (automatically post-incremented by count) 

 Valid Modes: All 



Boonton 4500B RF Peak Power Analyzer 

Remote Operation 5-72 

SENSe:IMPedance 
 

 Description: Set or return trigger channel impedance for the selected channel. In addition to changing the 

trigger channel input impedance, this can be used to calculate and display power from a voltage 

measurement.. 

 Syntax: SENSe[3|4]:IMPedance <n> 

 Argument: <n> = {1, 50}  ( 1 Megohm or 50 ohms )      

 Valid Modes: External trigger inputs only 

 

 

SENSe:NORMalize 
 

 Description: Set or return the state of distribution function normalization. When OFF, measured power (or 

voltage) is absolute; when ON, marker power (or voltage) is relative to CDF average power (or 

voltage). Marker units are dBr or percent.  Affects CH1, CH2, MEM1 and MEM2.  

 Syntax: SENSe:NORMalize <asc> 

 Argument: <asc> = {ON, OFF}   

 Valid Modes: Statistical 

 

 

SENSe:PULSe:DISTal 
 

 Description: Set or return the pulse amplitude percentage, which is used to define the end of a rising edge or 

beginning of a falling edge transition.  Typically, this is 90% voltage or 81% power relative to the 

―top level‖ of the pulse.  This setting is used when making automatic pulse risetime and falltime 

calculations returned by READ:ARRay:AMEASure:POWer. 

 Syntax: SENSe[1|2|3|4|6|7]:PULSe:DISTal <n> 

 Argument: <n> = 20.00 to 99.00 percent 

 Valid Modes: Pulse mode only 

 

 

SENSe:PULSe:ENDGT 
 

 Description: Set or return the point on a pulse, which is used to define the end of the pulse‘s ―active‖ interval.  

This point is defined in percent of the total pulse duration, with 0% corresponding to the midpoint 

of the rising edge, and 100% corresponding to the midpoint of the falling edge, as defined by the 

mesial setting.  For most pulse ―on‖ average power measurements, it is desirable to exclude the 

rising and falling intervals, and only measure power over the active portion of the pulse.  This is 

often known as time gating, and is used for the automatic pulse measurements returned by 

READ:ARRay:AMEASure:POWer. 

 Syntax: SENSe[1|2|3|4|6|7]:PULSe:ENDGT <n> 

 Argument: <n> = 60.00 to 100.00 percent 

 Valid Modes: Pulse mode only 
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SENSe:PULSe:MESIal 
 

 Description: Set or return the pulse amplitude percentage, which is used to define the midpoint of a rising or 

falling edge transition.  Typically, this is 50% voltage or 25% power relative to the ―top level‖ of 

the pulse.  This setting is used when making automatic pulse width and duty cycle calculations 

returned by FETCh:ARRay:AMEASure:POWer. 

 Syntax: SENSe[1|2|3|4|6|7]:PULSe:MESIal <n> 

 Argument: <n> = 10.00 to 90.00 percent 

 Valid Modes: Pulse mode only 

 

 

SENSe:PULSe:PROXimal 
 

 Description: Set or return the pulse amplitude percentage, which is used to define the beginning of a rising edge 

or end of a falling edge transition.  Typically, this is 10% voltage or 1% power relative to the ―top 

level‖ of the pulse.  This setting is used when making automatic pulse risetime and falltime 

calculations returned by FETCh:ARRay:AMEASure:POWer. 

 Syntax: SENSe[1|2|3|4|6|7]:PULSe:PROXimal <n> 

 Argument: <n> = 0.10 to 30.00 percent 

 Valid Modes: Pulse mode only 

 

 

SENSe:PULSe:STARTGT 
 

 Description: Set or return the point on a pulse, which is used to define the beginning of the pulse‘s ―active‖ 

interval.  This point is defined in percent of the total pulse duration, with 0% corresponding to the 

midpoint of the rising edge, and 100% corresponding to the midpoint of the falling edge, as 

defined by the mesial setting.  For most pulse ―on‖ average power measurements, it is desirable to 

exclude the rising and falling intervals, and only measure power over the active portion of the 

pulse.  This is often known as time gating, and is used for the automatic pulse measurements 

returned by FETCh:ARRay:AMEASure:POWer. 

 Syntax: SENSe[1|2|3|4|6|7]:PULSe:STARTGT <n> 

 Argument: <n> = 0.00 to 40.00 percent 

 Valid Modes: Pulse mode only 
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SENSe:PULSe:UNIT  
 

 Description: Set or return the units for entering the pulse distal, mesial and proximal levels.  If the function is 

set to VOLTS, the pulse transition levels will be defined as the specified percentage in voltage.  If 

set to WATTS, the levels are defined in percent power.  Many pulse measurements call for 10% to 

90% voltage (which equates to 1% to 81% power) for risetime and falltime measurements, and 

measure pulse widths from the half-power (-3dB, 50% power, or 71% voltage) points. 

 Syntax: SENSe[1|2|6|7]:PULSe:UNIT <asc>  

 Argument: <asc> = {WATTS, VOLTS} , see Restrictions below. 

 Valid Modes: Pulse mode only 

 Restrictions: For MEM1 and MEM2, if the waveform source is TRIG1 or TRIG2, units must be VOLTS.          

  

 

SENSe:RANGe  
 

 Description: Set or return the external trigger input full scale sensitivity in  volts. 

 Syntax: SENSe[3|4]:RANGe <asc>  

 Argument: <asc> = {5, 50} 

5 5 volts max, 1 v/div  

50  50 volts max, 10 v/div 

 Valid Modes: Pulse mode only 
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5.5.15  STATus Commands 

The STATus command subsystem enables you to control the SCPI defined status reporting structures.  The user may 

examine the status of the power analyzer by monitoring the Operation Status Register and Questionable Status Register  

Note that GPIB commands may be used to monitor device registers (See GPIB - IEEE-488.2 Commands). 

 

 

STATus:OPERation:CONDition? 
 

 Description: Return the current value (unlatched condition) of the SCPI Operation Status register.   The 

following table shows the bit assignments in the register: 

 Bit Value Definition 

 0 1 Calibrating 1 = sensor or trigger calibration in progress. 

 1 - 2 -- Not used always returns 0. 

 3 8 Trigger Status 1 = waiting for a trigger signal. 

 4 16 Measuring 1 = measurement in progress. 

 5 - 15 -- Not used always returns 0 

   
 
 Syntax: STATus:OPERation:CONDition? 

 Returns: 16-bit register value (0 to 32767) 

 Valid Modes: Any 

 

 

STATus:OPERation:ENABle 
 

 Description: Sets or returns the enable mask which allows true conditions in the Operation Status Event register 

to be reported in the summary bit. If a bit is 1 in the Operation Enable register and its associated 

event bit transitions to true, a positive transition will occur in the Operation Status summary bit. 

 

 Syntax: STATus:OPERation:ENABle <n> 

 Argument: <n> = 0 to 32767 

 Valid Modes: Any 
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STATus:OPERation:EVENt? 
 

 Description: This query returns the contents of the Operation Event register.  

 Syntax: STATus:OPERation:EVENt? 

 Returns: 16-bit register value (0 to 32767) 

 Valid Modes: Any 

 

 

STATus:OPERation:NTRansition 
 

 Description: Sets the negative transition filter. Setting a bit in the negative transition filter causes a 1 to 0  

transition in the corresponding bit of the Operation Status register to cause a 1 to be written in the 

associated bit of the Operation Event register. 

 

 Syntax: STATus:OPERation:NTRansition <arg> 

 Argument:  <arg> = 0 to 32767 

 Returns: 16-bit register value (0 to 32767) 

Valid Modes: Any 

 

 

STATus:OPERation:PTRansition 

 
Description: Sets the positive transition filter. Setting a bit in the positive transition filter causes a 0 to 1  

transition in the corresponding bit of the Operation Status register to cause a 1 to be written in the 

associated bit of the Operation Event register. 

 

 Syntax: STATus:OPERation:PTRansition <arg> 

 Argument:  <arg> = 0 to 32767 

 Returns: 16-bit register value (0 to 32767) 

Valid Modes: Any 

 

 

STATus:PRESet 
 

 Description: Sets device dependent SCPI registers to default states.  The Operational Enable and Questionable 

Enable mask registers are both cleared so an SRQ will not be generated for these conditions, and 

the error queue is cleared. 

 Syntax: STATus:PRESet 

 Argument: None 

 Valid Modes: Any 
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STATus:QUEStionable:CONDition? 
 

 Description: Return the current value (condition) of the SCPI Questionable Status register.   The following 

table shows the bit assignments in the register: 

 Bit Value Definition 

 0 1 Voltage 1 = an internal power supply voltage is out of spec. 

 1 –3 -- Not used always 0. 

 4 16 Temperature 1 = sensor temperature drift (see note below). 

 5 - 12 -- Not used always 0. 

 8 256 Calibration 1 = sensor requires calibration and/or zeroing 

 9 - 15 -- Not used always 0. 

  

Note: For temperature compensated sensors with Temp Comp 

―On‖, warning occurs for greater than ±30 degrees C from 

auto-cal temperature. For non-compensated sensors or Temp 

Comp ―Off‖, warning occurs for greater than ±4 degrees C. 

 

 Syntax: STATus:QUEStionable:CONDition? 

 Returns: 16-bit register value (0 to 32767) 

 Valid Modes: Any 

 

 

STATus:QUEStionable:ENABle 

 
Description: Sets or returns the enable mask which allows true conditions in the Questionable Status Event 

register to be reported in the summary bit. If a bit is 1 in the Questionable Enable register and its 

associated event bit transitions to true, a positive transition will occur in the Questionable Status  

summary bit. 
 

 Syntax: STATus:QUEStionable:ENABle <n> 

 Argument: <n> = 0 to 32767 

 Valid Modes: Any 

 

 

STATus:QUEStionable:EVENt? 
 

 Description: This query returns the contents of the Questionable Event register.  

 Syntax: STATus:QUEStionable:EVENt? 

 Returns: 16-bit register value (0 to 32767) 

 Valid Modes: Any 
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STATus:QUEStionable:NTRansition 
 

Description: Sets the negative transition filter. Setting a bit in the negative transition filter causes a 1 to 0 

transition in the corresponding bit of the Questionable Status register to cause a 1 to be written in 

the associated bit of the Questionable Event register. 

 

 Syntax: STATus:QUEStionable:NTRansition <arg> 

 Argument:  <arg> = 0 to 32767 

 Returns: 16-bit register value (0 to 32767) 

Valid Modes: Any 

 

 

STATus:QUEStionable:PTRansition 
 

Description: Sets the positive transition filter. Setting a bit in the positive transition filter causes a 0 to 1 

transition in the corresponding bit of the Questionable Status register to cause a 1 to be written in  

the associated bit of the Questionable Event register. 

   

 Syntax: STATus:QUEStionable:PTRansition <arg> 

 Argument:  <arg> = 0 to 32767 

 Returns: 16-bit register value (0 to 32767) 

Valid Modes: Any 
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5.5.16  SYSTem Subsystem 

The SYSTem group of commands is used to control system-level functions not directly related to instrument measurement 

performance.  SYSTem commands are used to return error codes or messages from the power analyzer error queue, control 

hardware features (backlight and key beep), set the command language, and configure communication parameters for the 

GPIB and serial interfaces. 

 

 

SYSTem:AUTOSET 
 

 Description: Perform the Auto Setup function to acquire a signal and display the trace in the Pulse mode. 

 Syntax: SYSTem:AUTOSET 

 Argument:  None 

 Valid Modes: Pulse mode is forced if not already set. 

 

 

SYSTem:BEEP 

   
 Description: Set or return the status of the audible keyboard beeper.  

 Syntax: SYSTem:BEEP <asc> 

    Argument: <asc> = {ON, OFF} 

 Valid Modes: Pulse mode is forced if not already set. 

 

 

SYSTem:COMMunicate:GPIB:EOI  

  
 Description: Set or return the 4500B as TALKER EOI control parameter.  

 Syntax: SYSTem:COMMunicate:GPIB:EOI  <asc> 

 Argument: <asc> = {ON, OFF} 

 Valid Modes: Any 
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SYSTem:COMMunicate:GPIB:LISTen 
 

 Description: Set or return the 4500B as LISTENER line termination parameter. EOIONLY is the default and 

the preferred setting. The 4500B always responds to EOI when listening.  When EOI is not in use 

or not available from the bus controller, select the CR or LF character for the end of string (EOS) 

indicator and set the controller to send the same character as the EOS. If this is not done, GPIB 

communication will not be possible.  

 Syntax: SYSTem:COMMunicate:GPIB:LISTen <asc> 

 Argument: <asc> = {EOIONLY, CR, LF} 

 Valid Modes: Any 

 

 

SYSTem:COMMunicate:GPIB:TALK 
 

 Description: Set or return the 4500B as TALKER line termination parameter. EOIONLY is the default and the 

preferred setting. The 4500B always sends EOI when talking.  When the bus controller does not or 

cannot respond to EOI, select the CR, LF or CRLF character(s) for the end of string (EOS) 

indicator and set the controller to accept the same character(s) as the EOS. If this is not done, 

GPIB communication will not be possible.  

 Syntax: SYSTem:COMMunicate:GPIB:TALK <asc> 

 Argument: <asc> = {EOIONLY, CR, LF, CRLF} 

 Valid Modes: Any 

 

 

SYSTem:COMMunicate:LOGGing  

  
 Description: Set or return the status of  GPIB command logging. Logging saves to a file all GPIB messages 

received and sent for review.   

 Syntax: SYSTem:COMMunicate:LOGGing <asc> 

 Argument: <asc> = {ON, OFF} 

 Valid Modes: Any 

 

 

SYSTem:COMMunicate:SERial:BAUD 
 

 Description: Set or return the Baud rate of the 4500B RS232 port (COM1).  

 Syntax: SYSTem:COMMunicate:SERial:BAUD <n> 

 Argument: <n> = 1200, 2400, 4800, 9600, 19200, 38400 

 Valid Modes: Any 
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SYSTem:COMMunicate:SERial:BITS 
 

 Description: Set or return the number of serial bits per byte.  

 Syntax: SYSTem:COMMunicate:SERial:BITS <n> 

 Argument: <n> = 7, 8 

 Valid Modes: Any 

 

 

SYSTem:COMMunicate:SERial:CTRL:RTS 

 
 Description: Set or return the serial handshake control mode. 

 Syntax: SYSTem:COMMunicate:SERial:CTRL:RTS <asc> 

 Argument: <asc> =  NONE, RTS, CTS, RTS&CTS 

 Valid Modes: Any 

 

 

SYSTem:COMMunicate:SERial:PARity 
 

 Description: Set or return the condition for setting the serial parity bit.  

 Syntax: SYSTem:COMMunicate:SERial:PARity <asc> 

 Argument: <asc> = NONE, ODD, EVEN 

 Valid Modes: Any 

 

 

SYSTem:COMMunicate:SERial:SBITs 
 

 Description: Set or return the number of serial stop bits per byte.  

 Syntax: SYSTem:COMMunicate:SERial:SBITs <n> 

 Argument: <n> = 1, 2 

 Valid Modes: Any 

 

 

SYSTem:COMMunicate:SERial:XON 
 

 Description: Set or return the state of character based handshake control for the serial port. 

 Syntax: SYSTem:COMMunicate:SERial:XON <asc> 

 Argument: <asc> =  OFF, ON 

 Valid Modes: Any 



Boonton 4500B RF Peak Power Analyzer 

Remote Operation 5-83 

SYSTem:DATE:DAY 
 

 Description: Set or return the day of the month of the real time clock. 

 Syntax: SYSTem:DATE:DAY <n> 

 Argument: <n> =  1 through 31   

 Valid Modes: Any 

 

 

SYSTem:DATE:MONTH 
 

 Description: Set or return the month of the real time clock. 

 Syntax: SYSTem:DATE:MONTH <n> 

 Argument: <n> =  1 through 12   

 Valid Modes: Any 

 

 

SYSTem:DATE:WEEKday? 
 

 Description: Return only the day of the week from the real time clock.  

 Syntax: SYSTem:DATE:WEEKday? 

 Returns: 1 thru 7, where 1 = Sunday … 7 = Saturday. 

 Valid Modes: Any 

 

 

SYSTem:DATE:YEAR 
 

 Description: Set or return the year of the real time clock. 

 Syntax: SYSTem:DATE:YEAR <n> 

 Argument: <n> =  2005 …   

 Valid Modes: Any 

 

SYSTem:DISPlay:BMP? 
 

 Description: Returns the 640 x 480 pixel display image in .BMP file format. 

 Syntax: SYSTem:DISPlay:BMP?  

 Returns: Binary data in IEEE488.2 definite length format   

 Valid Modes: Any 
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SYSTem:ERRor[:NEXT]? 
 

 Description: Returns the next queued error code number followed by a quoted ASCII text string describing the 

error.  Note that errors are stored in a ―first-in-first-out‖ queue, so if more than one error has 

occurred, repeating this command will report the errors in the sequence they happened. The action 

of reading an error will clear that error, so once the most recent error has been read, any more 

queries will report a code of zero, and ―No Error‖. See Appendix A for a more detailed description 

of the error codes that may be returned. 

 Syntax: SYSTem:ERRor[:NEXT]? 

 Returns: <numeric error code>, ―QUOTED ERROR DESCRIPTION‖ 

 Valid Modes: Any 

 

 

SYSTem:ERRor:CODE? 
 

 Description: Returns the next queued error code number. Note that errors are stored in a ―first-in-first-out‖ 

queue, so if more than one error has occurred, repeating this command will report the error codes 

in the sequence they happened. The action of reading an error will clear that error, so once the 

most recent error has been read, any more queries will report a code of zero. See Appendix A for a 

more detailed description of the error codes that may be returned. 

 Syntax: SYSTem:ERRor:CODE? 

 Returns: <numeric error code> 

 Valid Modes: Any 

 

 

SYSTem:LANGuage 
 

 Description: Set or return the remote interface language SCPI (SCPI compliant), or the emulation mode 

language EMUL4500A. The instrument powers up in the state set by the Util > Remote Conf > 

GPIB > Emulate4500A menu.  Activating the 4500A language extension will enable the 4500B to 

emulate the 4500A using its native language.  SCPI and the 4500A emulation language are 

incompatible. Use care when changing languages to avoid unexpected results. It is strongly 

recommended that any language change command be placed on a separate line. If this is not 

practical, it must be placed at the end of a line. DO NOT follow a language command with another 

command on the same line!   

 Syntax: SYSTem:LANGuage <asc> 

 Argument: <asc> = {SCPI, EMUL4500A} 

 Valid Modes: Any 
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SYSTem:PRESet 

 
 Description: Set 4500B default parameters. Equivalent to pressing the front panel INIT key. See Table 3-3, 

Initialized Parameters, for a list of the default values for each parameter. 

 Syntax: SYSTem:PRESet 

 Argument: None 

 Valid Modes: Any 

 

 

SYSTem:TIMe:HOUR 
 

 Description: Set or return  the hour of  the real time clock.  

 Syntax: SYSTem:TIMe:HOUR <n> 

 Argument: <n> = 0 though 23 

 Valid Modes: Any 

 

 

SYSTem:TIMe:MINUTE 
 

 Description: Set or return  the minute of  the real time clock. On entry, resets seconds to :00. 

 Syntax: SYSTem:TIMe:MINUTE <n> 

 Argument: <n> = 0 though 59 

 Valid Modes: Any 

 

 

SYSTem:VERSion 
 

 Description: Return the SCPI version compliance claimed.  

 Syntax: SYSTem:VERSion? 

 Returns: Version Code as <year.version> YYYY.V (will return 1990.0) 

 Valid Modes: Any 
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5.5.17 TRACe Data Array Commands 

The TRACe group of commands is used to control the output of acquired measurement arrays, which appear as a display 

trace when the power analyzer is in Graph mode.  The TRACe commands allow outputting a channel‘s entire trace (501 

measurement points) as one large array, or selecting and returning the array in smaller portions.  These commands are useful 

for capturing the displayed waveform and importing it into a database on the host. 

 

 

TRACe:AVERage:DATA[:NEXT]? 
 

 Description: Return a comma-delimited array of power or voltage pixel average values corresponding to all or a 

portion of the graph mode display trace for the selected channel.  Note that graph mode does not 

have to be active to read the trace, and the pixel values are returned without regard to display 

vertical scale and center settings.  The array will consist of COUNT trace pixel values, beginning 

at pixel number INDEX, up to the last pixel of the trace (index = 500), and will be returned in 

channel units. The selected channel must be ―ON‖ to return measurement data.  

 Syntax: TRACe[1|2|3|4|5|6|7]:AVERage:DATA? 

 Returns: P(index), P(index+1), P(index+2)....  P(index+count) or 

  V(index), V(index+1), V(index+2)....  V(index+count) 

 Valid Modes: All 

 

 

TRACe:AVERage:DATA:BINary? 
 

 Description: Returns IEEE488.2 binary block data values corresponding to all or a portion of the graph mode 

display trace for the selected channel.  Note that graph mode does not have to be active to read the 

trace, and the values are returned without regard to display vertical scale and center settings.  The 

data will be returned in channel units. The selected channel must be ―ON‖ to return measurement 

data. The array will consist of COUNT binary data values.  The format is as follows:  

  # is the first byte, the second byte is the number of characters indicating the size of the array to be 

read in bytes followed by that many bytes of floating point values. 

 Syntax: TRACe[1|2|3|4|5|6|7]:AVERage:DATA:BINary? 

 Returns: IEEE format 32 bit floating point values  

 Valid Modes: All 

 
 
TRACe:COUNt 
 

 Description: Set or return the number of trace points, which will be returned each time the TRACe:DATA? 

query is issued.  At the completion of each read, INDEX is automatically incremented by 

COUNT.  If COUNT is set to a number greater than the number of points remaining in the trace, 

the array will be truncated.  Setting COUNT to 501 (and INDEX to zero each time) will return the 

entire trace array. 

 Syntax: TRACe[1|2|3|4|5|6|7]:COUNt <n> 

 Argument: <n> = 1 to 501 

 Valid Modes: All 
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TRACe:DELImiter 
 

 Description: Set or return the ASCII data delimiter used to separate each data element in a trace array.  

 Syntax: TRACe:DELImiter <asc> 

 Argument: <asc> = {COMMA, CR, LF, SPACE} 

 Valid Modes: All 



Boonton 4500B RF Peak Power Analyzer 

Remote Operation 5-88 

TRACe:INDEX 
 

 Description: Set or return the array index for the first trace point to be returned next time the TRACe:DATA? 

query is issued.  Index 0 is the start of the trace buffer, and corresponds to the leftmost pixel on the 

graph display.  Index 500 is the last point, and is the rightmost pixel.  Each time a block of data is 

read, INDEX is automatically incremented by the COUNT value, so the full array can be split up 

into blocks of manageable size and read with successive TRACe:DATA? queries.  INDEX must 

be reset to zero for each new trace that is to be dumped, whether or not all the points have been 

read. 

 Syntax: TRACe[1|2|3|4|5|6|7]:INDEX <n> 

 Argument: <n> = 0 to 500 

 Valid Modes: All 

 

 

TRACe:MAXimum:DATA? 
 

 Description: Return a comma-delimited array of power or voltage maximum values corresponding to all or a 

portion of the graph mode display trace for the selected channel.  Note that graph mode does not 

have to be active to read the trace, and the maximum values are returned without regard to display 

vertical scale and center settings.  The array will consist of COUNT trace pixel maximum values, 

beginning at pixel number INDEX, up to the last pixel of the trace (index = 500), and will be 

returned in channel units. Maximum data is not available from the Math Channel (CHM). The 

selected channel must be ―ON‖ to return measurement data.  

 

 Syntax: TRACe[1|2|3|4|6|7]:MAXimum:DATA? 

 Returns: PMAX(index), PMAX(index+1), PMAX(index+2)....  PMAX(index+count) or 

  VMAX(index), VMAX(index+1), VMAX(index+2)....  VMAX(index+count) 

 Valid Modes: Modulated and Pulse. 

 

 

TRACe:MINimum:DATA? 
 

 Description: Return a comma-delimited array of power or voltage minimum values corresponding to all or a 

portion of the graph mode display trace for the selected channel.  Note that graph mode does not 

have to be active to read the trace, and the minimum values are returned without regard to display 

vertical scale and center settings.  The array will consist of COUNT trace pixel minimum values, 

beginning at pixel number INDEX, up to the last pixel of the trace (index = 500), and will be 

returned in channel units. Minimum data is not available from the Math Channel (CHM). The 

selected channel must be ―ON‖ to return measurement data.  

 Syntax: TRACe[1|2|3|4|6|7]:MINimum:DATA?  

 Returns: PMIN(index), PMIN(index+1), PMIN(index+2)....  PMIN(index+count) or 

  VMIN(index), VMIN(index+1), VMIN(index+2)....  VMIN(index+count) 

 Valid Modes: Modulated and Pulse. 
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TRACe:SEND 

 
 Description: Send the trace data for the source selected by TRACe:SOURce to the file specified by the 

argument string. The string must contain the entire path, a filename without an extension, and be 

enclosed in quotes. The application will append the .TXT extension automatically. The data 

delimiter is set by TRAce:DELImiter. If a folder specified in the path does not exist, the error 

―Folder Not Found‖ will be set.  If the file already exists, it can only be overwritten if the 

command MEMory:OVERwrite ON has been issued; otherwise, the ―File Already Exists‖ error 

message will be set.  

 Syntax: TRACe:SEND <asc> 

 Argument: <asc> = ―<drive>:\<path>\<filename>‖   e.g. ―C:\4500B\usr\dat\trace01‖ 

  Note: The internal hard drive is always C: The operating system will assign D:, E:, etc. to USB 

drives and other external drives.  

 Valid Modes: All 

 

 

TRACe:SOURce 
 

 Description: Set or return the source of a trace array or histogram array (Statistical mode only).  

 Syntax: TRACe:SOURce <asc> 

 Argument: <asc> = CH1, CH2, TRIG1, TRIG2, CHM, MEM1, MEM2, CAL1, CAL2, HIST1, HIST2  

 Valid Modes: All 
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5.5.18  TRIGger Subsystem 

The TRIGger group of commands is used to control synchronization of data acquisition with external events.  TRIGger 

commands generally affect only the Pulse mode and the gated Statistical mode. 

 

TRIGger:BTRIGger:ECOUNT 
 

 Description: Set or return the B trigger event count. The event count is used when  the B trigger is in the delay 

by events mode, TRIGger:BTRIGger:MODE is set to EDLY. 

 Syntax: TRIGger:BTRIGger:ECOUNT <n> 

 Argument: <n> = 1 to 999,999 

 Valid Modes: Pulse and gated Statistical modes only 

 

 

TRIGger:BTRIGger:LEVel 
 

 Description: Set or return the B trigger level for synchronizing data acquisition with a pulsed input signal or 

external trigger pulses.  The internal trigger level entered should include any global offset and will 

also be affected by the frequency Cal-factor. The available internal trigger level range is sensor 

dependent. For internal trigger, the trigger level is set and returned in channel units. The external 

trigger has two ranges, 5 and 50 volts.  Note that there is a small amount of hysteresis built into 

the trigger system, and the signal should have at least one dB greater swing in each direction past 

the internal trigger level setting, and somewhat more at low levels. The B Trigger is not active if 

TRIGger:BTRIGger:MODE is set to OFF. 

 Syntax: TRIGger:BTRIGger:LEVel <n> 

 Argument: <n> = -39.9 to +20 dBm (plus offset, if any)   (internal trigger) 

  <n> = 5.0 volts or 50 volts (external trigger) 

 Valid Modes: Pulse and gated Statistical modes only 

 

 

TRIGger:BTRIGger:MODE 
 

 Description: Set or return the B trigger mode for the delayed trigger function with pulsed signals. When set to 

OFF, the delayed B trigger is inactive. When set to TDLY, the B trigger is delayed in time from 

the main or A trigger.  The delay time is set by  the TRIGger:BTRIGger:TDLY command.  When 

set to EDLY, the B trigger is delayed by a number of trigger events starting at the A trigger time. 

The number of events to delay is set by the  TRIGger:BTRIGger:ECOUNT command.  

 Syntax: TRIGger:BTRIGger:MODE <asc> 

 Argument: <asc> = {OFF, TDLY, EDLY} 

 Valid Modes: Pulse and gated Statistical modes only 
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TRIGger:BTRIGger:SLOPe 
 

 Description: Set or return the B trigger slope or polarity.  When set to POS, B triggers will be generated when a 

signal‘s rising edge crosses the B trigger level threshold.  When NEG, B triggers are generated on 

the falling edge of the pulse. 

 Syntax: TRIGger:BTRIGger:SLOPe <asc> 

 Argument: <asc> = {NEG, POS} 

 Valid Modes: Pulse and gated Statistical modes only 

 

 

TRIGger:BTRIGger:SOURce 
 

 Description: Set or return the trigger source used for the B trigger. The  CH1 and CH2 (dual channel models 

only)  settings use the signal from the associated sensor.  TRIG1 and TRIG2 (dual channel models 

only) use the signal applied to the associated external trigger input.  

 Syntax: TRIGger:BTRIGger:SOURce <asc> 

 Argument: <asc> = {CH1, CH2, TRIG1, TRIG2} 

 Valid Modes: Pulse and gated Statistical modes only 

 

 

TRIGger:BTRIGger:TDLY 
 

 Description: Set or return the B trigger arming delay time in seconds with respect to the trigger. Active only 

when TRIGger:BTRIGger:MODE is set to TDLY.  

 Syntax: TRIGger:BTRIGger:DELay <n> 

 Argument:  <n> = 0.0 – 1.0 seconds in 10 nsec increments 

 Valid Modes: Pulse and gated Statistical modes only 
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TRIGger:CDF:COUNt 
 

 Description: Set or return the terminal count (sample population size) in millions of samples for statistical 

mode acquisition.  When the terminal count is reached, the CDF, CCDF or PDF is considered 

―complete‖, and the instrument will halt acquisition if INITiate:CONTinuous is set to OFF.  If 

INITiate:CONTinuous is ON, sample acquisition will continue in the manner specified by the 

TRIGger:CDF:DECImate setting. 

 Syntax: TRIGger:CDF:COUNt <n> 

 Argument: <n> = 2 to 4096 million samples 

 Valid Modes: Statistical mode only. 

 

 

TRIGger:CDF:DECImate 
 

 Description: Set or return the decimation status when running continuously in statistical mode.  This action 

occurs when the terminal count is reached (as defined by TRIGger:CDF:COUNt) or the terminal 

running time is reached (as defined by TRIGger:CDF:TIMe). When set to OFF, the CDF, CCDF 

or PDF will clear all data and restart.  If set to ON, the entire sample population will be decimated 

(divided by two), and new samples will continue to accumulate into the same histogram.  

Decimating has the effect of maintaining the ―shape‖ of the statistical result while slowly decaying 

away the effect of past history and updating to include new events.  This setting works best with 

relatively small terminal counts (1 to 10 million counts) and short running times (a few seconds). 

 Syntax: TRIGger:CDF:DECImate <asc> 

 Argument: <asc> = {OFF, ON} 

 Valid Modes: Statistical mode only. 

 

 

TRIGger:CDF:TIMe 
 

 Description: Set or return the terminal running time in seconds for statistical mode acquisition.  When the 

terminal time is reached, the CDF, CCDF or PDF is considered ―complete‖, and the instrument 

will halt acquisition if INITiate:CONTinuous is set to OFF.  If INITiate:CONTinuous is ON, 

sample acquisition will continue in the manner specified by the TRIGger:CDF:DECImate 

setting. 

 Syntax: TRIGger:CDF:TIMe <n> 

 Argument: <n> = 0 to 3600 seconds 

 Valid Modes: Statistical mode only. 
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TRIGger:DELay 
 

 Description: Set or return the trigger delay time in seconds with respect to the trigger.  Positive values cause the 

actual trigger to occur after the trigger condition is met.  This places the trigger event to the left of 

the trigger point on the display, and is useful for viewing events during a pulse, some fixed delay 

time after the rising edge trigger.  Negative trigger delay places the trigger event to the right of the 

trigger point on the display, and is useful for looking at events before the trigger edge.   

 Syntax: TRIGger:DELay <n> 

 Argument:       Timebase    Trigger Delay  <arg> 

  5 nsec/div to 500 nsec/div  -4 msec to +100 msec  

  1 usec/div to 10 msec/div  4000 divisions   

  20 msec/div to 3600 sec/div -40 to +100 sec 

 Valid Modes: Pulse and gated Statistical modes only 

  

 

 

TRIGger:FASTtrig 
 

 Description: Set or return the Fast Trigger mode status. 

 Syntax: TRIGger:FASTtrig <asc> 

 Argument: <asc> = {OFF, ON} 

 Valid Modes: Pulse and gated Statistical modes only 

 

 

TRIGger:HOLDoff 
 

 Description: Set or return the trigger holdoff time in seconds.  Trigger holdoff is used to disable the trigger for 

a specified amount of time after each trigger event.  The holdoff time starts immediately after each 

valid trigger edge, and will not permit any new triggers until the time has expired.  When the 

holdoff time is up, the trigger re-arms, and the next valid trigger event (edge) will cause a new 

sweep.  This feature is used to help synchronize the power analyzer with burst waveforms such as 

a TDMA or GSM frame.  The trigger holdoff resolution is 10 nanoseconds, and it should be set to 

a time that is just slightly shorter than the frame repetition interval. 

 Syntax: TRIGger:HOLDoff <n> 

 Argument: <n> =  0 to 1.00000000 seconds in 10 nsec increments, 0.0 = no holdoff     

 Valid Modes: Pulse and gated Statistical modes only 
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TRIGger:LEVel 
 

 Description: Set or return the trigger level for synchronizing data acquisition with a pulsed input signal or 

external trigger pulses.  The internal trigger level entered should include any global offset and will 

also be affected by the frequency Cal-factor. The available internal trigger level range is sensor 

dependent. For internal trigger, the trigger level is set and returned in channel units. The external 

trigger has two ranges, 5 and 50 volts.  Note that there is a small amount of hysteresis built into 

the trigger system, and the signal should have at least one dB greater swing in each direction past 

the trigger level setting, and somewhat more at low levels.  Note that explicitly setting the trigger 

level while TRIGger:MODE is set to AUTOPKPK will cancel the AUTOPKPK setting, and force 

the trigger mode back to AUTO. In AUTOPKPK the Trigger Level menu will display ―AUTO 

LEVEL‖.  

 Syntax: TRIGger:LEVel <n> 

 Argument: <n> = -39.9 to +20 dBm (plus offset, if any)   (internal trigger) 

  <n> = 5.0 volts or 50 volts (external trigger) 

 Valid Modes: Pulse, Statistical (gated) and Modulated (triggered) modes only 

 

 

TRIGger:MODE 
 

 Description: Set or return the trigger mode for synchronizing data acquisition with pulsed signals.  NORM 

mode will cause a sweep to be triggered each time the power level crosses the preset trigger level 

in the direction specified by TRIGger:SLOPe.  If there are no edges that cross this level, no data 

acquisition will occur.  AUTO mode operates in much the same way as NORM mode, but will 

automatically generate a trace if no trigger edges are detected for a period of time (100 to 500 

milliseconds, depending on timebase).  This will keep the trace updating even if the pulse edges 

stop.  The AUTOPKPK mode operates the same as AUTO mode, but will adjust the trigger level 

to halfway between the highest and lowest power or voltage levels detected.  This aids in 

maintaining synchronization with a pulse signal of varying level.  Note that a setting of PKTOPK 

will be overridden and forced back to AUTO if a TRIGger:LEVel is set. The FREERUN mode 

force traces at a high rate to assist in locating the signal. 

 Syntax: TRIGger:MODE <asc> 

 Argument: <asc> = {AUTO,  AUTOPKPK, NORMAL, FREERUN} 

 Valid Modes: Pulse and gated Statistical modes only 

 

 

TRIGger:MODUlated:MODE 
 

 Description: Set or return the trigger mode for Modulated signals. The normal mode is FREERUN, which 

results in continuous data acquisition. The TRIGGERED mode is used to start data acquisition 

when the trigger level and slope conditions are met. After a single start event, data is acquired 

continuously until stopped.  

 Syntax: TRIGger:MODUlated:MODE <asc> 

 Argument: <asc> = {FREERUN, TRIGGERED} 

Valid Modes: Modulated mode only.  
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TRIGger:POSition 
 

 Description: Set or return the position of the trigger event on displayed sweep.  Assuming zero trigger delay, 

setting the position to LEFT causes the entire trace to be post-trigger.  Setting it to RIGHT causes 

the entire trace to be pre-trigger.  And setting to MIDDLE will display both the pre- and post-

trigger portions of the trace.  Note that the TRIGger:DELay setting is in addition to this setting, 

and will cause the trigger position to appear in a different location. 

 Syntax: TRIGger:POSition <asc> 

 Argument: <asc> = {LEFT, MIDDLE, RIGHT} 

 Valid Modes: Pulse and gated Statistical modes only 

 

 

TRIGger:SLOPe 
 

 Description: Set or return the trigger slope or polarity.  When set to POS, triggers will be generated when a 

signal‘s rising edge crosses the trigger level threshold.  When NEG, triggers are generated on the 

falling edge of the pulse. 

 Syntax: TRIGger:SLOPe <asc> 

 Argument: <asc> = {NEG, POS} 

 Valid Modes: Pulse, Statistical (gated) and Modulated (triggered) modes only 

 

 

TRIGger:SOURce  
 

 Description: Set or return the trigger source used for synchronizing data acquisition. The  CH1 and CH2 (dual 

channel models only)  settings use the signal from the associated sensor.  TRIG1 and TRIG2 (dual 

channel models only) use the signal applied to the associated external trigger input.  

 Syntax: TRIGger:SOURce <asc> 

 Argument: <asc> = {CH1, CH2, TRIG1, TRIG2} 

 Valid Modes: Pulse, Statistical (gated) and Modulated (triggered) modes only 
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TRIGger:STATistical:GATE 
 

 Description: Set or return the marker locations in time relative to the trigger that define the time gate for gated 

statistical measurements. These two gate markers function in the same manner as time markers in 

the Pulse mode. See MARKer:POSItion[1|2]:TIMe <n> for more information. 

 Syntax: TRIGger:STATistical:GATE[1|2] <n> 

 Argument: <n> =  display-time in seconds (see restrictions) 

 Valid Modes: Gated Statistical mode 

 Restrictions: For zero delay trigger position in the center of the display , the following relationship must be 

satisfied: TrigDly - (5*time/div)  <  GateTime  <  TrigDly + (5*time/div) where the timebase 

setting is time/div 

 

 

TRIGger:STATistical:GATIng 
 

 Description: Set or return the type of statistical gating to be used. Set the gating to ―Off‖ if no gating is needed. 

This will result in continuous sampling of data to build the histogram. Set the gating to ―On‖ to 

accept only samples that fall within the gate defined by the Gate1 and Gate 2 markers.   

 Syntax: TRIGger:STATistical:GATIng <asc> 

 Argument: <asc> =  {ON, OFF} 

 Valid Modes: Statistical mode 
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Table 5-1. SCPI COMMAND SUMMARY 

 
 

*OPT  Return the instrument options 

 

*CLS  Clear Status Command 

 

*ESE  Set/get Standard Event Status Enable 

 

*ESR?  Standard Event Status Register Query 

 

*IDN  Identification Query 

 

*OPC?  Operation Complete Query 

 

*OPC  Operation Complete Command 

 

*RST  Reset Command 

 

*SRE  Set/get Service Request Enable 

 

*STB?  Read Status Byte Query 

 

*TRG  Simulate GET 

 

*TST?  Self-Test Query 

 

ABORt     Immediately set measurement trigger system to idle 

 

CALCulate:AMEAsure:BOTtom  Set/return state of IEEE automatic bottom detection.  <arg> = ON, OFF 

 

CALCulate:AMEAsure:EDGEdelay Set/return edge delay mode. <arg> =  FRST, LAST, BRST 

 

CALCulate:AMEAsure:MODE  Set/return argument A. <arg> = ALL, FRST, MRKRS, OFF 

 

CALCulate:MATH:ARGA  Set/return argument A. <arg> = CH1, CH2, TRIG1, TRIG2, MEM1, MEM2 

 

CALCulate:MATH:ARGB  Set/return argument B. <arg> = CH1, CH2, TRIG1, TRIG2, MEM1,MEM2 

 

CALCulate:MATH:OPERator  Set/return operator. <arg> = CH_SUM, CH_DIF, CH_RAT 

 

CALCulate:MODE   Set/return instrument mode. <arg> =  PULSE, MODULATED, STATISTICAL 

 

CALCulate[1|2|3|4]:PKHLD  Set/return state of the peak hold function. <arg> = OFF, ON 

 

CALCulate[1|2|3|4|5|6|7]:STATe  Enable currently selected channel allowing measurements to be made.   

     <arg> = ON, OFF 

 

CALCulate:SYSTRK   Set/return state of system tracking.  <arg> = ON, OFF 
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Table 5-1. SCPI COMMAND SUMMARY (continued) 

 
 

CALCulate[1|2|5|6|7]:UNIT               Change channel units. <arg> = dBm, W, V, dBV, dBmV, dBuV 

 

CALibration[1|2|3|4]:AUTO               Start auto calibration                   

 

CALibration[1|2]:USER:FREQcal           Start frequency calibration              

 

CALibration[1|2|3|4]:ZERO               Start zero calibration                   

 

DISPlay:ACTive                           Set/return active channel for talk commands. <arg> = CH1, CH2, TRIG1,  

     TRIG2, CHM, MEM1, MEM2 

 

DISPlay:BACKlight:BRIGhtness            Set/return display brightness. <arg> = 10 through 100 

 

DISPlay:BRIGhtness:BLUE                 Set display intensity of blue component. <arg> = 0 through 255 

 

DISPlay:BRIGhtness:COLor                Select item that color changes will affect. (Ex: <arg> = GRID) 

 

DISPlay:BRIGhtness:GREEn                Set display intensity of green component.  <arg> = 0 through 255 

 

DISPlay:BRIGhtness:INIT                 Initialize display colors to factory defaults 

 

DISPlay:BRIGhtness:RED                  Set display intensity of red component. <arg> = 0 through 255 

 

DISPlay:CLEar                            Clear measurement data and display       

 

DISPlay:DECAdes                          Display horizontal offset in the log presentation. <arg> = 1 through 7 

 

DISPlay:ENVElope                         Set the display envelope. <arg> = ON, OFF 

 

DISPlay:FULLscale                        Display fullscale in the log presentation 

 

DISPlay:GRID                             Select background markings of the window display. <arg> = GRID,   

     XHAIR, BOX, XHAIRGRID, HASH 

 

DISPlay:HEADer                           Select header displayed in the upper left corner. <arg> = BLANK, DATE,  

     LOGO, TEMP 

 

DISPlay:HELP                             Set or remove help menu. <arg> = ON, OFF 

 

DISPlay:MODE    Place display into graphics or text mode. <arg> = GRAPH, TEXT 

 

DISPlay:MODUlated:TIMEBASE              Set/return modulated timebase.           

 

DISPlay:PARAmeter:BOTtom:LEFT           Assign numbered parameter to bottom left field. (ex: <arg> = PWIDTH) 

 

DISPlay:PARAmeter:BOTtom:MIDdle         Assign numbered parameter to bottom middle field. (ex: <arg> =   

     PWIDTH) 

 

DISPlay:PARAmeter:BOTtom:RIGHt          Assign numbered parameter to bottom right field. (ex: <arg> = PWIDTH) 
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Table 5-1. SCPI COMMAND SUMMARY (continued) 

 
 

DISPlay:PARAmeter:MIDdle:LEFT           Assign numbered parameter to middle left field. (ex: <arg> = PWIDTH) 

 

DISPlay:PARAmeter:MIDdle:MIDdle         Assign numbered parameter to middle middle field. (ex: <arg> = PWIDTH) 

 

DISPlay:PARAmeter:MIDdle:RIGHt          Assign numbered parameter to middle right field. (ex: <arg> = PWIDTH) 

 

DISPlay:PARAmeter:MODE                  Set parameter mode to status or measure. <arg> = MEAS, STAT 

 

DISPlay:PARAmeter:TOP:LEFT              Assign numbered parameter to top left field. (ex: <arg> = PWIDTH) 

 

DISPlay:PARAmeter:TOP:MIDdle            Assign numbered parameter to top middle field. (ex: <arg> = PWIDTH) 

 

DISPlay:PARAmeter:TOP:RIGHt             Assign numbered parameter to top right field. (ex: <arg> = PWIDTH) 

 

DISPlay:PCTOFST                          Display horizontal offset in linear presentation. <arg> = 0.0 to 99.0 

 

DISPlay:PCTSCALE                        Display horizontal scale in linear presentation. <arg> = 10, 5, 2, 1, 0.5, 0.2, 0.1 

 

DISPlay:PERSistence                      Set/get display persistence. <arg> = ON, OFF 

 

DISPlay:PLABel:MODE                     Turn on/off four plot labels on graph display. <arg> = OFF, ON 

 

DISPlay:PLABel:TEXTA                    Enter string into first plot label field. <arg> = string of up to 19 characters 

 

DISPlay:PLABel:TEXTB                    Enter string into second plot label field. <arg> = string of up to 19 characters. 

 

DISPlay:PLABel:TEXTC                    Enter string into third plot label field. <arg> = string of up to 19 characters 

 

DISPlay:PLABel:TEXTD                    Enter string into fourth plot label field. <arg> = string of up to 19   

     characters 

DISPlay:PULSe:TIMEBASE                  Set/return horizontal timebase. (Ex: <arg> = 0.05 sets timebase to 50 ms) 

 

DISPlay:SCREensaver:BRIGhtness          Set/return display brightness in screensaver mode. <arg> = 10 to 50 

 

DISPlay:SCREensaver:STATe               Set/return state of screensaver mode. <arg> = ON, OFF 

 

DISPlay:SCREensaver:TIMe                Set/return time until display dims. <arg> = 1 through 240 

 

DISPlay:SKEW[1|2|3|4|6|7]:REFerence Set/return the skew reference channel. <arg> = CH1, CH2, TRIG1,   

     TRIG2, MEM1, MEM2 

 

DISPlay:STATistical:MODE                Set/return statistical mode. <arg> = CCDF, CDF, or PDF 

 

DISPlay:STATistical:PRESentation        Set/return presentation of horizontal grid. <arg> = LIN, LOG 

 

DISPlay:STATistical:PREView             Set/return display in split screen mode. <arg> = ON or OFF 
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Table 5-1. SCPI COMMAND SUMMARY (continued) 

 
 

DISPlay:TRACe:MKCENTer                  Change vertical center to value where active marker  crosses waveform 

 

DISPlay:TRACe:PDFBars                   PDF bars. <arg> = 1, 2, 5, 10, 20, 35    

 

DISPlay:TRACe[1|2|3|4|5|6|7]:TYPE       Set trace type to selected representation. <arg> = POINTS, LINES, OFF 

 

 

DISPlay:TRACe[1|2|3|4|5|6|7]:VCENTer    Change vertical center based on current units. Ex:<arg> = 1.23 

 

DISPlay:TRACe[1|2|3|4|5|6|7]:VSCALe     Change vertical scale based on current units. Ex:<arg> = 20 set to   

     20dB/div (current units) 

 

DISPlay:TSPAN                            Set/return horizontal time span. Ex:<arg> = 0.05 (50 ms) 

 

FETCh[1|2|3|4|6|7]:ARRay:AMEAsure:POWer?   Return current Ppeak, Pavgcyc, Pavgpulse, Ptop, Pbot,  

       Overshoot 

 

FETCh[1|2|3|4|6|7]:ARRay:AMEAsure:STATistical?  Return current Pavg, Ppeak, Pmin, Pk/Avg, Pmrk1,   

       Pmrk2, PCTmrk1, PCTmrk2, Tot(Msamples) 

 

FETCh[1|2|3|4|6|7]:ARRay:AMEAsure:TIMe?   Return current Freq, Period, Width, Offtime, Dcyc,   

       Risetime, Falltime 

 

FETCh[1|2|3|4|6|7]:ARRay:CW:POWer?        Return current Pavg, Pmax, Pmin, Ppulse or PK/AVG 

 

FETCh[1|2|3|4|6|7]:ARRay:MARKer:POWer?   Return current Pavg, Pmax, Pmin, P/Avg, Pmrk1,   

       Pmrk2, Pmrk1/Pmrk2 

 

FETCh:ARRay:MARKer:WINDow?               Return current reading at MK1, MK2, and center window. 

 

FETCh:ARRay:TEMPerature:AVERage?       Return CH1 flag, avg_temp1, CH2 flag, avg_temp2 in tenths  

       of a deg C 

 

FETCh:ARRay:TEMPerature:CALTemp?       Return CH1 flag, acal_temp1, CH2 flag, acal_temp2 in tenths  

       of a deg C 

 

FETCh:ARRay:TEMPerature:CURRent?       Return CH1 flag, temp1, CH2 flag, temp2 in deg C 

 

FETCh[1|2|3|4|5|6|7]:CW:POWer?           Return current average reading in power units 

 

FETCh[1|2|3|4|5|6|7]:INTERval:AVERage?   Return average power between MK1 and MK2. 

 

FETCh[1|2|3|4|6|7]:INTERval:MAXimum?   Return maximum instantaneous power between MK1 and MK2. 

 

FETCh[1|2|3|4|6|7]:INTERval:MINimum?   Return minimum instantaneous power between MK1 and MK2. 

 

FETCh[1|2|3|4|6|7]:INTERval:MAXFilt?   Return maximum filtered power between MK1 and MK2. 

 

FETCh[1|2|3|4|6|7]:INTERval:MINFilt?   Return minimum filtered power between MK1 and MK2. 
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Table 5-1. SCPI COMMAND SUMMARY (continued) 

 
 

FETCh[1|2|6|7]:INTERval:PKAVG?       Return peak to average power between MK1 and MK2. 

 

FETCh:KEY?                                Return code of last key depressed   

 

FETCh[1|2|3|4|5|6|7]:MARKer[1|2]:AVERage?  Return current reading at the specified marker. 

 

FETCh[1|2|3|4|5|6|7]:MARKer:DELTa?       Return difference between MK2 and MK1.   

 

FETCh[1|2|3|4|6|7]:MARKer[1|2]:MAXimum?  Return maximum reading at the specified marker 

 

FETCh[1|2|3|4|6|7]:MARKer[1|2]:MINimum?  Return minimum reading at the specified marker 

 

FETCh[1|2|3|4|5|6|7]:MARKer:RATio?       Return ratio between MK2 and MK1 as a percentage. 

 

FETCh[1|2|3|4|5|6|7]:MARKer:RDELTa?      Return difference between MK1 and MK2.  

 

FETCh[1|2|3|4|5|6|7]:MARKer:RRATio?      Return ratio between MK1 and MK2 as a percentage. 

 

FETCh[1|2]:TEMPerature:AVERage?          Return average sensor internal temperature in degrees C 

 

FETCh[1|2]:TEMPerature:CALTemp?          Return sensor calibration temperature in degrees C 

 

FETCh[1|2]:TEMPerature:CURRent?          Return current sensor calibration temperature in degrees C 

 

HCOPy:BACKground:COLor Set/return the background color used for printing the screen display.  <args> = BLACK, 

WHITE, GRAY 

 

INITiate:CONTinuous                     Set/return state of mode which triggers meas cycles continuously. <arg> = ON, OFF 

 

INITiate[:IMMediate[:ALL]]          Set mode which starts a measurement cycle when trigger event occurs 

 

MARKer[1|2]:ASSIgn                     Assign channel number to marker. <arg> = ACTIVE, CH1, CH2, TRIG1, TRIG2,  

    CHM, MEM1, MEM2 

 

MARKer:GROUp                            Sets marker group.  <arg> = BOTH, EACH    

 

MARKer:MATH:BOTH             Set marker group to both and delta marker, marker math, and units. (Ex: <args> =  

    RATIO MK1MK2 DBM) 

 

MARKer:MATH:EACH                 Set marker group to each and delta marker, marker math, and units. (Ex: <args> =  

    RATIO MK1MK2 DBM) 

 

MARKer[1|2]:POSItion:PERcent    Set/return marker position in percent for selected window. <arg> = 0 through 100 

 

MARKer[1|2]:POSItion:PIXel        Set/return marker position in pixels for selected window. <arg> = 0 through 500 

 

MARKer[1|2]:POSItion:TIMe      Set/return marker time relative to the trigger. Enter time in seconds. (Ex: enter 1ms  

    as 0.001) 
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Table 5-1. SCPI COMMAND SUMMARY (continued) 

 
 

MEASure[1|2]:POWer?  Return modulated mode Pavg in dBm                       

 

MEASure[1|2]:VOLTage?        Return modulated mode Pavg in equivalent volts   

 

MEMory:DRIVe                            Set/return active drive letter, A-Z          

 

MEMory:FDOFfset:TBLA:DATA  Set/return data array for frequency-dependent offset table A. N max = 60 pairs. 

 <asc> = Freq1, Ofset1, Freq2, Ofset2 ... FreqN, OfsetN 

. 

MEMory:FDOFfset:TBLB:DATA  Set/return data array for frequency-dependent offset table B. N max = 60 pairs. 

    <asc> = Freq1, Ofset1, Freq2, Ofset2 ... FreqN, OfsetN 

 

MEMory:FREE?                            Return the bytes of available memory free on selected drive 

 

MEMory:OVERwrite                       Set/return the file overwrite state.              

 

MEMory:SNSR[1|2]:CFFAST?       Return sensor data                       

 

MEMory:SNSR[1|2]:CFSLOW?    Return sensor data                       

 

MEMory:SNSR[1|2]:INFO?          Return sensor data                       

 

MEMory:SNSR[1|2]:MESSage?   Return sensor data       

                

MEMory:SNSR[1|2]:TEMPCOMP? Return sensor temperature compensation data 

 

MEMory:SYS:LOAD                      Recall setup file and configure instrument.  <arg> = filename with path but no   

    extension 

 

MEMory:SYS:STORe      Build an instrument setup file and save to file. <arg> = filename with path but no  

    extension 

 

MMEMory:COPY                           Copy from source argument to destination argument. (Ex: <args> = CH1 MEM2) 

 

MMEMory:LOAD                           Read a reference waveform from disk into a reference channel. (Ex: <args> =   

    filename MEM2) 

 

MMEMory:SAVE:DISPlay      Copy from display to destination argument. 

 

MMEMory:STORe                          Write a waveform to disk from a specified channel. (Ex: <args> = TRIG1 filename) 

 

OUTPut:LEVel:POWer  Set calibrator output level. <arg> = -50.0 to 20.0 dBm 

 

OUTPut:LEVel:LIMit                     Set maximum power level for calibrator output. <arg> = -50.0 to 20.0 dBm   

 

OUTPut:LEVel:STEP                      Set power step size for calibrator output level. <arg> = 0.1 to 60.0 dB 

 

OUTPut:MODUlation                      Set calibrator to selected output mode. <arg> = CW, PULSE 

 

OUTPut:POLArity                         Set calibrator edge to selected edge.  <arg> = POS, NEG 
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Table 5-1. SCPI COMMAND SUMMARY (continued) 

 
 

OUTPut:PULSe:CTRL               Set/return pulse control. <arg> = PRESET, VAR 

 

OUTPut:PULSe:DCYCle             Set/return duty cycle. <arg> = 10, 20, 30, 40, 50 

 

OUTPut:PULSe:PERWID            Set/return variable calibrator pulse period and pulse width.  

<arg1> = 28e-6 to 131.07e-3   <arg2> = 7e-6 to 65.535e-3 

 

OUTPut:PULSe:PERiod              Set/return preset calibrator pulse period in millseconds.  <arg> = 0.1, 1, 10   

 

OUTPut:PULSe:SOURce         Set/return calibrator pulse modulation source. <arg> = INT, EXT  

 

OUTPut:SIGnal                   Set/return state of calibrator RF output. <arg> = ON, OFF 

 

OUTPut:TRIGout[1/2]:SOURce Set/return signal source for trigger output.  <asc> = CH1/2, TRIG1/2, SWP, CLK 

 

OUTPut:TRIGout[1/2]:POLarity Set/return trigger output polarity.  <asc> = POS, NEG 

 

READ[1|2|3|4|6|7]:ARRay:AMEAsure:POWer?  Return new Ppeak, Pavgcyc, Pavgpulse, Ptop, Pbot, Overshoot 

 

READ[1|2|3|4|6|7]:ARRay:AMEAsure:STATistical?  Return new Pavg, Ppeak, Pmin, Pk/Avg, Pmrk1, Pmrk2,   

      PCTmrk1, PCTmrk2, Tot(Msamples) 

 

READ[1|2|3|4|6|7]:ARRay:AMEAsure:TIMe?  Return new Freq, Period, Width, Offtime, Dcyc, Risetime, Falltime, 

EdgeDly, Skew        

 

READ[1|2|3|4|6|7]:ARRay:CW:POWer?        Return new Pavg, Pmax, Pmin, Ppulse or PK/AVG 

 

READ[1|2|3|4|6|7]:ARRay:MARKer:POWer?   Return current Pavg, Pmax, Pmin, P/Av, Pmrk1, Pmrk2, Pmrk1/Pmrk2 

 

READ:ARRay:MARKer:WINDow?               Return current reading at MK1, MK2, and center window. 

 

READ[1|2|3|4|5|6|7]:CW:POWer?            Return new average reading in power units 

 

READ[1|2|3|4|5|6|7]:INTERval:AVERage?    Return average power between MK1 and MK2. 

 

READ[1|2|3|4|6|7]:INTERval:MAXimum?    Return maximum instantaneous power between MK1 and MK2. 

 

READ[1|2|3|4|6|7]:INTERval:MINimum?    Return minimum instantaneous power between MK1 and MK2. 

 

READ[1|2|3|4|6|7]:INTERval:MAXFilt?    Return maximum filtered power between MK1 and MK2. 

 

READ[1|2|3|4|6|7]:INTERval:MINFilt?    Return minimum filtered power between MK1 and MK2. 

 

READ[1|2|6|7]:INTERval:PKAVG?        Return peak to average power between MK1 and MK2. 

 

READ[1|2|3|4|5|6|7]:MARKer[1|2]:AVERage?  Return current reading at the specified marker. 

 

READ[1|2|3|4|5|6|7]:MARKer:DELTa?        Return difference between MK2 and MK1.   

 

READ[1|2|3|4|6|7]:MARKer[1|2]:MAXimum?  Return maximum  reading at the specified marker 

 

READ[1|2|3|4|6|7]:MARKer[1|2]:MINimum?  Return minimum  reading at the specified marker 
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Table 5-1. SCPI COMMAND SUMMARY (continued) 

 
 

READ[1|2|3|4|5|6|7]:MARKer:RATio?        Return ratio between MK2 and MK1.       

 

READ[1|2|3|4|5|6|7]:MARKer:RDELTa?       Return difference between MK1 and MK2.   

 

READ[1|2|3|4|5|6|7]:MARKer:RRATio?       Return ratio between MK1 and MK2.    

 

REFLine:ASSIgn                            Set ref lines 1 & 2 to specified channel. <arg> = OFF, ACTIVE,  

      CH1, CH2, TRIG1, TRIG2, CHM, MEM1, MEM2 

REFLine[1|2]:POSItion:LEVel             Set/return horizontal reference line level. <arg> = -99.00 to 99.00 

 

REFLine:POSItion:FORCetomk               Set reference line to current marker positions 

 

REFLine:TRACk                             Set/return reference line tracking. <arg> = OFF, X1X2,   

      TOPBOT, DISTMESIAL, DISTPROX 

 

SENSe[1|2|3|4]:AVERage                   Set/return trace averaging count. <arg> = 1 to 16384 

 

SENSe[1|2|3|4]:BANDwidth                 Set/return sensor video bandwidth.  <arg> = LOW, HIGH 

 

SENSe[1|2]:CALTAB:COUNt                  Set/return number of cal table values to return as data. <arg> = 1  

      to 16384 

 

SENSe[1|2]:CALTAB:DATA[:NEXT]?          Return count values from cal table, starting at index 

 

SENSe[1|2]:CALTAB:INDEX                  Set/return index of first cal table values to return as data. <arg> =  

      0 to 16383 

 

SENSe[1|2]:CORRection:CALFactor          Set correction factor in dB. <arg> = -3.00 to 3.00 

 

SENSe[1|2]:CORRection:FDOFfset           Set/return current frequency dependent offset table. <arg> = OFF,  

      TBLA, TBLB 

 

SENSe[1|2]:CORRection:FREQuency          Set channel frequency. <arg> =  0.001e9 to 40e9  

 

SENSe:CORRection:FRQTRK                  Set/return frequency tracking. <arg> = ON or OFF 

 

SENSe[1|2]:CORRection:OFFSet             Set/return sensor offset value in dB. <arg> = -99.99 to 99.99 

 

SENSe[1|2]:CORRection:TEMPcomp           Set/return temperature compensation. <arg> = ON, OFF 

 

SENSe[1|2]:FILTer:STATe                  Set/return filter state. <arg> = OFF, AUTO, ON 

 

SENSe[1|2]:FILTer:TIMe                   Set/return filter time. <arg> = 0.002 to 16.00 s in steps of 0.002 

 

SENSe[1|2]:HISTogram:COUNt               Set/return number of histogram bins to return as data. <arg> = 1  

      to 16384 

 

SENSe[1|2]:HISTogram:DATA[:NEXT]?       Return count values from signal histogram, starting at index 

 

SENSe[1|2]:HISTogram:INDEX               Set/return index of first bin to return as data. <arg> = 0 to 16383 
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SENSe[3|4]:IMPedance                      Set/return trigger impedance. <arg> = 1, 50 (1Mohm or 50 Ohm) 

 

SENSe:NORMalize    Set/return distribution function normalization. <arg> = ON, OFF 

 

SENSe[1|2|3|4|6|7]:PULSe:DISTal          Set/return distal parameter of the risetime. <arg> = 20.00 to 99.00 

 

SENSe[1|2|3|4|6|7]:PULSe:ENDGT           Set/return pulse gate end position in percent of pulse time   

      duration. <arg> = 60.00 to 100.00 

 

SENSe[1|2|3|4|6|7]:PULSe:MESIal          Set/return mesial parameter of the risetime. <arg> = 10.00 to 90.00 

 

SENSe[1|2|3|4|6|7]:PULSe:PROXimal        Set/return proximal parameter of the risetime.  <arg> = 0.10 to 30.00 

 

SENSe[1|2|3|4|6|7]:PULSe:STARTGT         Set/return pulse gate start position in percent of pulse time   

      duration. <arg> = 0.00 to 40.00 

 

SENSe[1|2|6|7]:PULSe:UNIT            Set/return pulse definitions units. <arg> = WATTS, VOLTS 

 

SENSe[3|4]:RANGe                          Set/return trigger range. <arg> = 5 50   

 

STATus:OPERation:CONDition?              Return value of Operation Condition Register 

 

STATus:OPERation:ENABle                  Set/return value of Operation Enable Mask 

 

STATus:OPERation:EVENt?                  Return value of Operation Event Register 

 

STATus:OPERation:NTRansition             Set/return the negative transition filter 

 

STATus:OPERation:PTRansition             Set/return the positive transition filter 

 

STATus:PRESet      Set device dependent SCPI registers to default states 

 

STATus:QUEStionable:CONDition?           Return value of Questionable Condition Register 

 

STATus:QUEStionable:ENABle               Set/return value of Questionable Enable Mask 

 

STATus:QUEStionable:EVENt?               Return value of Questionable Event Register 

 

STATus:QUEStionable:NTRansition          Set/return the negative transition filter 

 

STATus:QUEStionable:PTRansition          Set/return the positive transition filter 

 

SYSTem:AUTOSET                           Perform AutoSetup        

 

SYSTem:BEEP                               Set/return keypad audible beeper status. <arg> = ON, OFF 

 

SYSTem:COMMunicate:GPIB:EOI              Set/return EOI. <arg> = ON, OFF          
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Table 5-1. SCPI COMMAND SUMMARY (continued) 

 
 

SYSTem:COMMunicate:GPIB:LISTen         Set/return LISTENER line termination.  <arg> = EOIONLY, CR, LF 

 

SYSTem:COMMunicate:GPIB:TALK          Set/return TALKER line termination. <arg> = EOIONLY, CRLF, CR, 

LF 

 

SYSTem:DATE:DAY                          Set/get day. <arg> = 1 to 31             

 

SYSTem:DATE:MONTH                        Set/get month. <arg> = 1 to 12     

 

SYSTem:DATE:WEEKday?                     Get day of week                          

 

SYSTem:DATE:YEAR                         Set/get year. <arg> = 2005 to 2038                 

 

SYSTem:ERRor                              Return system error code and description 

 

SYSTem:ERRor:NEXT                        Return system error code and description 

 

SYSTem:ERRor:CODE                        Return system error code                 

 

SYSTem:LANGuage                          Set/return language selection. <arg> = SCPI, EMUL4500A 

 

SYSTem:PRESet                             Set instrument to default conditions.    

 

SYSTem:TIMe:HOUR                         Set/get hour. <arg> = 0 to 23     

 

SYSTem:TIMe:MINUTE                       Set/get minute. <arg> = 0 to 60          

 

SYSTem:VERSion?                           Return SCPI version compliance           

 

TRACe[1|2|3|4|5|6|7]:AVERage:DATA[:NEXT]?  Return count average power samples starting at index 

 

TRACe[1|2|3|4|5|6|7]:COUNt               Set/return total number of trace pwr points to  return.<arg> = 1 to 501 

 

TRACe:DELImiter                           Set/return the trace delimiter. <arg> = COMMA, CR, LF, SPACE 

 

TRACe[1|2|3|4|5|6|7]:INDEX               Set/return index of the next trace power point. <arg> = 0 to 500 

 

TRACe[1|2|3|4|6|7]:MAXimum:DATA[:NEXT]?  Return count maximum power samples starting at index 

 

TRACe[1|2|3|4|6|7]:MINimum:DATA[:NEXT]?  Return count minimum power samples starting at index 

 

TRACe:SEND                                Send trace data to file                        

 

TRACe:SOURce                            Set/return the trace source <arg>= CH1, CH2, TRIG1, TRIG2, CHM, 

MEM1, MEM2, CAL1,CAL2, HIST1,HIST2 

 

TRIGger:BTRIGger:ECOUNT         Set B trigger event count. <arg> = 0 to 999999 

 

TRIGger:BTRIGger:LEVel            Set B trigger level. <arg> = -39.99 to 20.00 
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Table 5-1. SCPI COMMAND SUMMARY (continued) 

 
 

TRIGger:BTRIGger:MODE      Select B trigger mode. <arg> = OFF, TDLY, EDLY 

 

TRIGger:BTRIGger:SLOPe        Set the B trigger slope of the pulse signal.  <arg> = POS, NEG 

 

TRIGger:BTRIGger:SOURce            Select B trigger source channel. <arg> = CH1, TRIG1, CH2, TRIG2 

 

TRIGger:BTRIGger:TDLY            Set B trigger Time Delay. <arg> = 0 to 10000e-3 sec 

 

TRIGger:CDF:COUNt              Set/return statistical mode terminal count. <arg> = 2 to 4096 

 

TRIGger:CDF:DECImate               Set/return perform decimation when terminal count is reached. <arg> = 

ON, OFF 

 

TRIGger:CDF:TIMe               Set/return statistical mode terminal time. <arg> = 0 to 3600 sec 

 

TRIGger:DELay                           Set/return trigger delay with respect to the trigger. <arg> = see 

Specifications Section 1-6. 

 

TRIGger:FASTtrig                          Set/return fast trigger. <arg> = ON, OFF 

 

TRIGger:HOLDoff                           Set/return trigger holdoff time. <arg> = 0 to 1 sec in 10 nsec increments 

 

TRIGger:LEVel                             Set/return trigger level. <arg> = -39.99 to 20.00 dBm  

 

TRIGger:MODE                            Set/return trigger mode on display. <arg> = AUTOPKPK, AUTO, 

NORMAL, FREERUN 

 

TRIGger:MODUlated:MODE      Set/return modulated trigger mode  on display.<arg> = FREERUN, 

TRIGGERED 

 

TRIGger:POSition                        Set/return trigger position on display. <arg> = LEFT, MIDDLE, 

RIGHT 

 

TRIGger:SLOPe                             Set/return trigger slope on display. <arg> = POS, NEG 

 

TRIGger:SOURce                            Select trigger source. <arg> = CH1, CH2, TRIG1, TRIG2 

 

TRIGger:STATistical:GATE[1|2]    Set/return marker time relative to the trigger. Enter time in seconds. 

(Ex: enter 1ms as 0.001) 

 

TRIGger:STATistical:GATIng        Set/return statistical gating to FreeRun (OFF)  or Pulse Gated (ON). 

<arg> = ON, OFF 
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Table 5-2. 4400/4500/4400A/4500A EMULATION COMMANDS 

 
Supported Commands 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Refer to Instruction Manual, Model 4500A RF Peak Power Meter Analyzer & Model 4400A RF Peak Power Meter, Boonton 

Electronics part number 98404700A and related publications for more information about Model 4400A/4500A Bus 

Command mnemonics. 

%1-CDF 
%CDF 
%OFFSET 
%PDF 
(BUSADDR)  
*CAL? 
*CLS 
*IDN? 
*OPT? 
*RCL 
*RST 
*SAV 
*SRE 
*SRE? 
*STB? 
*TRG 
*TST? 
A/B 
A+B 
A=CH1 
A=CH2 
A=REF1 
A=REF2 
A-B 
AUTOCAL 
AUTOSET 
AVERAGE  
AVG  
B=CH1 
B=CH2 
B=REF1 
B=REF2 
BLUE 
BUFCOUNT 
BUFDELCO 
BUFDELCR 
BUFDELLF 
BUFDELSP 
BWHIGH 
BWLOW 
CAL10% 
CAL100US 
CAL10MS 
CAL1MS 
CAL20% 
CAL30% 
CAL40% 
CAL50% 
CALCW 
 
 

CALEDGE- 
CALEDGE+ 
CALEXT 
CAL-FIXED 
CALIB-CF 
CALINT 
CALLEVEL 
CALLIMIT  
CALOFF 
CALON 
CALPD 
CALPR 
CALPULSE 
CALPW 
CALSTEP  
CALVR 
CFDB ## 
CH1 
CH1-CH2 
CH2 
CH2-CH1 
CHM 
CHOFF 
CHON 
CLRSCR 
COLOR  
CWOFF 
CWON 
DATACOM1 
DATADISK 
DATALPT1 
DATASEND 
DATSOCH1 
DATSOCH2 
DATSOCHM 
DATSORF1 
DATSORF2 
DAY  
DEBUGOFF 
DEBUGON 
DISTAL  
DSPWR 
DSTRIG 
ESC 
FILENO 
FIXCAL 
FREQ  
FREQBOTH 
FREQCH1 
 

FREQCH2  
FREQEACH 
GRAPH 
GREEN  
GRID 
GRIDBOX 
GRIDCH 
GRIDGH 
GRIDHM 
HDBLANK 
HDDATE 
HDLOGO 
HDTEMP 
HELPOFF 
HELPON 
HOLDOFF  
HOUR  
INSRCL  
INSSAV 
LABELOFF 
LABELON 
LIN 
LOCATION  
LOG 
M%1  
M%2  
MAX-MIN 
MESIAL  
MIN-MAX 
MINUTE  
MK1CH1 
MK1CH2 
MK1CHM 
MK1-MK2 
MK1REF1 
MK1REF2 
MK2CH1  
MK2CH2 
MK2CHM 
MK2-MK1 
MK2REF1 
MK2REF2 
MKAVG 
MKBOTH 
MKCENTER 
MKDELTA 
MKEACH 
MKRATIO 
MMPOWER 

MMPWR 
MMVOLTS 
MONTH # 
MP1 
MP2 
MT1 
MT2 
NEWCOLOR 
OFFSET 
OLD_TEMP 
PARAMBL 
PARAMBM 
PARAMBR 
PARAMML 
PARAMMM 
PARAMMR 
PARAMTL 
PARAMTM 
PARAMTR 
PERSOFF 
PERSON 
PK/AVG 
PLABEL1  
PLABEL2  
PLABEL3  
PLABEL4  
PLOT 
PMEAS 
POWER 
PROXIMAL  
PSTAT 
RD-S-DATA 
RD-S-FAST 
RD-S-SLOW 
RD-S-SMSG 
RD-S-TMCO 
RED  
REF1 
REF2 
REFCH1 
REFCH2 
REFSAV 
RL1 
RL2 
RLCH1 
RLCH2 
RLOFF 
RLREF1 
RLREF2 
 

 

RLSTOMKS 
RLTD&M 
RLTD&P 
RLTMKR 
RLTOFF 
RLTT&B 
RSDREF1 
RSDREF2 
RSSCH1 
RSSCH2 
RUN 
SAMPLES 
SCPI 
SERVCALOF 
SERVCALON 
SINGLE 
SSAVE  
STAT 
STOP 
TCOFF 
TCON 
TEXT 
TIMEBASE 
TKAMEAS 
TKATEMP 
TKBMEAS 
TKDISP 
TKEJD 
TKERR 
TKERRMSG 
TKFPDISP 
TKFREE 
TKFUNC 
TKKEY 
TKMEAS 
TKMKT 
TKMMODE 
TKRLMEAS 
TKSDATA 
TK-S-DATA 
TKSETUP 
TKSFAST 
TK-S-FAST 
TKSMSG 
TKSSLOW 
TK-S-SLOW 
TK-S-SMSG 
TKSTMCO 
TK-S-TMCO 

TKTAV 
TKTEMP 
TKTRIG 
TKUNITS 
TKXTMCO 
TK-X-TMCO 
TR1EXTTL 
TR2EXTTL 
TRAUTO 
TRCENTER 
TRCH1EXT 
TRCH1INT 
TRCH2EXT 
TRCH2INT 
TRDELAY 
TRECOUNT  
TREDGE- 
TREDGE+ 
TREVDELY  
TREVOF 
TREVON 
TRLEFT 
TRLEVEL 
TRLVL 
TRNORM 
TRRIGHT 
TTDOT 
TTLINE  
TTOFF 
UNDIM 
VCENTER 
VSCALE 
WEEKDAY 
WFMRCL 
WFMSAV 
WFRDREF1 
WFRDREF2 
WFSSREF1 
WFSSREF2 
XAXIS  
XOFF 
XON 
YEAR  
ZERO 
 



Boonton 4500B RF Peak Power Analyzer 

Remote Operation 5-110 

Table 5-2. 4400/4500/4400A/4500A EMULATION COMMANDS (continued) 

 
 

 

 

      Ignored Commands - These 4400/4500/4400A/4500A commands are 

      recognized but ignored by the 4500B. These commands never generate  

errors. 

 

 

 

 

 

 

 

 

 

        

 

. Unsupported commands - These 4400/4500/4400A/4500A commands 

generate error 10, "Not supported", when received.  If the user prefers 

that no error is generated, the menu selection Util > Remote > 

Emulation > Ignore Cmds should be set to ON. The 4500B will then 

ignore these commands. 

     

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Unsupported Commands 
 
%OFPK 
(4500S/N) 
A*B 
CON80% 
CON85% 
CON90% 
CON95% 
CON99% 
EXTTRCALB 
EXTTRZERO 
G&TOFF 
G&TON 
NZAUTOCAL 
PADDR 
PKINGON 
PLOT488 
PLOT7470 
PLOT7475 
PLOTCOM1 
PLOTF310 
PLOTHPGL 
PLOTLJET 
PLOTLPT1 
PLOTSER1 
PLOTTJET 
PRINTER 
REFCHM 
RLCHM 
RSSCHM 
SCRSPLIT 
SELDATTBL 
TK-ADCT##  
TKBDISP 
TKPLOT 
TK-TBLDAT 
TK-XDCT## 
TOPWIND 
TWTOP 

 

 

Ignored Commands 
 
BOTWIND 
INSDISK 
INSNVRAM 
PKINGOFF 
PLOT.BMP 
PLOTDISK 
PLOTTER 
SCRFULL 
TWBOT 
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6. Application Notes 
 
This section provides supplementary material to enhance your knowledge of Model 4500B operation, advanced features and 

measurement accuracy. Topics covered in this section include pulse measurement fundamentals, automatic measurement 

principles, and an analysis of measurement accuracy.  

 

 

6.1 Introduction to Pulse Measurements 
 

 

Power Measurements  The following is a brief review of power measurement fundamentals. 
 

Unmodulated Carrier Power. The average power of an unmodulated carrier 

consisting of a continuous, constant amplitude sinewave signal is also termed 

CW power. For a known value of load impedance R, and applied voltage Vrms, 

the average power is: 

 

P = Vrms²/R      watts 

 

Power meters designed to measure CW power can use thermoelectric detectors which 

respond to the heating effect of the signal or diode detectors which respond to the voltage 

of the signal. With careful calibration accurate measurements can be obtained over a wide 

range of input power levels. 

 

Modulated Carrier Power. The average power of a modulated carrier which has 

varying amplitude can be measured accurately by a CW type power meter with a 

thermoelectric detector, but the lack of sensitivity will limit the range. Diode detectors 

can be used at low power, square-law response levels. At higher power levels the diode 

responds in a more linear manner and significant error results. 

 

Pulse Power. Pulse power refers to power measured during the on time of pulsed RF  

signals (Figure 6-1). Traditionally, these signals have been measured in two steps: (1) 

thermoelectric sensors measure the average signal power, (2) the reading is then divided 

by the duty cycle to obtain pulse power, Ppulse: 

 

Ppulse = Average Power/ Duty Cycle          (measured) 

 

where Duty Cycle = Pulse Width/Pulse Period 

 

Pulse power provides useful results when applied to rectangular pulses, but is inaccurate 

for pulse shapes that include distortions, such as overshoot or droop 

(Figure 6-2). 
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Figure 6-1. 
Pulsed RF Signal 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 6-2. 
Distorted Pulse Signal 
 

 

 

 

 

 

 

 

 

 

Peak Power. The Model 4500B makes power measurements in a manner which 

overcomes the limitations of the pulse power method and provides both peak power and 

average power readings for all types of modulated carriers. The fast responding diode 

sensors detect the RF signal to produce a wideband video signal which is sampled with a 

narrow sampling gate The video sample levels are accurately converted to power on an 

individual basis at up to a 1 MSa/sec rate. Since this power conversion is correlated to the 

sensor pre-calibration table, these samples can be averaged to yield average power 

without restriction to the diode square-law region. In addition, if the signal is repetitive, 

the signal envelope can be reconstructed using an internal or external trigger. The 

envelope can be analyzed to obtain waveshape parameters including, pulse width, duty 

cycle, overshoot, risetime, falltime and droop. In addition to time domain measurements 

and simple averaging, the Model 4500B has additional capabilities which allow it to 

perform statistical, histogram type analyses on a complete set of continuously sampled 

data points. Data can be viewed and characterized using CDF, 1-CDF and PDF 

presentation formats. These analysis tools provide invaluable information about peak 

power levels and their frequency of occurrence, and are especially useful for non-

repetitive signals such as HDTV and CDMA. 
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Diode Detection  Wideband diode detectors are the dominant power sensing device used to measure pulsed RF 

signals. However, several diode characteristics must be compensated to make meaningful measurements. These include the 

detector‘s nonlinear amplitude response, temperature sensitivity, and frequency response characteristic. Additional potential 

error sources include detector mismatch, signal harmonics and noise. 

 

Detector Response. The response of a single-diode detector to a sinusoidal input is given  

by the diode equation: 

 

where: 

i = diode current 

v = net voltage across the diode 

Is = saturation current 

= constant 

 

An ideal diode response curve is plotted in Figure 6-3.   

 

 

 

 

Figure 6-3. 
Ideal Diode Response 

 

 

 

 

 

 

 

 

The curve indicates that for low microwave input levels (Region A), the single-diode 

detector output is proportional to the square of the input power. For high input signal 

levels (Region C), the output is linearly proportional to the input. In between these ranges 

(Region B), the detector response lies between square-law and linear. 

 

For accurate power measurements over all three regions illustrated in Figure 6-3, the 

detector response is pre-calibrated over the entire range. The calibration data is stored in 

the instrument and recalled to adjust each sample of the pulse power measurement. 

 

Temperature Effects. The sensitivity of microwave diode detectors (normally Low 

Barrier Schottky diodes) varies with temperature. However, ordinary circuit design 

procedures that compensate for temperature-induced errors adversely affect detector 

bandwidth. A more effective approach involves sensing the ambient temperature during 

calibration and recalibrating the sensor when the temperature drifts outside the calibrated 

range. 

 

This process can be made automatic by collecting calibration data over a wide 

temperature range and saving the data in a form that can be used by the power meter to 

correct readings for ambient temperature changes.  
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Frequency Response. The carrier frequency response of a diode detector is determined 

mostly by the diode junction capacitance and the device lead inductances. Accordingly, 

the frequency response will vary from detector to detector and cannot be compensated 

readily. Power measurements must be corrected by constructing a frequency response 

calibration table for each detector.  

 

Mismatch. Sensor impedance matching errors can contribute significantly to 

measurement uncertainty, depending on the mismatch between the device under test 

(DUT) and the sensor input. This error cannot be easily calibrated out, but can be 

minimized by employing an optimum matching circuit at the sensor input. 

 

Signal Harmonics. Measurement errors resulting from harmonics of the carrier 

frequency are level-dependent and cannot be calibrated out. In the square-law region of 

the detector response (Region A, Figure 6-3), the signal and second harmonic combine on 

a root mean square basis. The effects of harmonics on measurement accuracy in this 

region are relatively insignificant. However, in the linear region (Region C, Figure 6-3), 

the detector responds to the vector sum of the signal and harmonics. Depending on the 

relative amplitude and phase relationships between the harmonics and the fundamental, 

measurement accuracy may be significantly degraded. Errors caused by even-order 

harmonics can be reduced by using balanced diode detectors for the power sensor. This 

design responds to the peak-to-peak amplitude of the signal, which remains constant for 

any phase relationship between fundamental and even-order harmonics. Unfortunately, 

for odd-order harmonics, the peak-to-peak signal amplitude is sensitive to phasing, and 

balanced detectors provide no harmonic error improvement. 

 

Noise. For low-level signals, detector noise contributes to measurement uncertainty and 

cannot be calibrated out. Balanced detector sensors improve the signal-to-noise ratio by 3 

dB, because the signal is twice as large.  

 

 

Model 4500B FEATURES 

The Model 4500B design incorporates several significant features to reduce measurement 

error, simplify operation, and speed internal processing. These features include: 

 

 Balanced diode sensors enhance error performance by increasing signal-to-noise 

and suppressing even-order signal harmonics. 

 

 Random sampling achieves wide measurement bandwidth at moderately high 

sampling speeds. Waveforms can be displayed for repetitive signals when the 

trigger event is stable. 

 

 Smart Sensors (sensor-mounted EEPROM) store sensor frequency calibration 

and temperature compensation data, eliminating operator entry. 

 

 Floating Point Digital Signal Processors for each channel provide high speed 

processing for near real-time measurements. 

 

 A built-in programmable calibrator which creates a unique calibration table for 

each sensor as well as pulsed RF test signals. 
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6.2 Pulse Definitions 

 

IEEE Std 194™-1977 Standard Pulse Terms and Definitions ―provides fundamental 

definitions for general use in time domain pulse technology‖. Several key terms defined 

in the standard are reproduced in this subsection, which also defines the terms appearing 

in the Model 4500B text mode display of automatic measurement results. 

 

 

Standard IEEE Pulse     

The key terms defined by the IEEE standard are abstracted and summarized below. These 

terms are referenced to the standard pulse illustrated in Figure 6-4. 

 

 

 

 

 

 

Figure 6-4. 
IEEE Standard Pulse 
(IEEE Std 194™-1977) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note  IEEE Std 194™-1977 Standard Pulse Terms and Definitions has been superceded by IEEE Std 181™- 

  2003. Many of the terms used below have been deprecated by the IEEE. However, these terms are widely  

used in the industry and familiar to previous Model 4500 users. For this reason, they are retained. 
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Table 6-1. Pulse Terms 

 
 
TERM      DEFINITION 
 
Base Line  The two portions of a pulse waveform which represent the first nominal state from which a pulse departs 

and to which it ultimately returns. 

 

Top Line  The portion of a pulse waveform which represents the second nominal state of a pulse. 

 

First Transition  The major transition of a pulse waveform between the base line and the top line (commonly called the 

rising edge). 

Last Transition  The major transition of a pulse waveform between the top of the pulse and the base line. (Commonly called 

the falling edge.) 

 

Proximal Line  A magnitude reference line located near the base of a pulse at a specified percentage (normally 10%) of 

pulse magnitude. 

 
Distal Line  A magnitude reference line located near the top of a pulse at a specified percentage (normally 90%) of 

pulse magnitude. 

 

Mesial Line  A magnitude reference line located in the middle of a pulse at a specified percentage (normally 50%) of 

pulse magnitude. 

 

 

 
 
 

6.3 Automatic Measurements 
 
The Model 4400A/4500A automatically analyzes the waveform data in the buffers and calculates key waveform parameters. 

The calculated values are displayed in text mode when you press the TEXT/GRAPH system key. 

 

Automatic Measurement Criteria  

Automatic measurements are made on repetitive signals that meet the following 

    conditions: 

 

 Amplitude. The difference between the top and bottom signal amplitudes must 

exceed 6 dB to calculate waveform timing parameters (pulse width, period, duty 

cycle). The top-to-bottom amplitude difference must exceed 13 dB to measure 

rise and falltime. 

 

 Timing. In order to measure pulse repetition frequency and duty cycle, there 

must be at least three signal transitions. The interval between the first and third 

transition must be at least 1/5 of a division ( 1/50 of the screen width). For best 

accuracy on rise and falltime measurements, the timebase should be set so the 

transition interval is at least one- half division on the display. 
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Automatic Measurement Terms  

The following terms appear in the Model 4500B Text display in the Pulse mode. The Text column lists the 
abbreviated forms that appear on the display screen.  
 
 

Table 6-2.  Automatic Measurement Terms 

 
 
Text  TERM                                     DEFINITION 
 
Width  Pulse Width   The interval between the first and second signal crossings of the mesial line. 

 

Rise  Risetime   The interval between the first signal crossing of the proximal line to the first 

signal crossing of the distal line. 

 

Fall  Falltime    The interval between the last signal crossing of the distal line to the last signal 

crossing of the proximal line. 

 

Period  Pulse Period   The interval between two successive pulses. (Reciprocal of the Pulse Repetition 

Frequency) 

 

PRFreq  Pulse Repetition  The number of cycles of a repetitive signal that take place in one second. 

Frequency 

 

Duty C  Duty Cycle   The ratio of the pulse on-time to off-time. 

 

Offtime  Off-time   The time a repetitive pulse is off. (Equal to the pulse period minus the pulse 

width). 

 

Peak  Peak Power   The maximum power level of the captured waveform. 

 

Pulse  Pulse Power   The average power level across the pulse width, defined by the intersection of 

the pulse rising and falling edges with the mesial line. 

 

Oversh  Overshoot   A distortion following a major transition. (The difference between the maximum 

amplitude of the overshoot and the top line). 

 

Avg  Average Power   The equivalent heating effect of a signal. 

 

IEEETop Top Amplitude   The amplitude of the top line. (See IEEE definitions) 

 

IEEEBot Bottom Amplitude The amplitude of the base line. (See IEEE definitions) 

 

Skew Skew   The time between the mesial level of a pulse on Channel 1 and a pulse on 

     Channel 2. The pulse can be the power or trigger signal. 

 

EdgeDly  Edge Delay   The time between the left edge of the display and the first mesial transition  

level of either slope on the waveform. 
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Automatic Measurement Sequence  

The automatic measurement process analyzes the captured signal data in the following sequence: 

 

1. Approximately 500 samples of the waveform (equivalent to one screen width) 

are scanned to determine the maximum and minimum sample amplitudes. 

 

2. The difference between the maximum and minimum sample values is calculated 

and stored as the Signal Amplitude. 

 

3. The Transition Threshold is computed as one-half the sum of the maximum and 

minimum sample amplitudes. 

 

4. The processor locates each crossing of the Transition Threshold.  

 

5. Starting at the left edge of the screen, the processor classifies each Transition 

threshold crossing according to whether it is positive-going (– +) or negative-

going (+ –). Because the signal is repetitive, only three transitions are needed to 

classify the waveform, as follows: 

 

Type  Sequence  Description 

 
   0 none  No crossings detected 

   1   Not used 

   2   + –   One falling edge 

   3   – +  One rising edge 

   4  + – +  One falling, followed by one rising edge 

   5 – + –  One rising, followed by one falling edge 

   6  + – + –      Two falling edges 

   7  – + – +   Two rising edges 

 
 

 

 

 

 

 

 

Figure 6-5. 
Step Waveforms 
 

 

 

 

 

 

 

 

 

 

6. If the signal is Type 0, (No crossings detected) no measurements can be 

performed and the routine is terminated, pending the next reload of the data 

buffers. 
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7. The process locates the bottom amplitude (baseline) using the IEEE histogram 

method. A histogram is generated for all samples in the lowest 12.8 dB range of 

sample values. The range is subdivided into 64 power levels of 0.2 dB each. The 

histogram is scanned to locate the power level with the maximum number of 

crossings. This level is designated the baseline amplitude. If two or more power 

value have equal counts, the lowest is selected.  

 

8. The process follows a similar procedure to locate the top amplitude (top line). 

The power range for the top histogram is 5 dB and the resolution is 0.02 dB, 

resulting in 250 levels. The level-crossing histogram is computed for a single 

pulse, using the samples which exceed the transition threshold. If only one 

transition exists in the buffer (Types 2 and 3), the process uses the samples that 

lie between the edge of the screen and the transition threshold (See Figure 6-6). 

For a level to be designated the top amplitude, the number of crossings of that 

level must be at least 1 ¤16 the number of pixels in the pulse width; otherwise, 

the peak value is designated the top amplitude. 

 

9. The process establishes the proximal, mesial, and distal levels as a percentage of 

the difference between top amplitude and bottom amplitude power. The 

percentage can be calculated on a power or voltage basis. The proximal, mesial, 

and distal threshold values are user settable from 1% to 99%, with the restriction 

that the proximal < mesial < distal. Normally, these values will be set to 10%, 

50% and 90%, respectively. 

 

 

 

 

 

 

 

 

Figure 6-6. 
Time Interpolation 

 

 

 

 

 

 

 

 

 

 

 

 

 

10. The process determines horizontal position, in pixels, at which the signal crosses 

the mesial value. This is done to a resolution of 0.1 pixel, or 1/5000 of the screen 

width. Ordinarily, the sample values do not fall precisely on the mesial line, and 

it is necessary to interpolate between the two nearest samples to determine 

where the mesial crossing occurred. This process is demonstrated in the example 

above (Figure 6-6): 
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      Item   dBm   mW 
       

 
Mesial value  10.0   10.0 

Sample n  8.0   6.3 

Sample n+1  11.0   12.6 

       

 
 

The interpolated crossing time, tx, is calculated from: 

      

 

 

 

where P is in watts and n is the number of the sampling interval, referenced to 

the trigger event. For this example 

 

 

 

 

 

 

 

 

 

11. The processor computes the rise and/or falltimes of waveforms that meet the 

following conditions: 

 

a)   The waveform must have at least one usable edge (Types 2 through 7). 

 

b)   The signal peak must be at least 13 dB greater than the minimum sample 

      value. 

 

The risetime is defined as the time between the proximal and distal crossings  

(– +). 

 

The falltime is defined as the time between the distal and proximal crossings 

(+ –). 

 

If no samples lie between the proximal and distal values for either edge (rise or 

fall), the risetime for that edge is set to 0 seconds 
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12.  The processor calculates the output values according to the following 

definitions: 

 

 

a.) Pulse Width   Interval between mesial points 

 

b.) Risetime   See Step 11 

 

c.) Falltime   See Step 11 

 

d.) Period    Cycle time between mesial points 

 

e.) Pulse Repetition   Reciprocal of Period  
Frequency 

 

f.) Duty Cycle   Pulse Width/Period 

 

g.) Off-time   (Period) - (Pulse Width) 

 

h.) Peak Power  Maximum sample value (See Step 1) 

 

i.) Pulse Power  Average power in the pulse (between the  

mesial points) 

 

j.) Overshoot  (Peak Power) - (Top Amplitude) 

 

k.) Average Power   See Step 13 

 

l.) Top Amplitude   See Step 8 

 

m.) Bottom Amplitude  See Step 7 

 

n.) Skew   See Step 14 

 

 

Average Power Over an Interval 

13. The average power of the signal over a time interval is computed by: 

 

a.) summing the sample powers in the interval 

 

b.) dividing the sum by the number of samples 

 

This process calculates Pulse Power, Average Power and the average power 

between markers. 

 

Since each sample represents the power in a finite time interval, the endpoints 

are handled separately to avoid spreading the interval by one-half pixel at each 

end of the interval (See Figure 6-7). For the interval in Figure 6-7, the average 

power is given by: 
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Figure 6-7 
Sampling Intervals 
 

 

 

 

 

 

 

 

 

 

 

14. The processor calculates the delay between the two measurement channels. The 

time reference for each channel is established by the first signal crossing 

(starting from the left edge of the screen) which passes through the mesial 

level(or 50% point in trigger view). The signal excursion must be at least 6 dB 

in power mode, or 300 mV in trigger-view mode. 
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6.4 Statistical Mode Automatic Measurements (Model 4500B Opt 10 only) 
 
When operating in Statistical mode, the 4500B Option 10 has a unique text format display that is available when the 

TEXT/GRAPH system key is pressed. A sample of the text display is shown in Figure 6.8. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 6-8. Statistical Mode Text Display (Model 4500B Opt 10) 
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Table 6-3. Statistical Automatic Measurements (Opt 10 only) 

 
In the Statistical mode the following five automatic measurements are displayed in the Model 4500B Text display for both 

input channels and both trigger channels. The Text column lists the abbreviated forms that appear on the display screen.  

 
Text  TERM                                     DEFINITION 
 
Avg Average Power:   The unweighted avg of all power samples occurring since acquisition started. 

 

Peak  Peak Power  The highest power sample occurring since acquisition was started. 

 

Min   Minimum Power   The lowest power sample occurring since acquisition was started. In logarithmic 

units a reading below the clip level will display as down arrows. 

 

Pk/Avg  Pk/Avg Ratio  The ratio (in dB) of the Peak Power to the Average Power. 

 

Dyn Rng Dynamic Range  The ratio (in dB) of the Peak Power to the Minimum Power. Displays down  

     arrows if the minimum power is less than the clip level in log units. 

 

The following six cursor measurements display the set position and measured value where the movable cursor intersects the 

measurement trace. Note that the markers are undefined in PDF presentation format. The position and value text for each 

marker or reference line will be displayed with the color of the assigned channel for that particular cursor. 

 

Text  TERM                                     DEFINITION 
 
RefLine1 Reference Line 1  Measures the CDF (or 1-CDF) % at the power level where reference line 1 

intersect the assigned trace. 

 

Note that if the intersection falls outside the horizontal screen extents, the 

measured value will be clipped to % values within the horizontal axis. For this 

reason, avoid zooming in horizontally with Time > X-Axis if you wish to make 

Reference line measurements. 

 

RefDelta Reference Line Delta For logarithmic units, displays the ratio (in dB) of the Reference Line 1 and  

Reference Line 2 levels, or for linear units displays the difference (in %) 

between the Reference Line 1 and Reference Line 2 levels and the difference (in 

%) between their CDF (0r 1-CDF) values. 

 

RefLine2 Reference Line 2   See Ref Line 1, above 

 

Marker1  Marker 1  Measures the level at the selected %CDF (or 1-CDF). 

 

Note that marker positions are rounded to the nearest pixel positions (1/50th of a 

division), so for precise power measurements at very high or low % positions, it 

may be necessary to zoom in horizontally with Statistics (Time) > Horz Scale. 

 

Delta%  Marker Delta  Displays the difference (in %) between the marker positions and the ratio (in dB  

     for logarithmic units, % for linear units) of their levels. 

 

Marker2  Marker 2  See Marker 1, above. 
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The following two global status values are displayed:  

 

Text  TERM                                     DEFINITION 
      

Total   Time    The total time in Hours:Minutes:Seconds that the data acquisition has been  

     running. 

 

Samples The total number of data samples that has been acquired for each channel in the 

current run. 

 
Note  The sampling speed of  Channel 1 and Channel 2 is 25 MSa/sec. The sampling speed of the external 

Trigger 1  and Trigger 2 inputs is 2 MSa/sec. If Channel 1 and Channel 2 are running, the sampling speed of each is 

still 25   MSa/sec. If  Channel 1 and Trigger 1 are running, the sampling speed for both is 2 MSa/sec. The same is 

true for  Channel 2 and Trigger 2. For fastest sampling speed, do not run the CDF (or 1-CDF) of a channel and its 

external   trigger at the same time.    
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6.5 Measurement Accuracy 
 
The Model 4500B includes a precision, internal, 1 GHz RF reference calibrator that is traceable to the National Institute for 

Standards and Technology (NIST).  When the instrument is maintained according to the factory recommended one year 

calibration cycle, the calibrator enables you to make highly precise measurements of CW and modulated signals.  The error 

analyses in this chapter assumes that the power analyzer is being maintained correctly and is within its valid calibration 

period. 

Measurement uncertainties are attributable to the instrument, calibrator, sensor, and impedance mismatch between the sensor 

and the device under test (DUT).  Individual independent contributions from each of these sources are combined 

mathematically to quantify the upper error bound and probable error.  The probable error is obtained by combining the linear 

(percent) sources on a root-sum-of-squares (RSS) basis.  RSS uncertainty calculations also take into account the statistical 

shape of the expected error distribution. 

Note that uncertainty figures for individual components may be provided given in either percent or dB.  The following 

formulas may be used to convert between the two units: 

 U
%
 = (10(UdB/10) - 1) × 100   and  U

dB
 = 10 × Log

10
(1 + (U

% 
/ 100)) 

Section 6.5.1 outlines all the parameters that contribute to the power measurement uncertainty followed by a discussion on 

the method and calculations used to express the uncertainty. 

Section 6.5.2 continues discussing each of the uncertainty terms in more detail while presenting some of their values. 

Section 6.5.3 provides Power Measurement Uncertainty calculation examples for Peak Power sensors with complete 

Uncertainty Budgets. 

 

6.5.1 Uncertainty Contributions.  The total measurement uncertainty is calculated by combining the following terms: 

 Uncertainty Source Distribution Shape K 

1. Instrument Uncertainty Normal   0.500 

2. Calibrator Level Uncertainty Rectangular  0.577 

3. Calibrator Mismatch Uncertainty U-shaped  0.707 

4. Source Mismatch Uncertainty U-shaped  0.707 

5. Sensor Shaping Error Rectangular  0.577 

6. Sensor Temperature Coefficient Rectangular  0.577 

7. Sensor Noise Normal   0.500 

8. Sensor Zero Drift Rectangular  0.577 

9. Sensor Calibration Factor Uncertainty Normal   0.500 

 

 

 

The formula for worst-case measurement uncertainty is: 

 U
WorstCase

  =  U
1
  + U

2
 + U

3
 + U

4
 + ... U

N 

where U
1
 through U

N
 represent each of the worst-case uncertainty terms. 
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The worst case approach is a very conservative method in which the extreme conditions of each of the individual 

uncertainties are added together.  If the individual uncertainties are all independent of one another, the probability of 

all being at their worst-case conditions simultaneously is extremely small.  For this reason, the uncertainties are more 

commonly combined using the RSS method.  RSS is an abbreviation for ―root-sum-of-squares‖, a technique in which 

each uncertainty is squared, the squares are summed, and the square root of the summation is calculated. 

Before the RSS calculation can be performed, however, the worst-case uncertainty values must be scaled, or 

―normalized‖ to adjust for differences in each term‘s probability distribution or ―shape‖.  The distribution shape is a 

statistical description of how the actual error values are likely to vary from the ideal value.  Once normalized in this 

way, terms with different distribution shapes can be combined freely using the RSS method. 

Three main types of distributions are Normal (Gaussian), Rectangular, and U-shaped.  The multipliers for each type of 

distribution are as follows: 

 Distribution Multiplier ―K‖ 

 Normal  0.500 
 Rectangular sqrt(1/3)   = 0.577 
 U-shaped sqrt(1/2)   = 0.707 

 

The formula for calculating RSS measurement uncertainty from worst-case values and scale factors is: 

     

                             ‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗   

 U
RSS

 = √(U
1
K

1
)2  + (U

2
K

2
)2 + (U

3
K

3
)2 + (U

4
K

4
)2 + ... (U

N
K

N
)2 

 

where U
1
 through U

N
 represent each of the worst-case uncertainty terms, and  K

1
 through K

N
 represent the normalizing 

multipliers for each term based on its distribution shape. 

 

This calculation yields what is commonly referred to as the combined standard uncertainty, or U
C
, with a level of 

confidence of approximately 68%.  To gain higher levels of confidence an Expanded Uncertainty is often employed.  

Using a coverage factor of 2 (U = 2U
C 

) will provide an Expanded Uncertainty with a confidence level of 

approximately 95%. 

 

 

6.5.2 Discussion of Uncertainty Terms.  Following is a discussion of each term, its definition, and how it is 

calculated. 

Instrument Uncertainty.  This term represents the amplification and digitization uncertainty in the power meter, as 

well as internal component temperature drift.  In most cases, this is very small, since absolute errors in the circuitry 

are calibrated out by the AutoCal process.  The instrument uncertainty is 0.20% for the Model 4500B. 

Calibrator Level Uncertainty.  This term is the uncertainty in the calibrator‘s output level for a given setting for 

calibrators that are maintained in calibrated condition.  The figure is a calibrator specification which depends upon 

the output level: 

 

1GHz Calibrator Level Uncertainty: 

 ± (0.065 dB (1.51%) at 0 dBm + 0.03 dB (0.69%) per 5 dB from 0 dBm) 
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The value to use for calibration level uncertainty depends upon the sensor calibration technique used.  If AutoCal 

was performed, the calibrator‘s uncertainty at the measurement power level should be used.  For sensors calibrated 

with FixedCal, the calibrator is only used as a single-level source, and you should use the calibrator‘s uncertainty at 

the FixedCal level, (0dBm, for most sensors).  This may make FixedCal seem more accurate than AutoCal at some 

levels, but this is usually more than offset by the reduction in shaping error afforded by the AutoCal technique. 

 

Calibrator Mismatch Uncertainty.  This term is the mismatch error caused by impedance differences between the 

calibrator output and the sensor‘s termination.  It is calculated from the reflection coefficients of the calibrator (ρ
CAL

) 

and sensor (ρ
SNSR

) at the calibration frequency with the following equation: 

 Calibrator Mismatch Uncertainty  =  ±2 × ρ
CAL

 × ρ
SNSR

 × 100 % 

The calibrator reflection coefficient is a calibrator specification: 

 Internal 1 GHz Calibrator Reflection Coefficient (ρ
CAL

): 0.091 (at 1GHz) 

The sensor reflection coefficient, ρ
SNSR

 is frequency dependent, and may be looked up in the sensor datasheet or the 

Boonton Electronics Power Sensor Manual. 

 

Source Mismatch Uncertainty.  This term is the mismatch error caused by impedance differences between the 

measurement source output and the sensor‘s termination.  It is calculated from the reflection coefficients of the 

source (ρ
SRCE

) and sensor (ρ
SNSR

) at the measurement frequency with the following equation: 

 Source Mismatch Uncertainty  =  ±2 × ρ
SRCE

  × ρ
SNSR

  × 100 % 

The source reflection coefficient is a characteristic of the RF source under test.  If only the SWR of the source is 

known, its reflection coefficient may be calculated from the source SWR using the following equation: 

 Source Reflection Coefficient (ρ
SRCE

)  =  (SWR - 1) / (SWR + 1) 

The sensor reflection coefficient, ρ
SNSR

 is frequency dependent, and may be looked up in the sensor datasheet or the 

Boonton Electronics Power Sensor Manual.  For most measurements, this is the single largest error term, and care 

should be used to ensure the best possible match between source and sensor. 

 

Sensor Shaping Error.  This term is sometimes called ―linearity error‖, and is the residual non-linearity in the 

measurement after an AutoCal has been performed to characterize the ―transfer function‖ of the sensor (the 

relationship between applied RF power, and sensor output, or ―shaping‖).  Calibration is performed at discrete level 

steps and is extended to all levels.  Generally, sensor shaping error is close to zero at the autocal points, and 

increases in between due to imperfections in the curve-fitting algorithm. 

An additional component of sensor shaping error is due to the fact that the sensor‘s transfer function may not be 

identical at all frequencies.  The published shaping error includes terms to account for these deviations.  If your 

measurement frequency is close to your AutoCal frequency, it is probably acceptable to use a value lower than the 

published uncertainty in your calculations. 

All peak power sensors use the AutoCal method only.  The sensor shaping error for peak sensors is listed on the 

sensor‘s datasheet or in the Boonton Electronics Power Sensor Manual. 
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Sensor Temperature Coefficient.  This term is the error which occurs when the sensor‘s temperature has changed 

significantly from the temperature at which the sensor was AutoCal‘d.  This condition is detected by the Model 

4500B and a ―temperature drift‖ message warns the operator to recalibrate the sensor for drift exceeding  ±4C on 

non-temperature compensated peak sensors.  For these sensors, the typical temperature effect 4 degrees from the 

AutoCal temperature is shown as a graph versus level on the sensor datasheet. 

Temperature compensated peak sensors have a much smaller temperature coefficient, and a much larger temperature 

deviation, ±30C is permitted before a warning is issued.  For these sensors, the maximum uncertainty due to 

temperature drift from the autocal temperature is: 

 Temperature Error = ± 0.04dB (0.93%) + 0.003dB (0.069%) /degreeC 

Note that the first term of this equation is constant, while the second term  (0.069%) must be multiplied by the 

number of degrees that the sensor temperature has drifted from the AutoCal temperature. 

 

Sensor Noise.  The noise contribution to pulse measurements depends on the number of samples averaged to 

produce the power reading, which is set by the ―averaging‖ menu setting.  For continuous measurements with peak 

sensors in modulated mode, it depends on the integration time of the measurement, which is set by the ―filter‖ menu 

setting.  In general, increasing filtering or averaging reduces measurement noise.  Sensor noise is typically expressed 

as an absolute power level.  The uncertainty due to noise depends upon the ratio of the noise to the signal power 

being measured.  The following expression is used to calculate uncertainty due to noise: 

 Noise Error = ± Sensor Noise (in watts) / Signal Power (in watts) × 100 % 

The noise rating of a particular power sensor may be found on the sensor datasheet, or the Boonton Electronics 

Power Sensor Manual.  It may be necessary to adjust the sensor noise for more or less filtering or averaging, 

depending upon the application.  As a general rule (within a decade of the datasheet point), noise is inversely 

proportional to the filter time or averaging used.  Noise error is usually insignificant when measuring at high levels 

(25dB or more above the sensor‘s minimum power rating). 

 

Sensor Zero Drift.  Zero drift is the long-term change in the zero-power reading that is not a random, noise 

component.  Increasing filter or averaging will not reduce zero drift.  For low-level measurements, this can be 

controlled by zeroing the meter just before performing the measurement.  Zero drift is typically expressed as an 

absolute power level, and its error contribution may be calculated with the following formula: 

 Zero Drift Error = ± Sensor Zero Drift (in watts) / Signal Power (in watts) × 100 % 

The zero drift rating of a particular power sensor may be found on the sensor datasheet, or the Boonton Electronics 

Power Sensor Manual.   Zero drift error is usually insignificant when measuring at high levels (25dB or more above 

the sensor‘s minimum power rating).  The drift specification usually indicates a time interval such as one hour.  If 

the time since performing a sensor Zero or AutoCal is very short, the zero drift is greatly reduced. 

 

Sensor Calibration Factor Uncertainty.  Sensor frequency calibration factors (―calfactors‖) are used to correct for 

sensor frequency response deviations.  These calfactors are characterized during factory calibration  of each sensor 

by measuring its output at a series of test frequencies spanning its full operating range, and storing the ratio of the 

actual applied power to the measured power at each frequency.  This ratio is called a calfactor.  During measurement 

operation, the power reading is multiplied by the calfactor for the current measurement frequency to correct the 

reading for a flat response. 
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The sensor calfactor uncertainty is due to uncertainties encountered while performing this frequency calibration (due 

to both standards uncertainty, and measurement uncertainty), and is different for each frequency.  Both worst case 

and RSS uncertainties are provided for the frequency range covered by each sensor, and are listed on the sensor 

datasheet and in the Boonton Electronics Power Sensor Manual. 

If the measurement frequency is between sensor calfactor entries, the most conservative approach is to use the 

higher of the two corresponding uncertainty figures.  It is also be possible to estimate the figure by linear 

interpolation. 

If the measurement frequency is identical to the AutoCal frequency, a calfactor uncertainty of zero should be  used, 

since any absolute error in the calfactor cancels out during AutoCal.  At frequencies that are close to the AutoCal 

frequency, the calfactor uncertainty is only partially cancelled out during AutoCal, so it is generally acceptable to 

take the uncertainty for the next closest frequency, and scale it down. 

 

 

6.5.3 Sample Uncertainty Calculations.  The following example shows calculations for a peak power sensor, Model 

56518.  The figures used in this example are meant to show the general technique, and does not apply to all 

applications.  Some ―common sense‖ assumptions have been made to illustrate the fact that uncertainty calculation 

is not an exact science, and requires some understanding of your specific measurement conditions. 

 

Typical Example:  Model 56518 Peak Power Sensor 

 

Model 4500B measurement conditions: 

 Source Frequency: 900 MHz 

 Source Power: 13 dBm (20mW) 

 Source SWR : 1.12 (reflection coefficient = 0.057) at 900 MHz 

 AutoCal Source: Internal 1GHz Calibrator 

 AutoCal Temperature: 38C 

 Current Temperature:  49C 

 

In this example, we will assume that an AutoCal was performed on the sensor earlier in the day, so time and temperature drift 

may play a role in the uncertainty. 

 

Step 1:  The Instrument Uncertainty figure for the Model 4500B is ±0.20%.  Since it has been a while since AutoCal, we‘ll 

use the published figure. 

  U
Instrument

 =  ±0.20% 

Step 2:  The Calibrator Level Uncertainty for the Model 4500B internal 1GHz calibrator may be calculated from the 

calibrator‘s specification.  The 0dBm uncertainty is 0.065dB, or 1.51%.  To this figure, we must add 0.03dB or 0.69% per 

5dB step from 0dBm.  13dBm is 2.6 5dB steps (13/5) away from 0dBm.  Any fraction must always be rounded to the next 

highest whole number, so we‘re 3 steps away. 

  U
CalLevel

 =  ±(1.51% + (3 × 0.69%)) 

   =  ±3.11% 
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Step 3:  The Calibrator Mismatch Uncertainty is calculated using the formula in the previous section, using the 1 GHz 

calibrator‘s published figure for ρ
CAL

 and calculating the value ρ
SNSR

 from the SWR specification on the 56518‘s datasheet. 

  ρ
CAL

 =  0.091 (internal 1 GHz calibrator‘s reflection coefficient) 

  ρ
SNSR

  =  (1.15 - 1) / (1.15 + 1) = 0.070 (calculate reflection coefficient of 57518, max SWR = 1.15 at 1 GHz) 

  U
CalMismatch

 =  ±2 × ρ
CAL

 × ρ
SNSR

 × 100 % 

   =  ±2 × 0.091 × 0.070 × 100 % 

   =  ±1.27% 

Step 4:  The Source Mismatch Uncertainty is calculated using the formula in the previous section, using the DUT‘s 

specification for ρ
SRCE

 and calculating the value ρ
SNSR

 from the SWR specification on the 56518‘s datasheet. 

  ρ
SRCE

 =  0.057 (source reflection coefficient at 900 MHz) 

  ρ
SNSR

  =  (1.15 - 1) / (1.15 + 1) = 0.070 (calculate reflection coefficient of 56518, max SWR = 1.15 at 0.9 GHz) 

  U
SourceMismatch

 =  ±2 × ρ
SRCE

 × ρ
SNSR

 × 100 % 

   =  ±2 × 0.057 × 0.070 × 100 % 

   =  ±0.80% 

Step 5:  The uncertainty caused by Sensor Shaping Error for a 56518 peak sensor is 4% at all levels, from the sensor‘s 

datasheet.  But since we‘re measuring at 900MHz, which is very close to the 1GHz AutoCal frequency, we‘ll assume that the 

frequency-dependent portion of the shaping error becomes very small, and we‘ll estimate that 2% remains. 

  U
ShapingError

 =  ±2.0 % 

Step 6:  The Sensor Temperature Drift Error depends on how far the temperature has drifted from the sensor calibration 

temperature, and the temperature coefficient of the sensor.  In our case, we are using a temperature compensated sensor, and 

the temperature has drifted by 11 degrees C (49C - 38C) from the AutoCal temperature.  We will use the equation in the 

previous section to calculate sensor temperature drift uncertainty. 

  U
SnsrTempDrift

 =  ± (0.93% + 0.069% /degreeC) 

   =  ± (0.93 + (0.069  11.0)) % 

   =  ± 1.69% 

Step 7:  This is a relatively high-level measurement, so the noise contribution of the sensor is probably negligible, but we‘ll 

calculate it anyway.  We‘ll assume modulate mode with default filtering.  The signal level is 13dBm, or 20mW.  The ―noise 

and drift‖ specification for the 57518 sensor is 50nW, from the sensor‘s datasheet.  Noise uncertainty is the ratio of these two 

figures. 

  U
Noise&Drift

  =  ± Sensor Noise (in watts) / Signal Power (in watts) 

   =  ±50.0e-9 / 20.0e-3  100 % 

   =  ±0.0003% 

Step 8:  A separate Sensor Zero Drift calculation does not need to be performed for peak sensors, since ―noise and drift‖ are 

combined into one specification, so we‘ll just skip this step. 



Boonton 4500B RF Peak Power Analyzer 

Application Notes 6-22 

Step 9:  The Sensor Calfactor Uncertainty needs to be interpolated from the uncertainty values in the Boonton Electronics 

Power Sensor Manual.  At 1 GHz, the sensor‘s calfactor uncertainty is 2.23%, and at 0.5GHz it is 1.99%.  Note, however, 

that we are performing our AutoCal at a frequency of 1GHz, which is very close to the measurement frequency.  This means 

that the calfactor uncertainty cancels to zero at 1GHz, as discussed in the previous section.  We‘ll use linear interpolation 

between 0.5GHz and 1GHz to estimate a value.  900MHz is only 20% (one fifth) of the way from 1GHz down to 500MHz, 

so the uncertainty figure at 0.5GHz can be scaled by one fifth. 

  U
CalFactor

  =  1.99 × (900
 
- 1000)  / (500 - 1000) 

   =  1.99 × 0.2 

   =  ±0.40% 

 

Step 10:  Now that each of the individual uncertainty terms has been determined, we can combine them to calculate the 

worst-case and RSS uncertainty values: 

  U (±%) K (U×K)2  ( %2 ) 

1. instrument uncertainty 0.20 0.500 0.0025 

2. calibrator level uncertainty 3.11 0.577 3.2201 

3. calibrator mismatch uncertainty 1.27 0.707 0.8062 

4. source mismatch uncertainty 0.80 0.707 0.3199 

5. sensor shaping error uncertainty 2.00 0.577 1.3333 

6. sensor temperature drift uncertainty 1.69 0.577 0.9509 

7. sensor noise & drift uncertainty 0.00 0.500 0.0000 

8. sensor calibration factor uncertainty 0.40 0.500 0.0400 

  ___________________________ 

Total worst case uncertainty: ±18.43% 

Total sum of squares:   6.6729 %2 

Combined Standard uncertainty U
C  

(RSS) :   ±2.58 % 

Expanded Uncertainty U (coverage factor k = 2) :   ±5.17 % 

 

From this example, different error terms dominate.  Since the measurement is close to the calibration frequency, and 

matching is rather good, the shaping and level errors are the largest.  Expanded uncertainty of 5.16% translates to an 

uncertainty of about 0.22dB in the reading. 

 

 

It should be noted that measurement uncertainty calculation is a very complex process, and the techniques shown here are 

somewhat simplified to allow easier calculation.  For a more complete information, the following publications may be 

consulted: 

1. ―ISO Guide to the Expression of Uncertainty in Measurement‖ (1995) 

 International Organization for Standardization, Geneva, Switzerland 

 ISBN 92-67-10188-9 

 

2. ―U.S. Guide to the Expression of Uncertainty in Measurement‖ (1996) 

 National Conference of Standards Laboratories, Boulder, CO 80301 

 ANSI/NCSL Z540-2-1996 
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7. Maintenance 
 

This section presents procedures for maintaining the Model 4500B. 

 

7.1 Safety 
                                                                                                                        

Although the 4500B has been designed in accordance with international safety standards, general 

safety precautions must be observed during all phases of operation and maintenance. Failure to 

comply with the precautions listed in the Safety Summary located in the front of this manual 

could result in serious injury or death. Service and adjustments should be performed only by 

qualified service personnel. 

 

 

7.2 Cleaning 
Painted surfaces can be cleaned with a commercial spray-type window cleaner or a mild detergent and water solution. 

 
 

    CAUTION  

 

 When cleaning the instrument, do not allow cleaning fluid to enter the fan intake and exhaust 

vents. Avoid using chemical cleaning agents which can damage painted or plastic surfaces. 

 

 

 

  

7.3 Inspection 
   

If the Model 4500B malfunctions, perform a visual inspection of the instrument. Inspect for signs 

of  damage caused by excessive shock, vibration or overheating. Inspect for broken wires, loose 

electrical connections, or accumulations of dust or other foreign matter. 

 

Correct any problems you discover and conduct a performance test to verify that the instrument is 

operational. (See section 7.5 Performance Verification). If the malfunction persists of the 

instrument fails the performance verification, contact Boonton Electronics for service. 

  

  

 

 

7.4  Lithium Batteries 

 

The 4500B contains two coin cell Lithium batteries to provide for memory storage of start-up 

information. One is located on the Single Board Computer and the other on the topside left front 

corner of the Mother Board Printed Circuit assembly. Both should have a life of 5-10 years. When 

replacement is necessary, they must be disposed of in strict compliance with local environmental 

regulations.  
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7.5 Software Upgrade 
 

Instrument operating software has been loaded into the Model 4500B at the factory. This consists 

of the Windows® XP Operating System and the Boonton Electronics Model 4500B Application 

Software. The Application Software will be updated from time to time to correct errors and add 

new features. Users can upgrade their software by downloading a special Software Upgrade 

package from the Boonton Electronics webpage, www.boonton.com.  Copy the upgrade file(s) into 

a USB drive, and plug the drive into one of the instrument‘s USB ports (front or rear). Follow the 

instructions included in the Upgrade package.  

 

 

 

After loading updated software, the instrument may or may not report an AutoCal error. To clear 

the error, for each installed channel, connect a sensor to the channel and calibrator and initiate 

AutoCal, as instructed in Subsection 4.1 Calibration. 

 

If an error other than AutoCal error exists, clear it by pressing the CLR key and repeat the AutoCal 

procedure. 

 
 Caution 

When loading new software into the Model 4500B, some or all stored instrument configurations 

and preset operating selections may be lost. Read the Upgrade Instructions carefully to determine 

which files may be affected.  
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7.6 Test Equipment 
 

Table 7-1 lists the equipment required to test and calibrate the Model 4500B. Any substitutions for 

the recommended test equipment may require you to modify the procedures provided in this 

subsection. 

 

 

Table 7-1. Verification Test Equipment 
 
  Test      Equipment Description 

 
 
Calibrator Frequency   Agilent Model 53181A Frequency Counter 

 

Calibrator Linearity   Agilent EPM Series Power Meter 

     Agilent Model 8481A NIST Certified Power Sensor (0.01 to 18 GHz) 

15 dB Type N Precision Attenuator 

 

Calibrator External Pulse Input  Agilent/Hewlett-Packard 8012B Pulse Generator 

 

Calibrator 0 dBm Output Power  Agilent Model 432A Analog Power Meter 

     Agilent Model 8478B NIST Certified Thermistor Mount  (0.01 to 18 GHz) 

     Agilent Model 34401A Multimeter 

 

Sensor Return Loss to 18 GHz  Anritsu Model 54147A (or 54169A) Scalar Network Analyzer 
  Anritsu Model 560-97NF50-1 SWR Autotester (0.01 to 18 GHz) 

  Anritsu Model 22N50 Open/Short (0.01 to 18 GHz) 

 

Sensor Return Loss to 40 GHz  Anritsu Model 54169A Scalar Network Analyzer  
Anritsu Model 560-98KF50 SWR Autotester (0.01 to 40 GHz) 

     Anritsu Model 22K50 Open/Short (0.01 to 40 GHz) 
     Anritsu Model 41KC-6 6dB Attenuator (0.5 to 40 GHz) 

 
Sensor Calibration Factor to 18 GHz   Tegam System IIA Power Meter Calibration System (.01 to 18 GHz). 

Agilent Model E8257C Signal Generator  

 

Sensor Calibration Factor to 40 GHz Anritsu Model 54169A Scalar Network Analyzer 
  Anritsu Model 560-98KF50 SWR Autotester (0.01 to 40 GHz) 

     Anritsu Model 22K50 Open/Short (0.01 to 40 GHz) 
     Anritsu Model 41KC-6 6-dB Attenuator (0.5 to 40 GHz) 

     Agilent EPM Series Power Meter 

Agilent 8487 NIST Certified Power Sensor with 11904D 2.4 mm (f) to  

K-Connector®  (m) adapter (0.05 to 40 GHz) 

 

GPIB Bus PC GPIB (IEEE-488) Controller (e.g. National Instruments Measurement &  

Automation Explorer or NI VISA Interactive Control). 
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7.7 Performance Verification 
 

 

The verification procedure demonstrates that the Model 4500B is performing according to the 

specifications published in section 1.6 Specifications. This procedure should be performed when 

the instrument is first put into service and after making repairs or adjustments. Performance 

verification should be repeated at least once every twelve months. 

 

 

Checklist   The verification procedure is outlined in Table 7-2, Verification Checklist. Each time you verify  

the instrument performance, photocopy the Checklist and record the instrument‘s performance on 

the copy to provide a record of instrument history. Attach additional sheets as instructed in the 

verification procedures. 

 

 

Fuse Rating   The 2 fuses should be size 3AG, 250 volt, 1.6 amp, Type-T. 

 

 

Serial Number  The instrument‘s serial number is printed on the rear panel and is stored in the instrument 

memory. View the stored serial number by selecting Util > Inst Status > REPORT. The stored 

serial number should match the number on the rear panel. If the numbers do not match, contact 

Boonton Electronics Service. Record the instrument serial number on the Checklist. 

 

 

Control Software Ver The control software version number appears on the screen at power-up and may be displayed by 

selecting Util > Inst Status > REPORT. Record the control software version number on the 

Checklist. 

 

 

 

 

Time and Date  The time and date are factory set and maintained internally by a battery-backed real time clock. 

The time is set initially to U.S. Eastern time and may be viewed and adjusted by selecting Util > 

Clock. The time and date are not updated while they are being displayed. Record the time and date 

on the Checklist. 

  

  

           

Sensor Serial Number  
The sensor serial number is printed on the sensor and is stored in the sensor‘s internal memory. 

View the sensor serial number (as well as the sensor model number and frequency range) by 

selecting Spcl > Sensor Data > CH # Sensor > REPORT   (# designates the numerals 1 or 2).  The 

stored sensor serial number should match the number printed on the sensor. If the numbers do not 

match, contact Boonton Electronics Service. Record the stored serial number on the Checklist. 
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Calibrator Frequency Verification 

 

Before performing the calibrator frequency and linearity verification procedure, photocopy Table 

7-2 and use it to record the measurement data. Attach the completed table to the Checklist. 

 

To verify the calibrator frequency accuracy, proceed as follows: 

 

1. Press the Init system key to initialize the Model 4500B. 

        

2. Set the calibrator output level to 0.0 dBm by selecting Calibrator > Set Level > 0.0 dBm. 

 

3. Set the calibrator output mode to CW by selecting  Spcl > Calibrator > Cal Mode > CW. 

 

4. Connect the frequency counter to the Model 4500B 1 GHz calibrator output. 

 

5. Enable the calibrator output by selecting Calibrator > Cal Output > On. 

 

6. Measure the calibrator frequency and record the test result in Table 7-2. 

 

 

 

Calibrator Linearity Verification 

 

Verify calibrator linearity by establishing a reference at 0.0 dBm and measuring the error at 

various test levels in the range from -30 to +20 dBm. The measurement tolerance shown in Tables 

7-3a and 7-3b reflect both the specified calibrator performance and the uncertainty of the 

measurement setup. To avoid the nonlinearity term associated with using the HP8481A at levels 

above +9 dBm, use a 15 dB pad to attenuate higher calibrator levels to below +5.0 dBm. 

 

Before performing the calibrator linearity verification procedure, photocopy Tables 7-3a and 7-3b 

and use the copies to record the measurement data. Attach the completed tables to the Checklist. 

 

To verify calibrator linearity: 

 

1. Mount the 8481A sensor on the EPM Power Meter. After the warm up period, calibrate and 

zero the EPM power meter using its internal 50 MHz calibrator. 

  

2. Disable the calibrator output by selecting Calibrator > Cal Output > OFF. 

 

3. Connect the 8481A sensor to the Model 4500B 1 GHz calibrator output through the 15 dB 

precision attenuator. 

 

4. Set the calibrator output level to 0.0 dBm by selecting Calibrator > Set Level >  0.0 dBm. 

 

5. Enable the calibrator output by selecting Calibrator > Cal Output > ON. 

 

6. Set a reference on the EPM power meter at 0.0 dBm. 

 

7. Enter the calibrator levels listed in Table 7-3a and record the EPM power meter  

measurements in the column labeled ―Measured.‖ 

 

8. Disable the calibrator output by selecting Calibrator > Cal Output > OFF. 
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9. Remove the 15 dB attenuator and connect the HP8481A sensor directly to the Model 4500B  

1 GHz calibrator output. 

  

10. Zero the EPM power meter. 

 

11. Set the calibrator output level to 0.0 dBm. 

 

12. Enable the calibrator output by selecting Calibrator > Cal Output > ON. 

 

13. Set a reference on the EPM power meter at 0.0 dBm. 

 

14. Enter the calibrator level listed in Table 7-3b and record the EPM power meter measurements 

in the column labeled ―Measured.‖ 

 

 

Calibrator 0 dBm Verification 

    
To verify the calibrator 0 dBm RF output power level accuracy: 

 
1. With the 432A power meter off and AC power disconnected, measure the resistance between the 

center pin of the Vrf connector on the rear panel of the 432A and pin 1 on the thermistor mount 

end of the 432A interconnect cable with the multimeter.  Record the multimeter indication in 

ohms to two decimal places.  The value of the measurement should be approximately 200 ohms. 

Label this measurement R.  

  

2. Connect the 432A to AC power and set the line switch to ON. 

 

3. Ensure the 4500B calibrator output is off by selecting Calibrator > Cal Output > OFF.  Limit the 

maximum output power to 0 dBm by selecting Calibrator > Max Power > 0 dBm.  Connect the 

thermistor mount to the 4500B calibrator output.  Wait thirty minutes before proceeding to the 

next step.  This will allow the thermistor mount to stabilize.  

 

4. Set the 432A RANGE switch to COARSE ZERO and adjust the COARSE ZERO control to obtain 

a zero indication on the 432A meter.  

 

5. Set the 432A RANGE switch to –20 dBm and depress the FINE ZERO switch on the front panel. 

 

 

 

6.  Set the 432A RANGE switch to 0 dBm.  Set the multimeter to measure VDC.  Connect the 

positive lead of the multimeter to the center pin of the Vcomp connector on the 432A rear panel.  

Connect the negative lead of the multimeter to the center pin of the Vrf connector on the 432A rear 

panel.  

 

7. Depress the FINE ZERO switch on the front panel.  Record the multimeter indication in VDC to 

six decimal places (nearest microvolt).  Label this measurement V0.   

 

Note    

The multimeter should read in mVDC. To convert from mVDC to VDC, multiply the 

multimeter indication by 1000. 
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8. Set the 4500B calibrator to 0 dBm (CW) by selecting Calibrator > Set Level > 0.0 dBm,   

Calibrator > Cal Mode > CW and Calibrator  > Cal Output > ON.  Record the multimeter 

indication in VDC to six decimal places.  Label this measurement V1.  

 

9. Disconnect the multimeter negative lead from the Vrf and connect the lead to the 432A chassis 

ground. Record the multimeter indication in VDC to four decimal places.  Label this measurement 

Vcomp. 

 

10. Calculate the 4500B calibrator‘s 0 dBm power output (Po) using the following formula: 

 

 

(2 × VCOMP × (V1  VO)) + (VO
2
 – V1

2
) 

     PO =  

         4 × R × EffectiveEfficiency 

 

Where:   Po = 4500B calibrator‘s 0 dBm power output 

Vcomp = Value recorded in step 9. 
V1 = Value recorded in step 8. 
V0  = Value recorded in step 7. 

R = Value recorded in step 1. 

Effective Efficiency = Calibration factor at 1 GHz for the thermistor mount 

(traceable to NIST).    

 

 

 

11. Verify Po is between 0.985 mW and 1.015 mW. 

  

12. If Po is in tolerance, record Po and disconnect all test equipment.  If Po is out of tolerance, go to 

Section 7.7 to re-calibrate. 

 

 

 

Sensor Return Loss Verification 

    

Table 7-4 lists the Model 4500B sensors and return loss specifications for each frequency range. 

 

Referring to Subsection 7-5, select the test equipment appropriate for the frequency range of your 

sensor(s) and measure sensor return loss. Photocopy Table 7-4 and use it to record the minimum 

return loss for each range applicable to your sensor(s). Attach the completed table to the Checklist. 

 

 

 

Sensor Linearity Performance Verification 

 
   Verify sensor linearity with the internal calibrator by measuring the deviation from a linear  

   response at various levels. The pulse and CW modes are verified separately. Measurement error at  

   low power levels is dominated by the noise and drift of the power sensor. The tolerances listed in  

   table 7-5 through 7-10 reflect the combination of linearity error, noise, and drift. 

 

   Before verifying sensor linearity, select and photocopy those Tables (7-5 through 7-10) that apply  

   to your sensor and use them to record the measurement data. Attach the completed tables to the  

   checklist. 
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   Pulse Mode. To verify sensor linearity in the pulse measurement mode, proceed as follows: 

 

1. Connect the peak power sensor cable to Channel 1 of the Model 4500B. 

  

2. Connect the peak power sensor to the Model 4500B calibrator output. 

 

3. Press the Init system key to reset the Model 4500B settings to their default states. 

 

4. Autocalibrate the sensor by selecting Chan # > Calibration > AutoCal > START. 

 

5. When the Autocal procedure is complete, set the calibrator output mode to CW by selecting 

Calibrator > Cal Mode > CW. 

 

6. Enable the calibrator output by selecting Calibrator > Cal > Output > On. 

 

7. Set the timebase to 100 ms by selecting Time > Timebase > 100 ms/Div. 

 

8.  Set Markers to CH 1 by pressing Mark > Extensions > MK 1 > CH 1. 

 

9.  Set Marker 1 to -400 ms by selecting Mark > Marker 1 > 400 ms. 

 

10.  Set Marker 2 to 400 ms by selecting Mark > Marker 2 > 400 ms. 

 

11.  Set the Delta Marker mode to Average by selecting Mark > Extensions > Delta > Marker 

Avg. 

 

12. Select one of the sensor data tables (Tables 7-5 through 7-7) according to the sensor type 

being tested. 

  

13. Set the calibrator to the levels listed in the selected table by pressing Calibrator > Set Level 

and record the AVG readout values in the table. 

 

14. If CH 2 is installed, connect the peak power sensor cable to CH2 of the Model 4500B. 

 

15. Turn on CH 2 by pressing Chan > Select CH > Channel > On. 

 

16.  Repeat steps 4 - 13, substituting CH 2 for CH 1. 

 

 

Modulated Mode (CW). To verify sensor linearity for the Modulated measurement mode, 

proceed as follows: 

 

1. Perform Steps 1 through 8 of the Pulse Mode verification procedure. 

  

2. Select Modulated measurement mode by pressing Measure > Modulated in the top level 

menu. 

 

3. Set Marker 1 to Channel 1 at 0 ms by selecting Mark > Extensions > MK 1 > CH 1 and Mark 

> Marker 1 > 0 ms. 
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4. Select one of the following tables (Tables 7-8 through 7-10) according to the sensor type 

being tested. 

 
5. Set the calibrator to the levels listed in the selected table and record the Marker 1 readout 

values in the table. Occasionally zero the sensor when testing levels below -10 dBm by 

selecting Chan 1 > Calibration > Zeroing > START. 

 

6. If CH 2 is installed, repeat Steps 1 through 5, substituting Channel 2 for Channel 1. 

 

 

 

Sensor Frequency Calibration Factor Verification 

 
   Verify the frequency calibration factors for the peak power sensors by comparing the Model  

   4500B measurements to those of an NIST traceable power sensor. The specifications for Boonton  

   peak power sensors are listed in Tables 7-11 through 7-14. 

 

Before performing the sensor frequency calibration factor verification procedure, photocopy the 

tables (7-11 through 7-14) that are applicable to your sensor(s) (as explained in the procedures) 

and use them to record the measurement data. The sensor types 56318, 56418, 56518 and 57318 

use Table 7-11 starting with the 0.50 GHz frequency. Ignore readings below 0.50 GHz for sensors 

of this type. Sensor type 57518 uses Table 7-11 starting with 0.10 GHz. Ignore readings below 

0.10 GHz for sensors of this type. Sensor types 56340 and 56540 use Table 7-14 starting with 0.50 

GHz. Ignore readings below 0.50 GHz for sensors of this type. Attach the completed table(s) to 

the Checklist. 

 

   Verify the sensor frequency calibration factor for each sensor as follows: 

 

1. Connect the peak power sensor cable to Channel 1 of the Model 4500B. 

 

2. Connect the peak power sensor to the Model 4500B calibrator output. 

 

3. Press the Init system key to reset the Model 4500B settings to their default states. 

 

4. Autocalibrate the sensor by selecting Chan 1 > Calibration > AutoCal > START.   

 
5. Set the Timebase to 100 ms by selecting Time > Timebase > 100 ms/Div. 

 

6. Set Marker 1 to -400 ms by selecting Mark > Marker 1 > 400 ms. 

 

7. Set Marker 2 to 400 ms by selecting Mark > Marker 2 > 400 ms. 

 

8. Set the Delta Marker mode to Average by selecting Mark > Extensions > Delta Marker > 

Avg. 

 

9. Connect the appropriate reference sensor (NIST traceable) to the EPM power meter. 

 

10. Calibrate and zero the EPM power meter using its internal 50 MHz calibrator. 

 

11. Tune the Network Analyzer to 1.0 GHz and adjust its output level to 0 dBm. 
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12. For Type N sensors, connect the K-Connector® to-N adapter and the 44-6 6-dB attenuator to 

the Network Analyzer output. 

 

13. For K-Connector® sensors, connect the 41KC-6 6 dB attenuator to the Network Analyzer 

output.  

 

14. Connect the appropriate calibrated reference sensor to the Network Analyzer output. 

 

15. Set a reference on the EPM power meter at 0.00 dBm. 

 

16. Select the table (Table 7-11 through 7-14) that corresponds to the peak power sensor type to 

be tested and set the Network Analyzer to the test frequencies listed in the table. 

 

17. For each test frequency, calculate the corrected power measurements using the NIST traceable 

test data. Record the results in the ―Reference‖ column of the table. 

 

18. Disconnect the calibrated reference sensor from the Network Analyzer output. 

 

19. Tune the Network Analyzer to 1.0 GHz. 

 

20. Connect the peak power sensor to the Network Analyzer output. 

 

21. Set the Model 4500B frequency to 1.00 GHz by selecting Meas > Freq CH 1 > 1.00 GHz. 

 

22.  Adjust the Model 4500B using Chan 1 > Extensions > dB Offset until the Delta Marker 

reads 0.00 dB. 

 

23. Tune the Network Analyzer  to the test frequencies listed in the selected table. 

 

24. For each test frequency of the Network Analyzer, set the Model 4500B to the same frequency, 

using the Meas > Freq CH 1 > ##.## GHz function. 

  

25. For each test frequency, calculate the corrected power measurements by subtracting the 

previously recorded calibrated power measurements in the ―Reference‖ column of the table 

from the Avg. Marker measurement. Record the result in the ―Measured‖ column. 

 

26. Disconnect the peak power sensor from the Network Analyzer output. 

 

27. Repeat Steps 1 through 26, substituting Channel 2 for Channel 1. 
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Sensor Risetime Verification 

 
   The risetime test uses the internal calibrator and the automatic measuring (Text) mode of the  

   Model 4500B to measure the risetime of the sensor. 

 

   Before performing the sensor risetime verification procedure, photocopy Table 7-15 and use it to  

   record the measurement data. Attach the completed table to the Checklist. If cable lengths other  

   than 5 feet are used with the sensors, check the cable length specification in Chapter 1. 

 

   To measure sensor risetime: 

 

1. Connect the peak power sensor cable to Channel 1 of the Model 4500B. 

  

2. Connect the peak power sensor to the calibrator output. 

 

3. Perform AutoCal, if required. 

 

4. Press the Init system key to reset the instrument‘s settings to their default states (High Video 

BW mode). 

 

5. Set the calibrator to pulse mode by selecting Calibrator > Cal Mode > Pulse. 

 

6. Turn the calibrator on by selecting Calibrator > Cal Output > On. 

 

   For each of the levels in Table 7-15: 

 

7. Set the timebase to the value of the specified risetime for the sensor under test by selecting 

Time > Timebase #. 

  

8. Set the calibrator output level to the value listed in Table 7-15 by selecting Calibrator > Set 

Level #. 

 

9. Set the trigger level to the value listed in Table 7-15 by selecting Trig > Trig Level #. 

 

10. Press the Text system key to change the operating mode to the text display. 

 

11. Record the risetime reading in Table 7-15. 

 

12. Repeat Steps 8 through 11 for each level listed in Table 7-15. 

 

13. Select Low Video BW by pressing Chan > Extensions > Video BW  > Low. 

  

14. Repeat Steps 7 through 11 while in the Low Video BW mode. 

 

15. To measure CH 2 risetime, repeat steps 1-14, substituting CH 2 for CH 1, and setting the 

trigger source to CH2 internal by pressing Trig > Trig Source > CH 2 Int. 
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Calibrator External Pulse Verification  

 
   Verify the external pulse input for the calibrator after the sensor has been calibrated (Subsection  

   7.7). The external pulse input is a TTL-compatible input located on the rear panel of the Model  

   4500B. To test the external pulse input, proceed as follows: 

 

1. Connect the Channel 1 sensor to the calibrator output. 

  

2. Press the Init system key to reset the instrument‘s settings to their default states. 

 

3. Set the calibrator output to 5 dBm by selecting Calibrator > Set Level > 5 dBm. 

 

4. Set the calibrator trigger to External by selecting Calibrator > Pulse > Source Ext. 

 

5. Select positive trigger polarity by selecting Calibrator > Pulse > Polarity > +. 

 

6. Set the calibrator to pulse mode by selecting Calibrator > Cal Mode Pulse. 

 

7. Turn the calibrator on by selecting Calibrator > Cal Output > On. 

 

8. Connect a BNC cable between the external pulse generator output and the EXT PULSE input 

on the Model 4500B. 

 

9. Set the external pulse generator output for 5 volts, 50 ohms, 100 ms pulse period, 50 ms pulse 

width. 

 

10.  The Model 4500B should display a 5 dBm pulsed waveform with the period and pulse width 

indicated in Step 9. 
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GPIB (IEEE-488) Bus Verification 

 
   Use the GPIB Controller  and the Model 4500B to perform basic operations. 

1. Connect the GPIB controller and the 4500B with a GPIB cable.  

 

2. Press the Init system key and Init > Defaults > LOAD to put the 4500B in a known state. 

 

3. Set the 4500B to use the SCPI language mode (instead of  the 4500A emulation mode) 

with the Util > Remote Conf  > GPIB > Emulate 4500A > OFF menu selection. 

 

4. Set the 4500B‘s GPIB address using the Util > Remote Conf  > GPIB > Bus Setup > 

Address # menu. Choose a convenient number between 1 and 30 that will be unique to 

the test instrument. 

 

5. Press the CLR key to clear any pending errors. 

 

6. Using the GPIB controller, send the command *IDN? to the Model 4500B. The REM 

message should appear in the lower right display rectangle indicating that the Model 

4500B is in the ―remote‖ mode; the LSN message should appear when the command is 

sent, indicating that the Model 4500B is ―listen addressed.‖ No error messages should 

appear on the display. 

 

7. Use the GPIB controller to read a string from the 4500B.  A string similar to the 

following  should be returned: 

 

Boonton Electronics,4500B,103,ver20051007 

 

The string contains the manufacturer‘s name, the model number, serial number and 

software version number. The TLK message should appear indicating that the Model 

4500B is in the talk mode. 

  

8. Using the GPIB controller, send the command SYSTem:ERRor? The lower case letters 

are optional. Use the GPIB controller to read a string from the 4500B.  The following 

should be received: 

0, "No Error" 

 

    If there were an error, a non-zero code number and a short message would be received. 

 

9. Press the Local system key. The REM message should disappear. If it does not, the GPIB 

controller may have sent the ―Local Lockout‖ command. If this is the case, send the ―Go 

To Local‖ command from the controller and the REM message will disappear. 
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7.8 1GHz Calibrator Output Level Calibration 
 
Calibrator 0 dBm Setting  
 

   Use the following procedure to calibrate the calibrator 0 dBm output setting: 

 

1. Perform steps 1 – 10 of the Calibrator 0 dBm Verification procedure in section 7.6 

  

2.  If Po is between 0.985 mW and 1.015 mW, the output power is within specification. No 

calibration is needed. Otherwise, continue to the next step. 

 

3. Enable the UUT cal mode by selecting Spcl > Servicing > Cal Mode > ON. 

 

4. View the UUT fixed cal number by selecting Spcl > Calibrator > Extensions > Fixed Cal. 

 

5. Calculate the new fixed cal (to two decimal places) with the following formula: 

 

   N = Fixed Cal – [10 × LOG10 (Po )] 

 

Where: N = New fixed cal. 

Fixed Cal = Value recorded in Section 7.6 step 14. 

Po = Value recorded in Section 7.6 step 10. 

 

6. Enter the new fixed cal into the UUT by selecting Spcl > Calibrator > Extensions > Fixed 

Cal > N  (where N is the number calculated in step 5). 

  

7. Disable UUT cal mode by selecting Spcl > Servicing > Cal Mode > OFF.  This step must be 

accomplished to set the new EEPROM checksum in the UUT calibrator.  

 

8. Verify the new 0 dBm power output by repeating Section 7.6, steps 1 through 10.  

 

This completes the calibration procedure. 
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Table 7-2.  4500B Verification Checklist 

Check fuse type and rating:  □ 3AG,250 volt, 1.6 amp, Type-T 
 

Instrument Serial Number                                                                     . 

 

Control Software Version                                                                     .                       

 

Instrument Time and Date                                                                                                . 

 

Sensor Serial Number    CH1          . CH2                             .                                            

 

Sensor Model Number    CH1         . CH2                             .                                             

Calibrator Frequency Verification*           1.023900 GHz min.  □  1.024100 GHz max. 

1.024 GHz @ 0.0 dBm 

Calibrator Linearity Verification*  □ 
 

Calibrator 0 dBm Verification                     Cal Level                 dbm Cal Level                  dbm                 

Run AutoCal     □ CH1   □ CH2  □ No CH2 

Sensor Return Loss Verification *  □ CH1   □ CH2 

Sensor Linearity*    □ CH1    □ CH2 

 

Sensor Frequency Calibration Factor  □ CH1   □ CH2 

 Verification* 

Sensor Risetime Verification*  □ CH1   □ CH2 

Check External Trigger    □ CH1   □ CH2 

Check External Calibrator   □ 

Check IEEE-488 Bus   □ 
 

*Attach separate data sheet. 
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Table 7-3a.  Calibrator Linearity - High Power Range 

     Cal Level          Minimum            Measured                  Maximum 

       (dBm)                (dBm)                   (dBm)                           (dBm) 

           20.0                    19.84                 __________                          20.16 

           15.0                    14.84                 __________                          15.16 

           10.0                      9.84                 __________                          10.16 

  
 

 

 

 Table 7-3b.  Calibrator Linearity - Low Power Range 

     Cal Level          Minimum            Measured                  Maximum 

       (dBm)                (dBm)                   (dBm)                          (dBm) 

           5.0                        4.9                   __________                             5.1 

          -5.0                      -5.1                   __________                            -4.9 

        -10.0                  -10.16                  __________                          -9.84 

        -15.0                  -15.16                  __________                        -14.84 

        -20.0                  -20.25                  __________                        -19.75 

        -25.0                  -25.25                  __________                        -24.75 

        -30.0                  -30.25                  __________                        -29.75 
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Table 7-4.  Sensor VSWR/Return Loss 

Sensor 
Model(s) 

Freq Range 
(GHz) 

VSWR Return Loss 
(dB) 

Measured 
(dB) 

56006 
57006 

0.5 to 6 1.25 -19.1 ________ 

56218 

0.03 to 2 1.15 -23.1 ________ 

2 to 6 1.20 -20.8 ________ 

6 to 18 1.25 -19.1 ________ 

56318 
57318 
58318 
59318 

0.5 to 2 1.15 -23.1 ________ 

2 to 16 1.28 -18.2 ________ 

16 to 18 1.34 -16.8 ________ 

56518 
57518 

0.5 to 2 1.15 -23.1 ________ 

2 to 6 1.20 -20.8 ________ 

6 to 16 1.28 -18.2 ________ 

16 to 18 1.34 -16.8 ________ 

56326 

0.5 to 2 1.15 -23.1 ________ 

2 to 4 1.20 -20.8 ________ 

4 to 18 1.45 -14.7 ________ 

18 to 26.5 1.50 -14.0 ________ 

57340 
57540 
59340 

0.5 to 4 1.25 -19.1 ________ 

4 to 38 1.65 -12.2 ________ 

38 to 40 2.00 -9.5 ________ 

 

For sensor models not listed, consult the sensor datasheet or Boonton Power Sensor Guide. 
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Table 7-5.  56218/318/326/340, 57318/340, 59318/340 
Sensor Linearity (Pulse) 

                                                                                  Measured 

     Cal Level          Minimum                CH1                       CH2                            Maximum 

       (dBm)                (dB)                      (dB)                        (dB)                                 (dB)   

  

         20.0                    19.91                _________               _________                             20.09 

         15.0                    14.91                _________               _________                             15.09 

         10.0                      9.91                _________               _________                             10.09 

            5.0                     4.90                _________               _________                               5.10 

            0.0                   -0.13                 _________              _________                                0.13 

          -5.0                    -5.22                 _________              _________                              -4.78 

        -10.0                  -10.49                _________               _________                              -9.51 

        -15.0                  -16.26                _________               _________                            -13.74 

        -20.0                  -23.05                _________              __________                           -19.75 

  

 
 

 

Table 7-6.   56518/526/540, 57518/540, 59340 
Sensor Linearity (Pulse) 

                                                                                     Measured 

     Cal Level          Minimum                CH1                            CH2               Maximum 

       (dBm)                (dB)                      (dB)                             (dB)                    (dB)   

  

         20.0                   19.83                __________                   __________             20.17 

         15.0                   14.83                __________                   __________            15.17 

         10.0                     9.83                __________                   __________            10.17 

           5.0                     4.83                __________                   __________              5.17 

           0.0                   -0.17                __________                    __________              0.17 

          -5.0                   -5.17                __________                    __________            -4.83 

        -10.0                 -10.17                __________                   __________             -9.83 

        -15.0                 -15.18                __________                   __________           -14.82 

        -20.0                 -20.19                __________                   __________           -19.81 

        -25.0                 -25.24                __________                   __________           -24.76 

        -30.0                 -30.39                __________                   __________           -29.62 

        -35.0                 -35.92                __________                   __________           -34.19 

        -40.0                 -43.18                __________                   __________           -38.07 
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 Table 7-7.  57006 Sensor Linearity (Pulse) 

                                                                                   Measured 

     Cal Level          Minimum               CH1                             CH2                      Maximum 

       (dBm)                (dB)                      (dB)                             (dB)                          (dB)   

  

         20.0                    19.01              ___________               ___________                     20.09 

         15.0                    14.01              ___________               ___________                     15.09 

         10.0                      9.01              ___________               ___________                     10.09 

            5.0                     4.01              ___________               ___________                        5.09 

            0.0                    -0.11              ___________               ___________                        0.11 

          -5.0                    -5.14               ___________               ___________                      -4.86 

        -10.0                  -10.26               ___________              ___________                      -9.74 

        -15.0                  -15.59               ___________              ___________                     -14.41 

        -20.0                  -21.52               ___________              ___________                     -18.48 

        -24.0                  -27.05               ___________              ___________                     -20.95 

  
 

 

Table 7-8.  56218/318/326/340, 57318/340, 59318/340 
Sensor Linearity (CW) 

                                                                                      Measured 

     Cal Level          Minimum               CH1                             CH2                      Maximum 

       (dBm)                (dB)                      (dB)                             (dB)                           (dB)   

  

         20.0                    19.91               ___________               ___________                     20.09 

         15.0                    14.91               ___________               ___________                     15.09 

         10.0                      9.91               ___________                ___________                     10.09 

            5.0                     4.91                ___________               ___________                       5.09 

            0.0                   -0.09                ___________                ___________                      0.09 

          -5.0                   -5.09                ___________                ___________                     -4.91 

        -10.0                  -10.11              ___________                ___________                      -9.89 

        -15.0                  -15.14              ___________                ___________                    -14.86 

        -20.0                  -20.26              ___________                ___________                    -19.74 

        -25.0                  -25.59              ___________                ___________                    -24.41 

        -30.0                  -31.52              ___________                ___________                    -28.48 

        -34.0                  -37.05              ___________                ___________                    -30.95 
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 Table 7-9.  56518/526/540, 57518/540 
Sensor Linearity (CW) 

                                                                                      Measured 

     Cal Level          Minimum               CH1                              CH2                 Maximum 

       (dBm)                (dB)                      (dB)                              (dB)                      (dB)   

  

         20.0                    19.83              ___________                ___________                20.17 

         15.0                    14.83              ___________                ___________                15.17 

         10.0                      9.83              ___________                ___________                10.17 

           5.0                      4.83              ___________                ___________                  5.17 

           0.0                    -0.17               ___________                ___________                 0.17 

         -5.0                     -5.17               ___________                ___________               -4.83 

       -10.0                   -10.17               ___________               ___________               -9.83 

       -15.0                   -15.17               ___________               ___________             -14.83 

       -20.0                   -20.17               ___________               ___________             -19.83 

       -25.0                   -25.18               ___________               ___________             -24.82 

       -30.0                   -30.19               ___________               ___________             -29.81 

       -35.0                   -35.24               ___________               ___________             -34.76 

       -40.0                   -40.39               ___________               ___________             -39.62 

       -45.0                   -45.92               ___________               ___________             -44.19 

       -50.0                   -53.18               ___________               ___________             -48.07 
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Table 7-10.  57006 Sensor Linearity (CW) 

                                                                                     Measured 

     Cal Level          Minimum               CH1                             CH2                    Maximum 

       (dBm)                (dB)                      (dB)                             (dB)                         (dB)   

  

         20.0                    19.91               ___________               ___________                   20.09 

         15.0                    14.91               ___________               ___________                   15.09 

         10.0                      9.91               ___________               ___________                   10.09 

           5.0                      4.91               ___________               ___________                     5.09 

           0.0                    -0.09               ___________               ___________                      0.09 

         -5.0                     -5.09               ___________               ___________                    -4.91 

       -10.0                   -10.11              ___________               ___________                     -9.89 

       -15.0                   -15.14              ___________               ___________                   -14.86 

       -20.0                   -20.26              ___________               ___________                   -19.74 

       -25.0                   -25.59              ___________               ___________                   -24.41 

       -30.0                   -31.52              ___________               ___________                   -28.48 

       -34.0                   -37.05              ___________               ___________                   -30.95 

  
 

 

Table 7-11.  56218/318/518, 57318/518 
Sensor Frequency Calfactor Accuracy 
                                                                                                 Measured 

Frequency      Reference         Minimum         CH1                     CH2              Maximum 
    (GHz)              (dBm)                  (dB)               (dB)                    (dB)                  (dB) 
  
      0.03               ________               -0.13            ________             ________               0.13 
      0.10               ________               -0.13            ________             ________               0.13 
      0.50               ________               -0.13            ________             ________               0.13 
      2.00               ________               -0.16            ________             ________               0.16 
      4.00               ________               -0.17            ________             ________               0.17 
      6.00               ________               -0.19            ________             ________               0.19 
      8.00               ________               -0.20            ________             ________               0.20 
    10.00               ________               -0.20           ________             ________               0.20 
    12.00               ________               -0.20           ________             ________               0.20 
    14.00               ________               -0.21           ________             ________               0.21 
    16.00               ________               -0.21           ________             ________               0.21 
    18.00               ________               -0.21           ________             ________               0.21 
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Table 7-12.  59318 Sensor Frequency Calfactor Accuracy 
                                                                                                 Measured 

Frequency      Reference         Minimum         CH1                     CH2              Maximum 
    (GHz)              (dBm)                  (dB)               (dB)                    (dB)                  (dB) 
  
      0.50               ________               -0.14            ________             ________               0.14 
      1.00               ________               -0.14            ________             ________               0.14 
      2.00               ________               -0.15            ________             ________               0.15 
      4.00               ________               -0.17            ________             ________               0.17 
      6.00               ________               -0.17            ________             ________               0.17 
      7.00               ________               -0.19            ________             ________               0.19 
      8.00               ________               -0.19            ________             ________               0.19 
    10.00               ________               -0.19            ________             ________               0.19 
    12.00               ________               -0.20            ________             ________               0.20 
    14.00               ________               -0.20            ________             ________               0.20 
    16.00               ________               -0.20            ________             ________               0.20 
    18.00               ________               -0.21            ________             ________               0.21 

 
 
   

 

 

Table 7-13.  56326, 56526 
Sensor Frequency Calfactor Accuracy 

                                                                                                 Measured 

Frequency       Reference         Minimum         CH1                    CH2            Maximum 

    (GHz)              (dBm)                   (dB)               (dB)                    (dB)                 (dB) 

  

      0.50              ________                  -0.14           ________             ________               0.14 

      2.00              ________                  -0.15           ________             ________               0.15 

      4.00              ________                  -0.19           ________             ________               0.19 

      6.00              ________                  -0.19           ________             ________               0.19 

      8.00              ________                  -0.20           ________             ________               0.20 

    10.00              ________                  -0.20           ________             ________               0.20 

    12.00              ________                  -0.20           ________             ________               0.20 

    14.00              ________                  -0.21           ________             ________               0.21 

    16.00              ________                  -0.21           ________             ________               0.21 

    18.00              ________                  -0.21           ________             ________               0.21 

    20.00              ________                  -0.26           ________             ________               0.26 

    22.00              ________                  -0.26           ________             ________               0.26 

    24.00              ________                  -0.26           ________             ________               0.26 

    26.50              ________                  -0.26           ________             ________               0.26 

  



Boonton 4500B RF Peak Power Analyzer 

Maintenance 7-23 

 

Table 7-14.  56340/540, 57340/540, 59340 
Sensor Frequency Calfactor Accuracy 

                                                                                                 Measured 
Frequency      Reference          Minimum         CH1                   CH2            Maximum 

    (GHz)              (dBm)                   (dB)               (dB)                  (dB)                  (dB) 

  

      0.10              ________                 -0.14           ________             ________               0.14 

      0.50              ________                 -0.14           ________             ________               0.14 

      2.00              ________                 -0.15           ________             ________               0.15 

      4.00              ________                 -0.19           ________             ________               0.19 

      6.00              ________                 -0.19           ________             ________               0.19 

      8.00              ________                 -0.20           ________             ________               0.20 

    10.00              ________                 -0.20           ________             ________               0.20 

    12.00              ________                 -0.20           ________             ________               0.20 

    14.00              ________                 -0.21           ________             ________               0.21 

    16.00              ________                 -0.21           ________             ________               0.21 

    18.00              ________                 -0.21           ________             ________               0.21 

    20.00              ________                 -0.26           ________             ________               0.26 

    22.00              ________                 -0.26           ________             ________               0.26 

    24.00              ________                 -0.26           ________             ________               0.26 

    26.50              ________                 -0.26           ________             ________               0.26 

    28.00              ________                 -0.31           ________             ________               0.31 

    32.00              ________                 -0.31           ________             ________               0.31 

    36.00              ________                 -0.31           ________             ________               0.31 

    40.00              ________                 -0.31           ________             ________               0.31 
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Table 7-15.  Sensor Risetime 

Sensor 
Model(s) 

Test Level 
(dBm) 

 
Min 

High BW 
Measured 

 
Max 

 
Min 

Low BW 
Measured 

 
Max 

56006 

20 

  

________ 

7ns   

  

  

15 ________   

10 ________   

5 ________   

0 ________   

-5 ________   

56218 

20 

  

________ 

150ns   

________ 

500ns 

15 ________ ________ 

10 ________ ________ 

5 ________ ________ 

0 ________ ________ 

-5 ________ ________ 

56318 
56326 
56340 

20 

  

________ 

15ns   

________ 

200ns 

15 ________ ________ 

10 ________ ________ 

5 ________ ________ 

0 ________ ________ 

-5 ________ ________ 

56518 
56540 

20 

  

________ 

100ns   

________ 

300ns 

15 ________ ________ 

10 ________ ________ 

5 ________ ________ 

0 ________ ________ 

-5 ________ ________ 

57006 

20 

  

________ 

7ns 1us 

________ 

10us 

15 ________ ________ 

10 ________ ________ 

5 ________ ________ 

0 ________ ________ 

-5 ________ ________ 
 

(TABLE CONTINUED ON NEXT PAGE) 

For sensor models not listed, consult the sensor datasheet or Boonton Power Sensor Guide. 
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Table 7-15 (continued).  Sensor Risetime 

Sensor 
Model(s) 

Test Level 
(dBm) 

 
Min 

High BW 
Measured 

 
Max 

 
Min 

Low BW 
Measured 

 
Max 

57318 
57340 

20 

  

________ 

15ns 1us 

________ 

10us 

15 ________ ________ 

10 ________ ________ 

5 ________ ________ 

0 ________ ________ 

-5 ________ ________ 

57518 
57540 

20 

  

________ 

100ns 1us 

________ 

10us 

15 ________ ________ 

10 ________ ________ 

5 ________ ________ 

0 ________ ________ 

-5 ________ ________ 

58318 

20 

  

________ 

10ns   

  

  

15 ________   

10 ________   

5 ________   

0 ________   

-5 ________   

59318 
59340 

20 

  

________ 

10ns 1us 

________ 

10us 

15 ________ ________ 

10 ________ ________ 

5 ________ ________ 

0 ________ ________ 

-5 ________ ________ 
 

For sensor models not listed, consult the sensor datasheet or Boonton Power Sensor Guide. 
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8. Appendix A 
 

 
 

SCPI Error Messages 
 

 
NO.   MESSAGE     DESCRIPTION 
 

-100 "Command Error"  

 

-101 "Invalid character" 

 

-102 "Syntax error" 

 

-108 "Parameter not allowed"  

 

-109  "Missing parameter" 

 

-113 "Undefined header" 

 

-121 "Invalid character in number" 

 

-131 "Invalid suffix" 

 

-213 "Init ignored" 

 

-221 "Settings conflict" 

 

-222 "Data out of range" 

 

-224 "Illegal parameter value" 

 

-227 "CAL Level > Limit"  Attempt to set the calibrator level greater than the Max Power level. 

 

-241 "Error hardware missing"  

 

-242 "CH2 Not Responding"  Channel 2 is not responding to instrument control. 

 

-243 "CH1 Not Responding"  Channel 1 is not responding to instrument control. 

  

-244 "No channel responding"  CH1 and CH2 do not respond to instrument control.  

 

-245 "Sensor Disconnected." 

 

-247 "No Calibrator"   The calibrator is not responding to instrument control.  

 

-248 "Keyboard error" 
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NO.   MESSAGE     DESCRIPTION 
 

-249 "FPGA download err" 

 

-256 "Error file not found" 

 

-295 "Command not in language." 

 

-296 "Data out of range, set to limit." 

 

-297 "Command not supported."    

 

-315 "Err license chksum" 

 

-317 ―Temp comp table error‖   

 

-318 "There is no image in the folder" 

 

-340 ―Calibration failed‖ 

 

-341 "Temp comp corr out range" 

 

-342 "Temp comp pwr non-mono" 

 

-343 "Temp comp pwr out range" 

 

-344 "Temp comp temp non-mono" 

 

-345 "Temp comp temp out range" 

 

-346 "Temp comp table length" 

 

-347 "Err expand TC" 

 

-348 "Temp comp # pwr entries" 

 

-349 "Temp comp # temp entries" 

 

-350 "Error queue overflow" 

 

-360 ―Communication Error‖ 

 

-364 ―Error reading/writing sensor‖ 

 

-370  ―Unlicensed function‖ 

 

-371 "Err CH2 Sensor Data"  Checksum failure of the Channel 2 sensor EEPROM. 

 

-372 "Err CH1 Sensor Data"  Checksum failure of the Channel 1 sensor EEPROM . 

 

-373       ―Measurement Error‖ 

 

-374 "DSP no results 
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NO.   MESSAGE     DESCRIPTION 
 

-375 "Cmd not accepted" 

 

-376 "I2C Timeout"   Software has timed-out while communicating over the I2C bus. 

 

-377 "No I2C Ack"   Missing Acknowledge signal while assessing the I2C bus. 

 

-378       ―Dsp Error‖ 

 

-397 "Err CW signal." 

 

-397 "Err CW signal." 

 

-399 "AutoSetup did not complete." 
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9. Appendix B 

 
 

Microsoft® Windows® XP Professional 
 

END-USER LICENSE AGREEMENT 

 
IMPORTANT-READ CAREFULLY: This End-User License Agreement ("EULA") is a legal agreement between you (either 

an individual or a single entity) and Microsoft® Corporation for the Microsoft® software product identified above, which  

includes computer software and may include associated media, printed materials, "online" or electronic documentation, 

and Internet-based services ("Product").   An amendment or addendum to this EULA may accompany the Product.  YOU 

AGREE TO BE BOUND BY THE TERMS OF THIS EULA BY INSTALLING, COPYING, OR OTHERWISE USING 

THE PRODUCT. IF YOU DO NOT AGREE, DO NOT INSTALL OR USE THE PRODUCT; YOU MAY RETURN IT TO 

YOUR PLACE OF PURCHASE FOR A FULL REFUND. 

 

1. GRANT OF LICENSE. Microsoft® grants you the following rights provided that you comply with all terms and 

conditions of this EULA: 

 

 

* Installation and use.  You may install, use, access, display and run one copy of the Product on a single computer, such 

as a workstation, terminal or other device ("Workstation Computer").  The Product may not be used by more than two 

(2) processors at  any one time on any single Workstation Computer. You may permit a maximum of ten (10) computers 

or other electronic devices (each a "Device") to connect to the Workstation Computer to utilize the services of the 

Product solely for File and Print services, Internet Information Services, and remote access (including connection 

sharing and telephony services).  The ten connection maximum includes any indirect connections made through 

"multiplexing" or other software or hardware which pools or aggregates connections.  Except as otherwise permitted by 

the NetMeeting, Remote Assistance, and Remote Desktop features described below, you may not use the Product to 

permit any Device to use, access, display or run other executable software residing on the Workstation Computer, nor 

may you permit any Device to use, access, display, or run the Product or Product's user interface, unless the Device has 

a separate license for the Product.    

 

* Mandatory Activation. The license rights granted under this EULA are limited to the first thirty (30) days after you 

first install  the Product unless you supply information required to activate your licensed copy in the manner described 

during the setup sequence of the Product.  You can activate the Product through the use of the Internet or telephone; toll 

charges may apply. You may also need to reactivate the Product if you modify your computer hardware or alter the 

Product.  There are technological measures in this Product that are designed to prevent unlicensed or illegal use of the 

Product. You agree that we may use those measures. 

 

* Storage/Network Use. You may also store or install a copy of the Product on a storage device, such as a network 

server, used only to install or run the Product on your other Workstation Computers over an internal network; however, 

you must acquire and dedicate an additional license for each separate Workstation Computer on or from which the 

Product is installed, used, accessed, displayed or run. A license for the Product may not be shared or used concurrently 

on different Workstation Computers.  

 

* Reservation of Rights. Microsoft reserves all rights not expressly granted to you in this EULA. 
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2. UPGRADES. To use a Product identified as an upgrade, you must first be licensed for the product identified by 

Microsoft® as eligible for the upgrade. After upgrading, you may no longer use the product that formed the basis for 

your upgrade eligibility. 

 

3. ADDITIONAL SOFTWARE/SERVICES.  This EULA applies to updates, supplements, add-on components, or 

internet-based services components, of the Product that Microsoft® may provide to you or make available to you after    

the date you obtain your initial copy of the Product, unless we provide other terms along with the update, supplement, 

add-on component, or Internet-based services component.  Microsoft® reserves the right to discontinue any Internet-

based services provided to you or made available to you through the use of the Product.  This EULA does not grant you 

any rights to use the Windows® Media Format Software Development Kit ("WMFSDK") components contained in the 

Product to develop a software application that uses Windows Media technology.  If you wish to use the WMFSDK to 

develop such an application, visit http://msdn.microsoft.com/workshop/imedia/windowsmedia/sdk/wmsdk.asp, accept a 

separate license for the WMFSDK, download the appropriate WMFSDK, and install it on your system.  

  

4. TRANSFER-Internal.  You may move the Product to a different Workstation Computer.  After the transfer, you must     

completely remove the Product from the former Workstation Computer.  Transfer to Third Party. The initial user of the     

Product may make a one-time transfer of the Product to another end user.  The transfer has to include all component 

parts, media, printed materials, this EULA, and if applicable, the Certificate of Authenticity.  The transfer may not be an 

indirect transfer, such as a consignment.  Prior to the transfer, the end user receiving the transferred Product must agree 

to all the EULA terms. No Rental.  You may not rent, lease, lend or provide commercial hosting services to third parties 

with the Product.  

                                         

5. LIMITATION ON REVERSE ENGINEERING, DECOMPILATION, AND DISASSEMBLY. You may not reverse 

engineer, decompile, or disassemble the Product, except and only to the extent that it is expressly permitted by 

applicable law notwithstanding this limitation.   

 

6. TERMINATION. Without prejudice to any other rights, Microsoft® may cancel this EULA if you do not abide by the  

terms and conditions of this EULA, in which case you must destroy all copies of the Product and all of its component 

parts. 

      

7. DESCRIPTION OF OTHER RIGHTS AND LIMITATIONS. 

 

* NetMeeting/Remote Assistance/Remote Desktop Features.  The Product contains NetMeeting, Remote Assistance, 

and Remote Desktop technologies that enable the Product or other applications installed on the Workstation Computer 

to be used remotely between two or more computers, even if the Product or application is installed on only one 

Workstation Computer.  You may use NetMeeting, Remote Assistance, and Remote Desktop with all Microsoft 

products; provided however, use of these technologies with certain Microsoft products may require an additional 

license.  For Microsoft and non-Microsoft products, you should consult the license agreement accompanying the 

applicable product or contact the applicable licensor to determine whether use of NetMeeting, Remote Assistance, or 

Remote Desktop is permitted without an additional license. 

 

* Consent to Use of Data.  You agree that Microsoft® and its affiliates may collect and use technical information 

gathered in any manner as part of the product support services provided to you, if any, related to the Product. 

Microsoft® may use this information solely to improve our products or to provide customized services or technologies 

to you.  Microsoft® may disclose this information to others, but not in a form that personally identifies you.    

 

* Internet Gaming/Update Features.  If you choose to utilize the Internet gaming or update features within the Product, it 

is necessary to use certain computer system, hardware, and software information to implement the features.   By using 

these features, you explicitly authorize Microsoft® or its designated agent to access and utilize the necessary 

information for Internet gaming and/or updating purposes. Microsoft® may use this information solely to improve our 

products or to provide customized services or technologies to you.  Microsoft® may disclose this information to others, 

but not in a form that personally identifies you.      

http://msdn.microsoft.com/workshop/imedia/windowsmedia/sdk/wmsdk.asp
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* Internet-Based Services Components.  The Product contains components that enable and facilitate the use of certain 

Internet-based services.  You acknowledge and agree that Microsoft® may automatically check the version of the 

Product and/or its components that you are utilizing and may provide upgrades or fixes to the Product that will be 

automatically   downloaded to your Workstation Computer.   

 

* Security Updates.  Content providers are using the digital rights management technology ("Microsoft® DRM") 

contained      in this Product to protect the integrity of their content ("Secure Content") so that their intellectual property, 

including copyright, in such content is not misappropriated.  Owners of such Secure Content ("Secure Content Owners") 

may, from       time to time, request Microsoft® to provide security related updates to the Microsoft® DRM components 

of the Product ("Security Updates") that may affect your ability to copy, display and/or play Secure Content through 

Microsoft® software or third party applications that utilize Microsoft® DRM.  You therefore agree that, if you elect to 

download a license from the Internet which enables your use of Secure Content, Microsoft may, in conjunction with 

such license, also download onto your computer such Security Updates that a Secure Content Owner has requested that 

Microsoft® distribute.  Microsoft® will not retrieve any personally identifiable information, or any other information, 

from your computer by downloading such Security Updates. 

 

8. NOT FOR RESALE SOFTWARE. Product identified as "Not for Resale" or "NFR," may not be resold, transferred or 

used for any purpose other than demonstration, test or evaluation. 

 

9. ACADEMIC EDITION SOFTWARE.  To use Product identified as "Academic Edition" or "AE," you must be a 

"Qualified Educational User."   For qualification-related questions, please contact the Microsoft Sales Information 

Center/One Microsoft Way/Redmond, WA 98052-6399 or the Microsoft subsidiary serving your country. 

       

10. EXPORT RESTRICTIONS. You acknowledge that the Product is of U.S. origin and subject to U.S. export jurisdiction.  

You agree to comply with all applicable international and national laws that apply to the Product, including the U.S. 

Export Administration Regulations, as well as end-user, end-use, and destination restrictions issued by U.S. and other     

governments. For additional information see <http://www.microsoft.com/exporting/>. 

 

11. LIMITED WARRANTY FOR PRODUCT ACQUIRED IN THE US AND CANADA.   

 

Microsoft® warrants that the Product will perform substantially in accordance with the accompanying materials for a 

period of ninety days from the date of receipt.  

 

If an implied warranty or condition is created by your state/jurisdiction and federal or state/provincial law prohibits 

disclaimer of it, you also have an implied warranty or condition, BUT ONLY AS TO DEFECTS DISCOVERED 

DURING THE PERIOD OF THIS LIMITED WARRANTY (NINETY DAYS). AS TO ANY DEFECTS 

DISCOVERED AFTER THE NINETY (90) DAY PERIOD, THERE IS NO WARRANTY OR CONDITION OF ANY 

KIND. Some states/jurisdictions do not allow limitations on how  long an implied warranty or condition lasts, so the 

above limitation may not apply to you. 

 

Any supplements or updates to the Product, including without limitation, any (if any) service packs or hot fixes provided 

to you after the expiration of the ninety day Limited Warranty period are not covered by any warranty or condition, 

express, implied or statutory. 

 

LIMITATION ON REMEDIES; NO CONSEQUENTIAL OR OTHER DAMAGES. Your exclusive remedy for any  

breach of this Limited Warranty is as set forth below.  Except for any refund elected by Microsoft®, YOU ARE NOT 

ENTITLED TO ANY DAMAGES, INCLUDING BUT NOT LIMITED TO CONSEQUENTIAL DAMAGES, if  the 

Product does not meet Microsoft's Limited Warranty, and, to the maximum extent allowed by applicable law, even if 

any remedy fails of its essential purpose.  The terms of Section 13 below ("Exclusion of Incidental, Consequential and 

Certain Other Damages")  are also incorporated into this Limited Warranty. Some states/jurisdictions do not allow the 

exclusion or limitation of incidental or consequential damages, so the above limitation or exclusion may not apply to 

you.  This   Limited Warranty gives you specific legal rights.  You may have others which vary from state/jurisdiction to 

state/jurisdiction.  
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YOUR EXCLUSIVE REMEDY.  Microsoft's and its suppliers' entire liability and your exclusive remedy shall be, at 

Microsoft's option from time to time exercised subject to applicable law, (a) return of the price paid (if any) for the 

Product, or (b) repair or replacement of the Product, that does not meet this Limited Warranty and that is returned to 

Microsoft® with    a copy of your receipt. You will receive the remedy elected by Microsoft® without charge, except 

that you are responsible for any expenses you may incur (e.g. cost of shipping the Product to Microsoft).  This Limited 

Warranty is void if failure of the Product has resulted from accident, abuse, misapplication, abnormal use or a virus. 

Any replacement Product will be warranted for the remainder of the original warranty period or thirty (30) days, 

whichever is longer. Outside the United States or Canada, neither these remedies nor any product support services 

offered by Microsoft® are available without proof     of purchase from an authorized international source.  To exercise 

your remedy, contact:  Microsoft, Attn. Microsoft Sales Information Center/One Microsoft Way/Redmond, WA  98052-

6399, or the Microsoft subsidiary serving your country.  

 

LIMITED WARRANTY FOR PRODUCT ACQUIRED OUTSIDE THE US or CANADA. 

 

FOR THE LIMITED WARRANTIES AND SPECIAL PROVISIONS PERTAINING TO YOUR PARTICULAR  

JURISDICTION, PLEASE REFER TO YOUR WARRANTY BOOKLET INCLUDED WITH THIS PACKAGE OR 

PROVIDED WITH THE SOFTWARE PRODUCT PRINTED MATERIALS. 

  

12. DISCLAIMER OF  WARRANTIES. The Limited Warranty that appears above is the only express warranty made to 

you and is provided in lieu of any other express warranties (if any) created by any documentation, packaging, or other 

communications.  Except for the Limited Warranty and to the maximum extent permitted by applicable law, Microsoft® 

and its suppliers provide the Product and support services (if any) AS IS AND WITH ALL FAULTS, and hereby 

disclaim all other warranties and conditions, either express, implied or statutory, including, but not limited to, any (if 

any) implied warranties, duties or conditions of merchantability, of fitness for a particular purpose, of reliability or 

availability, of accuracy or completeness of responses, of results, of workmanlike effort, of lack of viruses, and of lack 

of negligence, all with regard to the Product, and the provision of or failure to provide support or other services, 

information, software, and related content through the Product or otherwise arising out of the use of the Product.  ALSO, 

THERE IS NO WARRANTY OR CONDITION OF TITLE, QUIET ENJOYMENT, QUIET POSSESSION, 

CORRESPONDENCE TO DESCRIPTION OR NON-INFRINGEMENT WITH REGARD TO THE PRODUCT. 

 

13. EXCLUSION OF INCIDENTAL, CONSEQUENTIAL AND CERTAIN OTHER DAMAGES.  TO THE MAXIMUM 

EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL MICROSOFT® OR ITS SUPPLIERS BE 

LIABLE FOR ANY SPECIAL, INCIDENTAL, PUNITIVE, INDIRECT, OR CONSEQUENTIAL DAMAGES 

WHATSOEVER  (INCLUDING, BUT NOT LIMITED TO, DAMAGES FOR LOSS OF PROFITS OR 

CONFIDENTIAL OR OTHER INFORMATION, FOR BUSINESS INTERRUPTION, FOR PERSONAL INJURY, 

FOR LOSS OF PRIVACY, FOR FAILURE TO MEET ANY DUTY INCLUDING OF GOOD FAITH OR OF    

REASONABLE CARE, FOR NEGLIGENCE, AND FOR ANY OTHER PECUNIARY OR OTHER LOSS     

WHATSOEVER) ARISING OUT OF OR IN ANY WAY RELATED TO THE USE OF OR INABILITY TO USE 

THE PRODUCT, THE PROVISION OF OR FAILURE TO PROVIDE SUPPORT OR OTHER SERVICES, 

INFORMATON, SOFTWARE, AND RELATED CONTENT THROUGH THE PRODUCT OR OTHERWISE 

ARISING OUT OF THE USE OF THE PRODUCT, OR OTHERWISE UNDER OR IN CONNECTION WITH ANY 

PROVISION OF THIS EULA, EVEN IN THE EVENT OF THE FAULT, TORT (INCLUDING NEGLIGENCE), 

STRICT LIABILITY, BREACH OF CONTRACT OR BREACH OF WARRANTY OF MICROSOFT® OR ANY     

SUPPLIER, AND EVEN IF MICROSOFT® OR ANY SUPPLIER HAS BEEN ADVISED OF THE POSSIBILITY OF 

SUCH DAMAGES.  

 

14. LINKS TO THIRD PARTY SITES.  You may link To third party sites through the use of the Product.  The third party 

sites are not under the control of Microsoft®, and Microsoft® is not responsible for the contents of any third party sites, 

any links contained in third party sites, or any changes or updates to third party sites. Microsoft® is not responsible for  

webcasting or any other form of transmission received from any third party sites. Microsoft® is providing these links to 

third party sites to you only as a convenience, and the inclusion of any link does not imply an endorsement by Microsoft 

of the third party site.             
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15. LIMITATION OF LIABILITY AND REMEDIES. Notwithstanding any damages that you might incur for any    reason 

whatsoever (including, without limitation, all damages referenced above and all direct or general damages), the entire 

liability of Microsoft and any of its suppliers under any provision of this EULA and your exclusive remedy for all of the 

foregoing (except for any remedy of repair or replacement elected by Microsoft with respect to any breach of the  

Limited Warranty) shall be limited to the greater of the amount actually paid by you for the Product or U.S.$5.00.  The 

foregoing limitations, exclusions and disclaimers (including Sections 11, 12 and 13 above) shall apply to the maximum 

extent permitted by applicable law, even if any remedy fails its essential purpose. 

   

16. U.S. GOVERNMENT LICENSE RIGHTS. All Product provided to the U.S. Government pursuant to solicitations 

issued on or after December 1, 1995 is provided with the commercial license rights and restrictions described elsewhere 

herein.  All Product provided to the U.S. Government pursuant to solicitations issued prior to December 1, 1995 is 

provided with "Restricted Rights" as provided for in FAR, 48 CFR 52.227-14 (JUNE 1987) or DFAR, 48 CFR 252.227-

7013 (OCT 1988), as applicable.  

 

17. APPLICABLE LAW.  If you acquired this Product in the United States, this EULA is governed by the laws of the State 

of  Washington.  If you acquired this Product in Canada, unless expressly prohibited by local law, this EULA is 

governed by the laws in force in the Province of Ontario, Canada; and, in respect of any dispute which may arise 

hereunder, you consent to the jurisdiction of the federal and provincial courts sitting in Toronto, Ontario. If this   

Product was acquired outside the United States, then local law may apply.  

 

18. ENTIRE AGREEMENT.  This EULA (including any addendum or amendment to this EULA which is included with the 

Product) are the entire agreement between you and Microsoft relating to the Product and the support services (if any) 

and they supersede all prior or contemporaneous oral or written communications,  proposals and representations with 

respect to the Product or any other subject matter covered by this EULA.  To the extent the terms of any Microsoft 

policies or programs for support services conflict with the terms of this EULA, the terms of this EULA shall control. 

 

19. The Product is protected by copyright and other intellectual property laws and treaties. Microsoft® or its suppliers own    

the title, copyright, and other intellectual property rights in the Product.  The Product is licensed, not sold. 

 

 

EULAID:WX.4_PRO_RTL_EN 
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"Boonton Electronics Model 4500B Operating Software" 
 

END-USER LICENSE AGREEMENT  
 

IMPORTANT-READ CAREFULLY: This End-User License Agreement ("EULA") is a legal agreement between you (either 

an individual or a single entity) and Boonton Electronics, a subsidiary of the Wireless Telecom Group, Inc., for the Boonton 

Electronics software product identified above, which includes instrument software and may include associated media, printed 

materials, "online" or electronic documentation, and Internet-based services ("Product").  An amendment or addendum to this 

EULA may accompany the Product.   

 

YOU AGREE TO BE BOUND BY THE TERMS OF THIS EULA BY INSTALLING, COPYING, OR OTHERWISE 

USING THE PRODUCT. IF YOU DO NOT AGREE, DO NOT INSTALL OR USE THE PRODUCT; YOU MAY 

RETURN IT TO YOUR PLACE OF PURCHASE FOR A FULL REFUND. 

 

1. GRANT OF LICENSE. Boonton Electronics grants you the following rights provided that you comply with all 

terms and conditions of this EULA:   

  

*Installation and use.  You may install, use, access, display and run one copy of the Product on a single Model  

4500B RF Peak Power Analyzer.  The Product may not be used on any other hardware.  

 

*Reservation of Rights. Boonton Electronics reserves all rights not expressly granted to you in this EULA. 

 

2. UPGRADES. To use a Product identified as an upgrade, you must first be licensed for the product identified by 

Boonton Electronics as eligible for the upgrade. After upgrading, you may no longer use the product that 

formed the basis for your upgrade eligibility. 

 

3. TRANSFERRABILITY.  This product is transferable only to other Boonton Model 4500B RF Peak Power 

Analyzer instruments.  You may not move the Product to a different instrument or computer. 

 

4. LIMITATION ON REVERSE ENGINEERING, DECOMPILATION, AND DISASSEMBLY. You may not 

reverse engineer, decompile, or disassemble the Product, except and only to the extent that it is expressly     

permitted by applicable law notwithstanding this limitation.   

 

5. TERMINATION. Without prejudice to any other rights, Boonton Electronics may cancel this EULA if you do 

not abide by the terms and conditions of this EULA, in which case you must destroy all copies of the Product 

and all of its component parts. 

 

6. NOT FOR RESALE SOFTWARE. This software product is "Not for Resale" and may not be separately resold, 

transferred or used for any purpose other than operation of a Boonton Electronics Model 4500B RF Peak Power 

Analyzer. 

 

7. EXPORT RESTRICTIONS. You acknowledge that the Product is of U.S. origin and subject to U.S. export 

jurisdiction.  You agree to comply with all applicable international and national laws that apply to the Product, 

including the U.S. Export Administration Regulations, as well as end-user, end-use, and destination     

restrictions issued by U.S. and other governments. 
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8. U.S. GOVERNMENT LICENSE RIGHTS. All Product provided to the U.S. Government pursuant to    

solicitations issued on or after December 1, 1995 is provided with the commercial license rights and     

restrictions described elsewhere herein.  All Product provided to the U.S. Government pursuant to solicitations    

issued prior to December 1, 1995 is provided with "Restricted Rights" as provided for in FAR, 48 CFR 52.227-

14 (JUNE 1987) or DFAR, 48 CFR 252.227-7013 (OCT 1988), as applicable.  

 

9. APPLICABLE LAW.  If you acquired this Product in the United States, this EULA is governed by the laws of 

the State of  New Jersey. If this Product was acquired outside the United States, then local law may apply.  

 

10. ENTIRE AGREEMENT.  This EULA (including any addendum or amendment to this EULA which is included 

with the Product) are the entire agreement between you and Boonton Electronics relating to the Product and the 

support services (if any) and they supersede all prior or contemporaneous oral or written communications,  

proposals and representations with respect to the Product or any other subject matter covered by this EULA.  To 

the extent the terms of any Boonton Electronics policies or programs for support services conflict with the terms 

of this EULA, the terms of this EULA shall control. 

 

11. The Product is protected by copyright and other intellectual property laws and treaties. Boonton Electronics 

owns the title, copyright, and other intellectual property rights in the Product.  The Product is licensed, not sold. 
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10. Appendix C 

 
Repair Policy 

 

Model 4500B Instrument.  

If the Boonton Model 4500B RF Peak Power Analyzer is not operating correctly and requires service, contact the Boonton 

Electronics Service Department for return authorization. You will be provided with an RMA number and shipping 

instructions. Customers outside the USA should contact the authorized Boonton distributor for your area. The entire 

instrument must be returned in its original packing container. If the original container is not available, Boonton Electronics 

will ship a replacement container and you will be billed for the container cost and shipping charges. 

Boonton Peak Power Sensors.  

Damaged or defective peak power sensors are repaired as separate accessories. Note that sensors which have failed due to 

overloading, improper mating, or connecting to an out-of-tolerance connector are not considered defective and will not be 

covered by the Boonton Warranty. If repair is needed, contact the Boonton Electronics Service Department for return 

authorization. You will be provided with an RMA number and shipping instructions. Customers outside the USA should 

contact the authorized Boonton distributor for your area. Only the defective sensor should be returned to Boonton, not the 

entire instrument. The sensor must be returned in its original packing container. If the original container is not available, 

Boonton Electronics will ship a replacement container and you will be billed for the container cost and shipping charges. If a 

new sensor is ordered, note that it does not include a sensor cable - this item must be ordered separately. 

Contacting Boonton. 

Customers in the United States having questions or equipment problems may contact Boonton Electronics directly during 

business hours (8 AM to 5 PM Eastern) by phoning (973) 386-9696. FAX messages may be sent at any time to (973) 386-

9191. E-mail inquiries should be sent to service@boonton.com. International customers should contact their 

authorized Boonton Electronics representative for assistance. A current list of authorized US and international representatives 

is available on the Boonton website at  www.boonton.com.  

 
 

 

mailto:service@boonton.com
http://www.boonton.com/
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Limited Warranty 
 
Boonton Electronics warrants its products to the original Purchaser to be free from defects in material and workmanship and 

to operate within applicable specifications for a period of one year from date of shipment for instruments, probes, power 

sensors and accessories. Boonton Electronics further warrants that its instruments will perform within all current 

specifications under normal use and service for one year from date of shipment. These warranties do not cover active devices 

that have given normal service, sealed assemblies which have been opened, or any item which has been repaired or altered 

without Boonton‘s authorization. 

Boonton‘s warranties are limited to either the repair or replacement, at Boonton‘s option, of any product found to be 

defective under the terms of these warranties. 

There will be no charge for parts and labor during the warranty period. The Purchaser shall prepay inbound shipping charges 

to Boonton or its designated service facility and shall return the product in its original or an equivalent shipping container. 

Boonton or its designated service facility shall pay shipping charges to return the product to the Purchaser for domestic 

shipping addresses. For addresses outside the United States, the Purchaser is responsible for prepaying all shipping charges, 

duties and taxes (both inbound and outbound). 

THE FOREGOING WARRANTIES ARE IN LIEU OF ALL OTHER WARRANTIES, EXPRESS OR 

IMPLIED, INCLUD-ING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 

MERCHANTABILITY AND FITNESS FOR A PAR-TICULAR PURPOSE. Boonton will not be liable 

for any incidental damages or for any consequential damages, as defined in Section 2-715 of the 

Uniform Commercial Code, in connection with products covered by the foregoing warranties. 

 

 


	General Information
	1.1 Organization
	1.2 Description
	1.3 Features
	1.4 Accessories
	Standard
	Optional
	Sensors

	1.5 Optional Configurations
	1.5.1 Other Options
	1.6 Specifications
	SENSOR INPUTS
	TIME BASE
	X-AXIS (Statistical)
	TRIGGER
	CALIBRATION SOURCE
	MEASUREMENT SYSTEM
	STATISTICAL ACQUISITION
	SYSTEM DISPLAYS
	PULSE AND MODULATED MODE MARKER MEASUREMENTS
	STATISTICAL MODE MARKER MEASUREMENTS
	PULSE MODE AUTOMATIC MEASUREMENTS
	MODULATED MODE AUTOMATIC MEASUREMENTS
	STATISTICAL MODE AUTOMATIC MEASUREMENTS
	WAVEFORM STORAGE
	EXTERNAL INTERFACES
	OTHER CHARACTERISTICS


	Installation
	2.1 Unpacking & Repacking
	2.2 Power Requirements
	2.3 Connections
	2.4 Preliminary Check

	Getting Started
	3.1 Organization
	3.2 Operating Controls, Indicators and Connections
	3.3 LCD Monitor Display
	3.4 Initialize
	3.5 Calibration
	3.6 Practice Exercise for Pulse Power Measurements
	3.7 Practice Exercise for Statistical Power Measurements (4500B Opt 10 only)

	Operation
	4.1 Calibration
	4.2 Manual Operation
	4.3 Menu Conventions
	4.4 Data Entry Controls
	4.5 Display Data
	4.6 Top Level Menu
	Table 4-1. Top Level Menu

	4.7 System Keys
	4.8 Function Keys
	4.9 CHAN Key and Chan # > Menu
	Table 4-2. Chan # > Menu
	Table 4-3. Chan # > Calibration > Submenu
	Table 4-4. Chan # > Extensions > Submenu
	Table 4-4A. Chan # > Extensions > Corrections > Submenu
	Table 4-4B. Chan # > Extensions > Define Pulse > Submenu
	Table 4-5. Chan Math > Menu
	Table 4-6. Chan Math > Expression > Submenu
	resolution in a floating point array. This            Chan Mem # >


	4.10 TIME (STAT) Key and Time > Menu
	Table 4-8A. Time > Menu
	Table 4-8B. Statistics > Menu
	Table 4-8C. Statistics > Term Settings > Submenu

	4.11 TRIG Key and Trig > Menu
	Table 4-9. Trig > Menu
	Table 4-9A. Trig > B Trig > Submenu
	Table 4-9B. Trig > Menu (modulated)
	Table 4-9C. Trig > Menu (statistical)

	4.12 MARK Key and Mark > Menu
	Table 4-11. Mark > Menu
	Table 4-12. Mark > Extensions > Submenu

	4.13 REF Key and Ref > Menu
	Table 4-13. Ref > Menu

	4.14 MEAS Key and Meas > Menu
	Table 4-14. Meas > Menu (pulse and modulated)
	Table 4-15. Meas > Menu (pulse and modulated) (continued)
	Table 4-15A. Meas > Auto Meas Menu (pulse) (continued)
	Table 4-15B. Meas > Auto Meas > Skew > Submenu (pulse)
	Table 4-16. Meas > Param Meas > Submenu (pulse)
	Table 4-16A. DISPLAY PARAMETER TABLE
	Table 4-17. Meas > Menu (Statistical)

	4.15 UTIL Key and Util > Menu
	Table 4-18. Util > Menu
	Table 4-19. Util > Remote Conf > Submenu
	Table 4-20. Util > Remote Conf > GPIB > Submenu
	Table 4-21. Util > Remote Conf > GPIB > Setup > Submenu
	Table 4-21A. Util > Remote > LAN Config > Submenu (Opt 11 only)
	Table 4-22. Util > Remote Conf > Emulation > Submenu
	Table 4-23. Util > Disk (1 of 2) > Submenu
	Table 4-24. Util > Disk (1 of 2) > Rename > Submenu
	Table 4-25. Util > Disk (1 of 2) > Copy > Submenu
	Table 4-26. Util > Disk (2 of 2) > Submenu
	Table 4-27. Util > Disk (2 of 2) > Folder > Submenu
	Table 4-28. Util > Disk (2 of 2) > Folder > Create  > Submenu
	Table 4-29. Util > Hardcopy > Submenu
	Table 4-30. Util > Clock > Menu

	4.16 CAL Key and Calibrator > Menu
	Table 4-31. Calibrator > Menu
	Table 4-32. Calibrator > Pulse (Preset) > Submenu
	Table 4-33. Calibrator > Pulse (Variable) > Submenu
	Table 4-34. Calibrator > Extensions > Submenu

	4.17 PRGM Key and Prgm > Menu
	Table 4-35. Prgm > Menu
	Table 4-36. Prgm > Inst Store > Menu
	Table 4-38. Prgm > Inst Store > Filename > Menu
	Table 4-39. Prgm > Inst Recall > Menu
	Table 4-40. Prgm > Mem Save > Menu
	Table 4-41. Prgm > WFM Store > Menu
	Table 4-42. Prgm > WFM Recall > Menu
	Table 4-43. Prgm > Trace Data > Menu

	4.18 DISP Key and Disp > Menu
	Table 4-44. Display > Menu
	Table 4-45. Display > Screen Saver > Submenu
	Table 4-46. Display > Format > Submenu
	Table 4-47. Display > Format > Trace Type (1 of 2 ) > Submenu
	Table 4-48. Display > Format > Trace Type (2 of 2 ) > Submenu
	Table 4-49. Display > Format > Set Color > Submenu

	4.19. SPCL Key and Spcl > Menu
	Table 4-50. Spcl > Menu
	Table 4-51. Spcl >Trigger Out>Menu
	Table 4-52. Spcl > Servicing > Submenu
	Table 4-53. Spcl > Servicing > Time Skew Adj > Submenu
	Table 4-54. Spcl > Sensor Data > Submenu
	Table 4-55. Spcl > Sensor Data > CH 1,(2) Detail > Submenu
	Table 4-56. Spcl > Exit > Submenu

	4.20 Automatic Operation
	AUTOMATIC MEASUREMENTS – PULSE MODE
	Table 4-57. Pulse Mode – Automatic Measurements I
	Table 4-58. Pulse Mode – Automatic Measurements II

	AUTOMATIC MEASUREMENTS – MODULATED MODE
	Table 4-59. Modulated Mode – Automatic Measurements I
	Table 4-60. Modulated Mode – Automatic Measurements II

	AUTOMATIC MEASUREMENTS – STATISTICAL MODE (Opt 10 only)
	Table 4-61. Statistical Mode – Automatic Measurements I
	Table 4-62. Statistical Mode – Automatic Measurements II


	4.21 Model 4500B MENU MAP
	Table 4-63. Control Menu Structure


	Remote Operation
	5.1  GPIB CONFIGURATION
	5.2   4500A EMULATION MODE
	5.3  SCPI LANGUAGE
	5.4  BASIC MEASUREMENT OPERATION.
	5.4.1  Service Request

	5.5  SCPI COMMAND REFERENCE.
	5.5.1  IEEE 488.2 Commands
	*CLS
	*ESE
	*ESR?
	*IDN?
	*OPC
	*OPC?
	*OPT?
	*RST
	*SRE
	*STB?
	*TRG
	*TST?
	*WAI

	5.5.2  CALCulate Subsystem
	CALCulate:AMEAsure:BOTtom
	CALCulate:AMEAsure:EDGEdelay
	CALCulate:AMEAsure:MODE
	CALCulate:MATH:ARGA
	CALCulate:MATH:ARGB
	CALCulate:MATH:OPERator
	CALCulate:MODE
	CALCulate:PKHLD
	CALCulate:STATe
	CALCulate: SYSTRK
	CALCulate:UNIT

	5.5.3  CALibration Subsystem
	CALibration:AUTO
	CALibration:AUTO
	CALibration:USER:FREQcal
	CALibration:ZERO
	CALibration:ZERO

	5.5.4  DISPlay Subsystem
	DISPlay:ACTive
	DISPlay:BACKlight:BRIGhtness
	DISPlay:BRIGhtness:COLor
	DISPlay:BRIGhtness:BLUE
	DISPlay:BRIGhtness:GREEn
	DISPlay:BRIGhtness:INIT
	DISPlay:BRIGhtness: RED
	DISPlay:CLEar
	DISPlay:DECAdes
	DISPlay:ENVElope
	DISPlay:FULLscale
	DISPlay:GRID
	DISPlay:HEADer
	DISPlay:HELP
	DISPlay:MODE
	DISPlay:MODUlated:TIMEBASE
	DISPlay:PARAmeter:MODE
	DISPlay:CHANnel:BOTtom:LEFT
	DISPlay:CHANnel:BOTtom:MIDdle
	DISPlay:CHANnel:BOTtom:RIGHt
	DISPlay:CHANnel: MIDdle: LEFT
	DISPlay:CHANnel: MIDdle:MIDdle
	DISPlay:CHANnel: MIDdle:RIGHt
	DISPlay:CHANnel:TOP:LEFT
	DISPlay:CHANnel:TOP: MIDdle
	DISPlay:CHANnel:TOP: RIGHt
	DISPlay:PARAmeter:BOTtom:LEFT
	DISPlay:PARAmeter:BOTtom:MIDdle
	DISPlay:PARAmeter:BOTtom:RIGHt
	DISPlay:PARAmeter:MIDdle:LEFT
	DISPlay:PARAmeter:MIDdle:MIDdle
	DISPlay:PARAmeter:MIDdle:RIGHt
	DISPlay:PARAmeter:TOP:LEFT
	DISPlay:PARAmeter:TOP:MIDdle
	DISPlay:PARAmeter:TOP:RIGHt
	DISPlay:PCTOFST
	DISPlay:PCTSCALE
	DISPlay:PERSistence
	DISPlay:PLABel:MODE
	DISPlay:PLABel:TEXTA
	DISPlay:PLABel:TEXTB
	DISPlay:PLABel:TEXTC
	DISPlay:PLABel:TEXTD
	DISPlay:PULSe:TIMEBASE
	DISPlay:SCREensaver:BRIGhtness
	DISPlay:SCREensaver:STATe
	DISPlay:SCREensaver:TIME
	DISPlay:SKEW:REFerence
	DISPlay:STATistical:MODE
	DISPlay:STATistical:PRESentation
	DISPlay:STATistical:PREView
	DISPlay:TRACe:MKCENTer
	DISPlay:TRACe:PDFBars
	DISPlay:TRACe:TYPE
	DISPlay:TRACe:VCENTer
	DISPlay:TRACe:VSCALe
	DISPlay:TSPAN

	5.5.5  FETCh Queries
	FETCh:ARRay:AMEAsure:POWer?
	FETCh:ARRay:AMEAsure:STATistical?
	FETCh:ARRay:AMEAsure:TIMe?
	FETCh:ARRay:CW:POWer?
	FETCh:ARRay:MARKer:POWer?
	FETCh:ARRay:MARKer:WINDow?
	FETCh:ARRay:TEMPerature:AVERage?
	FETCh:ARRay:TEMPerature:CALTemp?
	FETCh:ARRay:TEMPerature:CURRent?
	FETCh:CW:POWer?
	FETCh:INTERval:AVERage?
	FETCh:INTERval:MAXimum?
	FETCh:INTERval:MINimum?
	FETCh:INTERval:MAXFilt?
	FETCh:INTERval:MINFilt?
	FETCh:INTERval:PKAVG?
	FETCh:KEY?
	FETCh:MARKer:AVERage?
	FETCh:MARKer:DELTa?
	FETCh:MARKer:MAXimum?
	FETCh:MARKer:MINimum?
	FETCh:MARKer:RATio?
	FETCh:MARKer:RDELTa?
	FETCh:MARKer:RRATio?
	FETCh:TEMPerature:AVERage?
	FETCh:TEMPerature:CALTemp?
	FETCh:TEMPerature:CURRent?

	5.5.6  HCOPy Commands
	HCOPy:BACKground:COLor

	5.5.7  INITiate and ABORt Commands
	ABORt
	INITiate:CONTinuous
	INITiate[:IMMediate[:ALL]]

	5.5.8  MARKer Subsystem
	MARKer: ASSIgn
	MARKer:GROUp
	MARKer:MATH:BOTH
	MARKer:MATH:EACH
	MARKer:POSItion:PERcent
	MARKer:POSItion:PIXel
	MARKer:POSItion:TIMe

	5.5.9  MEASure Queries
	MEASure:POWer?
	MEASure:VOLTage?

	5.5.10  MEMory Subsystem
	MEMory:DRIVe
	MEMory:FDOFfset:TBLA:DATA
	MEMory:FDOFfset:TBLB:DATA
	MEMory:FREE?
	MEMory:OVERwrite
	MEMory:SNSR:CFFAST?
	MEMory:SNSR:CFSLOW?
	MEMory:SNSR:INFO?
	MEMory:SNSR:MESSage?
	MEMory:SNSR:TEMPCOMP?
	MEMory:SYS:LOAD
	MEMory:SYS:STORe
	MMEMory:COPY
	MMEMory:LOAD
	MMEMory:SAVE:DISPlay
	MMEMory:STORe

	5.5.11  OUTPut Subsystem
	OUTPut:LEVel:POWer
	OUTPut:LEVel:LIMit
	OUTPut:LEVel:STEP
	OUTPut:MODUlation
	OUTPut:POLArity
	OUTPut:PULSe:CTRL
	OUTPut:PULSe:DCYCle
	OUTPut:PULse:PERiod
	OUTPut:PULse:PERWID
	OUTPut:PULse:SOURce
	OUTPut:SIGNal
	OUTPut:TRIGout[1/2]:SOURce
	OUTPut:TRIGout[1/2]:POLArity

	5.5.12  READ Queries
	READ:ARRay:AMEAsure:POWer?
	READ:ARRay:AMEAsure:STATistical?
	READ:ARRay:AMEAsure:TIMe?
	READ:ARRay:CW:POWer?
	READ:ARRay:MARKer:POWer?
	READ:ARRay:MARKer:WINDow?
	READ:CW:POWer?
	READ:INTERval:AVERage?
	READ:INTERval:MAXimum?
	READ:INTERval:MINimum?
	READ:INTERval:MAXFilt?
	READ:INTERval:MINFilt?
	READ:INTERval:PKAVG?
	READ:MARKer:AVERage?
	READ:MARKer:DELTa?
	READ:MARKer:MAXimum?
	READ:MARKer:MINimum?
	READ:MARKer:RATio?
	READ:MARKer:RDELTa?
	READ:MARKer:RRATio?

	5.5.13  REFLine Subsystem
	REFLine:ASSIgn
	REFLine:POSItion:LEVel
	REFLine:POSItion:FORCetomk
	REFLine:TRACk

	5.5.14  SENSe Subsystem
	SENSe:AVERage
	SENSe:BANDwidth
	5.5.14.1  SENSe:CALTAB Data Array Commands
	SENSe:CALTAB:COUNt
	SENSe:CALTAB:DATA[:NEXT]?
	SENSe:CALTAB:INDEX


	SENSe:CORRection:CALFactor
	SENSe:CORRection:FDOFfset
	SENSe:CORRection:FREQuency
	SENSe:CORRection:FRQTRK
	SENSe:CORRection:OFFSet
	SENSe:CORRection:TEMPcomp
	SENSe:FILTer:STATe
	SENSe:FILTer:TIMe
	5.5.14.2  SENSe:HISTogram Data Array Commands
	SENSe:HISTogram:COUNt
	SENSe:HISTogram:DATA[:NEXT]?
	SENSe:HISTogram:INDEX


	SENSe:IMPedance
	SENSe:NORMalize
	SENSe:PULSe:DISTal
	SENSe:PULSe:ENDGT
	SENSe:PULSe:MESIal
	SENSe:PULSe:PROXimal
	SENSe:PULSe:STARTGT
	SENSe:PULSe:UNIT
	SENSe:RANGe

	5.5.15  STATus Commands
	STATus:OPERation:CONDition?
	STATus:OPERation:ENABle
	STATus:OPERation:EVENt?
	STATus:OPERation:NTRansition
	STATus:OPERation:PTRansition
	STATus:PRESet
	STATus:QUEStionable:CONDition?
	STATus:QUEStionable:ENABle
	STATus:QUEStionable:EVENt?
	STATus:QUEStionable:NTRansition
	STATus:QUEStionable:PTRansition

	5.5.16  SYSTem Subsystem
	SYSTem:AUTOSET
	SYSTem:BEEP
	SYSTem:COMMunicate:GPIB:EOI
	SYSTem:COMMunicate:GPIB:LISTen
	SYSTem:COMMunicate:GPIB:TALK
	SYSTem:COMMunicate:LOGGing
	SYSTem:COMMunicate:SERial:BAUD
	SYSTem:COMMunicate:SERial:BITS
	SYSTem:COMMunicate:SERial:CTRL:RTS
	SYSTem:COMMunicate:SERial:PARity
	SYSTem:COMMunicate:SERial:SBITs
	SYSTem:COMMunicate:SERial:XON
	SYSTem:DATE:DAY
	SYSTem:DATE:MONTH
	SYSTem:DATE:WEEKday?
	SYSTem:DATE:YEAR
	SYSTem:DISPlay:BMP?
	SYSTem:ERRor[:NEXT]?
	SYSTem:ERRor:CODE?
	SYSTem:LANGuage
	SYSTem:PRESet
	SYSTem:TIMe:HOUR
	SYSTem:TIMe:MINUTE
	SYSTem:VERSion

	5.5.17 TRACe Data Array Commands
	TRACe:AVERage:DATA[:NEXT]?
	TRACe:AVERage:DATA:BINary?
	TRACe:COUNt
	TRACe:DELImiter
	TRACe:INDEX
	TRACe:MAXimum:DATA?
	TRACe:MINimum:DATA?
	TRACe:SEND
	TRACe:SOURce

	5.5.18  TRIGger Subsystem
	TRIGger:BTRIGger:ECOUNT
	TRIGger:BTRIGger:LEVel
	TRIGger:BTRIGger:MODE
	TRIGger:BTRIGger:SLOPe
	TRIGger:BTRIGger:SOURce
	TRIGger:BTRIGger:TDLY
	TRIGger:CDF:COUNt
	TRIGger:CDF:DECImate
	TRIGger:CDF:TIMe
	TRIGger:DELay
	TRIGger:FASTtrig
	TRIGger:HOLDoff
	TRIGger:LEVel
	TRIGger:MODE
	TRIGger:MODUlated:MODE
	TRIGger:POSition
	TRIGger:SLOPe
	TRIGger:SOURce
	TRIGger:STATistical:GATE
	TRIGger:STATistical:GATIng
	Table 5-1. SCPI COMMAND SUMMARY
	Table 5-2. 4400/4500/4400A/4500A EMULATION COMMANDS




	Application Notes
	6.1 Introduction to Pulse Measurements
	Model 4500B FEATURES

	6.2 Pulse Definitions
	Standard IEEE Pulse
	Table 6-1. Pulse Terms


	6.3 Automatic Measurements
	Automatic Measurement Criteria
	Automatic Measurement Terms
	Table 6-2.  Automatic Measurement Terms

	Automatic Measurement Sequence
	Average Power Over an Interval

	6.4 Statistical Mode Automatic Measurements (Model 4500B Opt 10 only)
	Table 6-3. Statistical Automatic Measurements (Opt 10 only)

	6.5 Measurement Accuracy

	Maintenance
	7.1 Safety
	7.2 Cleaning
	7.3 Inspection
	7.4  Lithium Batteries
	7.5 Software Upgrade
	7.6 Test Equipment
	Table 7-1. Verification Test Equipment

	7.7 Performance Verification
	Calibrator Frequency Verification
	Calibrator Linearity Verification
	Calibrator 0 dBm Verification
	Sensor Return Loss Verification
	Sensor Linearity Performance Verification
	Sensor Frequency Calibration Factor Verification
	Sensor Risetime Verification
	Calibrator External Pulse Verification
	GPIB (IEEE-488) Bus Verification

	7.8 1GHz Calibrator Output Level Calibration

	Appendix A
	SCPI Error Messages

	Appendix B
	Microsoft® Windows® XP Professional

	Appendix C
	Repair Policy
	Limited Warranty


